123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185 |
- %global qt_module qtenginio
- # define to build docs, need to undef this for bootstrapping
- %define docs 1
- #define prerelease
- Summary: Qt5 - Enginio component
- Name: qt5-%{qt_module}
- Version: 1.6.3
- Release: 1%{?_dist_release}
- # See LICENSE.GPL LICENSE.LGPL LGPL_EXCEPTION.txt, for details
- # See also http://doc.qt.io/qt-5/licensing.html
- License: LGPLv2 with exceptions or GPLv3 with exceptions
- Url: http://www.qt.io
- Source0: http://download.qt.io/official_releases/qt/5.6/5.6.3/submodules/%{qt_module}-opensource-src-%{version}.tar.xz
- Vendor: Project Vine
- Distribution: Vine Linux
- BuildRequires: qt5-qtbase-devel >= 5.6
- BuildRequires: qt5-qtdeclarative-devel
- %description
- Client library for accessing Enginio service from Qt and QML code.
- %package devel
- Summary: Development files for %{name}
- Requires: %{name}%{?_isa} = %{version}-%{release}
- Requires: qt5-qtbase-devel%{?_isa}
- %description devel
- %{summary}.
- %if 0%{?docs}
- %package doc
- Summary: API documentation for %{name}
- License: GFDL
- #Requires: %{name} = %{version}-%{release}
- BuildRequires: qt5-qdoc
- BuildRequires: qt5-qhelpgenerator
- BuildArch: noarch
- %description doc
- %{summary}.
- %endif
- %package examples
- Summary: Programming examples for %{name}
- Requires: %{name}%{?_isa} = %{version}-%{release}
- %description examples
- %{summary}.
- %prep
- %setup -q -n %{qt_module}-opensource-src-%{version}
- %build
- mkdir %{_target_platform}
- pushd %{_target_platform}
- %{qmake_qt5} ..
- make %{?_smp_mflags}
- %if 0%{?docs}
- # HACK to avoid multilib conflicts in noarch content
- # see also https://bugreports.qt.io/browse/QTBUG-42071
- QT_HASH_SEED=0; export QT_HASH_SEED
- make %{?_smp_mflags} docs
- %endif
- popd
- %install
- make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
- %if 0%{?docs}
- make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
- %endif
- ## .prl/.la file love
- # nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
- pushd %{buildroot}%{_qt5_libdir}
- for prl_file in libEng*.prl ; do
- sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
- if [ -f "$(basename ${prl_file} .prl).so" ]; then
- rm -fv "$(basename ${prl_file} .prl).la"
- sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
- fi
- done
- popd
- %post -p /sbin/ldconfig
- %postun -p /sbin/ldconfig
- %files
- %license LICENSE* LGPL_EXCEPTION.txt
- %{_qt5_libdir}/libEnginio.so.1*
- %{_qt5_archdatadir}/qml/Enginio/
- %files devel
- %{_qt5_headerdir}/Enginio/
- %{_qt5_libdir}/libEnginio.so
- %{_qt5_libdir}/libEnginio.prl
- %dir %{_qt5_libdir}/cmake/Qt5Enginio/
- %{_qt5_libdir}/cmake/Qt5Enginio/Qt5EnginioConfig*.cmake
- %{_qt5_libdir}/pkgconfig/Enginio.pc
- %{_qt5_archdatadir}/mkspecs/modules/qt_lib_enginio*.pri
- %if 0%{?docs}
- %files doc
- %{_qt5_docdir}/qtenginio.qch
- %{_qt5_docdir}/qtenginio
- %{_qt5_docdir}/qtenginiooverview.qch
- %{_qt5_docdir}/qtenginiooverview
- %{_qt5_docdir}/qtenginioqml.qch
- %{_qt5_docdir}/qtenginioqml
- %endif
- %if 0%{?_qt5_examplesdir:1}
- %files examples
- %{_qt5_examplesdir}/
- %endif
- %changelog
- * Fri Jan 12 2018 Toshiaki Ara <ara_t@384.jp> - 1.6.3-1
- - update to 1.6.3
- * Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.6.1-3
- - initial build for Vine Linux.
- - dropped Epoch.
- * Wed Jun 15 2016 Rex Dieter <rdieter@fedoraproject.org> - 1:1.6.1-2
- - drop pkgconfig-style Qt5 deps
- * Thu Jun 09 2016 Jan Grulich <jgrulich@redhat.com> -1:1.6.1-1
- - Update to 1.6.1
- * Sun Mar 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 1:1.6.0-3
- - rebuild
- * Fri Mar 18 2016 Rex Dieter <rdieter@fedoraproject.org> - 1:1.6.0-2
- - rebuild
- * Mon Mar 14 2016 Helio Chissini de Castro <helio@kde.org> - 1.6.0-1
- - 1.6.0 final release
- - Epoch to adjust the version
- * Tue Feb 23 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.7.rc
- - Update to final RC
- * Mon Feb 15 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.6
- - Update RC release
- * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.5.beta1
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
- * Thu Jan 21 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.4.beta1
- - Fix Release, Fix sources, -docs: fix deps
- * Mon Dec 21 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.3
- - Update to final beta release
- * Thu Dec 10 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.2
- - Official beta release
- * Tue Nov 03 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.1
- - Start to implement 5.6.0 beta
- * Thu Oct 15 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-2
- - Update to final release 5.5.1
- * Tue Sep 29 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-1
- - Update to Qt 5.5.1 RC1
- * Wed Jul 1 2015 Helio Chissini de Castro <helio@kde.org> 5.5.0-1
- - New final upstream release Qt 5.5.0
- * Thu Jun 25 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
- - Update for official RC1 released packages
- * Thu Jun 25 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.1.rc
- - First release
|