rhythmbox-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639
  1. # -*- coding: utf-8-unix -*-
  2. %define desktop_file_utils_version 0.9
  3. %define enable_DLNA_UPnP 0
  4. Summary: Music Management Application
  5. Summary(ja): 音楽管理アプリケーション
  6. Name: rhythmbox
  7. Version: 0.13.3
  8. Release: 3%{?_dist_release}
  9. License: GPL2+ with exceptions and GFDL
  10. Group: Applications/Multimedia
  11. URL: http://projects.gnome.org/rhythmbox/
  12. Source0: http://download.gnome.org/sources/rhythmbox/0.13/%{name}-%{version}.tar.bz2
  13. Source101: rhythmbox-png.tar.bz2
  14. Patch0: rhythmbox-0.13.3-git20110809.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: avahi-glib-devel >= 0.6
  17. BuildRequires: brasero-devel >= 2.32.0
  18. BuildRequires: dbus-devel >= 1.0
  19. BuildRequires: dbus-glib-devel
  20. BuildRequires: gnome-vfs2-devel >= 2.18.0
  21. BuildRequires: gstreamer-plugins-base-devel >= 0.10
  22. BuildRequires: gstreamer-python-devel
  23. BuildRequires: json-glib-devel
  24. BuildRequires: libSM-devel
  25. BuildRequires: libffi-devel
  26. BuildRequires: libgnome-keyring-devel >= 2.30.0
  27. BuildRequires: libgnome-media-profiles-devel
  28. BuildRequires: libgnomeui-devel >= 2.18.0
  29. BuildRequires: libgpod-devel
  30. BuildRequires: libgudev1-devel
  31. BuildRequires: libmusicbrainz3-devel >= 3.0.2
  32. BuildRequires: libnotify-devel
  33. BuildRequires: libsexy-devel
  34. BuildRequires: libsoup-devel
  35. BuildRequires: popt-devel
  36. BuildRequires: python-devel, pygtk2-devel
  37. BuildRequires: sqlite3-devel
  38. BuildRequires: totem-pl-parser-devel
  39. BuildRequires: WebKit3-gtk-devel
  40. BuildRequires: libpeas-devel
  41. BuildRequires: clutter-gtk-devel
  42. BuildRequires: clutter-gst-devel
  43. BuildRequires: libmx-devel
  44. BuildRequires: check >= 0.8.2
  45. BuildRequires: gettext, rarian-compat
  46. BuildRequires: gnome-doc-utils >= 0.3.2
  47. BuildRequires: intltool >= 0.35.0
  48. BuildRequires: libmtp-devel
  49. BuildRequires: lirc
  50. Requires: libgpod
  51. Requires: libnotify
  52. Requires: libsexy
  53. Requires: lirc
  54. Requires: libmtp
  55. Requires: libgnomeui
  56. Requires: brasero
  57. Requires: gnome-python gnome-vfs2
  58. Requires: gnome-themes
  59. Requires: libgnome-keyring
  60. Requires: gstreamer-python
  61. %if %{enable_DLNA_UPnP}
  62. Requires: python-Coherence
  63. %endif
  64. Requires: desktop-file-utils >= %{desktop_file_utils_version}
  65. Requires: scrollkeeper GConf2
  66. # # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
  67. # # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
  68. # # respectively.
  69. # Requires: self-build-gstreamer-plugins-ffmpeg
  70. # Requires: self-build-gstreamer-plugins-ugly
  71. Vendor: Project Vine
  72. Distribution: Vine Linux
  73. %description
  74. Rhythmbox is an integrated music management application based on the powerful
  75. GStreamer media framework. It has a number of features, including an easy to
  76. use music browser, searching and sorting, comprehensive audio format support
  77. through GStreamer, Internet Radio support, playlists and more.
  78. Rhythmbox is extensible through a plugin system.
  79. %description -l ja
  80. Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
  81. 統合音楽管理アプリケーションです。
  82. 見やすいユーザインターフェースを備え、検索や整列ができ、
  83. GStreamer により数多くの音声フォーマットをサポート、
  84. インターネットラジオをサポート、プレイリスト管理などの
  85. 数多くの特徴を持ちます。
  86. %package devel
  87. Summary: Development tools for rhythmbox applications.
  88. Summary(ja): rhythmbox アプリケーションの開発用ファイル
  89. Group: Development/Libraries
  90. Requires: %{name} = %{version}-%{release}
  91. Requires: pkgconfig
  92. Requires: glib2-devel
  93. Requires: gtk2-devel
  94. Requires: libsoup-devel
  95. Requires: libgnome-media-profiles-devel
  96. Requires: totem-pl-parser-devel
  97. Requires: gstreamer-devel
  98. %description devel
  99. Header files and libraries for building a extension library for the rhythmbox.
  100. %description devel -l ja
  101. %prep
  102. %setup -q
  103. %patch0 -p1 -b .git20110730
  104. tar xjf %{SOURCE101}
  105. # Use the installed louie, not the one in Coherence
  106. find plugins/coherence/upnp_coherence/ -type f \
  107. -exec %__sed -i 's/coherence.extern.louie as louie/louie/' '{}' ';'
  108. %build
  109. # work around a gstreamer bug
  110. /usr/bin/gst-inspect-0.10 --print-all >& /dev/null || :
  111. libtoolize --force --copy
  112. autoreconf
  113. %configure --with-ipod \
  114. --with-mtp \
  115. --with-mdns=avahi \
  116. --with-libnautilus-burn \
  117. --enable-lirc \
  118. --enable-python \
  119. --disable-vala \
  120. --disable-browser-plugin \
  121. --disable-static \
  122. --disable-scrollkeeper \
  123. --disable-schemas-install \
  124. --without-hal
  125. %__make %{?_smp_mflags}
  126. %install
  127. %__rm -rf $RPM_BUILD_ROOT
  128. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  129. %__make install DESTDIR=$RPM_BUILD_ROOT
  130. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  131. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
  132. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
  133. %__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  134. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
  135. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
  136. %__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
  137. %__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
  138. ## Don't package DLNA/UPnP plugin
  139. %if !%{enable_DLNA_UPnP}
  140. %__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
  141. %endif
  142. %find_lang %{name}
  143. # Don't package api docs
  144. %__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
  145. # Don't package scrollkeeper catalogs
  146. %__rm -rf $RPM_BUILD_ROOT%{_localstatedir}
  147. # And don't package vala
  148. %__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
  149. %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
  150. # save space by linking identical images in translated docs
  151. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  152. for f in $helpdir/C/figures/*.png; do
  153. b="$(basename $f)"
  154. for d in $helpdir/*; do
  155. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  156. g="$d/figures/$b"
  157. if [ -f "$g" ]; then
  158. if cmp -s $f $g; then
  159. %__rm "$g"; ln -s "../../C/figures/$b" "$g"
  160. fi
  161. fi
  162. fi
  163. done
  164. done
  165. %clean
  166. %__rm -rf $RPM_BUILD_ROOT
  167. %post
  168. /sbin/ldconfig
  169. update-desktop-database -q
  170. scrollkeeper-update -q
  171. touch --no-create %{_datadir}/icons/hicolor
  172. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  173. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  174. fi
  175. %postun
  176. /sbin/ldconfig
  177. update-desktop-database -q
  178. scrollkeeper-update -q
  179. touch --no-create %{_datadir}/icons/hicolor
  180. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  181. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  182. fi
  183. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  184. %posttrans
  185. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  186. %files -f %{name}.lang
  187. %defattr(-, root, root)
  188. %doc AUTHORS COPYING ChangeLog README NEWS
  189. %{_bindir}/*
  190. %{_libdir}/girepository-1.0/*.typelib
  191. %{_libdir}/lib*.so.*
  192. %{_libdir}/rhythmbox/plugins
  193. %{_datadir}/applications/rhythmbox.desktop
  194. %{_datadir}/applications/rhythmbox-device.desktop
  195. %{_datadir}/dbus-1/services/org.gnome.Rhythmbox.service
  196. %{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
  197. %{_datadir}/gnome/help/rhythmbox
  198. %{_datadir}/icons/*
  199. %{_datadir}/omf/rhythmbox
  200. %{_datadir}/rhythmbox
  201. %{_mandir}/man1/*
  202. %{_libexecdir}/rhythmbox-metadata
  203. %files devel
  204. %defattr(-, root, root)
  205. %{_includedir}/%{name}/*
  206. %{_libdir}/*.so
  207. %{_libdir}/pkgconfig/*.pc
  208. %{_datadir}/gir-1.0/*.gir
  209. %changelog
  210. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
  211. - rebuild with libnotify-0.7
  212. - change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
  213. - change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
  214. - add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
  215. - add Patch0 (rhythmbox-0.13.3-git20110809.patch)
  216. - add Source101 (rhythmbox-png.tar.bz2)
  217. * Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
  218. - add BuildRequires: json-glib-devel
  219. - remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
  220. * Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
  221. - new upstream release
  222. - change BuildRequires: gstreamer-python-devel instead of gstreamer-python
  223. * Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
  224. - new upstream release
  225. * Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
  226. - rebuild with brasero-2.32.0
  227. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
  228. - rebuild with rpm-4.8.1 for pkg-config file
  229. * Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
  230. - new upstream release
  231. - fix %files (add rhythmbox-device.desktop)
  232. * Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
  233. - new upstream release
  234. - change BuildRequires: gnome-media-devel instead of gnome-media
  235. - add devel package
  236. - drop Patch0
  237. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
  238. - new upstream release
  239. - drop Patch1, Patch2, Patch3
  240. - change BuildRequires: nautilus-cd-burner -> brasero-devel
  241. - change Requires: nautilus-cd-burner -> brasero
  242. - change BuildRequires: hal-devel -> libgudev1-devel
  243. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  244. - change Requires: gnome-keyring -> libgnome-keyring
  245. - add configure option (--without-hal)
  246. * Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
  247. - rebuilt with new environment
  248. * Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
  249. - new upstream release
  250. - dropped upstreamed/obsolete patches
  251. - added patches applied Fedora development
  252. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
  253. - new upstream release
  254. - added configure options:
  255. --disable-vala
  256. --disable-browser-plugin
  257. * Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
  258. - added Japanese description
  259. * Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
  260. - new upstream release
  261. - dropped rb-disable-power-plugin-by-default.patch
  262. - added BuildRequires:
  263. - libSM-devel
  264. - gnome-media
  265. * Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
  266. - rebuild with libgpod-0.7.2
  267. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
  268. - new upstream release
  269. - corrected License tag
  270. - dropped rhythmbox-0.11.6-libmtp.patch
  271. - added BuildRequires:
  272. - sqlite3-devel
  273. - libffi-devel
  274. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
  275. - defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
  276. - applied rhythmbox-0.11.6-libmtp.patch
  277. - added Requires:
  278. - libgpod
  279. - libnotify
  280. - libsexy
  281. - lirc
  282. - libmtp
  283. - libgnomeui
  284. - nautilus-cd-burner
  285. - gstreamer-python
  286. - gnome-vfs2
  287. - gnome-themes
  288. - gnome-keyring
  289. - python-Coherence, if enable_DLNA_UPnP = 1
  290. - added BuildRequires:
  291. - libnotify-devel
  292. - libsexy-devel
  293. - lirc
  294. - libmtp-devel
  295. - gnome-vfs2-devel, instead of gnome-vfs2
  296. - gnome-keyring-devel
  297. - dropped --with-internal-libsexy in configure options
  298. - added in configure options:
  299. --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
  300. - added %%preun to remove the schema
  301. * Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
  302. - new upstream release
  303. - changed to --with-metadata-helper in configure options
  304. - added BuildRequires:
  305. - gstreamer-python
  306. - intltool >= 0.35.0
  307. - popt-devel
  308. * Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
  309. - added BuildRequires: totem-pl-parser-devel, instead of totem-devel
  310. - rebuilt with python-2.5.2
  311. - applied new versioning policy
  312. - spec in utf-8
  313. * Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
  314. - rebuilt with libgpod-0.6.0
  315. * Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
  316. - new upstream release
  317. * Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
  318. - new upstream release
  319. * Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
  320. - rebuilt with new toolchain and libgpod-0.4.2
  321. - add BuildRequires: dbus-glib-devel
  322. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
  323. - new upstream release
  324. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
  325. - rebuilt for VineSeed
  326. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
  327. - new upstream release
  328. - added --enable-python option to %%configure
  329. - added Requires: gnome-python
  330. * Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
  331. - new upstream release
  332. - built with libsoup 2.2.99
  333. * Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
  334. - added --with-cd-burner to configure
  335. - added BuildRequires: libsexy-devel hal-devel libsoup-devel
  336. * Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
  337. - add BuildRequires:
  338. - gnome-doc-utils >= 0.3.2
  339. - python-devel
  340. - pygtk2-devel
  341. - check >= 0.8.2
  342. * Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
  343. - rebuild with gnutls-1.4.1
  344. * Sun Oct 1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
  345. - new upstream release
  346. * Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
  347. - new upstream release
  348. - run scrollkeeper-update at %post and %postun
  349. - added BuildRequires: libnotify-devel
  350. * Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
  351. - new upstream release (dropped patch0)
  352. - added --without-metadata-helper at configure
  353. * Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
  354. - Initial build for Vine Linux based on FC pacakge
  355. * Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
  356. - add patch from James "Doc" Livingston to stop a hang
  357. for new users (bug 183883)
  358. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
  359. - bump again for double-long bug on ppc(64)
  360. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
  361. - rebuilt for new gcc4.1 snapshot and glibc changes
  362. * Sat Feb 4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
  363. - Update to 0.9.3.1
  364. - Use gstreamer (0.10)
  365. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
  366. - Remove hack for 173869, as its no longer needed.
  367. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
  368. - 0.9.3
  369. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
  370. - Newer CVS snapshot
  371. * Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
  372. - Update to latest CVS
  373. - Add hack to workaround bug #173869
  374. * Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
  375. - Rebuild, now that gstreamer08-plugins has been fixed
  376. * Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
  377. - bonobo multilib issue (bug 156982)
  378. * Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
  379. - rebuild with ipod support
  380. * Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
  381. - rebuilt again
  382. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  383. - rebuilt
  384. * Mon Dec 5 2005 Matthias Clasen <mclasen@redhat.com>
  385. - rebuild
  386. * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
  387. - rebuild for new dbus
  388. * Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
  389. - Update to 0.9.2
  390. * Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
  391. - Update to 0.9.1
  392. * Fri Sep 02 2005 Colin Walters <walters@redhat.com>
  393. - Add configure flags --with-bonobo --with-dbus
  394. - BR nautilus-cd-burner-devel
  395. - New upstream CVS snapshot for testing
  396. - Drop IDL file and ui .xml
  397. - Add dbus service file
  398. - Drop upstreamed rhythmbox-bluecurve.tar.gz
  399. - Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
  400. * Fri Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
  401. - Add Bluecurve-ized icons from Jeff Schroeder (157716)
  402. - Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
  403. cell renderer for playback icon (no longer necessary) and
  404. changes the rating renderer to work with non-b&w icons
  405. * Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
  406. - Rebuild for GCC4
  407. * Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
  408. - New upstream version
  409. - Remove librb-nautilus-context-menu.so, killed upstream
  410. * Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
  411. - PreReq desktop-file-utils >= 0.9
  412. * Sat Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
  413. - New upstream version
  414. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
  415. - Fix postun to use correct syntax, thanks Nils Philippsen
  416. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
  417. - New upstream version
  418. - Call update-desktop-database in post and postun
  419. * Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
  420. - New upstream version
  421. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  422. - rebuilt
  423. * Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
  424. - New upstream version
  425. - Remove backported patches
  426. - Gratuitiously bump various BuildRequires versions
  427. * Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
  428. - Remove code to unregister GConf schema for now (Closes: #122532)
  429. * Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
  430. - Apply tiny patch from 0.8 arch to fix GConf key used
  431. for initial sorting
  432. * Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
  433. - Apply patch from 0.8 arch tree to fix a number of memleaks
  434. * Thu May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
  435. - Update to 0.8.3: fixes showstopper bug with internet radio
  436. * Thu Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
  437. - Update to 0.8.2
  438. - Fix Source url
  439. - Add smp_mflags
  440. - Bump BuildRequires on gstreamer to 0.8.1
  441. * Tue Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
  442. - Uninstall GConf schemas on removal
  443. * Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
  444. - Update to 0.8.1
  445. * Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
  446. - Update to 0.8.0
  447. * Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
  448. - Update to 0.7.2
  449. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
  450. - Remove BuildRequires on autoconf and libvorbis-devel
  451. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
  452. - New major version - I know we are past major version slush, but
  453. this should have been done two weeks ago along with the GNOME 2.6
  454. upload. As upstream author as well, I believe this version is
  455. good enough for FC2.
  456. - Remove --disable-mp3
  457. - Remove id3, flac variables
  458. - Remove GStreamer major version patch
  459. - Fix typo in description
  460. * Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
  461. - rebuild for new gstreamer
  462. * Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
  463. - update to 0.6.8
  464. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  465. - rebuilt
  466. * Mon Mar 1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
  467. - update to 0.6.7
  468. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  469. - rebuilt
  470. * Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
  471. - New upstream version
  472. - Don't re-run the autotools; upstream incorporates newer versions.
  473. * Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
  474. - new version
  475. - remove smp_flags
  476. * Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
  477. - remove the initial iradio channels as they all are mp3 based.
  478. * Wed Oct 8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
  479. - Fix category from Development/Libraries to Applications/Multimedia.
  480. - Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
  481. - Fix SCHEMES vs. SCHEMAS in the post scriplet.
  482. - Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
  483. - Removed unnecessary date expansion define.
  484. - Updated description, including mp3 reference removal.
  485. - Added libid3tag and flac optional support for convenient rebuild.
  486. - Removed obsolete omf.make and xmldocs.make (included ones are the same now).
  487. * Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
  488. - new version
  489. - use %{_sysconfdir} instead of /etc
  490. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  491. - rebuilt
  492. * Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
  493. - gave up on other archs for the Beta
  494. - new version
  495. - remove werror and add missing files
  496. * Thu Nov 7 2002 Jeremy Katz <katzj@redhat.com>
  497. - update to newer cvs snap
  498. * Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
  499. - update to cvs snap
  500. * Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
  501. - use %%(lang)
  502. * Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
  503. - fix post to actually install the schema
  504. * Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  505. - Added gconf file
  506. - Added i18n directory
  507. * Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  508. - Updated for new rewrite of rhythmbox, thanks to Jeroen
  509. * Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
  510. - removed bonobo dependency
  511. * Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
  512. - created new spec file