self-build-k3b-extra-vl.spec 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136
  1. %define pkgname k3b-extra
  2. %define name self-build-%{pkgname}
  3. %define version 2.0.2
  4. %define release 2%{?_dist_release}
  5. %define sourceurl0 http://downloads.sourceforge.net/project/k3b/k3b/%{version}/k3b-%{version}.tar.bz2
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Source0: %{pkgname}-vl.spec
  12. License: GPLv2
  13. Group: Restricted Software
  14. Requires(post): self-build-setup >= 0.8
  15. Requires(post): self-build-ffmpeg
  16. Requires(post): self-build-lame
  17. Requires(post): self-build-libmad
  18. Requires(post): desktop-file-utils
  19. Requires(post): gettext
  20. Requires(post): kdelibs4-devel
  21. Requires(post): kdemultimedia4-devel
  22. Requires(post): libdvdread-devel
  23. Requires(post): libmusicbrainz-devel
  24. Requires(post): libsamplerate-devel
  25. Requires(post): libXpm-devel
  26. Requires(post): taglib-devel
  27. Requires: k3b >= %{version}
  28. BuildArch: noarch
  29. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  30. Packager: inagaki
  31. %description
  32. This package contains additional plugins for K3b.
  33. - FFMpeg decoder for decoding WMA file(s)
  34. - MAD decoder for decoding MP3 file(s)
  35. - Lame MP3 encoder for encoding MP3 file(s)
  36. If you install this package, it automaticaly downloads source
  37. code ,compile it, and create rpm packages of k3b-extra.
  38. And the created rpm packages are automatically installed
  39. if installation is executed by apt-get command or synaptic
  40. package manager.
  41. [Note]
  42. This package requires many other packages to compile
  43. targetsoftware. So it consume more disk space than usual.
  44. Also installation takes logner time because of compilation.
  45. (This will take a few minutes to quarter or half of an hour,
  46. depends on building environment)
  47. [About self-build package]
  48. For some kind of software, distributing of binary package
  49. may viorate the patent or law. Therefore we chose self-build
  50. packge, create binary package on your machine, for such kind
  51. of softwares instead of distributing binary package.
  52. Please obey the national law when you use the created binary
  53. packages. And if you want to use the softwares using patented
  54. thechnology, it may be required to get a permission, make an
  55. agreement or purchas a license. Please consider it with your
  56. purpose or way of use and take appropriate action.
  57. %description -l ja
  58. K3b 向けに以下の追加プラグインを提供します.
  59. - WMA ファイルをデコードするための FFMpeg デコーダ
  60. - MP3 ファイルをデコードするための MAD デコーダ
  61. - MP3 ファイルをエンコードするための Lame MP3 エンコーダ
  62. このパッケージをインストールすると、自動的にソースコードを
  63. ダウンロードしてコンパイルし、k3b-extra の rpm パッケージを作成します。
  64. また apt-get コマンドや synaptic パッケージマネージャから実行
  65. した場合は、作成された rpm パッケージのインストールも自動的に
  66. 行います。
  67. [注意]
  68. コンパイルに必要な多くの関連パッケージを要求するので通常より
  69. ディスクの領域を多く消費します。
  70. またインストール時にコンパイルを行うため、通常より時間がかか
  71. る場合があります。(環境にもよりますが数分から数十分程度)
  72. [self-build パッケージについて]
  73. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  74. 違反する可能性があるものがあります。その為、このような問題が
  75. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  76. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  77. ジという方法を採っています。
  78. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  79. アのライセンス、および利用する国の各種法令に従ってください。
  80. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  81. センスの購入などが必要となる場合がありますので、利用する目的
  82. や形態に応じて各自で判断し適切な対応を取ってください。
  83. %prep
  84. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  85. %install
  86. %{__rm} -rf ${RPM_BUILD_ROOT}
  87. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  88. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  89. %clean
  90. %{__rm} -rf ${RPM_BUILD_ROOT}
  91. %posttrans
  92. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}"
  93. %files
  94. %defattr(-,root,root)
  95. %{_datadir}/%{name}
  96. %changelog
  97. * Fri Mar 4 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.2-2
  98. - added BR: libXpm-devel
  99. * Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.2-1
  100. - new upstream release
  101. * Sun Sep 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-2
  102. - fixed %%build section to remove qt-devel dependency
  103. * Wed Sep 8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-1
  104. - new upstream release
  105. * Thu Jul 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-1
  106. - initial bulid for Vine Linux