kdepim3-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593
  1. Name: kdepim3
  2. Summary: Compatibility support for kdepim3
  3. Version: 3.5.10
  4. Release: 3%{?_dist_release}
  5. URL: http://www.kde.org/
  6. Group: Applications/Productivity
  7. License: GPLv2
  8. Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdepim-%{version}.tar.bz2
  9. Patch0: kdepim-3.5.10-gcc.patch
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: bison
  12. BuildRequires: desktop-file-utils
  13. BuildRequires: flex
  14. BuildRequires: kdelibs3-devel >= %{version}
  15. BuildRequires: libart_lgpl-devel
  16. BuildRequires: cyrus-sasl-devel
  17. BuildRequires: gpgme-devel
  18. BuildRequires: libXpm-devel libXScrnSaver-devel
  19. BuildRequires: zlib-devel
  20. BuildRequires: python-devel
  21. #BuildRequires: libmal-devel
  22. #BuildRequires: pilot-link-devel >= 0.9.5
  23. %description
  24. %{summary}, including libkcal.
  25. %package libs
  26. Summary: Runtime files for %{name}
  27. Summary(ja): %{name} のランタイムライブラリ
  28. Group: System Environment/Libraries
  29. Requires: kdelibs3 >= %{version}
  30. %description libs
  31. %{summary}, including libkcal.
  32. %package devel
  33. Summary: Development files for %{name}
  34. Summary(ja): %{name} の開発用ファイル
  35. Group: Development/Libraries
  36. Requires: %{name}-libs = %{version}-%{release}
  37. Requires: kdelibs3-devel
  38. %description devel
  39. Development files for %{name}.
  40. Install %{name}-devel if you want to write or compile %{name} plugins.
  41. %prep
  42. %setup -q -n kdepim-%{version}
  43. %patch0 -p1 -b .gcc47
  44. %build
  45. unset QTDIR || : ; . /etc/profile.d/qt.sh
  46. %configure \
  47. --with-qt-libraries=$QTDIR/lib \
  48. --enable-new-ldflags \
  49. --disable-dependency-tracking \
  50. --disable-rpath \
  51. --disable-debug --disable-warnings \
  52. --enable-final \
  53. --includedir=%{_includedir}/kde \
  54. --with-gpg=%{_bindir}/gpg \
  55. --with-gpgsm=%{_bindir}/gpgsm \
  56. --with-sasl \
  57. --without-gnokii \
  58. --without-mal \
  59. --without-pilot-link
  60. for lib in ktnef libkmime libemailfunctions libkcal libkdepim; do
  61. make %{?_smp_mflags} -C ${lib}
  62. done
  63. %install
  64. rm -rf $RPM_BUILD_ROOT
  65. for lib in ktnef libkmime libemailfunctions libkcal libkdepim; do
  66. make install DESTDIR=$RPM_BUILD_ROOT -C $lib
  67. done
  68. #unpackaged files
  69. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  70. rm -f $RPM_BUILD_ROOT%{_libdir}/libkdepim*
  71. rm -rf $RPM_BUILD_ROOT%{_datadir}/apps/libkdepim/
  72. rm -rf $RPM_BUILD_ROOT%{_datadir}/apps/kdepimwidgets/
  73. rm -f $RPM_BUILD_ROOT%{_libdir}/kde3/plugins/designer/*
  74. rm -f $RPM_BUILD_ROOT%{_libdir}/lib{kmime,ktnef}.so
  75. rm -rf $RPM_BUILD_ROOT%{_includedir}/kde/ktnef/
  76. rm -rf $RPM_BUILD_ROOT%{_datadir}/applications
  77. rm -rf $RPM_BUILD_ROOT%{_datadir}/icons
  78. rm -rf $RPM_BUILD_ROOT%{_datadir}/mimelnk
  79. rm -rf $RPM_BUILD_ROOT%{_datadir}/apps/ktnef
  80. rm -f $RPM_BUILD_ROOT%{_bindir}/ktnef
  81. %post libs -p /sbin/ldconfig
  82. %postun libs -p /sbin/ldconfig
  83. %clean
  84. rm -rf $RPM_BUILD_ROOT
  85. %files libs
  86. %defattr(-,root,root)
  87. %doc README korganizer/COPYING
  88. %{_datadir}/config.kcfg/pimemoticons.kcfg
  89. %{_datadir}/apps/libical/
  90. %{_datadir}/services/kresources/kcal*
  91. %{_libdir}/libkcal.so.2*
  92. %{_libdir}/kde3/kcal*
  93. %{_libdir}/libkmime.so.2*
  94. %{_libdir}/libktnef.so.1*
  95. %files devel
  96. %defattr(-,root,root)
  97. %{_includedir}/kde/kdepimmacros.h
  98. %{_includedir}/kde/libemailfunctions
  99. %{_includedir}/kde/libkcal
  100. %{_libdir}/libkcal.so
  101. %changelog
  102. * Fri Oct 24 2014 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-3
  103. - added Patch0 from fc
  104. - not link to libmal and pilot-link
  105. * Sat May 26 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-2
  106. - rebuilt with rpm-4.8.1-3
  107. - added BR: arts-devel
  108. * Sun Mar 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-1
  109. - updated to 3.5.10
  110. - built with new toolchain
  111. * Sat Sep 5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-2
  112. - renamed kdepim3
  113. * Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
  114. - applied new versioning policy, spec in UTF-8
  115. - added Japnaese summary
  116. * Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
  117. - rebuild for VineSeed
  118. * Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
  119. - new upstream release
  120. * Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
  121. - rebuild for VineSeed
  122. * Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
  123. - new upstream release
  124. - remove all patches
  125. * Mon Apr 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
  126. - new upstream release
  127. - add Patch0, 1 , 2 and 3
  128. * Mon Oct 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
  129. - added --with-qt-libraries and --enable-libsuffix option
  130. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
  131. - rebuild for VineSeed
  132. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
  133. - new upstream release
  134. * Mon Sep 4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl3
  135. - rebuild with pilot-link-0.12.0-0vl1
  136. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
  137. - rebuild for VineSeed
  138. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
  139. - new upstream release
  140. * Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
  141. - rebuild for VineSeed
  142. * Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
  143. - new upstream release
  144. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
  145. - rebuild for VineSeed
  146. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
  147. - new upstream release
  148. * Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
  149. - rebuild for VineSeed
  150. * Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
  151. - new upstream release
  152. - delete BuildPrereq: libmal-devel and Requires: libmal
  153. * Thu Dec 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
  154. - rebuild for VineSeed
  155. * Mon Nov 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
  156. - new upstream release
  157. * Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
  158. - new upstream release
  159. * Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
  160. - new upstream release
  161. - delete all patches
  162. - add Requires: kdeaccessibility >= %%{version}
  163. - add --enable-indexlib to configure option
  164. * Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
  165. - new upstream release
  166. - remove Patch0
  167. - add Patch0 - Patch1
  168. * Tue Aug 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
  169. - rebuild for VineSeed
  170. * Tue Aug 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
  171. - new upstream release
  172. - remove Patch0
  173. - add BuildPrereq: gpgme-devel >= 0.4.5
  174. - add Patch0 (http://bugs.kde.org/show_bug.cgi?id=109003)
  175. * Mon Jul 4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
  176. - rebuild for VineSeed
  177. - add --disable-rpath to configure option
  178. * Mon Jun 6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
  179. - new upstream release (delete old patch and add new security patch)
  180. - use %%{?_smp_mflags} for make option
  181. * Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
  182. - rebuild for VineSeed
  183. * Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
  184. - new upstream release
  185. - add patch0
  186. * Fri Mar 4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
  187. - new upstream release (3.4.0-rc1)
  188. * Tue Feb 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.92-0vl1
  189. - new upstream release
  190. * Wed Feb 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.91-0vl1
  191. - new upstream release
  192. * Sat Jan 1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
  193. - rebuild for VineSeed
  194. * Sat Jan 1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
  195. - new upstream release
  196. * Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
  197. - source upgrade
  198. - update %%files
  199. - all sub-packages are integrated into main package (exclude devel)
  200. * Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
  201. - rebuild with qt32
  202. * Tue Jun 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
  203. - source upgrade
  204. - remove lines about vine26
  205. * Sat May 1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
  206. - source upgrade
  207. - update %%files
  208. * Sat Mar 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
  209. - source upgrade
  210. - update %%description
  211. - add Obsoletes: kdenetwork < 3.2.0
  212. * Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
  213. - rebuild for VineSeedPlus
  214. * Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
  215. - source upgrade
  216. - build for VinePlus/2.6
  217. - (VinePlus/2.6) BuildPrereq: autoconf258
  218. - remove Patch
  219. * Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
  220. - build for VineSeed with new toolchain and qt-3.2.3
  221. - add configure option --with-xinerama --enable-final
  222. * Sun Nov 2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
  223. - rebuild with qt-3.2.1-0.26vl3
  224. * Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
  225. - rebuild with qt-3.2.1-0vl3
  226. * Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
  227. - build with gcc-3.2.3
  228. * Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl1
  229. - source upgrade
  230. - BuildPrereq: qt-devel >= 3.2.1 arts-devel >= 1:1.1.4
  231. * Sat Aug 2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0.26vl1
  232. - rebuild for Vine2.6
  233. * Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
  234. - source upgrade
  235. - change spec to build with gcc295
  236. - change make option for SMP and add script
  237. - add BuildPrereq: libmal-devel
  238. - add Requires: libmal for pilot
  239. * Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
  240. - source upgrade
  241. - remove Patch800 (included in this source)
  242. - built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
  243. * Sat Apr 5 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
  244. - source upgrade
  245. - change spec to build both VineSeed and Vine2.5/2.6
  246. - revised description and files section
  247. - remove source900
  248. - add patch0 (http://bugs.kde.org/show_bug.cgi?id=55541)
  249. - add patch800 (Kdeveloper:02753)
  250. * Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
  251. - objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
  252. * Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
  253. - source upgrade
  254. * Wed Oct 9 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl2
  255. - rebuild with qt-3.0.5-0vl1
  256. - BuildPrereq: autoconf253 objprelink2
  257. * Wed Sep 18 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
  258. - source upgrade
  259. * Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
  260. - source upgrade
  261. - add BuildPrereq: autoconf252 automake15
  262. * Thu Jul 4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-1vl1
  263. - merged with rawhide 3.0.1-1
  264. - change %%doc %%{_docdir}/HTML -> %%doc %%{_datadir}/doc/HTML
  265. - add Requires: for each package
  266. - There is Vine's previous changes, hacked for Vine
  267. -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
  268. - build for VineSeed
  269. - delete Epoch
  270. - objprelink (i386 only)
  271. * Tue Jun 25 2002 Than Ngo <than@redhat.com> 3.0.1-1
  272. - 3.0.1
  273. - fixed bug #67303
  274. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  275. - automated rebuild
  276. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  277. - automated rebuild
  278. * Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-3
  279. - Rename libraries
  280. * Wed Apr 10 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-2
  281. - Fix #61901
  282. * Fri Mar 29 2002 Than Ngo <than@redhat.com> 3.0.0-1
  283. - final
  284. * Tue Jan 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020122.1
  285. - Update
  286. - Fix build on ia64
  287. * Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010726.1
  288. - Update, fixes korganizer (#50006)
  289. * Sun May 13 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  290. - Update to get rid of abbrowser (moved to kdebase)
  291. * Thu Feb 22 2001 Than Ngo <than@redhat.com>
  292. - add missing ldconfig in %post anf %postun again
  293. - clean up specfile
  294. * Wed Feb 21 2001 Than Ngo <than@redhat.com>
  295. - 2.1-respin
  296. - fix dangling symlink
  297. - remove excludearch ia64, some hacks to build on ia64
  298. * Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  299. - 2.1
  300. * Mon Feb 5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  301. - Update
  302. * Tue Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  303. - Update
  304. * Wed Dec 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  305. - Update to CVS
  306. - Enable building kpilot
  307. - Obsolete kpilot
  308. - Don't exclude ia64, use -O0 on ia64
  309. - Disable building kpilot on ia64 (compiler breakage)
  310. * Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  311. - 2.0 final
  312. * Wed Oct 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  313. - 2.0
  314. * Sun Oct 1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  315. - new CVS
  316. - fix installation of fonts
  317. * Sat Sep 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  318. - new CVS snapshot
  319. - fix up spec file
  320. * Wed Aug 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  321. - get rid of the 3d-screensavers package - now that qt-GL is part of qt,
  322. there's no need to keep them separate to avoid the dependency.
  323. * Mon Aug 21 2000 Than Ngo <than@redhat.com>
  324. - fix gnome-session so that KDE2 can be started from gdm
  325. - pam/kde2 instead pam/kde to avoid problem with KDE1
  326. - don't requires qt-GL, It's now in qt
  327. * Sun Aug 20 2000 Than Ngo <than@redhat.com>
  328. - fix dependency problem with KDE1 so that KDE1 and KDE2 can be installed
  329. at the same time
  330. - add missing ldconfig in %post anf %postun
  331. - fix for reading config files in /etc/X11/xdm, add Xsession to requires
  332. * Tue Aug 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  333. - Fix keytable in konsole (Bug #15682)
  334. * Sun Aug 6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  335. - rebuild, now that kdelibs2 works on alpha
  336. - use the same ugly hack to get kdebase to compile
  337. - remove ksysguard on alpha (even more compiler problems)
  338. * Fri Aug 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  339. - new snapshot (fixed libGL detection in CVS)
  340. * Wed Aug 2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  341. - move to /usr/lib/kde2
  342. - new snapshot
  343. * Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
  344. - fix the --xdmdir arg to be correct (oops)
  345. * Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  346. - move kdm config files from /usr/config to /etc/X11 by forcing xdmdir
  347. * Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  348. - new snapshot
  349. - some fixes to spec file
  350. * Tue Jul 18 2000 Than Ngo <than@redhat.de>
  351. - rebuilt against glibc-2.1.92-14, gcc-2.96-40
  352. * Sun Jul 16 2000 Than Ngo <than@redhat.de>
  353. - use new snapshot
  354. - disable Motif
  355. * Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  356. - use gcc 2.96
  357. - new snapshot
  358. * Sun Jul 2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  359. - Epoch 3
  360. - Update to current
  361. - Use egcs++
  362. * Fri Jun 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  363. - Update (I put the fixes directly to CVS rather than collecting them
  364. in the spec)
  365. * Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  366. - remove man2html; we get that from man
  367. - new snapshot
  368. * Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  369. - new snapshot
  370. - ExcludeArch ia64 for now
  371. - remove gnome .desktop file, we get it from gnome-core now.
  372. * Wed Apr 5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  373. - remove dependency on xpm (now in XFree86)
  374. * Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  375. - new snapshot
  376. - move it to /usr, where it belongs
  377. * Sat Dec 25 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  378. - Build the OpenGL screensavers, and move them to a separate package
  379. - Improve the spec file (BuildPrereqs etc.)
  380. * Thu Dec 16 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  381. - remove patch #3 (obsoleted by kwin)
  382. * Sun Oct 24 1999 Bernhard Rosenkraenzer <bero@redhat.de>
  383. - 2.0 CVS snapshot
  384. - fix compilation
  385. * Thu Sep 23 1999 Preston Brown <pbrown@redhat.com>
  386. - clean up files in /tmp from startkde
  387. - mark doc files as such
  388. * Tue Sep 21 1999 Preston Brown <pbrown@redhat.com>
  389. - start autorun if present in startkde
  390. - check for configured soundcard before running sound services
  391. * Mon Sep 20 1999 Preston Brown <pbrown@redhat.com>
  392. - made kdelnks display Name property if they are of type Link
  393. * Thu Sep 16 1999 Preston Brown <pbrown@redhat.com>
  394. - moved png handling here (from kdelibs)
  395. - changed low color icon directory name to locolor
  396. * Tue Sep 14 1999 Preston Brown <pbrown@redhat.com>
  397. - added optional session management to logout dialog
  398. - include GNOME menus
  399. * Mon Sep 13 1999 Preston Brown <pbrown@redhat.com>
  400. - added link to /etc/X11/applnk, .directory file
  401. - included lowcolor icon sub-package
  402. - enable .desktop file access
  403. * Fri Sep 10 1999 Preston Brown <pbrown@redhat.com>
  404. - customized startkde script to set up user environment if not present.
  405. - mention kthememgr in description.
  406. * Wed Sep 08 1999 Preston Brown <pbrown@redhat.com>
  407. - upgraded to 1.1.2 release
  408. - kvt is back
  409. - kde icon included
  410. - linux console fonts included
  411. * Thu Jul 15 1999 Preston Brown <pbrown@redhat.com>
  412. - PAM console logout problem solved.
  413. * Mon Jul 12 1999 Preston Brown <pbrown@redhat.com>
  414. - now includes screensaver password security fix
  415. * Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
  416. - snapshot, includes kde 1.1.1 + fixes
  417. - kvt removed for security reasons. It is a steaming pile of...
  418. * Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
  419. - last snapshot before release
  420. * Fri Apr 16 1999 Preston Brown <pbrown@redhat.com>
  421. - today's snapshot makes kfm a bit nicer and some other fixes
  422. - moved default rc files to kdesupport
  423. * Thu Apr 15 1999 Preston Brown <pbrown@redhat.com>
  424. - SUID bit removed from konsole_grantpty -- not needed w/glibc 2.1
  425. * Wed Apr 14 1999 Preston Brown <pbrown@redhat.com>
  426. - built with today's snapshot -- had to rebuild to fix pam problems.
  427. * Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
  428. - new snapshot fixes mimetype video/x-flic problem
  429. * Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
  430. - latest stable snapshot
  431. * Fri Apr 09 1999 Preston Brown <pbrown@redhat.com>
  432. - removed bell.xpm (used to be in fvwm2-icons, don't want installer to see
  433. - this previous connection and autoselect kdebase for upgrade).
  434. * Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
  435. - moved gdm patch
  436. * Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
  437. - added gdm session control file
  438. * Fri Mar 19 1999 Preston Brown <pbrown@redhat.com>
  439. - added pam-console stuff to kde pam file
  440. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  441. - Injected new description and group.
  442. * Mon Feb 07 1999 Preston Brown <pbrown@redhat.com>
  443. - upgraded to KDE 1.1 final.
  444. * Tue Jan 19 1999 Preston Brown <pbrown@redhat.com>
  445. - updated macros for RPM 3.0, removed red hat logo.
  446. * Tue Jan 05 1999 Preston Brown <pbrown@redhat.com>
  447. - re-merged from Duncan Haldane's stuff