peco-vl.spec 2.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192939495969798
  1. %define pkg_name peco
  2. %define pkg_version 0.5.1
  3. %define pkg_release 1%{?_dist_release}
  4. %global gopath %{_datadir}/gocode
  5. Summary: Simplistic interactive filtering tool
  6. Summary(ja): シンプルな対話式フィルタリングツール
  7. Name: %{pkg_name}
  8. Version: %{pkg_version}
  9. Release: %{pkg_release}
  10. License: MIT License
  11. Group: Applications/Text
  12. URL: https://github.com/peco/peco
  13. Source: https://github.com/peco/peco/archive/v%{version}.tar.gz#/peco-%{version}.tar.gz
  14. BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-root
  15. BuildRequires: golang
  16. BuildRequires: golang(github.com/google/btree)
  17. BuildRequires: golang(github.com/mattn/go-runewidth)
  18. BuildRequires: golang(github.com/jessevdk/go-flags)
  19. BuildRequires: golang(github.com/nsf/termbox-go)
  20. BuildRequires: golang(github.com/pkg/errors)
  21. BuildRequires: golang(github.com/lestrrat/go-pdebug)
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: ara_t
  25. %description
  26. peco is a simplistic interactive filtering tool
  27. based on a python tool, percol, and written in Go.
  28. %description -l ja
  29. pecoはシンプルな対話式フィルタリングツールであり、
  30. Pyhon製のpercolをGo言語で実装したプログラムです。
  31. %prep
  32. %{__rm} -rf ${RPM_BUILD_ROOT}
  33. %setup -q
  34. %build
  35. export BUILD_DIR=$(pwd)/.build
  36. export GOPATH=$BUILD_DIR:%{gopath}
  37. %{__mkdir_p} $BUILD_DIR/src/github.com/peco/peco
  38. %{__cp} -r * $BUILD_DIR/src/github.com/peco/peco
  39. cd $BUILD_DIR/src/github.com/peco/peco
  40. go build cmd/peco/peco.go
  41. %install
  42. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_bindir}
  43. export BUILD_DIR=$(pwd)/.build
  44. cd $BUILD_DIR/src/github.com/peco/peco
  45. %{__install} -m 755 peco ${RPM_BUILD_ROOT}%{_bindir}
  46. %clean
  47. %{__rm} -rf ${RPM_BUILD_ROOT}
  48. %files
  49. %defattr(-, root, root)
  50. %doc LICENSE
  51. %doc README.md Changes
  52. %{_bindir}/
  53. %changelog
  54. * Wed Jun 07 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 0.5.1-1
  55. - update to 0.5.1
  56. - update BuildRequires
  57. * Wed May 11 2016 Toshiaki Ara <ara_t@384.jp> 0.3.6-1
  58. - update to 0.3.6
  59. * Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-5
  60. - correct SPEC file
  61. * Fri Jan 29 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-4
  62. - defile %%{gopath}
  63. * Mon Jan 25 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.5-3
  64. - using golang-* RPM packages for BuildRequires
  65. - stop 'go get' in build section
  66. - update build section
  67. - add LICENSE, README.md and Changes
  68. * Tue Jan 19 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-2
  69. - build with Go
  70. - change spec file
  71. * Sun Jan 17 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-1
  72. - new package