zlib-vl.spec 9.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: The zlib compression and decompression library.
  3. Summary(ja): zlib 圧縮/展開ライブラリ
  4. Name: zlib
  5. Version: 1.2.8
  6. Release: 2%{?_dist_release}
  7. Group: System Environment/Libraries
  8. Source: http://www.zlib.net/zlib-%{version}.tar.xz
  9. # Patch0: zlib-1.2.5-lfs-decls.patch
  10. Requires(post): /sbin/ldconfig
  11. Requires(postun): /sbin/ldconfig
  12. URL: http://www.zlib.net/
  13. License: zlib and Boost
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. %description
  16. The zlib compression library provides in-memory compression and
  17. decompression functions, including integrity checks of the
  18. uncompressed data. This version of the library supports only one
  19. compression method (deflation), but other algorithms may be added
  20. later, which will have the same stream interface. The zlib library is
  21. used by many different system programs.
  22. %description -l ja
  23. zlib圧縮ライブラリーは、メモリ内で圧縮と解凍を行う関数や、解凍後
  24. のデータの整合性チェックを行う関数を提供します。今バージョンのラ
  25. イブラリは「デフレーション(deflation)」という圧縮方法のみをサポ
  26. ートしていますが、今後同じストリームインターフェースを持つ他の圧
  27. 縮方法も追加する予定です。zlibライブラリーは多種のプログラムで使
  28. 用されています。
  29. %package devel
  30. Summary: Header files and libraries for developing apps which will use zlib.
  31. Summary(ja): zlib を使ったプログラム開発に必要なヘッダファイル/ライブラリ
  32. Group: Development/Libraries
  33. Requires: %{name} = %{version}-%{release}
  34. %description devel
  35. The zlib-devel package contains the header files and libraries needed
  36. to develop programs that use the zlib compression and decompression
  37. library.
  38. %package static
  39. Summary: Static libraries for %{name}
  40. Summary(ja): %{name} のスタティックライブラリ
  41. Group: Development/Libraries
  42. Requires: %{name}-devel = %{version}-%{release}
  43. %description static
  44. The zlib-static package contains the static library for %{name}
  45. ## to build compat32 for x86_64 architecture support
  46. %package -n compat32-%{name}
  47. Summary: The zlib compression and decompression library.
  48. Summary(ja): zlib 圧縮/展開ライブラリ
  49. Group: System Environment/Libraries
  50. Requires: %{name} = %{version}-%{release}
  51. Requires(post): /sbin/ldconfig
  52. Requires(postun): /sbin/ldconfig
  53. %description -n compat32-%{name}
  54. The zlib compression library provides in-memory compression and
  55. decompression functions, including integrity checks of the
  56. uncompressed data. This version of the library supports only one
  57. compression method (deflation), but other algorithms may be added
  58. later, which will have the same stream interface. The zlib library is
  59. used by many different system programs.
  60. %description -n compat32-%{name} -l ja
  61. zlib圧縮ライブラリーは、メモリ内で圧縮と解凍を行う関数や、解凍後
  62. のデータの整合性チェックを行う関数を提供します。今バージョンのラ
  63. イブラリは「デフレーション(deflation)」という圧縮方法のみをサポ
  64. ートしていますが、今後同じストリームインターフェースを持つ他の圧
  65. 縮方法も追加する予定です。zlibライブラリーは多種のプログラムで使
  66. 用されています。
  67. %package -n compat32-%{name}-devel
  68. Summary: Header files and libraries for developing apps which will use zlib.
  69. Summary(ja): zlib を使ったプログラム開発に必要なヘッダファイル/ライブラリ
  70. Group: Development/Libraries
  71. Requires: %{name} = %{version}-%{release}
  72. Requires: %{name}-devel = %{version}-%{release}
  73. %description -n compat32-%{name}-devel
  74. The zlib-devel package contains the header files and libraries needed
  75. to develop programs that use the zlib compression and decompression
  76. library.
  77. Install the zlib-devel package if you want to develop applications that
  78. will use the zlib library.
  79. %prep
  80. %setup -q
  81. # %patch0 -p1
  82. %build
  83. mkdir static shared
  84. # build shared lib
  85. CFLAGS="$RPM_OPT_FLAGS -fPIC" ./configure --shared --prefix=%{_prefix}
  86. make %{?_smp_mflags}
  87. mv -f Makefile zconf.h *.o *.so* shared/
  88. # build static lib
  89. CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix}
  90. make %{?_smp_mflags}
  91. mv -f Makefile zconf.h *.o *.a static/
  92. %install
  93. rm -rf ${RPM_BUILD_ROOT}
  94. mkdir -p ${RPM_BUILD_ROOT}%{_prefix}
  95. mv -f shared/* .
  96. make install prefix=${RPM_BUILD_ROOT}%{_prefix}
  97. mv -f Makefile zconf.h *.o *.so* shared/
  98. mv -f static/* .
  99. make install prefix=${RPM_BUILD_ROOT}%{_prefix}
  100. install -m644 zutil.h ${RPM_BUILD_ROOT}%{_includedir}/zutil.h
  101. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man3
  102. install -m644 zlib.3 ${RPM_BUILD_ROOT}%{_mandir}/man3
  103. if [ "%{_prefix}/lib" != "%{_libdir}" ]; then
  104. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  105. mv ${RPM_BUILD_ROOT}%{_prefix}/lib/* ${RPM_BUILD_ROOT}%{_libdir}
  106. rmdir ${RPM_BUILD_ROOT}%{_prefix}/lib
  107. fi
  108. %clean
  109. rm -rf ${RPM_BUILD_ROOT}
  110. %post -p /sbin/ldconfig
  111. %postun -p /sbin/ldconfig
  112. %post -n compat32-%{name} -p /sbin/ldconfig
  113. %postun -n compat32-%{name} -p /sbin/ldconfig
  114. %files
  115. %defattr(-,root,root)
  116. %doc README
  117. %{_libdir}/*.so
  118. %{_libdir}/libz.so.*
  119. %files devel
  120. %defattr(-,root,root)
  121. %doc ChangeLog doc/algorithm.txt
  122. %{_libdir}/pkgconfig/zlib.pc
  123. %{_includedir}/*
  124. %{_mandir}/man3/zlib.3*
  125. %files static
  126. %defattr(-,root,root)
  127. %{_libdir}/*.a
  128. %if %{build_compat32}
  129. %files -n compat32-%{name}
  130. %defattr(-,root,root)
  131. %{_libdir}/*.so
  132. %{_libdir}/libz.so.*
  133. %files -n compat32-%{name}-devel
  134. %defattr(-,root,root)
  135. %{_libdir}/pkgconfig/zlib.pc
  136. %endif
  137. %changelog
  138. * Sat Mar 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.8-2
  139. - moved libz.so into the main package.
  140. * Fri Mar 21 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.8-1
  141. - new upstream release
  142. - changed archive type bz2 to xz
  143. * Fri Oct 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.2.7-1
  144. - new upstream release
  145. - drop patch0 (resolved by upstream)
  146. - use smp flag in make section
  147. * Fri Oct 1 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.5-2
  148. - added patch0 from gentoo to fix zlib.h errors on i686 compiling some applications
  149. * Wed Sep 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.5-1
  150. - new upstream release (built with rpm-4.8.1-1 for pkg-config file)
  151. - changed License: BSD to zlib and Boost
  152. - added %%{_libdir}/pkgconfig/zlib.pc in -devel package
  153. - fixed %%doc files in -devel package
  154. * Fri Mar 05 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-7
  155. - add Requires(post,pre): /sbin/ldconfig
  156. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-6
  157. - rebuilt with gcc-4.4.3-3 on ppc
  158. * Mon Feb 8 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-5
  159. - rebuilt with new toolchain
  160. * Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-4
  161. - split static library to zlib-static
  162. - needed by tuxonice-userui
  163. * Wed Dec 17 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.3-3
  164. - change spec into UTF-8
  165. * Sun May 18 2008 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.3-2
  166. - removed %%if !%%{build_compat32} case condition
  167. * Sat May 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-1
  168. - applied new versioning policy
  169. - rebuilt with new toolchains
  170. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.3-0vl5
  171. - moved macros _lib to /usr/lib/rpm/rpmrc or macros files
  172. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.3-0vl4
  173. - added compat32-* packages for x86_64 architecture support
  174. * Tue Oct 25 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 1.2.3-0vl3
  175. - added compat32- packages for x86_64 architecture support
  176. * Tue Oct 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl2
  177. - clean up specfile (do not build twice..)
  178. * Tue Jul 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
  179. - new upstream release
  180. * Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2.2-0vl1
  181. - new upstream release
  182. - add Patch1 for CAN-2005-2096
  183. * Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
  184. - new upstream version
  185. - add translated descriptions (thanks to spec file translation project)
  186. * Sun Apr 06 2003 Satoshi MACHINO <machino@vinelinux.org> 1.1.4-0vl3
  187. - fixed buffer overrun on gzprintf
  188. -- added zlib-1.1.4-vsnprintf.patch from http://archives.neohapsis.com/archives/bugtraq/2003-02/0290.html
  189. * Fri Sep 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.4-0vl2
  190. - changed URL to more preferable site
  191. * Tue Mar 12 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.1.4-0vl1
  192. - upstream release
  193. * Tue Dec 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  194. - 1.1.3-14vl1
  195. - based on 1.1.3-14 from Rawhide
  196. - added Japanese summary
  197. * Fri Sep 15 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  198. - add -fPIC for shared libs (patch by Fritz Elfert)
  199. * Thu Sep 7 2000 Jeff Johnson <jbj@redhat.com>
  200. - on 64bit systems, make sure libraries are located correctly.
  201. * Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
  202. - summaries from specspo.
  203. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  204. - automatic rebuild
  205. * Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
  206. - rebuild
  207. * Tue Jun 13 2000 Jeff Johnson <jbj@redhat.com>
  208. - FHS packaging to build on solaris2.5.1.
  209. * Wed Jun 07 2000 Trond Eivind Glomsr <teg@redhat.com>
  210. - use %%{_mandir} and %%{_tmppath}
  211. * Fri May 12 2000 Trond Eivind Glomsr <teg@redhat.com>
  212. - updated URL and source location
  213. - moved README to main package
  214. * Mon Feb 7 2000 Jeff Johnson <jbj@redhat.com>
  215. - compress man page.
  216. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  217. - auto rebuild in the new build environment (release 5)
  218. * Wed Sep 09 1998 Cristian Gafton <gafton@redhat.com>
  219. - link against glibc
  220. * Mon Jul 27 1998 Jeff Johnson <jbj@redhat.com>
  221. - upgrade to 1.1.3
  222. * Fri May 08 1998 Prospector System <bugs@redhat.com>
  223. - translations modified for de, fr, tr
  224. * Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
  225. - upgraded to 1.1.2
  226. - buildroot
  227. * Tue Oct 07 1997 Donnie Barnes <djb@redhat.com>
  228. - added URL tag (down at the moment so it may not be correct)
  229. - made zlib-devel require zlib
  230. * Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
  231. - built against glibc