yajl-vl.spec 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140
  1. Name: yajl
  2. Summary: Yet Another JSON Library (YAJL)
  3. Version: 2.0.4
  4. Release: 1%{?_dist_release}
  5. Group: System Environment/Libraries
  6. License: ISC
  7. URL: http://lloyd.github.com/yajl/
  8. #
  9. # NB, upstream does not provide pre-built tar.gz downloads. Instead
  10. # they make you use the 'on the fly' generated tar.gz from GITHub's
  11. # web interface
  12. #
  13. # The Source0 for any version is obtained by a URL
  14. #
  15. # http://github.com/lloyd/yajl/tarball/1.0.7
  16. #
  17. # Which causes a download of a archive named after
  18. # the GIT hash corresponding to the version tag
  19. #
  20. # eg lloyd-yajl-45a1bdb.tar.gz
  21. #
  22. # NB even though the tar.gz is generated on the fly by GITHub it
  23. # will always have identical md5sum
  24. #
  25. # So for new versions, update 'githash' to match the hash of the
  26. # GIT tag associated with updated 'Version:' field just above
  27. %global githash fee1ebe
  28. Source0: lloyd-%{name}-%{version}-0-g%{githash}.tar.gz
  29. Patch1: lloyd-%{name}-%{version}-pkgconfig-location.patch
  30. Patch2: lloyd-%{name}-%{version}-pkgconfig-includedir.patch
  31. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  32. BuildRequires: cmake
  33. %description
  34. Yet Another JSON Library. YAJL is a small event-driven
  35. (SAX-style) JSON parser written in ANSI C, and a small
  36. validating JSON generator.
  37. %package devel
  38. Summary: Libraries, includes, etc to develop with YAJL
  39. Group: Development/Libraries
  40. Requires: %{name} = %{version}-%{release}
  41. %description devel
  42. Yet Another JSON Library. YAJL is a small event-driven
  43. (SAX-style) JSON parser written in ANSI C, and a small
  44. validating JSON generator.
  45. This sub-package provides the libraries and includes
  46. necessary for developing against the YAJL library
  47. %prep
  48. %setup -q -n lloyd-%{name}-%{githash}
  49. %patch1 -p1
  50. %patch2 -p1
  51. %build
  52. # NB, we are not using upstream's 'configure'/'make'
  53. # wrapper, instead we use cmake directly to better
  54. # align with Fedora standards
  55. mkdir build
  56. cd build
  57. %cmake ..
  58. make VERBOSE=1 %{?_smp_mflags}
  59. %install
  60. rm -rf %{buildroot}
  61. cd build
  62. make install DESTDIR=%{buildroot}
  63. # No static libraries
  64. rm -f %{buildroot}%{_libdir}/libyajl_s.a
  65. %check
  66. cd test
  67. ./run_tests.sh
  68. %clean
  69. rm -rf %{buildroot}
  70. %post -p /sbin/ldconfig
  71. %postun -p /sbin/ldconfig
  72. %files
  73. %defattr(-,root,root,-)
  74. %doc COPYING ChangeLog README TODO
  75. %{_bindir}/json_reformat
  76. %{_bindir}/json_verify
  77. %{_libdir}/libyajl.so.2
  78. %{_libdir}/libyajl.so.2.*
  79. %files devel
  80. %defattr(-,root,root,-)
  81. %doc COPYING
  82. %dir %{_includedir}/yajl
  83. %{_includedir}/yajl/yajl_common.h
  84. %{_includedir}/yajl/yajl_gen.h
  85. %{_includedir}/yajl/yajl_parse.h
  86. %{_includedir}/yajl/yajl_tree.h
  87. %{_includedir}/yajl/yajl_version.h
  88. %{_libdir}/libyajl.so
  89. %{_libdir}/pkgconfig/yajl.pc
  90. %changelog
  91. * Tue Oct 29 2013 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.4-1
  92. - updated to 2.0.4 release
  93. - Patch1 and Patch2 imported from Fedora
  94. - fix License tag: s/BSD/ISC/
  95. * Wed Mar 28 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-2
  96. - rebuild
  97. * Sun Nov 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.1-1
  98. - updated to 2.0.1
  99. * Thu Aug 18 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.12-2
  100. - Initial build for Vine Linux
  101. * Tue May 3 2011 Daniel P. Berrange <berrange@redhat.com> - 1.0.12-1
  102. - Update to 1.0.12 release
  103. * Fri Dec 17 2010 Daniel P. Berrange <berrange@redhat.com> - 1.0.11-1
  104. - Update to 1.0.11 release
  105. * Mon Jan 11 2010 Daniel P. Berrange <berrange@redhat.com> - 1.0.7-3
  106. - Fix ignoring of cflags (rhbz #547500)
  107. * Tue Dec 8 2009 Daniel P. Berrange <berrange@redhat.com> - 1.0.7-2
  108. - Change use of 'define' to 'global'
  109. * Mon Dec 7 2009 Daniel P. Berrange <berrange@redhat.com> - 1.0.7-1
  110. - Initial Fedora package