wxPython-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298
  1. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. %define buildflags WXPORT=gtk2 UNICODE=1
  4. Name: wxPython
  5. Version: 2.8.12.1
  6. Release: 3%{?dist}
  7. Summary: GUI toolkit for the Python programming language
  8. Group: Development/Languages
  9. License: LGPLv2+ and wxWidgets
  10. URL: http://www.wxpython.org/
  11. Source0: http://downloads.sourceforge.net/wxpython/%{name}-src-%{version}.tar.bz2
  12. # fix aui imports
  13. # http://trac.wxwidgets.org/ticket/12107
  14. Patch0: wxPython-2.8.12.0-aui.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. # make sure to keep this updated as appropriate
  17. BuildRequires: wxGTK-devel >= 2.8.11
  18. BuildRequires: python-devel
  19. BuildRequires: gtk2-devel
  20. BuildRequires: mesa-libGL-devel mesa-libGLU-devel
  21. # packages should depend on "wxPython", not "wxPythonGTK2", but in case
  22. # one does, here's the provides for it.
  23. Provides: wxPythonGTK2 = %{version}-%{release}
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. %description
  27. wxPython is a GUI toolkit for the Python programming language. It allows
  28. Python programmers to create programs with a robust, highly functional
  29. graphical user interface, simply and easily. It is implemented as a Python
  30. extension module (native code) that wraps the popular wxWindows cross
  31. platform GUI library, which is written in C++.
  32. %package devel
  33. Group: Development/Libraries
  34. Summary: Development files for wxPython add-on modules
  35. Requires: %{name} = %{version}-%{release}
  36. Requires: wxGTK-devel >= 2.8.11
  37. %description devel
  38. This package includes C++ header files and SWIG files needed for developing
  39. add-on modules for wxPython. It is NOT needed for development of most
  40. programs which use the wxPython toolkit.
  41. %package docs
  42. Group: Documentation
  43. Summary: Documentation and samples for wxPython
  44. Requires: %{name} = %{version}-%{release}
  45. BuildArch: noarch
  46. %description docs
  47. Documentation, samples and demo application for wxPython.
  48. %prep
  49. %setup -q -n wxPython-src-%{version}
  50. %patch0 -p1 -b .aui
  51. # fix libdir otherwise additional wx libs cannot be found
  52. %__sed -i -e 's|/usr/lib|%{_libdir}|' wxPython/config.py
  53. %build
  54. # Just build the wxPython part, not all of wxWindows which we already have
  55. # in Fedora
  56. cd wxPython
  57. # included distutils is not multilib aware; use normal
  58. %__rm -rf distutils
  59. python setup.py %{buildflags} build
  60. %install
  61. %__rm -rf $RPM_BUILD_ROOT
  62. cd wxPython
  63. python setup.py %{buildflags} install --root=$RPM_BUILD_ROOT
  64. # this is a kludge....
  65. %if "%{python_sitelib}" != "%{python_sitearch}"
  66. %__mv $RPM_BUILD_ROOT%{python_sitelib}/wx.pth $RPM_BUILD_ROOT%{python_sitearch}
  67. %__mv $RPM_BUILD_ROOT%{python_sitelib}/wxversion.py* $RPM_BUILD_ROOT%{python_sitearch}
  68. %endif
  69. %clean
  70. %__rm -rf $RPM_BUILD_ROOT
  71. %files
  72. %defattr(-,root,root,-)
  73. %doc wxPython/licence
  74. %{_bindir}/*
  75. %{python_sitearch}/wx.pth
  76. %{python_sitearch}/wxversion.py*
  77. %dir %{python_sitearch}/wx-2.8-gtk2-unicode/
  78. %{python_sitearch}/wx-2.8-gtk2-unicode/wx
  79. %{python_sitearch}/wx-2.8-gtk2-unicode/wxPython
  80. %{python_sitelib}/*egg-info
  81. %{python_sitearch}/wx-2.8-gtk2-unicode/*egg-info
  82. %files devel
  83. %defattr(-,root,root,-)
  84. %dir %{_includedir}/wx-2.8/wx/wxPython
  85. %{_includedir}/wx-2.8/wx/wxPython/*.h
  86. %dir %{_includedir}/wx-2.8/wx/wxPython/i_files
  87. %{_includedir}/wx-2.8/wx/wxPython/i_files/*.i
  88. %{_includedir}/wx-2.8/wx/wxPython/i_files/*.py*
  89. %{_includedir}/wx-2.8/wx/wxPython/i_files/*.swg
  90. %files docs
  91. %defattr(-,root,root,-)
  92. %doc wxPython/docs wxPython/demo wxPython/samples
  93. %changelog
  94. * Fri Aug 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.12.1-3
  95. - s/wx-gtk2/wxGTK/g
  96. * Sun Jul 29 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.12.1-2
  97. - rebuilt with wx-gtk2-devel-2.8.12-2
  98. * Fri Apr 6 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.12.1-1
  99. - updated to 2.8.12.1
  100. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.0-2
  101. - rebuild with python-2.7.2
  102. * Sun May 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.12.0-1
  103. - initial build based on Fedora rawhide
  104. * Tue Apr 26 2011 Dan Horák <dan[at]danny.cz> - 2.8.12.0-1
  105. - update to 2.8.12.0 (#699207)
  106. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.11.0-5
  107. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  108. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 2.8.11.0-4
  109. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  110. * Mon Jul 12 2010 Dan Horák <dan@danny.cz> - 2.8.11.0-3
  111. - rebuilt against wxGTK-2.8.11-2
  112. * Sun Jul 11 2010 Lubomir Rintel <lkundrak@v3.sk> - 2.8.11.0-2
  113. - Include egg-info when build on recent RHEL
  114. * Mon May 31 2010 Dan Horák <dan[at]danny.cz> - 2.8.11.0-1
  115. - update to 2.8.11.0 (#593837, #595936, #597639)
  116. * Sun May 2 2010 Dan Horák <dan[at]danny.cz> - 2.8.10.1-3
  117. - rebuilt with wxGTK 2.8.11
  118. * Wed Mar 17 2010 Dan Horák <dan[at]danny.cz> - 2.8.10.1-2
  119. - add missing module (#573961)
  120. * Sat Jan 16 2010 Dan Horák <dan[at]danny.cz> - 2.8.10.1-1
  121. - update to 2.8.10.1
  122. - backport to wxGTK 2.8.10 API
  123. - cleaned up BRs
  124. * Thu Jan 7 2010 Hans de Goede <hdegoede@redhat.com> - 2.8.9.2-4
  125. - Change python_foo macros to use %%global as the new rpm will break
  126. using %%define here, see:
  127. https://www.redhat.com/archives/fedora-devel-list/2010-January/msg00093.html
  128. * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.9.2-3
  129. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  130. * Fri Apr 10 2009 Dan Horák <dan[at]danny.cz> - 2.8.9.2-2
  131. - add patch to fix compile failure for contrib/gizmos/_treelist.i
  132. * Fri Apr 10 2009 Dan Horák <dan[at]danny.cz> - 2.8.9.2-1
  133. - update to 2.8.9.2
  134. - create noarch docs subpackage
  135. * Thu Mar 5 2009 Lubomir Rintel <lkundrak@v3.sk> - 2.8.9.1-4
  136. - Rebuilt for newer wxgtk package
  137. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.9.1-3
  138. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  139. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.8.9.1-2
  140. - Rebuild for Python 2.6
  141. * Tue Sep 30 2008 Dan Horak <dan[at]danny.cz> - 2.8.9.1-1
  142. - update to 2.8.9.1
  143. - fix libdir for additional wx libraries (#306761)
  144. * Mon Sep 29 2008 Dan Horak <dan[at]danny.cz> - 2.8.9.0-1
  145. - update to 2.8.9.0
  146. * Sat Sep 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.8.8.0-2
  147. - fix license tag
  148. * Thu Jul 31 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.8.0-1
  149. - update to 2.8.8.0 (bug #457408)
  150. - a fix for bug #450073 is included in the upstream release, so
  151. dropping that patch.
  152. * Thu Jun 12 2008 Hans de Goede <j.w.r.degoede@hhs.nl> - 2.8.7.1-5
  153. - Fix an attribute error when importing wxPython (compat) module
  154. (redhat bugzilla 450073, 450074)
  155. * Sat Jun 6 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.7.1-4
  156. - gratuitously bump package release number to work around build system
  157. glitch. again, but it will work this time.
  158. * Wed Jun 4 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.7.1-3
  159. - gratuitously bump package release number to work around build system
  160. glitch
  161. * Thu Feb 21 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.7.1-2
  162. - include egg-info files for fedora 9 or greater
  163. * Wed Feb 20 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.7.1-1
  164. - update to 2.8.7.1
  165. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.8.4.0-3
  166. - Autorebuild for GCC 4.3
  167. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.8.4.0-2
  168. - Rebuild for selinux ppc32 issue.
  169. * Wed Jul 11 2007 Matthew Miller <mattdm@mattdm.org> - 2.8.4.0-1
  170. - update to 2.8.4.0
  171. - obsolete compat-wxPythonGTK
  172. * Sun Apr 15 2007 Matthew Miller <mattdm@mattdm.org> - 2.8.3.0-1
  173. - update to 2.8.3.0
  174. * Fri Dec 15 2006 Matthew Miller <mattdm@mattdm.org> - 2.8.0.1-1
  175. - update to 2.8.0.1
  176. - make buildrequire wxGTK of version-wxpythonsubrelease
  177. - add wxaddons to filelist
  178. * Mon Dec 11 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.2-3
  179. - bump release for rebuild against python 2.5.
  180. * Mon Aug 28 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.2-2
  181. - bump release for FC6 rebuild
  182. * Thu Apr 13 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.2-1
  183. - version 2.6.3.2
  184. - move wxversion.py _into_ lib64. Apparently that's the right thing to do. :)
  185. - upstream tarball no longer includes embedded.o (since I finally got around
  186. to pointing that out to the developers instead of just kludging it away.)
  187. - buildrequires to just libGLU-devel instead of mesa-libGL-devel
  188. * Fri Mar 31 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.0-4
  189. - grr. bump relnumber.
  190. * Fri Mar 31 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.0-3
  191. - oh yeah -- wxversion.py not lib64.
  192. * Fri Mar 31 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.0-2
  193. - buildrequires mesa-libGLU-devel
  194. * Thu Mar 30 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.0-1
  195. - update to 2.6.3.0
  196. - wxGTK and wxPython versions are inexorably linked; make BuildRequires
  197. be exact, rather than >=.
  198. - make devel subpackage as per comment #7 in bug #163440.
  199. * Thu Nov 24 2005 Matthew Miller <mattdm@mattdm.org> - 2.6.1.0-1
  200. - update to 2.6.0.0
  201. - merge in changes from current extras 2.4.x package
  202. - Happy Thanksgiving
  203. - build animate extention again -- works now.
  204. * Thu Apr 28 2005 Matthew Miller <mattdm@bu.edu> - 2.6.0.0-bu45.1
  205. - get rid of accidental binaries in source tarball -- they generates
  206. spurious dependencies and serve no purpose
  207. - update to 2.6.0.0 and build for Velouria
  208. - switch to Fedora Extras base spec file
  209. - enable gtk2 and unicode and all the code stuff (as FE does)
  210. - disable BUILD_ANIMATE extension from contrib -- doesn't build
  211. - files are in a different location now -- adjust to that
  212. - zap include files (needed only for building wxPython 3rd-party modules),
  213. because I don't think this is likely to be very useful. Other option
  214. would be to create a -devel package, but I think that'd be confusing.
  215. * Tue Feb 08 2005 Thorsten Leemhuis <fedora at leemhuis dot info> 0:2.4.2.4-4
  216. - remove included disutils - it is not multilib aware; this
  217. fixes build on x86_64
  218. * Tue Jan 06 2004 Panu Matilainen <pmatilai@welho.com> 0:2.4.2.4-0.fdr.3
  219. - rename package to wxPythonGTK2, provide wxPython (see bug 927)
  220. - dont ship binaries in /usr/share
  221. * Thu Nov 20 2003 Panu Matilainen <pmatilai@welho.com> 0:2.4.2.4-0.fdr.2
  222. - add missing buildrequires: python-devel, wxGTK2-gl
  223. * Sun Nov 02 2003 Panu Matilainen <pmatilai@welho.com> 0:2.4.2.4-0.fdr.1
  224. - Initial RPM release.
  225. ~