wxGlade-vl.spec 5.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177
  1. %define tipversion 20110516
  2. %define hgnode 96ff5a770485
  3. Summary: A wxWidgets/wxPython/wxPerl GUI designer
  4. Name: wxGlade
  5. Version: 0.6.3
  6. Release: 1%{?tipversion:.tip%tipversion}%{?_dist_release}
  7. #Source0: http://downloads.sourceforge.net/wxglade/%{name}-%{version}.tar.gz
  8. ## renamed https://bitbucket.org/agriggio/wxglade/get/tip.tar.bz2 to Source0:
  9. Source0: wxGlade-0.6.3%{?tipversion:.tip%tipversion}.tar.bz2
  10. Source1: wxglade.desktop
  11. Source2: wxglade.png
  12. License: MIT
  13. URL: http://wxglade.sourceforge.net/
  14. Group: Development/Tools
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. BuildArch: noarch
  17. BuildRequires: desktop-file-utils
  18. Requires: python >= 2.2
  19. Requires: wxPython >= 2.6
  20. Distribution: Vine
  21. Vendor: Project Vine
  22. %description
  23. wxGlade is a GUI designer written in Python with the popular GUI
  24. toolkit wxPython, that helps you create wxWidgets/wxPython user
  25. interfaces. At the moment it can generate Python, C++, Perl and XRC
  26. (wxWidgets' XML resources) code.
  27. %prep
  28. %setup -q -n agriggio-wxglade-%{hgnode}
  29. %build
  30. # nothing to do
  31. %install
  32. # cleanup
  33. %__rm -rf $RPM_BUILD_ROOT
  34. # make dirs
  35. %__install -m 755 -d $RPM_BUILD_ROOT%{_bindir}
  36. %__install -m 755 -d $RPM_BUILD_ROOT%{_datadir}/%{name}
  37. %__install -m 755 -d $RPM_BUILD_ROOT%{_datadir}/%{name}/codegen
  38. %__install -m 755 -d $RPM_BUILD_ROOT%{_datadir}/%{name}/edit_sizers
  39. %__install -m 755 -d $RPM_BUILD_ROOT%{_datadir}/%{name}/res
  40. %__install -m 755 -d $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
  41. %__install -m 755 -d $RPM_BUILD_ROOT%{_datadir}/%{name}/icons/gtk
  42. # copy files needed at runtime
  43. %__install -m644 -p *.py $RPM_BUILD_ROOT%{_datadir}/%{name}
  44. %__install -m644 -p codegen/* $RPM_BUILD_ROOT%{_datadir}/%{name}/codegen
  45. %__install -m644 -p edit_sizers/* $RPM_BUILD_ROOT%{_datadir}/%{name}/edit_sizers
  46. %__install -m644 -p res/* $RPM_BUILD_ROOT%{_datadir}/%{name}/res
  47. %__install -m644 -p icons/*.ico icons/*.png icons/*.xpm $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
  48. %__install -m644 -p icons/gtk/*.xpm $RPM_BUILD_ROOT%{_datadir}/%{name}/icons/gtk
  49. %__cp -Rp widgets $RPM_BUILD_ROOT%{_datadir}/%{name}/widgets
  50. find docs -type f -exec chmod 644 {} \;
  51. # make a launcher script
  52. cat > $RPM_BUILD_ROOT%{_bindir}/wxglade <<EOF
  53. #!/bin/bash
  54. exec python %{_datadir}/%{name}/wxglade.py "\$@"
  55. EOF
  56. chmod +x $RPM_BUILD_ROOT%{_bindir}/wxglade
  57. # install desktop entry
  58. desktop-file-install --vendor=vine \
  59. --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
  60. %{SOURCE1}
  61. %__install -m 755 -d $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
  62. %__install -m 644 -p %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
  63. # docs symlink
  64. %__ln_s %{_docdir}/%{name}-%{version}/docs $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
  65. %post
  66. touch --no-create %{_datadir}/icons/hicolor || :
  67. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  68. update-desktop-database %{_datadir}/applications &>/dev/null || :
  69. %postun
  70. touch --no-create %{_datadir}/icons/hicolor || :
  71. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  72. update-desktop-database %{_datadir}/applications &>/dev/null || :
  73. %clean
  74. %__rm -rf $RPM_BUILD_ROOT
  75. %files
  76. %defattr(-,root,root,-)
  77. %doc docs CHANGES.txt README.txt TODO.txt credits.txt license.txt
  78. %{_bindir}/wxglade
  79. %{_datadir}/%{name}
  80. %{_datadir}/icons/hicolor/32x32/apps/*
  81. %{_datadir}/applications/*
  82. %changelog
  83. * Mon May 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1.tip20110516
  84. - initial build
  85. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.3tip20100625-3
  86. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  87. * Wed Aug 11 2010 David Malcolm <dmalcolm@redhat.com> - 0.6.3tip20100625-2
  88. - recompiling .py files against Python 2.7 (rhbz#623417)
  89. * Fri Jun 25 2010 ZC Miao <hellwolf.misty@gmail.com> - 0.6.3tip20100625-1
  90. - update to tip20100625
  91. * Sun Jun 6 2010 ZC Miao <hellwolf.misty@gmail.com> - 0.6.3tip20091130-2
  92. - update source
  93. * Mon Nov 30 2009 ZC Miao <hellwolf.misty@gmail.com> - 0.6.3tip20091130-1
  94. - update to tip version
  95. * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.3-4
  96. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  97. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.3-3
  98. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  99. * Sat May 24 2008 ZC Miao <hellwolf.misty@gmail.com> - 0.6.3-2
  100. - update to 0.6.3
  101. * Sat Nov 24 2007 ZC Miao <hellwolf.misty@gmail.com> - 0.6.1-1
  102. - update to 0.6.1
  103. - remove docs path patch, add a docs symlink instead
  104. * Thu Jul 19 2007 ZC Miao <hellwolf.misty@gmail.com> - 0.5-6
  105. - 248795 , patch for launch help docs correctly
  106. * Mon Apr 16 2007 ZC Miao <hellwolf.misty@gmail.com> - 0.5-5
  107. - update to fix EVR problem
  108. * Sun Apr 15 2007 ZC Miao <hellwolf.misty@gmail.com> - 0.5-2
  109. - file permissions with install command
  110. * Sun Apr 15 2007 ZC Miao <hellwolf.misty@gmail.com> - 0.5-1
  111. - update to 0.5
  112. - launch script with quoted $@
  113. - name to wxGlade
  114. * Tue Feb 27 2007 ZC Miao <hellwolf.misty@gmail.com> - 0.4.1-3
  115. - Desktop entry do not need version number
  116. - remove some comments
  117. * Sun Feb 25 2007 ZC Miao <hellwolf.misty@gmail.com> - 0.4.1-2
  118. - install icon to hicolor directory
  119. - change name to wxglade
  120. - BuildRequires desktop-file-utils
  121. - remove Application category in desktop file
  122. - remove some macro redefination
  123. * Fri Feb 16 2007 ZC Miao <hellwolf.misty@gmail.com> - 0.4.1-2
  124. - Add missing icons
  125. * Fri Feb 16 2007 ZC Miao <hellwolf.misty@gmail.com> - 0.4.1-1
  126. - update to 0.4.1
  127. * Wed Oct 27 2004 Alberto Griggio <agriggio@users.sf.net> 0.3.5-1
  128. - Updated to version 0.3.5
  129. * Wed Mar 10 2004 Alberto Griggio <agriggio@users.sf.net> 0.3.4-1
  130. - Updated to version 0.3.4
  131. * Wed Mar 10 2004 Alberto Griggio <albgrig@tiscalinet.it> 0.3.2-1
  132. - Updated to version 0.3.2
  133. * Tue Sep 02 2003 Alberto Griggio <albgrig@tiscalinet.it> 0.3.1-1
  134. - Updated to version 0.3.1
  135. * Fri Aug 29 2003 Robin Dunn <robind@alldunn.com> 0.3-5
  136. - Initial version