wxGTK3-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235
  1. %global srcname wxWidgets
  2. %global wxgtkname wxGTK3
  3. %global wxbasename wxBase3
  4. %global gtkver 3
  5. Name: %{wxgtkname}
  6. Version: 3.0.2
  7. Release: 2%{?_dist_release}
  8. Summary: GTK port of the wxWidgets GUI library
  9. License: wxWidgets
  10. Group: System Environment/Libraries
  11. URL: http://www.wxwidgets.org/
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. Source0: http://downloads.sf.net/wxwindows/%{srcname}-%{version}.tar.bz2
  15. ##Source1: http://downloads.sf.net/wxwindows/%{srcname}-%{version}-docs-html.tar.bz2
  16. Source10: wx-config
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. BuildRequires: gtk%{gtkver}-devel
  19. #Note webkitgtk (GTK2) does not appear to be supported
  20. BuildRequires: WebKit3-gtk-devel
  21. BuildRequires: zlib-devel
  22. BuildRequires: libpng-devel
  23. BuildRequires: libjpeg-turbo-devel
  24. BuildRequires: libtiff-devel
  25. BuildRequires: expat-devel
  26. BuildRequires: SDL-devel
  27. BuildRequires: libgnomeprintui-devel
  28. BuildRequires: libGLU-devel
  29. BuildRequires: libSM-devel
  30. BuildRequires: gstreamer-plugins-base-devel
  31. BuildRequires: GConf2-devel
  32. BuildRequires: gettext
  33. BuildRequires: cppunit-devel
  34. BuildRequires: libmspack-devel
  35. Provides: %{srcname} = %{version}-%{release}
  36. Requires: %{wxbasename}%{?_isa} = %{version}-%{release}
  37. %description
  38. wxWidgets is the GTK port of the C++ cross-platform wxWidgets
  39. GUI library, offering classes for all common GUI controls as well as a
  40. comprehensive set of helper classes for most common application tasks,
  41. ranging from networking to HTML display and image manipulation.
  42. %package devel
  43. Group: Development/Libraries
  44. Summary: Development files for the wxGTK3 library
  45. Requires: %{name}%{?_isa} = %{version}-%{release}
  46. Requires: %{wxbasename} = %{version}-%{release}
  47. Requires: gtk%{gtkver}-devel
  48. Requires: libGLU-devel
  49. Provides: %{srcname}-devel = %{version}-%{release}
  50. %description devel
  51. This package include files needed to link with the wxGTK3 library.
  52. wxWidgets is the GTK port of the C++ cross-platform wxWidgets
  53. GUI library, offering classes for all common GUI controls as well as a
  54. comprehensive set of helper classes for most common application tasks,
  55. ranging from networking to HTML display and image manipulation.
  56. %package -n %{wxbasename}
  57. Summary: Non-GUI support classes from the wxWidgets library
  58. Group: System Environment/Libraries
  59. %description -n %{wxbasename}
  60. Every wxWidgets application must link against this library. It contains
  61. mandatory classes that any wxWidgets code depends on (like wxString) and
  62. portability classes that abstract differences between platforms. wxBase can
  63. be used to develop console mode applications -- it does not require any GUI
  64. libraries or the X Window System.
  65. #%package docs
  66. #Group: Development/Libraries
  67. #Summary: Documentation for the wxGTK3 library
  68. #Requires: %{name} = %{version}-%{release}
  69. #Provides: %{srcname}-docs = %{version}-%{release}
  70. #BuildArch: noarch
  71. #%description docs
  72. #This package provides documentation for the %{srcname} library.
  73. %prep
  74. %setup -q -n %{srcname}-%{version}
  75. # in case of gtk3
  76. %if %{gtkver} == 3
  77. sed -i -e 's|gtk2|gtk3|' %{SOURCE10}
  78. %endif
  79. # patch some installed files to avoid conflicts with 2.8.*
  80. sed -i -e 's|aclocal)|aclocal/wxwin3.m4)|' Makefile.in
  81. sed -i -e 's|wxstd.mo|wxstd3.mo|' Makefile.in
  82. sed -i -e 's|wxmsw.mo|wxmsw3.mo|' Makefile.in
  83. # rename docs directory
  84. #mv %{srcname}-%{version} html
  85. sed -i -e 's|/usr/lib\b|%{_libdir}|' wx-config.in configure
  86. # fix plugin dir for 64-bit
  87. sed -i -e 's|/lib|/%{_lib}|' src/unix/stdpaths.cpp
  88. %build
  89. # likely still dereferences type-punned pointers
  90. CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  91. CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  92. # fix unused-direct-shlib-dependency error:
  93. export LDFLAGS="-Wl,--as-needed"
  94. %configure \
  95. --with-gtk=%{gtkver} \
  96. --with-opengl \
  97. --with-sdl \
  98. --with-gnomeprint \
  99. --with-libmspack \
  100. --enable-intl \
  101. --enable-no_deps \
  102. --disable-rpath \
  103. --enable-ipv6 \
  104. --enable-utf8 \
  105. make %{?_smp_mflags}
  106. %install
  107. %makeinstall
  108. # install our multilib-aware wrapper
  109. rm %{buildroot}%{_bindir}/wx-config
  110. rm %{buildroot}%{_bindir}/wxrc
  111. install -p -m 755 %{SOURCE10} %{buildroot}%{_bindir}/wx-config-3.0
  112. # move bakefiles to avoid conflicts with 2.8.*
  113. mkdir %{buildroot}%{_datadir}/bakefile/presets/wx3
  114. mv %{buildroot}%{_datadir}/bakefile/presets/*.* %{buildroot}%{_datadir}/bakefile/presets/wx3
  115. %find_lang wxstd3
  116. %find_lang wxmsw3
  117. cat wxmsw3.lang >> wxstd3.lang
  118. %check
  119. pushd tests
  120. make %{?_smp_mflags} test
  121. popd
  122. %post -p /sbin/ldconfig
  123. %postun -p /sbin/ldconfig
  124. %post -n %{wxbasename} -p /sbin/ldconfig
  125. %postun -n %{wxbasename} -p /sbin/ldconfig
  126. %files -f wxstd3.lang
  127. %doc docs/changes.txt docs/gpl.txt docs/lgpl.txt docs/licence.txt
  128. %doc docs/licendoc.txt docs/preamble.txt docs/readme.txt
  129. %{_libdir}/libwx_gtk%{gtkver}u_adv-*.so.*
  130. %{_libdir}/libwx_gtk%{gtkver}u_aui-*.so.*
  131. %{_libdir}/libwx_gtk%{gtkver}u_core-*.so.*
  132. %{_libdir}/libwx_gtk%{gtkver}u_html-*.so.*
  133. %{_libdir}/libwx_gtk%{gtkver}u_gl-*.so.*
  134. %{_libdir}/libwx_gtk%{gtkver}u_media-*.so.*
  135. %{_libdir}/libwx_gtk%{gtkver}u_propgrid-*.so.*
  136. %{_libdir}/libwx_gtk%{gtkver}u_qa-*.so.*
  137. %{_libdir}/libwx_gtk%{gtkver}u_ribbon-*.so.*
  138. %{_libdir}/libwx_gtk%{gtkver}u_richtext-*.so.*
  139. %{_libdir}/libwx_gtk%{gtkver}u_stc-*.so.*
  140. %if %{gtkver} == 3
  141. %{_libdir}/libwx_gtk%{gtkver}u_webview-*.so.*
  142. %endif
  143. %{_libdir}/libwx_gtk%{gtkver}u_xrc-*.so.*
  144. %files devel
  145. %{_bindir}/wx-config*
  146. %{_bindir}/wxrc-3.0
  147. %{_includedir}/wx-3.0
  148. %{_libdir}/libwx_*.so
  149. %{_libdir}/wx
  150. %{_datadir}/aclocal/wxwin3.m4
  151. %{_datadir}/bakefile/presets/wx3/
  152. %files -n %{wxbasename}
  153. %doc docs/changes.txt docs/gpl.txt docs/lgpl.txt docs/licence.txt
  154. %doc docs/licendoc.txt docs/preamble.txt docs/readme.txt
  155. %{_libdir}/libwx_baseu-*.so.*
  156. %{_libdir}/libwx_baseu_net-*.so.*
  157. %{_libdir}/libwx_baseu_xml-*.so.*
  158. #%files docs
  159. #%doc html
  160. %changelog
  161. * Fri Jul 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.0.2-2
  162. - rebuilt with new toolchain.
  163. * Sat Nov 29 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.2-1
  164. - new upstream release
  165. * Fri Sep 05 2014 Toshiharu Kudoh <kudoh@vinelinux.org> - 3.0.1-1
  166. - initial build for Vine Linux
  167. * Sat Jul 5 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.1-1
  168. - Bump to 3.0.1 RH#1076617
  169. * Tue Mar 18 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-6
  170. - Removed disable-catch_segvs, see RH#1076617
  171. * Mon Mar 17 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-5
  172. - Renable combat28 - without it causes bugs RH#1076617 and a few others
  173. * Wed Feb 19 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-4
  174. - Fixed GTK3 bug with wx-config
  175. - Fixed a unused-direct-shlib-dependency error
  176. * Mon Feb 17 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-3
  177. - Added patch to avoid build fail on gtk 3.10+
  178. - Reverted patching to make devel package compatible with wxGTK-devel
  179. - Added combatibility for RHEL 6+
  180. - Changed all mention of GTK3 and GTK2 to GTK for consistency
  181. * Mon Feb 10 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-2
  182. - Changed to build against gtk3
  183. - Add webkit to build requires
  184. - Removed patching to make devel package compatible with wxGTK-devel
  185. - Disable 2.8.* combatibility (redundant functionality)
  186. * Sat Jan 4 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-1
  187. - Initial build of wxwidgets version 3, mostly based on wxGTK spec