wxGTK-vl.spec 7.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251
  1. %define name wxGTK
  2. %define wxconfig gtk2-unicode-release-2.8
  3. %define wx_ver 2.8
  4. Summary: The GTK+ 2 port of the wxWidgets library
  5. Summary(ja): wxWidgets ライブラリーの GTK+ 2 ポート
  6. Name: %{name}
  7. Version: %{wx_ver}.12
  8. Release: 7%{?_dist_release}
  9. License: wxWindows License
  10. Group: System Environment/Libraries
  11. URL: http://www.wxwidgets.org/
  12. Source0: wxGTK-%{version}.tar.bz2
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: cppunit-devel
  15. #BuildRequires: gstreamer-devel >= 0.10
  16. #BuildRequires: gstreamer-plugins-base-devel >= 0.10
  17. BuildRequires: gtk2-devel
  18. BuildRequires: expat-devel
  19. BuildRequires: libgnomeprintui-devel
  20. BuildRequires: libjpeg-turbo-devel
  21. BuildRequires: libpng-devel
  22. BuildRequires: libSM-devel
  23. BuildRequires: libtiff-devel
  24. BuildRequires: mesa-libGL-devel
  25. BuildRequires: mesa-libGLU-devel
  26. BuildRequires: pkgconfig
  27. BuildRequires: SDL-devel
  28. BuildRequires: zlib-devel
  29. Obsoletes: wx-gtk2 < %{version}-%{release}
  30. Vendor: Project Vine
  31. Distribution: Vine Linux
  32. Packager: toshi_kd
  33. %description
  34. wxWidgets is a free C++ library for cross-platform GUI development.
  35. With wxWidgets, you can create applications for different GUIs (GTK+,
  36. Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
  37. %package devel
  38. Summary: The GTK+ 2 port of the wxWidgets library
  39. Summary(ja): wxWidgets ライブラリーの開発用ファイル
  40. Group: Development/Libraries
  41. Requires: %{name} = %{version}-%{release}
  42. Requires: wxBase = %{version}-%{release}
  43. Requires: gtk2-devel
  44. Requires: mesa-libGL-devel, mesa-libGLU-devel
  45. Obsoletes: wx-gtk2-devel < %{version}-%{release}
  46. %description devel
  47. The GTK+ 2 port of the wxWidgets library, header files.
  48. %package -n wxBase
  49. Summary: Non-GUI support classes from the wxWidgets library
  50. Group: System Environment/Libraries
  51. %description -n wxBase
  52. Every wxWidgets application must link against this library. It contains
  53. mandatory classes that any wxWidgets code depends on (like wxString) and
  54. portability classes that abstract differences between platforms. wxBase can
  55. be used to develop console mode applications -- it does not require any GUI
  56. libraries or the X Window System.
  57. %prep
  58. %setup -qn wxGTK-%{version}
  59. sed -i -e 's|/usr/lib\b|%{_libdir}|' wx-config.in configure
  60. # fix plugin dir for 64-bit
  61. sed -i -e 's|/lib|/%{_lib}|' src/unix/stdpaths.cpp
  62. # fix permissions for sources
  63. chmod a-x include/wx/{msgout.h,dcgraph.h,graphics.h}
  64. chmod a-x src/common/msgout.cpp
  65. %build
  66. %configure --enable-accel \
  67. --enable-controls \
  68. --enable-shared \
  69. --enable-unicode \
  70. --enable-sound \
  71. --enable-intl \
  72. --enable-display \
  73. --enable-geometry \
  74. --enable-graphics_ctx \
  75. --disable-rpath \
  76. --with-expat \
  77. --with-gtk \
  78. --with-libpng \
  79. --with-libjpeg \
  80. --with-libtiff \
  81. --with-libxpm \
  82. --with-opengl \
  83. --with-regex \
  84. --with-sdl \
  85. --with-zlib
  86. %{__make} %{?_smp_mflags}
  87. %install
  88. %__rm -rf %{buildroot}
  89. %makeinstall
  90. ln -sf %{_libdir}/wx/config/%{wxconfig} %{buildroot}%{_bindir}/wx-config
  91. %makeinstall -C contrib
  92. %clean
  93. %__rm -rf %{buildroot}
  94. %post -p /sbin/ldconfig
  95. %postun -p /sbin/ldconfig
  96. %post -n wxBase -p /sbin/ldconfig
  97. %postun -n wxBase -p /sbin/ldconfig
  98. %files
  99. %defattr(-,root,root,-)
  100. %doc docs/changes.txt docs/gpl.txt docs/lgpl.txt docs/licence.txt
  101. %doc docs/licendoc.txt docs/preamble.txt docs/readme.txt
  102. %{_libdir}/libwx_gtk2u_adv-*.so.*
  103. %{_libdir}/libwx_gtk2u_aui-*.so.*
  104. %{_libdir}/libwx_gtk2u_core-*.so.*
  105. %{_libdir}/libwx_gtk2u_fl-*.so.*
  106. %{_libdir}/libwx_gtk2u_gizmos-*.so.*
  107. %{_libdir}/libwx_gtk2u_gizmos_xrc*.so.*
  108. %{_libdir}/libwx_gtk2u_gl-*.so.*
  109. %{_libdir}/libwx_gtk2u_html-*.so.*
  110. %{_libdir}/libwx_gtk2u_ogl-*.so.*
  111. %{_libdir}/libwx_gtk2u_plot-*.so.*
  112. %{_libdir}/libwx_gtk2u_qa-*.so.*
  113. %{_libdir}/libwx_gtk2u_richtext-*.so.*
  114. %{_libdir}/libwx_gtk2u_stc-*.so.*
  115. %{_libdir}/libwx_gtk2u_svg-*.so.*
  116. %{_libdir}/libwx_gtk2u_xrc-*.so.*
  117. %files devel
  118. %defattr(-,root,root,-)
  119. %{_bindir}/wx-config
  120. %{_bindir}/wxrc*
  121. %{_includedir}/wx-2.8
  122. %{_libdir}/libwx_*.so
  123. %dir %{_libdir}/wx
  124. %dir %{_libdir}/wx/include
  125. %{_libdir}/wx/include/gtk2*
  126. %dir %{_libdir}/wx/config
  127. %{_libdir}/wx/config/gtk2*
  128. %{_datadir}/aclocal/*
  129. %{_datadir}/bakefile/presets/*
  130. %files -n wxBase
  131. %defattr(-,root,root,-)
  132. %doc docs/changes.txt docs/gpl.txt docs/lgpl.txt docs/licence.txt
  133. %doc docs/licendoc.txt docs/preamble.txt docs/readme.txt
  134. %{_libdir}/libwx_baseu-*.so.*
  135. %{_libdir}/libwx_baseu_net-*.so.*
  136. %{_libdir}/libwx_baseu_xml-*.so.*
  137. %changelog
  138. * Fri Jul 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.12-7
  139. - rebuilt with new toolchain.
  140. * Fri Jul 18 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.12-6
  141. - rebuilt with libpng-1.6.12
  142. * Mon Jan 13 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2.8.12-5
  143. - rebuilt with the current environment
  144. * Sat Jan 26 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.12-4
  145. - added configure option: --enable-accel, --enable-controls
  146. * Thu Aug 09 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.12-3
  147. - increment release number (+2)
  148. - add version-release to Obsoletes tag
  149. - O: wx-gtk2 < %{version}-%{release}
  150. - O: wx-gtk2-devel < %{version}-%{release}
  151. - remove wx-gtk2* package from repository
  152. * Sun Jul 01 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.12-1
  153. - redefined name, package structure and configure
  154. * Wed May 4 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.12-1
  155. - new upstream version
  156. * Thu Sep 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.11-2
  157. - built with rpm-4.8.1-1 for pkg-config file
  158. - changed libjpeg-devel to libjpeg-turbo-devel
  159. - added BuildRequires: libSM-devel, cppunit-devel, libgnomeprintui-devel
  160. * Tue Jun 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.11-1
  161. - new upstream version
  162. - dropt all patches
  163. * Tue Feb 23 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.10-4
  164. - added Patch10: wxGTK-2.8.10-gsockgtk.patch
  165. - added conrib libraries
  166. - rebuilt with new toolchain
  167. * Tue Jul 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.10-3
  168. - add patch100 for fix CVE-2009-2369 (Interger OF) from fc10
  169. * Mon Jun 22 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10-2vl5
  170. - spec in UTF-8
  171. * Thu Mar 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10-1vl5
  172. - new upstream version
  173. - built with gtk2-2.16.0
  174. * Wed Jan 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.9-1vl5
  175. - new upstream version
  176. - modified BuildPreReq: mesa-libGL-devel mesa-libGLU-devel (instead of XOrg-gl-devel)
  177. * Tue Feb 26 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.8.7-0vl5
  178. - rebuild with expat-2.0.1
  179. - add BuildPreReq: expat-devel pkgconfig
  180. * Sun Jan 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.7-0vl4
  181. - rebuilt with gtk2-2.12.5
  182. * Sun Dec 30 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.8.7-0vl3
  183. - rebuilt for VineSeed
  184. * Sun Dec 30 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.8.7-0vl2
  185. - add --enable-unicode configure option
  186. * Sat Dec 29 2007 Shu KONNO <owa@bg.wakwak.com> - 2.8.7-0vl1
  187. - new upstream version
  188. * Fri Jun 1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.3-0vl2
  189. - rebuilt with new toolchain
  190. * Thu May 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.3-0vl1
  191. - new upstream version
  192. - fixed Obsoletes tag
  193. * Fri Oct 21 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.2-0vl1
  194. - new upstream version
  195. - added Obsoletes: %{name}-gl %{name}-samples
  196. * Sun Jul 10 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.6.1-0vl1
  197. - new upstream version
  198. - remove private symbol patch
  199. - remove wx-gtk2-gl, wx-gtk2-samples subpackage
  200. * Tue May 25 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.4.2-0vl1
  201. - Initial build.