wpa_supplicant-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360
  1. %define build_gui 1
  2. Summary: WPA/WPA2/IEEE 802.1X Supplicant
  3. Name: wpa_supplicant
  4. Version: 2.5
  5. Release: 3%{?_dist_release}
  6. License: BSD
  7. Group: System Environment/Base
  8. URL: http://w1.fi/wpa_supplicant/
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. Source0: http://hostap.epitest.fi/releases/%{name}-%{version}.tar.gz
  12. Source1: %{name}.build-config
  13. Source2: %{name}.conf
  14. Source3: %{name}.init.d
  15. Source4: %{name}.sysconfig
  16. Source6: %{name}.logrotate
  17. # distro specific customization and not suitable for upstream,
  18. # works around busted drivers
  19. Patch0: wpa_supplicant-assoc-timeout.patch
  20. # ensures that debug output gets flushed immediately to help diagnose driver
  21. # bugs, not suitable for upstream
  22. Patch1: wpa_supplicant-flush-debug-output.patch
  23. # disto specific customization for log paths, not suitable for upstream
  24. Patch2: wpa_supplicant-dbus-service-file-args.patch
  25. # quiet an annoying and frequent syslog message
  26. Patch3: wpa_supplicant-quiet-scan-results-message.patch
  27. # allow more private key encryption algorithms
  28. Patch5: wpa_supplicant-openssl-more-algs.patch
  29. # Less aggressive roaming; signal strength is wildly variable
  30. Patch8: rh837402-less-aggressive-roaming.patch
  31. # CVE-2015-1863, backport from upstream master, will be in 2.5
  32. # http://w1.fi/cgit/hostap/commit/?id=9ed4eee345f85e3025c33c6e20aa25696e341ccd
  33. Patch9: 0001-P2P-Validate-SSID-element-length-before-copying-it-C.patch
  34. # Fix a crash - rh #1231973
  35. # http://w1.fi/cgit/hostap/commit/wpa_supplicant/dbus/dbus_new_handlers.c?id=8a78e227df1ead19be8e12a4108e448887e64d6f
  36. Patch10: rh1231973-dbus-fix-operations-for-p2p-mgmt.patch
  37. # Fix a security issue - rh #rh1241907
  38. # http://w1.fi/security/2015-5/0001-NFC-Fix-payload-length-validation-in-NDEF-record-par.patch
  39. Patch11: rh1241907-NFC-Fix-payload-length-validation-in-NDEF-record-par.patch
  40. ## Vine patches
  41. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  42. %if %{build_gui}
  43. BuildRequires: qt4-devel
  44. %endif
  45. BuildRequires: openssl-devel
  46. BuildRequires: readline-devel
  47. BuildRequires: dbus-devel
  48. BuildRequires: libnl3-devel
  49. BuildRequires: docbook-utils
  50. Requires(post): /sbin/chkconfig
  51. Requires(preun): /sbin/chkconfig /sbin/service
  52. Requires(postun): /sbin/service
  53. %description
  54. wpa_supplicant is a WPA Supplicant for Linux, BSD and Windows with support
  55. for WPA and WPA2 (IEEE 802.11i / RSN). Supplicant is the IEEE 802.1X/WPA
  56. component that is used in the client stations. It implements key negotiation
  57. with a WPA Authenticator and it controls the roaming and IEEE 802.11
  58. authentication/association of the wlan driver.
  59. %if %{build_gui}
  60. %package gui
  61. Summary: Graphical User Interface for %{name}
  62. Summary(ja): %{name} のグラフィカルユーザインタフェース
  63. Group: Applications/System
  64. %description gui
  65. Graphical User Interface for wpa_supplicant written using QT4
  66. %description -l ja gui
  67. QT4 を用いた wpa_supplicant のグラフィカルユーザインタフェース
  68. %endif
  69. %prep
  70. %setup -q
  71. %patch0 -p1 -b .assoc-timeout
  72. %patch1 -p1 -b .flush-debug-output
  73. %patch2 -p1 -b .dbus-service-file
  74. %patch3 -p1 -b .quiet-scan-results-msg
  75. %patch5 -p1 -b .more-openssl-algs
  76. %patch8 -p1 -b .rh837402-less-aggressive-roaming
  77. %build
  78. pushd wpa_supplicant
  79. cp %{SOURCE1} .config
  80. CFLAGS="${CFLAGS:-%optflags} -fPIE -DPIE" ; export CFLAGS ;
  81. CXXFLAGS="${CXXFLAGS:-%optflags} -fPIE -DPIE" ; export CXXFLAGS ;
  82. LDFLAGS="${LDFLAGS:-%optflags} -pie -Wl,-z,now" ; export LDFLAGS ;
  83. # yes, BINDIR=_sbindir
  84. BINDIR="%{_sbindir}" ; export BINDIR ;
  85. LIBDIR="%{_libdir}" ; export LIBDIR ;
  86. make %{?_smp_mflags}
  87. %if %{build_gui}
  88. QTDIR=%{_libdir}/qt4 make wpa_gui-qt4 %{?_smp_mflags}
  89. %endif
  90. make eapol_test
  91. popd
  92. %install
  93. rm -rf %{buildroot}
  94. # init scripts
  95. install -D -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/rc.d/init.d/%{name}
  96. install -D -m 0644 %{SOURCE4} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
  97. install -D -m 0644 %{SOURCE6} %{buildroot}/%{_sysconfdir}/logrotate.d/%{name}
  98. # config
  99. install -D -m 0600 %{SOURCE2} %{buildroot}/%{_sysconfdir}/%{name}/%{name}.conf
  100. # binary
  101. install -d %{buildroot}/%{_sbindir}
  102. install -m 0755 %{name}/wpa_passphrase %{buildroot}/%{_sbindir}
  103. install -m 0755 %{name}/wpa_cli %{buildroot}/%{_sbindir}
  104. install -m 0755 %{name}/wpa_supplicant %{buildroot}/%{_sbindir}
  105. install -D -m 0644 %{name}/dbus/dbus-wpa_supplicant.conf %{buildroot}/%{_sysconfdir}/dbus-1/system.d/wpa_supplicant.conf
  106. install -D -m 0644 %{name}/dbus/fi.w1.wpa_supplicant1.service %{buildroot}/%{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
  107. install -D -m 0644 %{name}/dbus/fi.epitest.hostap.WPASupplicant.service %{buildroot}/%{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
  108. %if %{build_gui}
  109. # gui
  110. install -d %{buildroot}/%{_bindir}
  111. install -m 0755 %{name}/wpa_gui-qt4/wpa_gui %{buildroot}/%{_bindir}
  112. %endif
  113. # running
  114. mkdir -p %{buildroot}/%{_localstatedir}/run/%{name}
  115. # man pages
  116. install -d %{buildroot}%{_mandir}/man{5,8}
  117. install -m 0644 %{name}/doc/docbook/*.8 %{buildroot}%{_mandir}/man8
  118. install -m 0644 %{name}/doc/docbook/*.5 %{buildroot}%{_mandir}/man5
  119. # some cleanup in docs
  120. rm -f %{name}/doc/.cvsignore
  121. rm -rf %{name}/doc/docbook
  122. chmod -R 0644 %{name}/examples/*.py
  123. %clean
  124. rm -rf %{buildroot}
  125. %post
  126. if [ $1 = 1 ]; then
  127. /sbin/chkconfig --add %{name}
  128. fi
  129. %preun
  130. if [ $1 = 0 ]; then
  131. /sbin/service %{name} stop > /dev/null 2>&1
  132. killall -TERM wpa_supplicant >/dev/null 2>&1
  133. /sbin/chkconfig --del %{name}
  134. fi
  135. %postun
  136. if [ $1 -ge 1 ]; then
  137. /sbin/service %{name} condrestart > /dev/null 2>&1
  138. fi
  139. %files
  140. %defattr(-, root, root)
  141. %doc COPYING %{name}/ChangeLog README %{name}/eap_testing.txt %{name}/todo.txt %{name}/wpa_supplicant.conf %{name}/examples
  142. %config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
  143. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  144. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  145. %{_sysconfdir}/rc.d/init.d/%{name}
  146. %{_sysconfdir}/dbus-1/system.d/%{name}.conf
  147. %{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
  148. %{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
  149. %{_sbindir}/wpa_passphrase
  150. %{_sbindir}/wpa_supplicant
  151. %{_sbindir}/wpa_cli
  152. %dir %{_localstatedir}/run/%{name}
  153. %dir %{_sysconfdir}/%{name}
  154. %{_mandir}/man8/*
  155. %{_mandir}/man5/*
  156. %if %{build_gui}
  157. %files gui
  158. %defattr(-, root, root)
  159. %{_bindir}/wpa_gui
  160. %endif
  161. %changelog
  162. * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.5-3
  163. - rebuilt with new toolchain.
  164. * Tue Mar 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.5-2
  165. - rebuild with openssl-1.0.2g
  166. * Thu Oct 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.5-1
  167. - update to 2.5
  168. - update SOURCE1
  169. - remove Patch7 (libnl3-includes.patch)
  170. - add Patch 9,10,11 from Fedora
  171. - remove Patch 6, 700
  172. * Thu Feb 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.3-1
  173. - updated to 2.3
  174. - built with libnl3 instead of libnl
  175. - added Patch 6, 7 and 8 from Fedora
  176. - added Patch700
  177. * Mon Aug 22 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.3-3
  178. - import Patch8 from Fedora 1:0.7.3-9 to fix some crashes
  179. - Wed Jul 27 2011 Dan Williams <dcbw@redhat.com> - 1:0.7.3-9
  180. - Fix various crashes with D-Bus interface (rh #678625) (rh #725517)
  181. * Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-2
  182. - rebuild with openssl-1.0.0c
  183. - add BuildRequires: qt4-designer, libnl-devel
  184. * Thu Jan 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-1
  185. - new upstream release
  186. - update patches
  187. - change License to BSD due to linkage against OpsnSSL since there is no
  188. OpenSSL exception in upstream GPLv2 license text.
  189. - build with qt4
  190. - update build config
  191. * Wed Jan 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.4-1
  192. - new upstream release
  193. - remove hostap/madwifi/prism54 drivers, use 'wext' instead.
  194. - drop upstream patches
  195. - import some fedora patches
  196. - Handle encryption keys correctly when switching 802.11 modes (rh #459399)
  197. - Better scanning behavior on resume from suspend/hibernate
  198. - Better interaction with newer kernels and drivers
  199. * Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-2
  200. - start wpa_supplicant by default.
  201. * Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-1
  202. - new upstream release
  203. - import some fedora patches
  204. * Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl2
  205. - rebuild with new openssl
  206. * Mon May 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl1
  207. - new upstream release
  208. * Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
  209. - initial build for Vine Linux based on FC package.
  210. * Thu Apr 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-10
  211. - Add fix for madwifi and WEP (wpa_supplicant/hostap bud #140) (#rh190075#)
  212. - Fix up madwifi-ng private ioctl()s for r1331 and later
  213. - Update madwifi headers to r1475
  214. * Tue Apr 25 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-9
  215. - Enable Wired driver, PKCS12, and Smartcard options (#rh189805#)
  216. * Tue Apr 11 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-8
  217. - Fix control interface key obfuscation a bit
  218. * Sun Apr 2 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-7
  219. - Work around older & incorrect drivers that return null-terminated SSIDs
  220. * Mon Mar 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-6
  221. - Add patch to make orinoco happy with WEP keys
  222. - Enable Prism54-specific driver
  223. - Disable ipw-specific driver; ipw2x00 should be using WEXT instead
  224. * Fri Mar 3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-5
  225. - Increase association timeout, mainly for drivers that don't
  226. fully support WPA ioctls yet
  227. * Fri Mar 3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-4
  228. - Add additional BuildRequires #rh181914#
  229. - Add prereq on chkconfig #rh182905# #rh182906#
  230. - Own /var/run/wpa_supplicant and /etc/wpa_supplicant #rh183696#
  231. * Wed Mar 1 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-3
  232. - Install wpa_passphrase too #rh183480#
  233. * Mon Feb 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-2
  234. - Don't expose private data on the control interface unless requested
  235. * Fri Feb 24 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-1
  236. - Downgrade to 0.4.8 stable release rather than a dev release
  237. * Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-3
  238. - Documentation cleanup (Terje Rosten <terje.rosten@ntnu.no>)
  239. * Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-2
  240. - Move initscript to /etc/rc.d/init.d
  241. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.2
  242. - bump again for double-long bug on ppc(64)
  243. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.1
  244. - rebuilt for new gcc4.1 snapshot and glibc changes
  245. * Sun Feb 5 2006 Dan Williams <dcbw@redhat.com> 0.5.1-1
  246. - Update to 0.5.1
  247. - Add WE auth fallback to actually work with older drivers
  248. * Thu Jan 26 2006 Dan Williams <dcbw@redhat.com> 0.4.7-2
  249. - Bring package into Fedora Core
  250. - Add ap_scan control interface patch
  251. - Enable madwifi-ng driver
  252. * Sun Jan 15 2006 Douglas E. Warner <silfreed@silfreed.net> 0.4.7-1
  253. - upgrade to 0.4.7
  254. - added package w/ wpa_gui in it
  255. * Mon Nov 14 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.6-1
  256. - upgrade to 0.4.6
  257. - adding ctrl interface changes recommended
  258. by Hugo Paredes <hugo.paredes@e-know.org>
  259. * Sun Oct 9 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.5-1
  260. - upgrade to 0.4.5
  261. - updated config file wpa_supplicant is built with
  262. especially, the ipw2100 driver changed to just ipw
  263. and enabled a bunch more EAP
  264. - disabled dist tag
  265. * Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-3
  266. - fix typo in init script
  267. * Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-2
  268. - fixing init script using fedora-extras' template
  269. - removing chkconfig default startup
  270. * Tue Jun 21 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-1
  271. - upgrade to 0.4.2
  272. - new sample conf file that will use any unrestricted AP
  273. - make sysconfig config entry
  274. - new BuildRoot for Fedora Extras
  275. - adding dist tag to Release
  276. * Fri May 06 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.8-1
  277. - upgrade to 0.3.8
  278. * Thu Feb 10 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-2
  279. - compile ipw driver in
  280. * Wed Feb 09 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-1
  281. - upgrade to 0.3.6
  282. * Thu Dec 23 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-4
  283. - fixing init script
  284. * Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-3
  285. - fixing init script
  286. - adding post/preun items to add/remove via chkconfig
  287. * Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-2
  288. - adding sysV scripts
  289. * Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-1
  290. - Initial RPM release.