wordpress-vl.spec 8.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231
  1. Summary: WordPress blogging software
  2. Summary(ja): WordPress ブログソフトウエア
  3. URL: http://www.wordpress.org
  4. Name: wordpress
  5. Version: 2.9.2
  6. Group: Applications/Publishing
  7. Release: 1%{?_dist_release}
  8. License: GPLv2
  9. #Source0: http://wordpress.org/%{name}-%{version}.tar.gz
  10. Source0: http://ja.wordpress.org/wordpress-%{version}-ja.tar.gz
  11. Source1: wordpress-httpd-conf
  12. Source2: README.wordpress
  13. Source3: README.ja.wordpress
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. Requires: php5
  16. BuildArch: noarch
  17. %description
  18. Wordpress is an online publishing / weblog package that makes it very easy,
  19. almost trivial, to get information out to people on the web.
  20. %prep
  21. %setup -q -n wordpress
  22. # disable wp_version_check, updates are always installed via rpm
  23. sed -i -e "s,\(.*\)'wp_version_check'\(.*\),#\1'wp_version_check'\2,g" \
  24. wp-includes/update.php
  25. # disable update_nag() function
  26. sed -i -e "s,\(.*\)'update_nag'\(.*\),#\1'update_nag'\2,g; \
  27. s,\(.*\)\$msg .=\(.*\),\1\$msg .= '';,g;" \
  28. wp-admin/includes/update.php
  29. # fix file encoding
  30. sed -i -e 's/\r//' license.txt
  31. %install
  32. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/wordpress
  33. mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/wordpress
  34. install -m 0644 -D -p %{SOURCE1} ${RPM_BUILD_ROOT}%{_sysconfdir}/httpd/conf.d/wordpress.conf
  35. cp -pr * ${RPM_BUILD_ROOT}%{_datadir}/wordpress
  36. cat wp-config-sample.php | sed -e "s|dirname(__FILE__).'/'|'/usr/share/wordpress/'|g" > \
  37. ${RPM_BUILD_ROOT}%{_sysconfdir}/wordpress/wp-config.php
  38. /bin/ln -sf ../../../etc/wordpress/wp-config.php ${RPM_BUILD_ROOT}%{_datadir}/wordpress/wp-config.php
  39. /bin/cp %{SOURCE2} ./README.vine
  40. /bin/cp %{SOURCE3} ./README.ja.vine
  41. # Remove empty files to make rpmlint happy
  42. find ${RPM_BUILD_ROOT} -type f -empty -exec rm -f {} \;
  43. # These are docs, remove them from here, docify them later
  44. rm -f ${RPM_BUILD_ROOT}%{_datadir}/wordpress/{license.txt,readme.html}
  45. %clean
  46. rm -rf ${RPM_BUILD_ROOT}
  47. %post
  48. if [ "$1" -eq 1 ]; then
  49. if [ "$LANG"="ja_JP.UTF-8" ]; then
  50. echo "Wordpress: MySQL に Wordpress データベースを作成する必要があります。"
  51. echo "Wordpress: %{_docdir}/%{name}-%{version}/README.ja.vine を参照して"
  52. echo "Wordpress: 初期設定を行って下さい。"
  53. else
  54. echo "Wordpress: You may need to setup your MySQL database for Wordpress."
  55. echo "Wordpress: Please read \"%{_docdir}/%{name}-%{version}/README.vine\""
  56. echo "Wordpress: to initial setup."
  57. fi
  58. fi
  59. %files
  60. %defattr(-,root,root,-)
  61. %config(noreplace) %{_sysconfdir}/httpd/conf.d/wordpress.conf
  62. %dir %{_datadir}/wordpress
  63. %{_datadir}/wordpress/wp-admin
  64. %{_datadir}/wordpress/wp-content
  65. %{_datadir}/wordpress/wp-includes
  66. %{_datadir}/wordpress/index.php
  67. %doc license.txt
  68. %doc readme.html
  69. %doc README.vine
  70. %doc README.ja.vine
  71. %{_datadir}/wordpress/wp-atom.php
  72. %{_datadir}/wordpress/wp-app.php
  73. %{_datadir}/wordpress/wp-blog-header.php
  74. %{_datadir}/wordpress/wp-comments-post.php
  75. %{_datadir}/wordpress/wp-commentsrss2.php
  76. %{_datadir}/wordpress/wp-config-sample.php
  77. %{_datadir}/wordpress/wp-config.php
  78. %config(noreplace) %{_sysconfdir}/wordpress/wp-config.php
  79. %{_datadir}/wordpress/wp-cron.php
  80. %{_datadir}/wordpress/wp-feed.php
  81. %{_datadir}/wordpress/wp-links-opml.php
  82. %{_datadir}/wordpress/wp-load.php
  83. %{_datadir}/wordpress/wp-login.php
  84. %{_datadir}/wordpress/wp-mail.php
  85. %{_datadir}/wordpress/wp-pass.php
  86. %{_datadir}/wordpress/wp-rdf.php
  87. %{_datadir}/wordpress/wp-register.php
  88. %{_datadir}/wordpress/wp-rss.php
  89. %{_datadir}/wordpress/wp-rss2.php
  90. %{_datadir}/wordpress/wp-settings.php
  91. %{_datadir}/wordpress/wp-trackback.php
  92. %{_datadir}/wordpress/xmlrpc.php
  93. %dir %{_sysconfdir}/wordpress
  94. %changelog
  95. * Tue Apr 20 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.2-1
  96. - initial build for Vine Linux based on fedora package
  97. - update to 2.9.2 japanese version
  98. * Mon Nov 16 2009 Adrian Reber <adrian@lisas.de> - 2.8.6-2
  99. - updated to 2.8.6 (Security Release)
  100. * Wed Oct 21 2009 Adrian Reber <adrian@lisas.de> - 2.8.5-1
  101. - updated to 2.8.5 (Hardening Release)
  102. * Sun Aug 30 2009 Adrian Reber <adrian@lisas.de> - 2.8.4-1
  103. - updated to 2.8.4 (security fixes were already available with 2.8.3-2)
  104. * Tue Aug 11 2009 Adrian Reber <adrian@lisas.de> - 2.8.3-2
  105. - another security update to fix "Remote admin reset password":
  106. http://lists.grok.org.uk/pipermail/full-disclosure/2009-August/070137.html
  107. * Mon Aug 03 2009 Adrian Reber <adrian@lisas.de> - 2.8.3-1
  108. - updated to 2.8.3 for security fixes
  109. * Tue Jul 28 2009 Adrian Reber <adrian@lisas.de> - 2.8.2-1
  110. - updated to 2.8.2 for security fixes - BZ 512900
  111. - fixed "wrong-script-end-of-line-encoding" of license.txt
  112. - correctly disable auto update check
  113. - fixed an error message from 'find' during the build
  114. * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.1-2
  115. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  116. * Fri Jul 10 2009 Adrian Reber <adrian@lisas.de> - 2.8.1-1
  117. - updated to 2.8.1 for security fixes - BZ 510745
  118. * Mon Jun 22 2009 Adrian Reber <adrian@lisas.de> - 2.8-1
  119. - updated to 2.8
  120. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.1-2
  121. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  122. * Wed Feb 11 2009 Adrian Reber <adrian@lisas.de> - 2.7.1-1
  123. - updated to 2.7.1
  124. * Wed Nov 26 2008 Adrian Reber <adrian@lisas.de> - 2.6.5-2
  125. - updated to 2.6.5
  126. * Fri Oct 24 2008 Adrian Reber <adrian@lisas.de> - 2.6.3-1
  127. - updated to 2.6.3
  128. * Tue Sep 09 2008 Adrian Reber <adrian@lisas.de> - 2.6.2-1
  129. - updated to 2.6.2
  130. * Sun Aug 24 2008 Adrian Reber <adrian@lisas.de> - 2.6.1-1
  131. - updated to 2.6.1
  132. * Mon Jul 21 2008 Adrian Reber <adrian@lisas.de> - 2.6-1
  133. - updated to 2.6
  134. * Sat Apr 26 2008 Adrian Reber <adrian@lisas.de> - 2.5.1-1
  135. - updated to 2.5.1 for security fixes - BZ 444396
  136. * Fri Feb 8 2008 John Berninger <john at ncphotography dot com> - 2.3.3-0
  137. - update to 2.3.3 for security fixes - BZ 431547
  138. * Sun Dec 30 2007 Adrian Reber <adrian@lisas.de> - 2.3.2-1
  139. - updated to 2.3.2 (bz 426431, Draft Information Disclosure)
  140. * Tue Oct 30 2007 Adrian Reber <adrian@lisas.de> - 2.3.1-1
  141. - updated to 2.3.1 (bz 357731, wordpress XSS issue)
  142. * Mon Oct 15 2007 Adrian Reber <adrian@lisas.de> - 2.3-1
  143. - updated to 2.3
  144. - disabled wordpress-core-update
  145. * Tue Sep 11 2007 Adrian Reber <adrian@lisas.de> - 2.2.3-0
  146. - updated to 2.2.3 (security release)
  147. * Wed Aug 29 2007 John Berninger <john at ncphotography dot com> - 2.2.2-0
  148. - update to upstream 2.2.2
  149. - license tag update
  150. * Mon Apr 16 2007 john Berninger <jwb at redhat dot com> - 2.1.3-1
  151. - update to 2.1.3 final - bz235912
  152. * Mon Mar 26 2007 John Berninger <jwb at redhat dot com> - 2.1.3-rc2
  153. - update to 2.1.3rc2 for bz 233703
  154. * Sat Mar 3 2007 John Berninger <jwb at redhat dot com> - 2.1.2-0
  155. - update to 2.1.2 - backdoor exploit introduced upstream in 2.1.1 - bz 230825
  156. * Tue Feb 27 2007 John Berninger <jwb at redhat dot com> - 2.1.1-0
  157. - update to 2.1.1 to fix vuln in bz 229991
  158. * Wed Jan 31 2007 John Berninger <jwb at redhat dot com> - 2.1-0
  159. - update to v2.1 to fix multiple bz/vuln's
  160. * Sun Dec 3 2006 John Berninger <jwb at redhat dot com> - 2.0.5-2
  161. - Remove mysql-server dependency
  162. * Sun Dec 3 2006 John Berninger <jwb at redhat dot com> - 2.0.5-1
  163. - Update to upstream 2.0.5 to fix vuln in bz 213985
  164. * Thu Oct 26 2006 John Berninger <jwb at redhat dot com> - 2.0.4-1
  165. - Doc fix for BZ 207822
  166. * Sat Aug 12 2006 John Berninger <jwb at redhat dot com> - 2.0.4-0
  167. - Upstream security vulns - bz 201989
  168. * Sun Jul 23 2006 John Berninger <jwb at redhat dot com> - 2.0.3-4
  169. - Fix broken upgrade path from FE4
  170. * Tue Jul 4 2006 John Berninger <jwb at redhat dot com> - 2.0.3-3
  171. - Add a README.fedora file
  172. - Add php-mysql requires
  173. * Tue Jun 20 2006 John Berninger <jwb at redhat dot com> - 2.0.3-2
  174. - Remove use of installprefix macro
  175. - %%{_datadir}/wordpress/wp-config.php is not a config file
  176. - Symlink is relative
  177. * Mon Jun 19 2006 John Berninger <jwb at redhat dot com> - 2.0.3-1
  178. - Changes from Jarod Wilson as below
  179. - Update to 2.0.3
  180. - Rearrange to use /usr/share/wordpress and /etc/wordpress
  181. - Remove patch (included upstream)
  182. - Remove empty files to make rpmlint happy
  183. * Tue May 30 2006 John Berninger <jwb at redhat dot com> - 2.0.2-1
  184. - Added patch for \n cache injection - upstream changeset #3797
  185. * Sat May 27 2006 John Berninger <jwb at redhat dot com> - 2.0.2-0
  186. - Initial build