wl-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. ## To build wl-2.14.0, we use emacs-23.X
  4. %define __emacs %(rpm -q --queryformat "%%{name}-%%{version}" emacs | grep "emacs-23")
  5. %define origname wl
  6. %define origver 2.14.0
  7. # if the package is not prerelease, set %%{prever} to %{nil}
  8. %define prever %{nill}
  9. %define emacsen_pkgdir /usr/lib/emacsen-common/packages
  10. Summary: IMAP-capable mail/news reader for emacsen
  11. Summary(ja): (X)Emacs 用IMAP に対応したメール/ニュースリーダ
  12. Name: %{origname}
  13. Version: %{origver}
  14. Release: 4%{?_dist_release}
  15. Source0: ftp://ftp.gohome.org/%{origname}/stable/%{origname}-%{origver}.tar.gz
  16. Source1: %{origname}-install.sh
  17. Source2: %{origname}-remove.sh
  18. Source3: %{origname}-init.el
  19. Source4: vine-default-%{origname}.el
  20. Patch1: wl-2.14.0-wl-news.patch
  21. Patch10: wl-2.8.1-texi-ja.diff
  22. Patch11: wl-2.8.1-install-utils.diff
  23. License: GPLv2
  24. Group: Applications/Editors/Emacs
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. BuildArch: noarch
  27. Obsoletes: wl-el, Wanderlust, Wanderlust-xemacs
  28. Requires(post): emacsen
  29. %prereq_ge emacsen-common
  30. %prereq_ge semi
  31. %prereq_ge w3m-el
  32. BuildRequires: emacsen-common, semi, w3m-el
  33. Vendor: Project Vine
  34. Distribution: Vine Linux
  35. Packager: shaolin, munepi
  36. %description
  37. Wanderlust is a mail/news reader supporting IMAP for emacsen.
  38. Overall impression resembles to Mew, but Wanderlust have nifty
  39. features like IMAP support, threading display, and so on.
  40. #(eigo wakannai)
  41. #After installation, you must modify your ~/.emacs file to contain
  42. #at least:
  43. #
  44. # (load "mime-setup")
  45. #
  46. # (autoload 'wl "wl" "Wanderlust t)
  47. # (autoload 'wl-draft "wl" "Write draft with Wanderlust." t)
  48. Other detailed information can be available at:
  49. http://www.gohome.org/wl/index-e.html
  50. (sorry, much detailed info is currently available only in Japanese)
  51. If you install both wl and wl-beta packages on your system,
  52. you may add the following configure in your emacs init file
  53. %if %{?_dist_release} == "vl5"
  54. ~/.emacs.el:
  55. %else
  56. ~/.emacs.d/emacsXX-vine-default.el (XX: emacs major version):
  57. %endif
  58. ;; I use wl.
  59. (setq vine-default-wl-beta nil)
  60. %description -l ja
  61. Wanderlust は、elisp のみで実装された IMAP 対応のメール/ニュースリーダです。
  62. 使用感は Mew に近く、加えてスレッド表示や未読管理などにも対応しています。
  63. 主な特徴(Wanderlust web ページより抜粋)
  64. - elisp のみによる実装
  65. - IMAPrev1, NNTP, POP, MH 形式のサポート
  66. - Mew っぽい Folder Specification に基づくメッセージへの
  67. 統一的アクセス
  68. - Mew っぽいキーバインドとマーク処理
  69. - インタラクティブなスレッド表示
  70. - 未読管理
  71. - 購読フォルダの一覧を表示するフォルダモード
  72. - メッセージキャッシュ、オフライン処理 (IMAP4)
  73. - MIME 対応 (by SEMI or tm)
  74. #インストール後、~/.emacs に最低でも以下の記述を追加して下さい:
  75. #
  76. # (load "mime-setup")
  77. #
  78. # (autoload 'wl "wl" "Wanderlust t)
  79. # (autoload 'wl-draft "wl" "Write draft with Wanderlust." t)
  80. # Emacs/XEmacs 起動時に以下の設定ファイルを読み込みます。
  81. # M-x wl で起動します。
  82. # /etc/emacs-??.?/site-start.d/55wl-init.el
  83. # /etc/xemacs-??.?.??/site-start.d/55wl-init.el
  84. アカウント毎の設定は、
  85. %{_defaultdocdir}/%{name}-%{origver}/samples/ja/dot.wl
  86. %{_defaultdocdir}/%{name}-%{origver}/samples/ja/dot.folders
  87. %{_defaultdocdir}/%{name}-%{origver}/samples/ja/dot.addresses
  88. をベースに、
  89. ~/.wl
  90. ~/.folders
  91. ~/.address
  92. を作成下さい。
  93. 詳しくは、Wanderlust の web ページ
  94. http://www.gohome.org/wl/
  95. を見て下さい。
  96. wl と wl-beta パッケージの両方をインストールする場合、
  97. %if %{?_dist_release} == "vl5"
  98. ~/.emacs.el:
  99. %else
  100. ~/.emacs.d/emacsXX-vine-default.el (XX: emacs のメジャーバージョン)
  101. %endif
  102. に以下の設定を追加するとよいでしょう。
  103. ;; wl を使う
  104. (setq vine-default-wl-beta nil)
  105. %prep
  106. ## we use emacs-23.X to build wl-2.14.0
  107. [ -z "%__emacs" ] && exit 1
  108. %__rm -rf ${RPM_BUILD_DIR}/%{origname}-%{origver}
  109. %setup -q -n %{origname}-%{origver}
  110. %patch1 -p1
  111. #%patch10 -p1
  112. %patch11 -p1
  113. touch doc/*.texi
  114. %install
  115. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  116. [ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
  117. %__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}/etc
  118. #%__mkdir_p ${RPM_BUILD_ROOT}%{_libdir}/emacsen-common/packages/install
  119. #%__mkdir_p ${RPM_BUILD_ROOT}%{_libdir}/emacsen-common/packages/remove
  120. %__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
  121. %__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
  122. %__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
  123. #
  124. # install el files
  125. #
  126. %__cp -a WL-* Makefile wl %{SOURCE3} %{SOURCE4} \
  127. ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
  128. %__cp -a utils elmo \
  129. ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
  130. %__cp -a etc/icons \
  131. ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}/etc/.
  132. # 2004.12.13 add Irokawa
  133. %__cp -a NEWS* \
  134. ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
  135. #
  136. # build & install info
  137. #
  138. yes | %__sed -e "s/y/\n/g" | %__make EMACS=%__emacs info
  139. %__make EMACS=%__emacs INFODIR=${RPM_BUILD_ROOT}%{_infodir} install-info
  140. #
  141. # install script( bytecompile el and install elc , remove )
  142. #
  143. %_installemacsenscript %{origname} %{SOURCE1}
  144. %_removeemacsenscript %{origname} %{SOURCE2}
  145. %post
  146. #
  147. # bytecompile and install
  148. #
  149. if [ "$1" = 2 ]; then
  150. %_emacsenPackageRemove %{origname}
  151. fi
  152. %_addemacsenlist %{origname}
  153. %_emacsenPackageInstall %{origname}
  154. /sbin/install-info %{_infodir}/wl-ja.info.gz %{_infodir}/dir \
  155. --section="Message User Agent"
  156. /sbin/install-info %{_infodir}/wl.info.gz %{_infodir}/dir \
  157. --section="Message User Agent"
  158. %preun
  159. if [ "$1" = 0 ]; then
  160. %_emacsenPackageRemove %{origname}
  161. %_removeemacsenlist %{origname}
  162. /sbin/install-info --delete %{_infodir}/wl-ja.info.gz %{_infodir}/dir \
  163. --section="Message User Agent"
  164. /sbin/install-info --delete %{_infodir}/wl.info.gz %{_infodir}/dir \
  165. --section="Message User Agent"
  166. fi
  167. %clean
  168. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  169. %files
  170. %defattr(-,root,root)
  171. %doc BUGS* COPYING* ChangeLog*
  172. %doc INSTALL* NEWS* README*
  173. %doc doc etc samples tests
  174. %{_datadir}/emacs/site-lisp/%{origname}/
  175. #%{_libdir}/emacsen-common/packages/install/%{origname}
  176. #%{_libdir}/emacsen-common/packages/remove/%{origname}
  177. %{emacsen_pkgdir}/install/%{origname}
  178. %{emacsen_pkgdir}/remove/%{origname}
  179. %{_infodir}/wl*.info*
  180. %changelog
  181. * Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.14.0-4
  182. - defined %%__emacs
  183. - use emacs-23.X to build wl-2.14.0
  184. - updated wl-init.el
  185. - output "Loading vine-default-wl ..." to the buffer *Messages*
  186. - changed from PreReq: emacsen to Requires(post): emacsen
  187. * Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.14.0-3
  188. - fixed wl-init.el
  189. * Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.14.0-2
  190. - added vine-default-wl.el
  191. - updated wl-install.sh for vine-default-wl.el
  192. * Sat Sep 06 2008 Shu KONNO <owa@bg.wakwak.com> 2.14.0-1vl5
  193. - applied new versioning policy, spec in utf-8
  194. - added macro %%emacsen_pkgdir
  195. * Fri Dec 7 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.0-0vl5
  196. - rebuild
  197. * Wed Jan 10 2007 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 2.14.0-0vl4
  198. - rebuild
  199. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl3
  200. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  201. * Fri Sep 30 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.0-0vl2
  202. - added Patch1 (wl-news.elc was not generated with emacs22)
  203. * Fri Apr 15 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.0-0vl1
  204. - updated to new upstream release 2.14.0
  205. * Sun Dec 26 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 2.12.0-0vl1
  206. - updated to new upstream release 2.12.1
  207. * Mon Dec 13 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 2.12.0-0vl0.pre
  208. - updated to new release canditate 2.12.0pre
  209. * Wed Dec 24 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.1-0vl2
  210. - increased release number for the new flim/semi release
  211. * Tue Jul 8 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 2.10.1-0vl1
  212. - updated to new upstream release 2.10.1
  213. * Mon Jun 09 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.0-0vl2
  214. - increased release number for the new apel release
  215. * Wed Dec 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.0-0vl1
  216. - updated to new upstream release 2.10.0
  217. * Sat Dec 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.0-0vl0.1
  218. - updated to new release canditate 2.10.0pre4
  219. * Fri Jan 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.1-0vl3
  220. - Obsoletes: wl-el now, instead of Conflicts:
  221. - added %%triggerpostun -- wl-el
  222. * Fri Jan 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.1-0vl2
  223. - added PreReq: w3m-el, for shimbun-guys will be happy :)
  224. * Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.1-0vl1
  225. - updated to new upstream release
  226. * Thu Dec 27 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.1-0vl5
  227. - modified wl-install.sh to put pixmaps in a proper place even with emacs21
  228. * Sat Dec 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.1-0vl4
  229. - modified wl-install.sh to put xemacs pixmaps in a proper place (AGAIN)
  230. * Fri Dec 07 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.1-0vl3
  231. - spec file cleaned-up too much now
  232. * Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.1-0vl2
  233. - modified wl-install.sh to put xemacs pixmaps in a proper place
  234. * Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.1-0vl1
  235. - updated to 2.6.1 stable release
  236. - the changelog was incorrect. now merged from original Wanderlust spec file
  237. * Wed Jul 18 2001 Kazuhisa TAKEI <takei@vinelinux.org>
  238. - emacsenize
  239. * Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  240. - 2.6.0-0vl2
  241. - added patch to fix recursive load problem
  242. (see wl:07309, wl:07812)
  243. * Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  244. - 2.6.0-0vl1
  245. - updated to 2.6.0 stable release
  246. * Wed Feb 14 2001 MATSUBAYASHI 'Shaolin' Kohji
  247. - 2.4.1-0vl1
  248. - updated to 2.4.1 stable release
  249. - merge emacs/xemacs package again into one source rpm :-)
  250. * Fri Dec 01 2000 MATSUBAYASHI 'Shaolin' Kohji
  251. - 2.4.0-0vl1
  252. - updated to 2.4.0 stable release
  253. * Thu Nov 23 2000 MATSUBAYASHI 'Shaolin' Kohji
  254. - 2.4.0-0.3vl1
  255. - updated to 2.4.0pre3 release canditate
  256. * Wed Nov 15 2000 MATSUBAYASHI 'Shaolin' Kohji
  257. - 2.4.0-0.2vl1
  258. - updated to 2.4.0pre2 release canditate
  259. * Sun Nov 12 2000 MATSUBAYASHI 'Shaolin' Kohji
  260. - 2.4.0-0.1vl1
  261. - updated to 2.4.0pre release canditate
  262. * Fri Aug 25 2000 MATSUBAYASHI 'Shaolin' Kohji
  263. - 1.1.1-0vl3
  264. - modified %files section to handle compressed man page(s)
  265. * Wed May 10 2000 MATSUBAYASHI 'Shaolin' Kohji
  266. - 1.1.1-0vl2
  267. - included a patch to fix Maildir-related problem
  268. (Thanks Teranishi-kun!)
  269. * Wed May 10 2000 MATSUBAYASHI 'Shaolin' Kohji
  270. - 1.1.1-0vl1
  271. - updated to 1.1.1 release
  272. * Mon Mar 27 2000 MATSUBAYASHI 'Shaolin' Kohji
  273. - 1.1.0-1vl2
  274. - added small patch by Mr. Yuuichi Teranishi himself :-)
  275. * Fri Mar 24 2000 MATSUBAYASHI 'Shaolin' Kohji
  276. - 1.1.0-1vl1
  277. - updated to 1.1.0 release
  278. - added a patch (see wl:04506)
  279. * Thu Mar 09 2000 MATSUBAYASHI 'Shaolin' Kohji
  280. - 1.1.0-0.3vl1
  281. - updated to 1.1.0pre3 release canditate
  282. * Fri Mar 03 2000 MATSUBAYASHI 'Shaolin' Kohji
  283. - 1.1.0-0.1vl1, 1.1.0-0.1vl2
  284. - updated to 1.1.0pre1 release canditate
  285. - added patches (see wl:04218, wl:04281)
  286. * Mon Feb 21 2000 MATSUBAYASHI 'Shaolin' Kohji
  287. - 2.2.18-1
  288. - updated to 2.2.18 beta release
  289. * Wed Jan 12 2000 MATSUBAYASHI 'Shaolin' Kohji
  290. - 2.2.15-1
  291. - updated to 2.2.15 beta release
  292. - included patches (see wl:03792, wl:03793)
  293. * Sat Jan 08 2000 MATSUBAYASHI 'Shaolin' Kohji
  294. - 2.2.14-1
  295. - updated to 2.2.14 beta release
  296. - included patches (see wl:03746, wl:03751)
  297. * Thu Jan 06 2000 MATSUBAYASHI 'Shaolin' Kohji
  298. - 2.2.13-2
  299. - included patches (see wl:03604, wl:03709, wl:03713, wl:03722)
  300. - fixed %install section to get wl be installed in proper directory
  301. * Tue Dec 28 1999 MATSUBAYASHI 'Shaolin' Kohji
  302. - 2.2.13-1
  303. - updated to 2.2.13 beta release
  304. - now utils are also installed
  305. - included a patch (see wl:03684)
  306. * Tue Dec 21 1999 MATSUBAYASHI 'Shaolin' Kohji
  307. - 2.2.12-3
  308. - included patches (see wl:03595, wl:03620, wl:03637, wl:03651)
  309. * Tue Dec 7 1999 MATSUBAYASHI 'Shaolin' Kohji
  310. - 2.2.12-2
  311. - updated to 2.2.12 beta release
  312. - included paches (see wl:03357, wl:03564)
  313. * Mon Dec 6 1999 MATSUBAYASHI 'Shaolin' Kohji
  314. - 2.2.11-1
  315. - updated to 2.2.11 beta release
  316. - included patches (see wl:03526, wl:03528)
  317. * Sat Dec 4 1999 MATSUBAYASHI 'Shaolin' Kohji
  318. - 2.2.10-2
  319. - included patches (see wl:03489, wl:03491)
  320. * Fri Dec 3 1999 MATSUBAYASHI 'Shaolin' Kohji
  321. - 2.2.10-1
  322. - udpated to 2.2.10 beta release
  323. - included patches (see wl:03480, wl:03484)
  324. * Mon Nov 29 1999 MATSUBAYASHI 'Shaolin' Kohji
  325. - 2.2.8-1
  326. - udpated to 2.2.8 beta release for semi-1.13.7
  327. - included patches (see wl:03171, wl:03182)
  328. * Sat Nov 27 1999 MATSUBAYASHI 'Shaolin' Kohji
  329. - 1.0.3-4
  330. - Obsolete: Wanderlust-mule added
  331. - %post and %preun section modified
  332. * Fri Oct 29 1999 MATSUBAYASHI 'Shaolin' Kohji
  333. - 1.0.3-3
  334. - %post and %preun section added for install-info
  335. * Wed Sep 29 1999 MATSUBAYASHI 'Shaolin' Kohji
  336. - 1.0.3-2
  337. - package name changed from Wanderlust-emacs to Wanderlust
  338. * Wed Sep 15 1999 MATSUBAYASHI 'Shaolin' Kohji
  339. - 1.0.3-1
  340. - first release for FSF Emacs 20.4