wl-beta-vl.spec 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define pkgname wl
  4. %define cvsdate 20120304
  5. Summary: IMAP-capable mail/news reader for emacsen (development version)
  6. Summary(ja): Emacsen 用 IMAP に対応したメール/ニュースリーダ(開発版)
  7. Name: wl-beta
  8. Version: 2.15.9
  9. Release: 4%{?cvsdate:.cvs%cvsdate}%{?_dist_release}
  10. License: GPLv2
  11. Group: Applications/Editors/Emacs
  12. Source0: %{pkgname}-%{version}%{?cvsdate:.cvs%cvsdate}.tar.xz
  13. Source1: %{name}-install.sh
  14. Source2: %{name}-remove.sh
  15. Source3: %{name}-init.el
  16. Source4: vine-default-%{name}.el
  17. # Script used to create the %{pkgname}-%{version}.cvs%{cvsdate}.tar.xz
  18. # archive from Wanderlust CVS
  19. Source10: wl-snapshot.sh
  20. Patch1: wl-2.14.0-wl-news.patch
  21. #Patch10: wl-2.8.1-texi-ja.diff
  22. Patch11: wl-2.8.1-install-utils.diff
  23. Patch50: wl-2.15.9-wl-beta.patch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. BuildArch: noarch
  26. Requires(post): emacsen
  27. %prereq_ge emacsen-common
  28. %prereq_ge semi
  29. %prereq_ge w3m-el
  30. BuildRequires: emacsen-common, semi, w3m-el
  31. Vendor: Project Vine
  32. Distribution: Vine Linux
  33. Packager: munepi
  34. %description
  35. Wanderlust is a mail/news management system with IMAP4rev1 support for Emacs.
  36. Overall impression resembles to Mew, but Wanderlust have nifty
  37. features like IMAP support, threading display, and so on.
  38. This is a development version of Wanderlust.
  39. If you install both wl and wl-beta packages on your system,
  40. you may add the following configure in your emacs init file
  41. %if %{?_dist_release} == "vl5"
  42. ~/.emacs.el:
  43. %else
  44. ~/.emacs.d/emacsXX-vine-default.el (XX: emacs major version):
  45. %endif
  46. ;; I use wl-beta.
  47. (setq vine-default-wl nil)
  48. %description -l ja
  49. Wanderlust は、elisp のみで実装された IMAPrev1 対応の
  50. メール/ニュースリーダです。
  51. 使用感は Mew に近く、加えてスレッド表示や未読管理などにも対応しています。
  52. これは Wanderlust の開発バージョンです。
  53. wl と wl-beta パッケージの両方をインストールする場合、
  54. %if %{?_dist_release} == "vl5"
  55. ~/.emacs.el:
  56. %else
  57. ~/.emacs.d/emacsXX-vine-default.el (XX: emacs のメジャーバージョン)
  58. %endif
  59. に以下の設定を追加するとよいでしょう。
  60. ;; wl-beta を使う
  61. (setq vine-default-wl nil)
  62. %prep
  63. %__rm -rf ${RPM_BUILD_DIR}/%{pkgname}-%{version}
  64. %setup -q -n %{pkgname}-%{version}
  65. %patch1 -p1
  66. #%patch10 -p1
  67. %patch11 -p1
  68. %patch50 -p1 -b .vine
  69. touch doc/*.texi
  70. %install
  71. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  72. [ "${RPM_BUILD_ROOT}" != "/" ] && %__mkdir_p ${RPM_BUILD_ROOT}
  73. %__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}/etc
  74. %__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
  75. %__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
  76. %__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
  77. #
  78. # install el files
  79. #
  80. %__cp -a WL-* Makefile wl %{SOURCE3} %{SOURCE4} \
  81. ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
  82. %__cp -a utils elmo \
  83. ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
  84. %__cp -a etc/icons \
  85. ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}/etc/.
  86. %__cp -a NEWS* \
  87. ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
  88. #
  89. # build & install info
  90. #
  91. # %__make EMACS=emacs info
  92. # %__make EMACS=emacs INFODIR=${RPM_BUILD_ROOT}%{_infodir} install-info
  93. #
  94. # install script( bytecompile el and install elc , remove )
  95. #
  96. %_installemacsenscript %{name} %{SOURCE1}
  97. %_removeemacsenscript %{name} %{SOURCE2}
  98. %post
  99. #
  100. # bytecompile and install
  101. #
  102. if [ "$1" = 2 ]; then
  103. %_emacsenPackageRemove %{name}
  104. fi
  105. %_addemacsenlist %{name}
  106. %_emacsenPackageInstall %{name}
  107. # /sbin/install-info %{_infodir}/wl-ja.info.gz %{_infodir}/dir \
  108. # --section="Message User Agent"
  109. # /sbin/install-info %{_infodir}/wl.info.gz %{_infodir}/dir \
  110. # --section="Message User Agent"
  111. %preun
  112. if [ "$1" = 0 ]; then
  113. %_emacsenPackageRemove %{name}
  114. %_removeemacsenlist %{name}
  115. # /sbin/install-info --delete %{_infodir}/wl-ja.info.gz %{_infodir}/dir \
  116. # --section="Message User Agent"
  117. # /sbin/install-info --delete %{_infodir}/wl.info.gz %{_infodir}/dir \
  118. # --section="Message User Agent"
  119. fi
  120. %clean
  121. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  122. %files
  123. %defattr(-,root,root)
  124. %doc BUGS* COPYING* ChangeLog*
  125. %doc INSTALL* NEWS* README*
  126. %doc doc etc samples tests
  127. %{_datadir}/emacs/site-lisp/%{name}/
  128. %{emacsen_pkgdir}/install/%{name}
  129. %{emacsen_pkgdir}/remove/%{name}
  130. #%{_infodir}/wl*.info*
  131. %changelog
  132. * Sun Mar 4 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.15.9-4.cvs20120304
  133. - source snapshot 20120304
  134. * Thu Dec 1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.15.9-3.cvs20111201
  135. - source snapshot 20111201
  136. * Tue May 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.15.9-3.cvs20110524
  137. - source snapshot 20110524
  138. * Thu Apr 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.15.9-2.cvs20110414
  139. - source snapshot 20110414
  140. * Sun Feb 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.15.9-1.cvs20110220
  141. - initial build based on wl-2.14.0-3vl6