wine-vl.spec 29 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865866867868869870871872873874875876877878879880881882883884885886887888889890891892893894895896897898899900901902903904905906907908909910911912913914915916917918919920921922923924925926927928929930931932933934935936937938939940941942943944
  1. %define pkg_major_version 1.8.3
  2. %define pkg_name wine
  3. %define pkg_release 1%{?_dist_release}
  4. # NEW Release: numbering rule. -- Release: 1%{?_dist_release}
  5. # spec file for package wine.. # base (SUSE10 and fedora core 9)
  6. Summary: Allows running Windows 16/32 bit programs on Unix.
  7. Summary(ja): Unix で 16/32ビットWindoowsプログラムを実行させます
  8. Name: %{pkg_name}
  9. Version: %{pkg_major_version}
  10. Release: %{pkg_release}
  11. URL: http://www.winehq.org/
  12. License: LGPLv2+
  13. Group: Applications/System
  14. #--------------------------------------------------------------------
  15. Source0: http://prdownloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
  16. #--------------------------------------------------------------------
  17. Source1: wine.init
  18. Source3: wine-README-Fedora
  19. Source4: wine-32.conf
  20. Source5: wine-64.conf
  21. # desktop stuff
  22. Source100: wine-notepad.desktop
  23. Source101: wine-regedit.desktop
  24. Source102: wine-uninstaller.desktop
  25. Source103: wine-winecfg.desktop
  26. Source104: wine-winefile.desktop
  27. Source105: wine-winemine.desktop
  28. Source106: wine-winhelp.desktop
  29. Source107: wine-wineboot.desktop
  30. # desktop dir
  31. Source200: wine.menu
  32. Source201: wine.directory
  33. # mime types
  34. Source300: wine-mime-msi.desktop
  35. Patch0: wine-prefixfonts.patch
  36. Patch1: wine-1.1.28-rpath.patch
  37. Patch2: wine-1.7.40-x86_64_gstreamer.patch
  38. Patch3: wine-cjk.patch
  39. # ADD ja
  40. Source801: wine_README.ja
  41. Source803: wine-README-Fedora.ja
  42. Source804: wine_README_add.ja
  43. Source805: fonts-replace-list.txt
  44. Source806: ja_fonts_replace-js2ipa.reg
  45. Source807: ja_fonts_replace-js2vl.reg
  46. Source808: ja_fonts_replace-ms2ipa.reg
  47. Source809: ja_fonts_replace-ms2vl.reg
  48. Vendor: Project Vine
  49. Distribution: Vine Linux
  50. Packager: daisuke, Takemikaduchi
  51. ExclusiveArch: %{ix86} x86_64
  52. #--------------------------------------------------------------------
  53. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  54. #--------------------------------------------------------------------
  55. ## FedoraCore ##
  56. BuildRequires: bison, flex
  57. BuildRequires: audiofile, audiofile-devel
  58. BuildRequires: alsa-lib-devel
  59. BuildRequires: freeglut-devel, lcms-devel
  60. ## BuildRequires: libieee1284-devel
  61. BuildRequires: libjpeg-devel, libpng-devel
  62. BuildRequires: libstdc++-devel
  63. BuildRequires: libusb-devel
  64. BuildRequires: libxml2-devel, libxslt-devel
  65. BuildRequires: openldap-devel, ncurses-devel
  66. BuildRequires: unixODBC-devel, openssl-devel
  67. # BuildRequires: sane-devel
  68. BuildRequires: zlib-devel
  69. BuildRequires: desktop-file-utils
  70. BuildRequires: fontforge
  71. ## BuildRequires: gphoto2, gphoto2-devel
  72. ## BuildRequires: jack-audio-connection-kit-devel
  73. ## BuildRequires: isdn4k-utils-devel
  74. BuildRequires: cups-devel
  75. BuildRequires: dbus-devel
  76. BuildRequires: gstreamer-plugins-base-devel
  77. ## Requires: %{_bindir}/xmessage
  78. ## X modular(fc) > X 7.2
  79. BuildRequires: libX11-devel
  80. BuildRequires: mesa-libGL-devel
  81. BuildRequires: mesa-libGLU-devel
  82. BuildRequires: mesa-libOSMesa-devel
  83. BuildRequires: libXxf86dga-devel, libXxf86vm-devel
  84. BuildRequires: libXrandr-devel
  85. BuildRequires: libXrender-devel
  86. BuildRequires: libXext-devel
  87. BuildRequires: libXinerama-devel
  88. BuildRequires: libXcomposite-devel
  89. BuildRequires: libXmu-devel
  90. BuildRequires: libXi-devel
  91. BuildRequires: libXcursor-devel
  92. BuildRequires: fontconfig-devel
  93. BuildRequires: giflib-devel
  94. BuildRequires: libtiff-devel
  95. BuildRequires: pkgconfig
  96. BuildRequires: libicu-devel
  97. BuildRequires: freetype2-devel
  98. BuildRequires: lcms2-devel
  99. BuildRequires: gsm-devel
  100. %ifarch x86_64
  101. BuildRequires: compat32-glibc-devel
  102. BuildRequires: compat32-glibc-devel
  103. BuildRequires: compat32-libX11-devel
  104. BuildRequires: compat32-libxcb-devel
  105. BuildRequires: compat32-freetype2-devel
  106. BuildRequires: compat32-libSM-devel
  107. BuildRequires: compat32-libXext-devel
  108. BuildRequires: compat32-libXrender-devel
  109. BuildRequires: compat32-mesa-libGL-devel
  110. BuildRequires: compat32-mesa-libGLU-devel
  111. BuildRequires: compat32-mesa-libOSMesa-devel
  112. BuildRequires: compat32-libxml2-devel
  113. BuildRequires: compat32-libxslt-devel
  114. BuildRequires: compat32-openssl-devel
  115. BuildRequires: compat32-libjpeg-devel
  116. BuildRequires: compat32-libpng-devel
  117. BuildRequires: compat32-zlib-devel
  118. BuildRequires: compat32-alsa-lib-devel
  119. BuildRequires: compat32-dbus-devel
  120. BuildRequires: compat32-lcms2-devel
  121. BuildRequires: compat32-cups-devel
  122. BuildRequires: compat32-gnutls-devel
  123. BuildRequires: compat32-gstreamer-devel
  124. BuildRequires: compat32-gstreamer-plugins-base-devel
  125. BuildRequires: compat32-gsm-devel
  126. ## extension
  127. BuildRequires: compat32-libXcursor-devel
  128. BuildRequires: compat32-libXi-devel
  129. BuildRequires: compat32-libXxf86vm-devel
  130. BuildRequires: compat32-libXrandr-devel
  131. BuildRequires: compat32-libXinerama-devel
  132. BuildRequires: compat32-libXcomposite-devel
  133. BuildRequires: compat32-ncurses-devel
  134. BuildRequires: compat32-fontconfig-devel
  135. BuildRequires: compat32-libtiff-devel
  136. BuildRequires: compat32-openldap-devel
  137. Requires: compat32-freetype2
  138. Requires: compat32-ncurses
  139. Requires: compat32-eudev-libudev
  140. %endif
  141. Requires(post): /sbin/ldconfig, /sbin/chkconfig, /sbin/service
  142. Requires(post): desktop-file-utils >= 0.8
  143. Requires(preun): /sbin/chkconfig, /sbin/service
  144. Requires(postun): /sbin/ldconfig
  145. Requires(postun): desktop-file-utils >= 0.8
  146. #--------------------------------------------------------------------
  147. %description
  148. (WINE Is Not an Emulator)
  149. While Wine is usually thought of as a Windows(TM) emulator,
  150. the Wine developers would prefer that users thought of
  151. Wine as a Windows compatibility layer for UNIX.
  152. This package includes a program loader, which allows
  153. unmodified Windows 3.x/9x/NT binaries to run on x86 and
  154. x86_64 Unixes.
  155. Wine does not require MS Windows, but it can use native
  156. system .dll files if they are available.
  157. %description -l ja
  158. (WINE Is Not an Emulator)
  159. WINEは普段、Windows(TM)のエミュレーターと考えられているが、WINEの
  160. 開発者達は、むしろユーザーが、「WINEはUnix環境のためのWindows
  161. 互換レイヤー」と考えてくれる事を好むでしょう。
  162. このパッケージはプログラムローダーを含み、これは未修正の
  163. Windows 3.x/9x/NT バイナリを x86 や x86_64 のUnix システムで動作
  164. させます。
  165. WINE は動作にあたって MS Windows を必要とはしませんが、ネイティブ
  166. Windows システムの .dll ファイルが存在するのならば、それを使用する
  167. 事もできます
  168. #--------------------------------------------------------------------
  169. %package 64bit
  170. Summary: Allows running Windows 64 bit programs on Unix.
  171. Summary(ja): Unix で 64ビットWindoowsプログラムを実行させます
  172. Group: Applications/System
  173. Requires: %{name} = %{version}-%{release}
  174. %description 64bit
  175. (WINE Is Not an Emulator)
  176. While Wine is usually thought of as a Windows(TM) emulator,
  177. the Wine developers would prefer that users thought of
  178. Wine as a Windows compatibility layer for UNIX.
  179. This package includes a program loader, which allows
  180. unmodified Windows 64bit binaries to run on x86_64 Unixes.
  181. Wine does not require MS Windows, but it can use native
  182. system .dll files if they are available.
  183. #--------------------------------------------------------------------
  184. %package devel
  185. Summary: Wine development environment
  186. Summary(ja): WINE の開発ファイルです
  187. Group: System Environment/Libraries
  188. Requires: %{name} = %{version}-%{release}
  189. %description devel
  190. This RPM contains the header files and development tools
  191. for the WINE libraries.
  192. %description devel -l ja
  193. WINEの開発用ライブラリやヘッダーファイル、そして開発用の
  194. アプリケーション(例:winebuild)のパッケージです
  195. (development packages)
  196. #--------------------------------------------------------------------
  197. %package init
  198. Summary: WINE binfmt_misc kernel function used for init file.
  199. Summary(ja): WINE で binfmt_misc機能 を使うための起動ファイルです
  200. Group: System Environment/Libraries
  201. Requires: %{name} = %{version}-%{release}
  202. %description init
  203. WINE binfmt_misc kernel function used for init file.
  204. WIN32-binary attribute run with a Linux-binary run the same way as possible.
  205. (init.d packages)
  206. ** example **
  207. Until now, "$ wine /file/to/path/arege.exe" and then you were running
  208. from the usual binary Linux as "$ /file/to/path/arege.exe"
  209. and just be able to run.
  210. Of course, please be mindful of security.
  211. %description init -l ja
  212. カーネルの binfmt_misc機能 をWINEで使うための initファイルです。
  213. 実行属性の付いた WIN32バイナリを Linuxバイナリと同じように実行できる
  214. ようにします。
  215. (init.d packages)
  216. ※ 例 ※
  217. これまで "$ wine /file/to/path/arege.exe" と入力してから実行していました
  218. が、通常の Linuxバイナリ のように "$ /file/to/path/arege.exe" とする
  219. だけで実行できるようになります。
  220. 無論、セキュリティに留意して下さい。
  221. #--------------------------------------------------------------------
  222. %prep
  223. %setup -q -n %{name}-%{version}
  224. %ifarch x86_64
  225. %patch2 -p1
  226. rm -rf ../64bit
  227. mkdir ../64bit
  228. cp -r * ../64bit/
  229. %endif
  230. %patch3 -p1 -b .cjk
  231. # fix typo
  232. sed -i "s|Thamoa|Tahoma|" po/ja.po
  233. %build
  234. autoreconf -if
  235. %ifarch x86_64
  236. export CFLAGS="-O2 -m32 -march=i686 -mtune=generic -fasynchronous-unwind-tables -fno-strict-aliasing -fno-schedule-insns2"
  237. ./configure \
  238. --prefix=%{_prefix} \
  239. --libdir=%{_prefix}/lib \
  240. --with-x \
  241. --without-capi \
  242. --without-gphoto \
  243. --without-hal \
  244. --without-mpg123 \
  245. --without-sane
  246. pushd ../64bit
  247. autoreconf -if
  248. export CFLAGS="$RPM_OPT_FLAGS"
  249. %{configure} \
  250. --prefix=%{_prefix} \
  251. --with-x \
  252. --without-capi \
  253. --without-gphoto \
  254. --without-hal \
  255. --without-mpg123 \
  256. --without-sane \
  257. --enable-win64
  258. popd
  259. %else
  260. export CFLAGS="$RPM_OPT_FLAGS"
  261. %{configure} \
  262. --prefix=%{_prefix} \
  263. --with-x \
  264. --without-jack \
  265. --without-capi \
  266. --without-gphoto \
  267. --without-hal \
  268. --without-mpg123 \
  269. --without-sane
  270. %endif
  271. grep "have_x=yes" config.log || exit 1
  272. %ifarch x86_64
  273. export CFLAGS="-O2 -m32 -march=i686 -mtune=generic -fasynchronous-unwind-tables -fno-strict-aliasing -fno-schedule-insns2"
  274. %{__make} depend
  275. %{__make} %{?_smp_mflags}
  276. export CFLAGS="$RPM_OPT_FLAGS"
  277. pushd ../64bit
  278. %{__make} depend
  279. %{__make} %{?_smp_mflags}
  280. popd
  281. %else
  282. %{__make} depend
  283. %{__make} %{?_smp_mflags}
  284. %endif
  285. %install
  286. rm -rf ${RPM_BUILD_ROOT}
  287. %ifarch x86_64
  288. pushd ../64bit
  289. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  290. mv ${RPM_BUILD_ROOT}%{_bindir}/wineserver ${RPM_BUILD_ROOT}%{_bindir}/wineserver64
  291. popd
  292. %endif
  293. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  294. #-----------------------------------------------------------FC9
  295. mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/wine
  296. # Allow users to launch Windows programs by just clicking on the .exe file...
  297. mkdir -p ${RPM_BUILD_ROOT}%{_initrddir}
  298. install -p -c -m 755 %{SOURCE1} ${RPM_BUILD_ROOT}%{_initrddir}/wine
  299. # add wine dir to desktop
  300. mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged
  301. install -p -m 644 %{SOURCE200} \
  302. ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
  303. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/desktop-directories
  304. install -p -m 644 %{SOURCE201} \
  305. ${RPM_BUILD_ROOT}%{_datadir}/desktop-directories/Wine.directory
  306. ## mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/applications
  307. ## %%{_datadir}/applications
  308. # install desktop files
  309. desktop-file-install \
  310. --vendor=vine \
  311. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  312. %{SOURCE100}
  313. desktop-file-install \
  314. --vendor=vine \
  315. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  316. %{SOURCE101}
  317. desktop-file-install \
  318. --vendor=vine \
  319. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  320. %{SOURCE102}
  321. desktop-file-install \
  322. --vendor=vine \
  323. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  324. %{SOURCE103}
  325. desktop-file-install \
  326. --vendor=vine \
  327. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  328. %{SOURCE104}
  329. desktop-file-install \
  330. --vendor=vine \
  331. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  332. %{SOURCE105}
  333. desktop-file-install \
  334. --vendor=vine \
  335. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  336. %{SOURCE106}
  337. desktop-file-install \
  338. --vendor=vine \
  339. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  340. %{SOURCE107}
  341. desktop-file-install \
  342. --vendor=vine \
  343. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  344. --delete-original \
  345. ${RPM_BUILD_ROOT}/%{_datadir}/applications/wine.desktop
  346. #mime-types
  347. desktop-file-install \
  348. --vendor=vine \
  349. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  350. %{SOURCE300}
  351. ## other files
  352. cp %{SOURCE3} README-Fedora
  353. cp %{SOURCE803} README-Fedora.ja
  354. cp %{SOURCE801} documentation/README.ja
  355. cp %{SOURCE804} documentation/README_add.ja
  356. cp %{SOURCE805} %{SOURCE806} %{SOURCE807} %{SOURCE808} %{SOURCE809} documentation/
  357. mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/ld.so.conf.d/
  358. install -p -m644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_sysconfdir}/ld.so.conf.d/
  359. %ifarch x86_64
  360. install -p -m644 %{SOURCE5} ${RPM_BUILD_ROOT}%{_sysconfdir}/ld.so.conf.d/
  361. %endif
  362. # check desktop files
  363. %check
  364. desktop-file-validate \
  365. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-notepad.desktop
  366. desktop-file-validate \
  367. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-regedit.desktop
  368. desktop-file-validate \
  369. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-uninstaller.desktop
  370. desktop-file-validate \
  371. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winecfg.desktop
  372. desktop-file-validate \
  373. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winefile.desktop
  374. desktop-file-validate \
  375. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winemine.desktop
  376. desktop-file-validate \
  377. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winhelp.desktop
  378. desktop-file-validate \
  379. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-wineboot.desktop
  380. desktop-file-validate \
  381. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-mime-msi.desktop
  382. #--------------------------------------------------------------------
  383. %clean
  384. rm -rf ${RPM_BUILD_ROOT}
  385. %post
  386. /sbin/ldconfig
  387. update-desktop-database &>/dev/null || :
  388. ### add vinelinux
  389. if [ "$LANG" = "ja_JP.UTF-8" ]; then
  390. echo "WINEのシステムフォントをリプレースするには"
  391. echo " fonts-replace-list.txt をお読み下さい。"
  392. else
  393. echo "You need to Japanese fonts name replace, "
  394. echo "See fonts-replace-list.txt ."
  395. fi
  396. %postun
  397. /sbin/ldconfig
  398. update-desktop-database &>/dev/null || :
  399. %post 64bit -p /sbin/ldconfig
  400. %postun 64bit -p /sbin/ldconfig
  401. %post init
  402. if [ $1 = 1 ]; then
  403. /sbin/chkconfig --add wine
  404. /sbin/chkconfig --level 2345 wine on
  405. /sbin/service wine start &>/dev/null || :
  406. fi
  407. ### add vinelinux
  408. if [ "$LANG" = "ja_JP.UTF-8" ]; then
  409. echo "WINE から binfmt_misc 機能を利用するための起動ファイルが"
  410. echo "インストールされ、ランレベル2、3、4、5で有効になりました。"
  411. echo "(ファイル名は /etc/init.d/wine です)"
  412. echo "起動時にファイルシステムのマウントが必要です。"
  413. echo "root権限で次のコマンドを使い、 /etc/fstab に追記して下さい。"
  414. echo "(削除も手動でお願いします)"
  415. echo ""
  416. echo "# cp /etc/fstab /etc/fstab.before ##バックアップの作成"
  417. echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
  418. echo "参照(Ja) http://opentechpress.jp/developer/article.pl?sid=06/08/24/0033257 "
  419. else
  420. echo "WINE binfmt_misc feature from the boot files "
  421. echo "to be installed and enabled 2,3,4,5 runlevel."
  422. echo "(File name in the /etc/init.d/wine )"
  423. echo "Filesystem mounted at boot time is required."
  424. echo "Root privileges using the following command in the /etc/fstab"
  425. echo "please Addenda.(Please delete manually.)"
  426. echo ""
  427. echo "# cp /etc/fstab /etc/fstab.before ##(Create backup)"
  428. echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
  429. echo "See also(en)http://www.linux.com/articles/56032 "
  430. fi
  431. %preun init
  432. if [ $1 = 0 ]; then
  433. /sbin/service wine stop >/dev/null 2>&1
  434. /sbin/chkconfig --del wine
  435. fi
  436. #--------------------------------------------------------------------
  437. ## deleted /usr/share/applications/wine.desktop
  438. %files
  439. %defattr(-,root,root,-)
  440. %doc ANNOUNCE AUTHORS COPYING.LIB LICENSE LICENSE.OLD
  441. %doc README VERSION
  442. %doc README-Fedora
  443. %doc README-Fedora.ja
  444. %doc documentation/README*
  445. %doc documentation/ja_fonts_replace*
  446. %doc documentation/fonts-replace-list.txt
  447. %{_sysconfdir}/xdg/menus/applications-merged/wine.menu
  448. %{_sysconfdir}/ld.so.conf.d/wine-32.conf
  449. %{_bindir}/msiexec
  450. %{_bindir}/regedit
  451. %{_bindir}/regsvr32
  452. %{_bindir}/wine
  453. %{_bindir}/wineboot
  454. %{_bindir}/wineconsole
  455. %{_bindir}/winecfg
  456. %{_bindir}/wine-preloader
  457. %{_bindir}/wineserver
  458. %{_bindir}/notepad
  459. %{_bindir}/winedbg
  460. %{_bindir}/winedump
  461. %{_bindir}/winefile
  462. %{_bindir}/winemaker
  463. %{_bindir}/winemine
  464. %{_bindir}/winepath
  465. %ifarch x86_64
  466. %{_prefix}/lib/libwine.so.1*
  467. %dir %{_prefix}/lib/wine
  468. %{_prefix}/lib/wine/*.cpl.so
  469. %{_prefix}/lib/wine/*.exe.so
  470. %{_prefix}/lib/wine/*.exe16.so
  471. %{_prefix}/lib/wine/*.dll.so
  472. %{_prefix}/lib/wine/*.dll16.so
  473. %{_prefix}/lib/wine/*.drv.so
  474. %{_prefix}/lib/wine/*.drv16.so
  475. %{_prefix}/lib/wine/*.mod16.so
  476. %{_prefix}/lib/wine/*.ds.so
  477. %{_prefix}/lib/wine/*.ocx.so
  478. %{_prefix}/lib/wine/*.vxd.so
  479. %{_prefix}/lib/wine/*.acm.so
  480. %{_prefix}/lib/wine/*.sys.so
  481. %{_prefix}/lib/wine/*.tlb.so
  482. %dir %{_prefix}/lib/wine/fakedlls
  483. %{_prefix}/lib/wine/fakedlls/*
  484. %else
  485. %{_libdir}/libwine.so.1*
  486. %dir %{_libdir}/wine
  487. %{_libdir}/wine/*.cpl.so
  488. %{_libdir}/wine/*.exe.so
  489. %{_libdir}/wine/*.dll.so
  490. %{_libdir}/wine/*.drv.so
  491. %{_libdir}/wine/*.ds.so
  492. %{_libdir}/wine/*.ocx.so
  493. %{_libdir}/wine/*.acm.so
  494. %{_libdir}/wine/*.sys.so
  495. %{_libdir}/wine/*.tlb.so
  496. %{_libdir}/wine/*.exe16.so
  497. %{_libdir}/wine/*.dll16.so
  498. %{_libdir}/wine/*.drv16.so
  499. %{_libdir}/wine/*.mod16.so
  500. %{_libdir}/wine/*.vxd.so
  501. %dir %{_libdir}/wine/fakedlls
  502. %{_libdir}/wine/fakedlls/*
  503. %endif
  504. %dir %{_datadir}/wine
  505. %{_datadir}/wine/*
  506. %{_datadir}/applications/vine-wine-mime-msi.desktop
  507. %{_datadir}/applications/vine-wine.desktop
  508. %{_datadir}/applications/vine-wine-regedit.desktop
  509. %{_datadir}/applications/vine-wine-uninstaller.desktop
  510. %{_datadir}/applications/vine-wine-winecfg.desktop
  511. %{_datadir}/applications/vine-wine-wineboot.desktop
  512. %{_datadir}/applications/vine-wine-notepad.desktop
  513. %{_datadir}/applications/vine-wine-winefile.desktop
  514. %{_datadir}/applications/vine-wine-winemine.desktop
  515. %{_datadir}/applications/vine-wine-winhelp.desktop
  516. %{_datadir}/desktop-directories/Wine.directory
  517. %{_mandir}/man1/wine.1.*
  518. %{_mandir}/man1/wineserver.1*
  519. %{_mandir}/man1/msiexec.1*
  520. %{_mandir}/man1/notepad.1*
  521. %{_mandir}/man1/regedit.1*
  522. %{_mandir}/man1/regsvr32.1*
  523. %{_mandir}/man1/wineboot.1*
  524. %{_mandir}/man1/winecfg.1*
  525. %{_mandir}/man1/wineconsole.1*
  526. %{_mandir}/man1/winefile.1*
  527. %{_mandir}/man1/winemine.1*
  528. %{_mandir}/man1/winepath.1*
  529. %lang(de) %{_mandir}/de.UTF-8/man1/*.1*
  530. %lang(fr) %{_mandir}/fr.UTF-8/man1/*
  531. %lang(pl) %{_mandir}/pl.UTF-8/man1/wine.1*
  532. #--------------------------------------------------------------------
  533. %ifarch x86_64
  534. %files 64bit
  535. %defattr(-,root,root,-)
  536. %{_sysconfdir}/ld.so.conf.d/wine-64.conf
  537. %{_bindir}/wine64
  538. %{_bindir}/wine64-preloader
  539. %{_bindir}/wineserver64
  540. %{_libdir}/libwine.so.1*
  541. %dir %{_libdir}/wine
  542. %{_libdir}/wine/*.cpl.so
  543. %{_libdir}/wine/*.exe.so
  544. %{_libdir}/wine/*.dll.so
  545. %{_libdir}/wine/*.drv.so
  546. %{_libdir}/wine/*.ds.so
  547. %{_libdir}/wine/*.ocx.so
  548. %{_libdir}/wine/*.acm.so
  549. %{_libdir}/wine/*.sys.so
  550. %{_libdir}/wine/*.tlb.so
  551. %dir %{_libdir}/wine/fakedlls
  552. %{_libdir}/wine/fakedlls/*
  553. %endif
  554. #--------------------------------------------------------------------
  555. %files devel
  556. %defattr(-,root,root,-)
  557. %{_bindir}/function_grep.pl
  558. %{_bindir}/widl
  559. %{_bindir}/winebuild
  560. %{_bindir}/winecpp
  561. %{_bindir}/winedump
  562. %{_bindir}/wineg++
  563. %{_bindir}/winegcc
  564. %{_bindir}/winemaker
  565. %{_bindir}/wmc
  566. %{_bindir}/wrc
  567. %{_includedir}/wine
  568. %{_libdir}/*.so
  569. %{_libdir}/wine/*.a
  570. %{_libdir}/wine/*.def
  571. %ifarch x86_64
  572. %{_prefix}/lib/*.so
  573. %{_prefix}/lib/wine/*.a
  574. %{_prefix}/lib/wine/*.def
  575. %endif
  576. %{_mandir}/man1/widl.1*
  577. %{_mandir}/man1/winebuild.1*
  578. %{_mandir}/man1/winecpp.1*
  579. %{_mandir}/man1/winedump.1*
  580. %{_mandir}/man1/winegcc.1*
  581. %{_mandir}/man1/winemaker.1*
  582. %{_mandir}/man1/wmc.1*
  583. %{_mandir}/man1/wrc.1*
  584. %{_mandir}/man1/winedbg.1*
  585. %{_mandir}/man1/wineg++.1*
  586. #--------------------------------------------------------------------
  587. %files init
  588. %defattr(-,root,root,-)
  589. %{_initrddir}/wine
  590. %doc documentation/README_add.ja
  591. #--------------------------------------------------------------------
  592. %changelog
  593. * Sat Jun 18 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.3-1
  594. - new upstream release
  595. * Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
  596. - new upstream release
  597. * Thu Feb 11 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
  598. - new upstream release
  599. - add Source5 (wine-64.conf)
  600. - add Patch3 (wine-cjk.patch) based on fedora
  601. - add Requires: compat32-eudev-libudev
  602. - add configure option (--enable-win64)
  603. - create wine-64bit subpackage
  604. * Sun Dec 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8-1
  605. - new upstream release
  606. - remove Patch400,401,402
  607. - remove Source402,802
  608. * Sat Nov 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.54-1
  609. - update to 1.7.54
  610. * Sat Oct 24 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.53-1
  611. - update to 1.7.53
  612. * Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.52-1
  613. - update to 1.7.52
  614. * Sun Sep 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.51-1
  615. - update to 1.7.51
  616. * Sun Aug 23 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.50-1
  617. - update to 1.7.50
  618. * Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.49-1
  619. - update to 1.7.49
  620. * Sat Aug 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.48-1
  621. - update to 1.7.48
  622. * Sun Jun 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.44-1
  623. - update to 1.7.44
  624. * Sun May 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.42-1
  625. - update to 1.7.42
  626. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.40-1
  627. - update to 1.7.40
  628. - update Patch2 (wine-1.7.40-x86_64_gstreamer.patch)
  629. - add BuildRequires: compat32-mesa-libOSMesa-devel, compat32-lcms2-devel, compat32-gsm-devel (x86_64 only)
  630. - add BuildRequires: mesa-libOSMesa-devel, lcms2-devel, gsm-devel
  631. * Sat Jan 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
  632. - new upstream release
  633. * Sun Nov 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
  634. - new upstream release
  635. * Sat Jul 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6-1
  636. - new upstream release
  637. - remove Patch1000 (wine-1.4.1-vine.patch)
  638. - update Patch2 (wine-1.6-x86_64_gstreamer.patch)
  639. * Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.17-1
  640. - update to 1.5.17
  641. * Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
  642. - new upstream release
  643. - update Patch1000 (wine-1.4.1-vine.patch)
  644. * Thu Mar 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4-1
  645. - new upstream release
  646. - add Patch2 (wine-1.4-x86_64_gstreamer.patch)
  647. - add BuildRequires: gstreamer-plugins-base-devel
  648. * Sat Jul 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
  649. - update to 1.2.3
  650. - add Requires: compat32-freetype2 (x86_64 only)
  651. * Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
  652. - new upstream release
  653. * Thu Oct 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
  654. - new upstream release
  655. - drop Patch1
  656. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-2
  657. - new upstream release
  658. - fix %configure (add configu:e and gcc option of x86_64)
  659. - fix %install (remove wine.desktop and change make install option)
  660. - add ExclusiveArch: %{ix86} x86_64
  661. - add BuildRequires for x86_64 (compat32 packages)
  662. * Sat Jun 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-1.rc2
  663. - update to 1.2-rc2
  664. - fix spec file
  665. - if [ "$LANG" = "ja_JP.eucJP" ];
  666. + if [ "$LANG" = "ja_JP.UTF-8" ];
  667. - convert kanji code (ja_JP.eucJP -> ja_JP.UTF-8)
  668. - SOURCE801, SOURCE802, SOURCE803, SOURCE804, SOURCE805
  669. - fix %files
  670. - drop patches (Patch0, Patch400, Patch402)
  671. * Sun Sep 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-2
  672. - update BRs
  673. - remove freetype-devel
  674. - remove libungif-devel, add giflib-devel
  675. - remove gphoto2-devel, add libgphoto2-devel
  676. * Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-1
  677. - update to 1.1.29
  678. * Tue Sep 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.28-1
  679. - update to 1.1.28
  680. - update winepulse patches
  681. * Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.23-1
  682. - update to 1.1.23
  683. - spec in utf-8
  684. - add patch1000 to enable FontSmoothing by deafult.
  685. - update pulseaudio patches
  686. - remove invalid Provides: Wine HQ
  687. - remove unneeded patches
  688. * Tue Jul 8 2008 Seiichirou Babasaki 1.1.0-1
  689. - Wine development release 1.1.0.
  690. - Updated specfile (for VineSeed)
  691. #--------------------------------------------------------------------
  692. * Sat Jul 5 2008 Seiichirou Babasaki 1.0-2
  693. - added "ja_fonts_replace-*.reg" files.
  694. - Updated specfile
  695. * Fri Jul 4 2008 Seiichirou Babasaki 1.0-1
  696. - version upgrade
  697. - Updated specfile
  698. - Update to 1.0
  699. - fix wine.desktop mime types (fc)
  700. - add desktop package including desktop files and binary handler (fc)
  701. - pull in some wine alsa/pulseaudio patches (fc)
  702. -- NEWS "June 17, 2008: Wine 1.0 Released"
  703. -- read http://www.winehq.org/?issue=348
  704. * Wed Jun 11 2008 Seiichirou Babasaki 1.0-1rc4
  705. - Updated specfile
  706. - Update to 1.0-rc4
  707. - NEWS "June 6, 2008: Wine 1.0-rc4 Released"
  708. -- ntdll: Add local defines for VIF and VIP flags.
  709. -- wininet: Include openssl/ssl.h before Windows headers.
  710. -- shell32: Fixed the French about box.
  711. -- ChangeLog: Moved to documentation/ChangeLog.BETA.
  712. -- fonts: Add a non-breaking space glyph to the Tahoma fonts.
  713. -- ....others , read ChangeLog
  714. --- Bug fixes only, we are in code freeze.
  715. * Tue Jun 03 2008 Seiichirou Babasaki 1.0-1rc3
  716. - Updated specfile
  717. - Update to 1.0-rc3
  718. - NEWS "May 30, 2008: Wine 1.0-rc3 Released"
  719. -- The default version is now Windows XP.
  720. -- Many Richedit improvements.
  721. -- Beginning of jscript dll support.
  722. -- Shell folders now respect XDG directory configuration.
  723. -- Many translation updates.
  724. -- Lots of bug fixes.
  725. -- * Bug fixes only, we are in code freeze.
  726. --- kernel32: Add a builtin 16-bit winhelp.exe.
  727. --- This should be moved to winhlp32.exe once we support 16-bit modules in
  728. --- executables.
  729. ---- winhelp -> renamed winhlp32.exe
  730. ---- programs: Remove winelauncher from install rules.
  731. * Fri Apr 04 2008 Seiichirou Babasaki 0.9.59
  732. - Updated specfile
  733. - Update to 0.9.59
  734. - NEWS.. "April 4, 2008: Wine 0.9.59 Released"
  735. -- * Improved support for the .NET framework.
  736. -- * Better services handling through a separate services.exe process.
  737. -- * Support for ATI fragment shader.
  738. -- * Better support for http proxies.
  739. -- * Window management fixes.
  740. -- * Pre-compiled fonts are now available in the source tree.
  741. -- * Lots of bug fixes.
  742. * Mon Mar 24 2008 Seiichirou Babasaki 0.9.58
  743. - Updated specfile (split wine-init package)
  744. - Update to 0.9.58
  745. - NEWS.. "March 21, 2008: Wine 0.9.58 Released"
  746. -- * The default version is now Windows XP.
  747. -- * Many Richedit improvements.
  748. -- * Beginning of jscript dll support.
  749. -- * Shell folders now respect XDG directory configuration.
  750. -- * Many translation updates.
  751. -- * Lots of bug fixes.
  752. * Tue Mar 11 2008 Seiichirou Babasaki 0.9.57-1vl1
  753. - Updated specfile (*.desktop file %check .)
  754. - Update to 0.9.57
  755. - NEWS.. "March 7, 2008: Wine 0.9.57 Released"
  756. -- * Support for multiple OpenGL pixel formats.
  757. -- * Improved support for color profiles.
  758. -- * Many window management fixes.
  759. -- * Better fullscreen support.
  760. -- * Lots of bug fixes.
  761. * Fri Feb 29 2008 Seiichirou Babasaki 0.9.56-1vl1
  762. - Updated specfile
  763. - ("Build Tool" from the wine-package to move to devel-packages)
  764. - Update to 0.9.56
  765. - NEWS.. "February 22, 2008: Wine 0.9.56 Released"
  766. -- * Proper handling of OpenGL/Direct3D windows with menu bars.
  767. -- * Stubs for all the d3dx9_xx dlls.
  768. -- * Several graphics optimizations.
  769. -- * Many installer fixes.
  770. -- * Improved MIME message support.
  771. -- * Lots of bug fixes.
  772. * Fri Feb 15 2008 Seiichirou Babasaki 0.9.55-1vl2
  773. - Updated specfile (cf. VineLinux .spec file format)
  774. - Add Installed messages for "binfmt_misc" .
  775. - *.desktop file "Name" change to japanese. (UTF8)
  776. * Wed Feb 13 2008 Seiichirou Babasaki 0.9.55-1vl1
  777. - Import WINE - Packager: Babasaki
  778. - Updated specfile (SUSE base + FC9 cfg)
  779. - Update to 0.9.55
  780. - Update to 0.9.54 from FC9
  781. - Update to 0.9.53 from Private package
  782. # FC9 ------------------------------------------------------------- FC9
  783. * Sun Feb 10 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  784. - 0.9.55-1
  785. - version upgrade
  786. * Fri Jan 25 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  787. - 0.9.54-1
  788. - version upgrade
  789. - remove default pulseaudio workaround (#429420,#428745)
  790. - improve pulseaudio readme
  791. * Sun Jan 13 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  792. - 0.9.53-2
  793. - add some missing BR
  794. * Sat Jan 12 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  795. - 0.9.53-1
  796. - version upgrade
  797. * Sat Dec 29 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  798. - 0.9.52-2
  799. - fix menu bug (#393641)
  800. * Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  801. - 0.9.52-1
  802. - version upgrade
  803. * Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  804. - 0.9.51-3
  805. - add -n Wine to pulseaudio workaround
  806. - try to fix menu bug #393641
  807. * Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  808. - 0.9.51-2
  809. - add fix for #344281 pulseaudio workaround
  810. - fix #253474: wine-jack should require jack-audio-connection-kit
  811. * Sun Dec 16 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  812. - 0.9.51-1
  813. - version upgrade
  814. # ---- abbreviatio ----------------------------------------------------#
  815. # ----------and suse.
  816. # * Fri Mar 17 2006 - meissner@suse.de
  817. # - Avoid ulimit leading to out of memory situations by using
  818. # the compat address space layout personality. #152115