wbar-vl.spec 8.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286
  1. # -*- coding: utf-8-unix -*-
  2. %define wbarconfversion 0.5
  3. %define wbar_utilversion 1.0
  4. %define ttfontdir /usr/share/fonts/TrueType-vlgothic
  5. %define vlgothic TrueType-vlgothic
  6. Version: 1.3.3
  7. Release: 7%{?_dist_release}
  8. Name: wbar
  9. Summary: Quick Launch Bar such as a Dock of Max OS X
  10. Summary(ja): Mac OS X の Dock のようなクイックランチャーバー
  11. Source: http://www.tecapli.com.ar/warlock/%{name}-%{version}.tbz2
  12. Source2: http://kapsi.fi/ighea/wbarconf/%{name}conf-%{wbarconfversion}.tar.gz
  13. Patch1: wbar-makefile.patch
  14. Patch2: wbar-kde-above-desk.patch
  15. ## vine
  16. Source1: wbar.desktop
  17. Source3: http://home.arcor.de/max.federle/wbarutil/downloads/%{name}_util-%{wbar_utilversion}.tar.bz2
  18. Source4: wbar_util-bytecompile.py
  19. # scripts
  20. Source12: wbar_session
  21. Source13: wbar_gen
  22. Source14: wbar_readme
  23. # icons
  24. Source20: mlterm.png
  25. Source21: urxvt.png
  26. Source22: rox-filer.png
  27. Source23: wbar_util-2.png
  28. Source24: vine-wbar.png
  29. Source25: readme.png
  30. Source26: default.png
  31. Source27: grape.png
  32. Source28: xterm.png
  33. Source29: unicode-term.png
  34. Source30: mailer.png
  35. # conf-file template
  36. Source40: dot.wbar.jp
  37. # documents
  38. Source41: vine_readme_wbar.html
  39. Source42: vine_readme_wbar.txt
  40. #Patch10: wbar-default-setting.patch
  41. Patch11: wbar_util-1.0-vine.patch
  42. #Patch12: wbar-dot-bar-default.patch
  43. Patch13: wbar-dot-bar-default2.patch
  44. Patch14: wbar-session.patch
  45. Patch15: wbar-1.3.3_gcc43_fixes.patch
  46. ## ja_po
  47. Source11: wbar_util-1.0-ja.po
  48. URL: http://freshmeat.net/projects/wbar/
  49. Group: User Interface/Desktops
  50. License: GPLv2
  51. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  52. BuildRequires: imlib2-devel
  53. BuildRequires: XOrg-devel
  54. BuildRequires: freetype2-devel
  55. BuildRequires: zlib-devel
  56. BuildRequires: gcc-c++
  57. BuildRequires: libstdc++34-devel
  58. BuildRequires: make
  59. BuildRequires: glibc-devel
  60. BuildRequires: desktop-file-utils
  61. Requires: imlib2-loader
  62. %if %{?_dist_release} == "vl5"
  63. Requires: pyxdg zenity
  64. %endif
  65. ## vine
  66. Requires: %{vlgothic}
  67. ## ja_po
  68. BuildRequires: gettext
  69. %description
  70. wbar is a quick launch bar. Its fast, light and cool eye-candy.
  71. Its hacked in c++ trying to keep code as readable as possible with out
  72. sacrificing speed. It works directly on top of X to avoid going throug a lot
  73. of layers.
  74. Initially developed for Fluxbox, then tested on WindowMaker, Xfce, Gnome, etc.
  75. Since version 1.0 can run on top of desktops such as xfdesktop or nautilus
  76. with the -above-desk switch.
  77. This package contained in some wbar configuration utilityies:
  78. - wbarconf
  79. - wbar_util
  80. %description -l ja
  81. wbar は(Dock でありませんが Dock 風な)クイックランチャーバーです.
  82. 速くて,軽くて,見た目にもクールです.
  83. wbar は可能な限り可読性のあるコードの保守を試みて C++ でハックされています.
  84. with out sacrificing speed.
  85. たくさんのレイヤーを通していくのを避けるために X 上で直接的に動作します.
  86. 当初は Fluxbox に対して開発されていましたが、それから
  87. WindowMaker, Xfce, Gnome 上で試みていました。
  88. バージョン 1.0 以降、-above-desk オプションを付けることで
  89. Xfdesktop あるいは Nautilus のようなデスクトップの最前面で起動できます。
  90. このパッケージには、いくつかの wbar 環境設定ユーティリティーを同梱しています:
  91. - wbarconf
  92. - wbar_util
  93. %prep
  94. %setup -q -a 3
  95. %patch1
  96. %patch2
  97. ## vine
  98. #% patch10
  99. %patch11 -p1
  100. #%patch12 -p1
  101. %patch13 -p1
  102. ## tools
  103. %__install -m0755 %{SOURCE12} %{SOURCE13} %{SOURCE14} wbar_util/usr/local/bin/
  104. ## icons
  105. %__install -m0644 %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23} %{SOURCE24} \
  106. %{SOURCE25} %{SOURCE26} %{SOURCE27} %{SOURCE28} %{SOURCE29} %{SOURCE30} \
  107. iconpack/wbar.osx/
  108. %patch14 -p1
  109. %patch15 -p1
  110. ## ja_po
  111. %__install -d -m0755 wbar_util/opt/wbar_util/locale/ja/LC_MESSAGES
  112. %__install %{SOURCE11} wbar_util/opt/wbar_util/locale/ja/LC_MESSAGES/main.po
  113. pushd wbar_util/opt/wbar_util/locale/ja/LC_MESSAGES/
  114. msgfmt -o main.mo main.po
  115. popd
  116. %build
  117. %__make \
  118. CXXFLAGS="`imlib2-config --cflags` %{optflags}" \
  119. LDFLAGS="`imlib2-config --libs`" \
  120. PREFIX="%{_datadir}/wbar"
  121. %install
  122. %{__rm} -rf $RPM_BUILD_ROOT
  123. #% makeinstall DESTDIR=%{buildroot} PREFIX=%{_datadir}/wbar
  124. %{__make} DESTDIR=$RPM_BUILD_ROOT install
  125. ## make sybolic link to ttf font for subtitle
  126. #%if %{?_dist_release} == "vl5"
  127. #ln -sf %{ttfontdir}/TrueType-vlgothic/VL-PGothic-Regular.ttf \
  128. ln -sf %{ttfontdir}/VL-PGothic-Regular.ttf \
  129. ${RPM_BUILD_ROOT}%{_datadir}/wbar/iconpack/wbar.osx/font.ttf;
  130. #%endif
  131. #%if %{?_dist_release} == "vl4"
  132. #ln -sf %{ttfontdir}/VL-PGothic-Regular.ttf \
  133. # ${RPM_BUILD_ROOT}%{_datadir}/mplayer/subfont.ttf;
  134. #%endif
  135. ## install Gnome menu
  136. desktop-file-install \
  137. --vendor vine \
  138. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  139. %{SOURCE1}
  140. ## install wbarconf
  141. pushd $RPM_BUILD_ROOT%{_datadir}
  142. tar zxf %{SOURCE2}
  143. popd
  144. pushd $RPM_BUILD_ROOT%{_bindir}
  145. ln -sf %{_datadir}/wbarconf/wbarconf.py wbarconf
  146. popd
  147. ## install wbar_util
  148. pushd wbar_util
  149. %__python %{SOURCE4}
  150. %__rm -f ./usr/share/wbar_util/wbar.desktop
  151. yes | DESTDIR=$RPM_BUILD_ROOT ./install.sh
  152. desktop-file-install \
  153. --vendor "vine" \
  154. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  155. $(pwd)/usr/share/applications/wbar_util.desktop
  156. popd
  157. ## install Japanese template
  158. %__install -m0644 %{SOURCE40} $RPM_BUILD_ROOT%{_datadir}/wbar/
  159. ## install Vine documents
  160. %__install -m0644 %{SOURCE41} %{SOURCE42} \
  161. $RPM_BUILD_ROOT%{_datadir}/wbar/
  162. %clean
  163. %__rm -rf "%{buildroot}"
  164. %post
  165. %{_bindir}/update-desktop-database -q %{_datadir}/applications || :
  166. %postun
  167. %{_bindir}/update-desktop-database -q %{_datadir}/applications
  168. %files
  169. %defattr(-,root,root)
  170. %doc gpl.txt AUTHORS COPYING NEWS README
  171. %{_bindir}/wbar*
  172. %dir %{_datadir}/wbar
  173. %config(noreplace) %{_datadir}/wbar/dot.wbar
  174. %{_datadir}/wbar/dot.wbar.jp
  175. %{_datadir}/wbar/vine_readme_wbar.*
  176. %dir %{_datadir}/wbar/iconpack
  177. %{_datadir}/wbar/iconpack/*.ttf
  178. %dir %{_datadir}/wbar/iconpack/wbar.*
  179. %{_datadir}/wbar/iconpack/*/*
  180. %{_datadir}/applications/*.desktop
  181. %{_datadir}/wbarconf
  182. %{_datadir}/wbar_util
  183. %changelog
  184. * Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.3-7
  185. - rebuild with current VineSeed environment
  186. - add Patch15 (wbar-1.3.3_gcc43_fixes.patch)
  187. - add BuildRequires: desktop-file-utils
  188. - fix Source40 and Patch14
  189. * Mon May 18 2009 KATO Masashi <mkato@par.odn.ne.jp> 1.3.3-6
  190. - added Requires for pyxdg (for main.py) and zenity (for warning messages)
  191. - updated wbar.desktop:
  192. - changed Icon=/usr/share/wbar/iconpack/wbar.osx/vine-wbar.png
  193. - added dot.wbar.jp
  194. - for Japanese title support
  195. - update wbar-dot-bar-default.patch:
  196. - corrected a command name (soffice -> oofice)
  197. - added some items (xterm,synaptic...etc.)
  198. - added wbar_gen (for Vine Linux):
  199. - for extracting only executable items from dot.wbar
  200. - applied wbar-session-vine.patch (for wbar_session)
  201. - generating initial user config file ('$HOME/.wbar'; by wbar_gen)
  202. - overwritable options
  203. - verification of icon-path
  204. - supported help message
  205. - setting '-above-desk' option automatically. (detecting DE or WM)
  206. * Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-5
  207. - applied wbar-dot-bar-default.patch
  208. * Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-4
  209. - added %%description -l ja
  210. * Tue Feb 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-3
  211. - added wbar_util-1.0-ja.po
  212. - added wbar_session (for Vine Linux)
  213. - updated wbar.desktop:
  214. - changed Exec=wbar_session
  215. - updated wbar_util-1.0-vine.patch:
  216. - for restarting wbar
  217. * Sun Feb 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-2
  218. - changed to Group: User Interface/Desktops
  219. - added comment[ja] in wbar.desktop
  220. - added wbar_util v1.0
  221. - applied wbar_util-1.0-vine.patch
  222. * Sat Apr 11 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-1
  223. - initial build
  224. * Tue Oct 23 2007 Pascal Bleser <guru@unixtech.be> 1.3.3-0.pm.2
  225. - added Requires for imlib2-loaders (for PNG support)
  226. * Fri Sep 28 2007 Pascal Bleser <guru@unixtech.be> 1.3.3-0.pm.1
  227. - new upstream version
  228. * Sun Sep 16 2007 Pascal Bleser <guru@unixtech.be> 1.3.2-0.pm.1
  229. - new package