wayland-vl.spec 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211
  1. %define ver 1.0.3
  2. %define rel 1
  3. #global gitdate 20120424
  4. Name: wayland
  5. Version: %{ver}
  6. Release: %{rel}%{?gitdate:.date%{gitdate}}%{?_dist_release}
  7. Summary: Wayland Compositor Infrastructure
  8. Group: User Interface/X
  9. License: MIT
  10. URL: http://%{name}.freedesktop.org/
  11. %if 0%{?gitdate}
  12. Source0: wayland-%{gitdate}.tar.bz2
  13. %else
  14. Source0: http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
  15. %endif
  16. Source1: make-git-snapshot.sh
  17. BuildRequires: autoconf automake libtool
  18. BuildRequires: doxygen
  19. BuildRequires: pkgconfig(libffi)
  20. BuildRequires: expat-devel
  21. BuildRequires: libxslt
  22. BuildRequires: docbook-style-xsl
  23. Provides: %{name}-common = %{version}-%{release}
  24. Distribution: Vine Linux
  25. Vendor: Project Vine
  26. Packager: iwaim
  27. %description
  28. Wayland is a protocol for a compositor to talk to its clients as well as a C
  29. library implementation of that protocol. The compositor can be a standalone
  30. display server running on Linux kernel modesetting and evdev input devices,
  31. an X application, or a wayland client itself. The clients can be traditional
  32. applications, X servers (rootless or fullscreen) or other display servers.
  33. %package devel
  34. Summary: Common headers for wayland
  35. License: MIT
  36. %description devel
  37. Common headers for wayland
  38. %package -n libwayland-client
  39. Summary: Wayland client library
  40. License: MIT
  41. %description -n libwayland-client
  42. Wayland client library
  43. %package -n libwayland-cursor
  44. Summary: Wayland cursor library
  45. License: MIT
  46. %description -n libwayland-cursor
  47. Wayland cursor library
  48. %package -n libwayland-server
  49. Summary: Wayland server library
  50. License: MIT
  51. %description -n libwayland-server
  52. Wayland server library
  53. %package -n libwayland-client-devel
  54. Summary: Headers and symlinks for developing wayland client applications
  55. License: MIT
  56. Requires: libwayland-client%{?_isa} = %{version}-%{release}
  57. Requires: wayland-devel%{?_isa} = %{version}-%{release}
  58. %description -n libwayland-client-devel
  59. Headers and symlinks for developing wayland client applications.
  60. %package -n libwayland-cursor-devel
  61. Summary: Headers and symlinks for developing wayland cursor applications
  62. License: MIT
  63. Requires: libwayland-cursor%{?_isa} = %{version}-%{release}
  64. Requires: wayland-devel%{?_isa} = %{version}-%{release}
  65. %description -n libwayland-cursor-devel
  66. Headers and symlinks for developing wayland cursor applications.
  67. %package -n libwayland-server-devel
  68. Summary: Headers and symlinks for developing wayland server applications
  69. License: MIT
  70. Requires: libwayland-server%{?_isa} = %{version}-%{release}
  71. Requires: wayland-devel%{?_isa} = %{version}-%{release}
  72. %description -n libwayland-server-devel
  73. Headers and symlinks for developing wayland server applications.
  74. %prep
  75. %setup -q -n %{name}-%{?gitdate:%{gitdate}}%{!?gitdate:%{version}}
  76. %build
  77. autoreconf -v --install
  78. %configure --disable-static --enable-documentation
  79. make %{?_smp_mflags}
  80. %install
  81. rm -rf $RPM_BUILD_ROOT
  82. make install DESTDIR=$RPM_BUILD_ROOT
  83. find $RPM_BUILD_ROOT -name \*.la | xargs rm -f
  84. %clean
  85. rm -rf $RPM_BUILD_ROOT
  86. %post -n libwayland-client -p /sbin/ldconfig
  87. %postun -n libwayland-client -p /sbin/ldconfig
  88. %post -n libwayland-server -p /sbin/ldconfig
  89. %postun -n libwayland-server -p /sbin/ldconfig
  90. %files
  91. %defattr(-,root,root,-)
  92. %doc README TODO
  93. #doc %{_datadir}/doc/wayland/*
  94. %files devel
  95. %defattr(-,root,root,-)
  96. %{_bindir}/wayland-scanner
  97. %{_includedir}/wayland-util.h
  98. %{_includedir}/wayland-egl.h
  99. %{_includedir}/wayland-version.h
  100. %{_datadir}/aclocal/wayland-scanner.m4
  101. %{_datadir}/aclocal/wayland-scanner.mk
  102. %{_mandir}/man3/*.3*
  103. %files -n libwayland-client
  104. %defattr(-,root,root,-)
  105. %{_libdir}/libwayland-client.so.0*
  106. %files -n libwayland-cursor
  107. %defattr(-,root,root,-)
  108. %{_libdir}/libwayland-cursor.so.0*
  109. %files -n libwayland-server
  110. %defattr(-,root,root,-)
  111. %{_libdir}/libwayland-server.so.0*
  112. %files -n libwayland-client-devel
  113. %defattr(-,root,root,-)
  114. %{_includedir}/wayland-client*.h
  115. %{_libdir}/libwayland-client.so
  116. %{_libdir}/pkgconfig/wayland-client.pc
  117. %files -n libwayland-cursor-devel
  118. %defattr(-,root,root,-)
  119. %{_includedir}/wayland-cursor*.h
  120. %{_libdir}/libwayland-cursor.so
  121. %{_libdir}/pkgconfig/wayland-cursor.pc
  122. %files -n libwayland-server-devel
  123. %defattr(-,root,root,-)
  124. %{_includedir}/wayland-server*.h
  125. %{_libdir}/libwayland-server.so
  126. %{_libdir}/pkgconfig/wayland-server.pc
  127. %changelog
  128. * Sun Jan 6 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.3-1
  129. - initial build for Vine Linux
  130. - drop Obsoletes: wayland-common
  131. * Wed Jan 02 2013 Adam Jackson <ajax@redhat.com> 1.0.3-1
  132. - wayland 1.0.3
  133. * Tue Oct 23 2012 Adam Jackson <ajax@redhat.com> 1.0.0-1
  134. - wayland 1.0
  135. * Thu Oct 18 2012 Adam Jackson <ajax@redhat.com> 0.99.0-1
  136. - wayland 0.99.0
  137. * Tue Sep 04 2012 Adam Jackson <ajax@redhat.com> 0.95.0-1
  138. - wayland 0.95.0 (#843738)
  139. * Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.89.0-2.20120424
  140. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  141. * Tue Apr 24 2012 Richard Hughes <rhughes@redhat.com> - 0.89.0-1
  142. - Update to a git snapshot based on 0.89.0
  143. * Sat Feb 18 2012 Thorsten Leemhuis <fedora@leemhuis.info> - 0.85.0-1
  144. - update to 0.85.0
  145. - adjust license, as upstream changed it to MIT
  146. - update make-git-snapshot.sh to current locations and scheme
  147. - drop common package, not needed anymore
  148. - compositor is now in a separate package, hence reduce BuildRequires to what
  149. is actually needed (a lot less) and adjust summary
  150. - make usage of a git checkout in spec file optional
  151. - a %%{?_isa} to requires where it makes sense
  152. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1-0.6.20101221
  153. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  154. * Tue Dec 06 2011 Adam Jackson <ajax@redhat.com> - 0.1-0.5.20101221
  155. - Rebuild for new libpng
  156. * Wed Jun 15 2011 Lubomir Rintel <lkundrak@v3.sk> - 0.1-0.4.20101221
  157. - Install real compositor binary instead of a libtool wrapper
  158. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1-0.3.20101221
  159. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  160. * Tue Dec 21 2010 Adam Jackson <ajax@redhat.com> 0.1-0.2.20101221
  161. - Today's git snap
  162. * Tue Nov 23 2010 Adam Jackson <ajax@redhat.com> 0.1-0.2.20101123
  163. - Today's git snap
  164. - Fix udev rule install (#653353)
  165. * Mon Nov 15 2010 Adam Jackson <ajax@redhat.com> 0.1-0.1.20101111
  166. - Initial packaging