w3m-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419
  1. #define __perl_requires %{_rpmconfigdir}/perl.req | grep -v w3mhelp
  2. #define __find_requires /bin/true
  3. %define _docdir %{_defaultdocdir}
  4. #%define cvsdate 20060815
  5. Summary: A Pager with WWW capability
  6. Summary(ja): World Wide Web に対応したページャ
  7. Name: w3m
  8. Version: 0.5.3
  9. Release: 4%{?_dist_release}
  10. License: BSD
  11. Group: Applications/Internet
  12. URL: http://w3m.sourceforge.net/
  13. Source0: %{name}-%{version}.tar.gz
  14. Source1: w3m.sh
  15. Source2: w3m.csh
  16. Source10: w3m-term
  17. Source11: filter-requires-w3m.sh
  18. Patch200: w3m-fh-def.patch
  19. Patch201: w3m-gc7.patch
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. BuildRequires: gc-devel >= 7.0
  22. BuildRequires: gtk2-devel
  23. BuildRequires: ncurses-devel
  24. BuildRequires: openssl-devel >= 0.9
  25. BuildRequires: sed
  26. Requires: perl
  27. Requires: openssl >= 0.9
  28. Requires(post): alternatives
  29. Requires(preun): alternatives
  30. Provides: webclient, pager
  31. Obsoletes: w3m-m17n
  32. Vendor: Project Vine
  33. Distribution: Vine Linux
  34. Packager: shaolin
  35. # work around for [VineSeed-x86_64:00178]
  36. %define __perl_requires %{SOURCE11}
  37. %description
  38. w3m is a pager with WWW capability. It IS a pager, but it can be
  39. used as a text-mode WWW browser. The features of w3m are as follows:
  40. - When reading HTML document, you can follow links and view images
  41. (using external image viewer).
  42. - It has 'internet message mode', which determines the type of document
  43. from header. If the Content-Type: field of the document is text/html,
  44. that document is displayed as HTML document.
  45. - You can change URL description like 'http://hogege.net' in plain text
  46. into link to that URL.
  47. %description -l ja
  48. w3m は,ページャfmをベースに開発された World Wide Web に対応したページャ
  49. です.fm の機能に加えて、w3m の特徴には,次のようなものがあります.
  50. ・WWW 対応なので,HTML の文書を読んでいる時には,その中のリンクを辿った
  51. り,画像を見ることができる.
  52. ・Internet message 表示のためのモードがある.この時,Content-Type: が
  53. text/html の場合は,自動的に HTML の文書として表示する.また,自力で
  54. MIME header のデコードをする.
  55. ・見ている plain text 文書中に URL 表記があった場合,その部分からリンク
  56. をたどることができる.
  57. %package img
  58. Summary: inline image extension support utilities for w3m
  59. Summary(ja): w3m 用インライン画像拡張サポートユーティリティ
  60. Group: Applications/Internet
  61. Requires: %{name} = %{version}-%{release}
  62. %description img
  63. w3m-img provides some utilities to support inline
  64. images for w3m
  65. on terminal emulator in X Window System environments.
  66. %description -l ja img
  67. w3m-img は X 環境のターミナルエミュレータ上の w3m でインライン画像を
  68. 表示するためのユーティリティです。
  69. %prep
  70. %setup -q
  71. %patch200 -p0 -b .fh
  72. %patch201 -p1 -b .gc7
  73. find Bonus -type f | \
  74. xargs sed -i -e "s|/usr/local/bin/ruby|/usr/bin/ruby|g;"
  75. %build
  76. %configure \
  77. --enable-japanese=E \
  78. --with-termlib=ncurses \
  79. --enable-image=x11 \
  80. --with-imagelib=gtk2 \
  81. --with-browser=gnome-open \
  82. --with-mailer=gnome-open \
  83. --with-editor=%{_sysbindir}/vi
  84. sed -i -e 's|#define USE_GPM 1|/* #undef USE_GPM */|' config.h
  85. sed -i -e 's|\-lgpm||g' Makefile
  86. sed -i -e 's|\-ldl|\-ldl \-lX11|g' Makefile
  87. make %{?_smp_mflags}
  88. %install
  89. rm -rf %{buildroot}
  90. make install DESTDIR=%{buildroot}
  91. mkdir -p %{buildroot}/etc/profile.d
  92. cp %{SOURCE1} %{buildroot}/etc/profile.d/w3m.sh
  93. cp %{SOURCE2} %{buildroot}/etc/profile.d/w3m.csh
  94. mkdir -p %{buildroot}%{_bindir}
  95. cp %{SOURCE10} %{buildroot}%{_bindir}/w3m-term
  96. chmod +x %{buildroot}%{_bindir}/w3m-term
  97. mkdir -p %{buildroot}%{_mandir}/{man1,ja/man1}
  98. install -p -m 644 doc-jp/w3m.1 %{buildroot}%{_mandir}/ja/man1
  99. install -p -m 644 doc/w3m.1 %{buildroot}%{_mandir}/man1
  100. # dont include duplicated man pages and CVS directory in doc
  101. rm -f doc-jp/w3m.1 doc/w3m.1
  102. find . -type d -name "CVS" | xargs rm -rf
  103. # prepare system-wide preference file
  104. mkdir -p %{buildroot}%{_sysconfdir}/w3m
  105. mkdir -p %{buildroot}%{_datadir}/applications
  106. cat > %{buildroot}%{_datadir}/applications/%{name}.desktop <<EOF
  107. [Desktop Entry]
  108. Name=%{name}
  109. Type=Application
  110. Comment=A Pager with WWW capability
  111. Comment[ja]=WWW対応ページャ
  112. Exec=w3m-term
  113. Terminal=false
  114. Categories=Network;
  115. EOF
  116. # eliminate executable bit in %doc
  117. find Bonus/ -type f -perm +111 | xargs -r chmod -x
  118. %clean
  119. rm -rf %{buildroot}
  120. %post
  121. %{_syssbindir}/update-alternatives --install /usr/bin/pager pager /usr/bin/w3m 30
  122. %preun
  123. if [ "$1" = "0" ]; then
  124. %{_syssbindir}/update-alternatives --remove pager /usr/bin/w3m
  125. fi
  126. %files
  127. %defattr(-,root,root)
  128. %doc Bonus ChangeLog NEWS README doc doc-jp
  129. %attr(755,root,root) %config /etc/profile.d/*
  130. %dir %{_sysconfdir}/w3m
  131. %{_bindir}/w3m*
  132. %exclude %{_libexecdir}/w3m/w3mimgdisplay
  133. %{_libexecdir}/w3m/
  134. %{_datadir}/applications/%{name}.desktop
  135. %{_datadir}/w3m/
  136. %{_datadir}/locale/*/LC_MESSAGES/*
  137. %{_mandir}/ja/man1/w3m.1*
  138. %{_mandir}/man1/w3m*
  139. %files img
  140. %{_libexecdir}/w3m/w3mimgdisplay
  141. %changelog
  142. * Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.3-4
  143. - rebuild with openssl-1.0.2
  144. * Tue Nov 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.3-3
  145. - change localtion of desktop file
  146. * Mon Sep 15 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.5.3-2
  147. - updated Source11 to call /usr/lib/rpm/perl.req
  148. - added Patch200 and 201 for building current environment
  149. - rebuilt for removing libpng12 dependency
  150. * Thu Apr 21 2011 IWAI, Masaharu <iwai@alib.jp> 0.5.3-1
  151. - new upstream release
  152. - drop unnecessary patches: upstream fixed
  153. - ambwidth patch (Patch10)
  154. - sudden crash patch (Patch11)
  155. - x86_64 patch (Patch100)
  156. * Wed Jan 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.5.2-7
  157. - rebuild with openssl-1.0.0c
  158. - add Patch100 (w3m-0.5.2-x86_64-vine.patch)
  159. * Sun Sep 26 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-6
  160. - add Patch10 to fix display utf8 ambiguous width characters
  161. (from: http://www.j10n.org/files/w3m-cvs-1.914-ambwidth.patch)
  162. - add Patch11 to fix sudden crash
  163. (from: http://www.sic.med.tohoku.ac.jp/~satodai/w3m-dev/200708.month/4286.html)
  164. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-5
  165. - rebuilt with gcc-4.4.3-3 on ppc
  166. * Tue Feb 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-4
  167. - rebuilt with new toolchain
  168. * Tue Apr 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-2
  169. - spec in utf-8
  170. - remove Requires: indexhtml
  171. - set HTTP_HOME to http://vinelinux.org/
  172. - update w3m-term
  173. * Wed Apr 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.2-1
  174. - new upstream release
  175. - dropped Patch100 (merged into upstream)
  176. * Sun Jun 3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.1.20060815-0vl6
  177. - rebuilt with new toolchain and environment
  178. * Fri Apr 13 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.5.1.20060815-0vl5
  179. - add Provides: pager
  180. - add Requires(post,preun): alternatives
  181. * Tue Apr 10 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.5.1.20060815-0vl3
  182. - add update-alternatives: pager in %post and %preun scriptlet
  183. * Fri Jan 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  184. - 0.5.1.20060815-0vl2
  185. - rebuilt for VineSeed
  186. * Sat Dec 30 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  187. - 0.5.1.20060815-0vl1.1
  188. - add patch100 for fix "inputAnswer()" SSL Certificate Handling Vulnerabilit
  189. * Tue Aug 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp>
  190. - update to cvs snapshot
  191. - use gtk2 for w3m-img instead of gdk-pixbuf
  192. * Sun Jul 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.5.1-0vl6
  193. - use filter-requires-w3m.sh as find-requires (rpm's bug?)
  194. * Sat Sep 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl5
  195. - use %%{_docdir}/Vine/index.html as default homepage
  196. * Sun Jul 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl4
  197. - change default editor to %%{_sysbindir}/vi
  198. - use ncurses explicitly as termlib
  199. * Sun Jul 11 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl3
  200. - fix typo
  201. - add BuildPrereq: gtk+-devel, gdk-pixbuf-devel
  202. * Wed Jul 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
  203. - rebuild without gpm
  204. * Wed May 5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
  205. - new upstream release
  206. - Obsoletes: w3m-m17n
  207. * Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5-0vl2
  208. - add message catalogs to %%files
  209. * Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5-0vl1
  210. - new upstream release
  211. - fix w3mimgdisplay path in w3m-term
  212. * Sun Dec 14 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.2-0vl1
  213. - new upstream release
  214. - split w3mimgdisplay to w3m-img subpackage.
  215. - Requires: gc >= 6.2
  216. * Sat May 31 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 0.4.1-0vl1
  217. - new upstream release
  218. * Tue Feb 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4-0vl1
  219. - new upstream release
  220. * Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.2-0vl1
  221. - new upstream release.
  222. w3m 0.3.2.2 - 2002-12-06
  223. * security fix: html_quote for img alt attributes
  224. * Fri Nov 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.1-0vl2
  225. - change default page path to /usr/doc/HTML.
  226. this should be changed to /usr/share/doc in next release.
  227. ( TODO: indexhtml package )
  228. * Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.1-0vl1
  229. - new upstream release
  230. w3m 0.3.2.1 - 2002-11-27
  231. * security fix: html_quote for frame contents
  232. * backport from w3m 0.3.2+cvs
  233. - fix segmentation fault by large complex table.
  234. [w3m-dev 03371][w3m-dev 03438]
  235. * Wed Nov 6 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
  236. - new upstream release
  237. w3m 0.3.2 - 2002-11-05
  238. * ~/.netrc: password for ftp
  239. * rc: display_lineinfo: display current line number
  240. * rc: passwd_file: passwd file for HTTP auth
  241. * func: MARK_WORD
  242. * rc: imgsize: obsoleted
  243. * w3m-img for framebuffer merged
  244. * Mon Sep 30 2002 Tomoya TAKA <taka@vinelinux.org> 0.3.1-0vl2
  245. - replace gc with an old version on alpha (Source20)
  246. * Wed Jul 17 2002 IWAI Masaharu <iwai@alib.jp> 0.3.1-0vl1
  247. - upstream release
  248. - coped new configure options
  249. * Sun Apr 21 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.3-0vl2
  250. - fixed configure option ([VineSeed:06372])
  251. - added openssl-devel version in {Build,}Requires
  252. * Mon Mar 18 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.3-0vl1
  253. - updated in sync with upstream 0.3 release
  254. (now w3m-img patch is included in the upstream version)
  255. * Tue Feb 05 2002 Toru Sagami <sagami@vinelinux.org> 0.2.5-0vl1
  256. - w3m-0.2.5 with 0.2.5+cvs-1.302
  257. * Tue Jan 29 2002 Toru Sagami <sagami@vinelinux.org> 0.2.4-0vl2
  258. - eliminate executable bit in %doc
  259. - spec cleanup
  260. * Wed Jan 16 2002 Toru Sagami <sagami@vinelinux.org> 0.2.4-0vl1
  261. - updated to current stable release
  262. * Thu Jan 03 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.2.3.2-0vl1
  263. - updated to new upstream release
  264. - FIXME: system-wide /etc/w3m/w3mconfig should be prepared. Anyone? :)
  265. * Fri Sep 28 2001 <masato@nets.ce.hiroshima-cu.ac.jp>
  266. - 0.2.1-0vl9
  267. - added sparc patch
  268. * Thu Aug 23 2001 <shom@vinelinux.org>
  269. - 0.2.1-0vl8: add w3m-term script
  270. * Mon Aug 06 2001 <sagami@vinelinux.org>
  271. - 0.2.1-0vl7: added imlib-devel ncurses-devel for BuildPreReq
  272. - update img patch to version 1.10 from 1.9
  273. * Mon Aug 6 2001 Jun Nishii <jun@vinelinux.org> 0.2.1-0vl6
  274. - added img patch
  275. * Mon Jul 16 2001 <sagami@vinelinux.org>
  276. - 0.2.1-0vl5: spec file clean up
  277. - openssl-devel for BuildPrereq, not openssl
  278. - install more sophisticated w3m.sh w3m.csh with any %%{_docdir} definition
  279. * Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  280. - 0.2.1-0vl4
  281. - rebuilt with openssl-0.9.6b
  282. * Sun Jun 24 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  283. - 0.2.1-0vl3
  284. - security fixes (http://www.lac.co.jp/security/snsadv/32.html)
  285. * Sat Jun 09 2001 <sagami@vinelinux.org>
  286. - 0.2.1-0vl2: minor spec fixes(URL, License and etc.)
  287. - actually rebuilt with ncurses5 (i386)
  288. * Sat Mar 24 2001 Yoichi Imai <yoichi@silver-forest.com>
  289. - 0.2.1-0vl1
  290. * Wed Dec 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  291. - 0.1.10-0vl6
  292. - use better macros
  293. - rebuilt with ncurses5
  294. * Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
  295. - w3m-0.1.10-0vl5
  296. - use applnk instead of wmconfig
  297. - use openssl
  298. * Thu Jul 27 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
  299. - w3m-0.1.10-0vl4
  300. - fix typo in w3m.csh and w3m.wmconfig
  301. * Sun Jul 09 2000 Toru Sagami <czs14350@nifty.ne.jp>
  302. - w3m-0.1.10-0vl3
  303. - provide default HTTP_HOME in /etc/profile.d
  304. * Fri Jul 07 2000 Toru Sagami <czs14350@nifty.ne.jp>
  305. - Provides: webclient, Requires: indexhtml (capability of lynx)
  306. - added w3m.wmconfig
  307. - give them(who?) RPM_OPT_FLAGS(what?)
  308. - dont include duplicated man pages and CVS directory in doc
  309. * Wed Jun 21 2000 Jun Nishii <jun@vinelinux.org>
  310. - 0.1.10-0vl1
  311. * Sat Jan 22 2000 Yoichi Imai <yoichi@silver-forest.com>
  312. - fix spec file
  313. * Sat Jan 22 2000 Yoichi Imai <yoichi@silver-forest.com>
  314. - updated from 0.1.4 to 0.1.6
  315. * Thu Jan 13 2000 Yoichi Imai <yoichi@silver-forest.com>
  316. - updated from 991203 to 0.1.4
  317. * Fri Dec 03 1999 Yoichi Imai <yoichi@silver-forest.com>
  318. - updated from 991028 to 991203
  319. * Sat Oct 30 1999 Yoichi Imai <bonaim@mutt.freemail.ne.jp>
  320. - updated from 990820 to 991028
  321. * Thu Aug 26 1999 Ryo Hattori <ryoh@vs01.vaio.ne.jp>
  322. - updated from 990716 to 990820
  323. * Wed Aug 11 1999 Ryo Hattori <ryoh@vs01.vaio.ne.jp>
  324. - initial Release to VinePlus