w3c-libwww-vl.spec 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122
  1. # Note that this is NOT a relocatable package
  2. %define ver 5.4.0
  3. %define rel 1%{?_dist_release}
  4. %define name w3c-libwww
  5. Name: %name
  6. Version: %ver
  7. Release: %rel
  8. License: W3C (see: http://www.w3.org/Consortium/Legal/copyright-software.html), (L)GPL compatible
  9. Group: System Environment/Libraries
  10. Source: http://www.w3.org/Library/Distribution/%{name}-%{ver}.tgz
  11. URL: http://www.w3.org/Library
  12. BuildRoot: %{_tmppath}/%{name}-%{ver}-root
  13. Summary: General-purpose Web API written in C
  14. %description
  15. Libwww is a general-purpose Web API written in C for Unix and Windows (Win32).
  16. With a highly extensible and layered API, it can accommodate many different
  17. types of applications including clients, robots, etc. The purpose of libwww
  18. is to provide a highly optimized HTTP sample implementation as well as other
  19. Internet protocols and to serve as a testbed for protocol experiments. Libwww
  20. also supports HTTPS, thru OpenSSL. Because of the US export restrictions, we
  21. can't distribute the libwwwssl pre-compiled library. You'll have to compile
  22. libwww yourself to use it.
  23. %package devel
  24. Summary: Libraries and header files for programs that use libwww.
  25. Group: Development/Libraries
  26. Requires: %{name} = %{ver}
  27. %description devel
  28. Static libraries and header files for libwww, which are available as public
  29. libraries.
  30. %package apps
  31. Summary: Applications built using Libwww web library: e.g. Robot, command line tool, etc.
  32. Group: Applications/Internet
  33. Requires: %{name} = %{ver}
  34. %description apps
  35. Web applications built using Libwww: Robot, Command line tool,
  36. line mode browser. The Robot can crawl web sites faster, and
  37. with lower load, than any other web walker that we know of,
  38. due to its extensive pipelining and use of HTTP/1.1.
  39. The command line tool (w3c) is very useful for manipulation of
  40. Web sites that implement more than just HTTP GET (e.g. PUT,
  41. POST, etc.).
  42. The line mode browser is a minimal line mode web browser;
  43. often useful to convert to ascii text. Currently unavailable
  44. until someone updates it to some new interfaces. (hint, hint...)
  45. %prep
  46. %setup -q
  47. %build
  48. %configure --with-regex --with-zlib
  49. %__make %{?_smp_mflags}
  50. %install
  51. rm -rf $RPM_BUILD_ROOT
  52. %makeinstall
  53. ./config/mkinstalldirs $RPM_BUILD_ROOT/%{_datadir}/w3c-libwww
  54. mv $RPM_BUILD_ROOT/%{_datadir}/*.xbm $RPM_BUILD_ROOT/%{_datadir}/w3c-libwww/
  55. ## remove unuse files
  56. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  57. %clean
  58. rm -rf $RPM_BUILD_ROOT
  59. %post -p /sbin/ldconfig
  60. %postun -p /sbin/ldconfig
  61. %files
  62. %defattr(-,root,root)
  63. %{_libdir}/*.so.*
  64. %{_datadir}/w3c-libwww
  65. %doc *.html Icons/*/*.gif
  66. %files apps
  67. %defattr(-,root,root)
  68. %{_bindir}/w3c
  69. %{_bindir}/webbot
  70. %{_bindir}/www
  71. %files devel
  72. %defattr(-,root,root)
  73. %{_bindir}/libwww-config
  74. %{_libdir}/*.a
  75. #%{_libdir}/*.la
  76. %{_libdir}/*.so
  77. %{_includedir}/*
  78. %changelog
  79. * Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 5.4.0-1vl5
  80. - applied new versioning policy
  81. - removed *.la
  82. * Sun Aug 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.4.0-0vl1
  83. - Rebuild with new toolchains
  84. - updated to 5.4.0
  85. - s/Copyright/License/
  86. * Thu Dec 28 2000 Akira Tagoh <tagoh@gnome.gr.jp>
  87. - 5.3.1-3vl1
  88. - Rebuild for Vine
  89. * Fri Aug 04 2000 Jose Kahan <jose@w3.org)
  90. - Added blurb about the OpenSSL support, some esthetical changes
  91. * Mon Apr 12 1999 Jim Gettys <jg@w3.org)
  92. - down covert for older RPM currently widespread
  93. * Mon Apr 12 1999 Jeff Johnson <jbj@redhat.com>
  94. - repackage for Red Hat 6.0.