vtk-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624
  1. # Disable OSMesa builds for now - see Bug 744434
  2. %bcond_with OSMesa
  3. # Make Java conditional
  4. %bcond_without java
  5. %{!?tcl_version: %global tcl_version %(echo 'puts $tcl_version' | tclsh)}
  6. %{!?tcl_sitelib: %global tcl_sitelib %{_datadir}/tcl%{tcl_version}}
  7. %define _hdf5_version 1.8.14
  8. Summary: The Visualization Toolkit - A high level 3D visualization library
  9. Summary(ja): The Visualization Toolkit - ハイレベル3D可視化ライブラリ
  10. Name: vtk
  11. Version: 6.1.0
  12. Release: 1%{?_dist_release}
  13. # This is a variant BSD license, a cross between BSD and ZLIB.
  14. # For all intents, it has the same rights and restrictions as BSD.
  15. # http://fedoraproject.org/wiki/Licensing/BSD#VTKBSDVariant
  16. License: BSD style
  17. Group: System Environment/Libraries
  18. URL: http://www.vtk.org/
  19. Source0: http://www.vtk.org/files/release/6.1/VTK-%{version}.tar.gz
  20. Source1: http://www.vtk.org/files/release/6.1/VTKData-%{version}.tar.gz
  21. # Use system libraries
  22. # http://public.kitware.com/Bug/view.php?id=11823
  23. Patch0: vtk-6.1.0-system.patch
  24. # Install some more needed cmake files to try to support paraview build
  25. # http://www.vtk.org/Bug/view.php?id=14157
  26. Patch1: vtk-install.patch
  27. # Patch to vtk to use system netcdf library
  28. Patch2: vtk-6.1.0-netcdf.patch
  29. # Fix compilation with mesa 10.4
  30. # https://bugzilla.redhat.com/show_bug.cgi?id=1138466
  31. Patch3: vtk-glext.patch
  32. # Fix types for std::min/man
  33. # http://www.vtk.org/Bug/view.php?id=15249
  34. Patch4: vtk-type.patch
  35. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  36. BuildRequires: cmake >= 2.0.0
  37. BuildRequires: gcc-c++
  38. %{?with_java:BuildRequires: java-devel}
  39. BuildRequires: libX11-devel, libXt-devel, libXext-devel
  40. BuildRequires: libICE-devel, libGL-devel
  41. %{?with_OSMesa:BuildRequires: mesa-libOSMesa-devel}
  42. BuildRequires: tk-devel, tcl-devel
  43. BuildRequires: python-devel
  44. BuildRequires: expat-devel, freetype2-devel, libjpeg-turbo-devel, libpng-devel
  45. BuildRequires: gl2ps-devel
  46. BuildRequires: libtiff-devel, zlib-devel
  47. BuildRequires: libxml2-devel
  48. BuildRequires: qt4-devel qt4-designer
  49. #BuildRequires: qtwebkit-devel
  50. BuildRequires: chrpath
  51. BuildRequires: doxygen, graphviz
  52. BuildRequires: gnuplot
  53. BuildRequires: libboost-devel
  54. BuildRequires: hdf5-devel
  55. BuildRequires: jsoncpp-devel
  56. BuildRequires: libtheora-devel
  57. #BuildRequires: mysql-devel
  58. BuildRequires: mariadb-devel
  59. BuildRequires: netcdf-cxx-devel
  60. #BuildRequires: postgresql-devel
  61. BuildRequires: libpq-devel
  62. BuildRequires: R-devel
  63. BuildRequires: PyQt4-devel
  64. BuildRequires: sip-devel
  65. BuildRequires: sqlite3-devel
  66. BuildRequires: wget
  67. #BuildRequires: %{_includedir}/Xm
  68. BuildRequires: openMotif-devel
  69. BuildRequires: blas-devel
  70. BuildRequires: lapack-devel
  71. %{!?with_java:Conflicts: vtk-java}
  72. Requires: hdf5 = %{_hdf5_version}
  73. Distribution: Project Vine
  74. Vendor: Vine Linux
  75. Packager: owa
  76. # Do not check .so files in the python_sitearch directory
  77. %global __provides_exclude_from ^%{python_sitearch}/.*\\.so$
  78. %description
  79. VTK is an open-source software system for image processing, 3D
  80. graphics, volume rendering and visualization. VTK includes many
  81. advanced algorithms (e.g., surface reconstruction, implicit modeling,
  82. decimation) and rendering techniques (e.g., hardware-accelerated
  83. volume rendering, LOD control).
  84. %package devel
  85. Summary: VTK header files for building C++ code.
  86. Summary(ja): C++ プログラムをビルドするための VTK ヘッダファイル集
  87. Group: Development/Libraries
  88. Requires: %{name} = %{version}-%{release}
  89. %{?with_OSMesa:Requires: mesa-libOSMesa-devel}
  90. Requires: cmake
  91. Requires: blas-devel
  92. Requires: gl2ps-devel
  93. Requires: expat-devel
  94. Requires: freetype2-devel
  95. Requires: hdf5-devel
  96. Requires: lapack-devel
  97. Requires: libjpeg-turbo-devel
  98. Requires: libpng-devel
  99. Requires: libogg-devel
  100. Requires: libtheora-devel
  101. Requires: libtiff-devel
  102. Requires: libxml2-devel
  103. Requires: libpq-devel
  104. Requires: libmysqlclient-devel
  105. Requires: qt4-devel
  106. #Requires: qtwebkit-devel%{?_isa}
  107. #Requires: jsoncpp-devel%{?_isa}
  108. # bz #1183210 + #1183530
  109. Requires: python-devel
  110. %description devel
  111. This provides the VTK header files required to compile C++
  112. programs that use VTK to do 3D visualisation.
  113. %package tcl
  114. Summary: Tcl bindings for VTK
  115. Summary(ja): VTK の tcl バインディング
  116. Group: System Environment/Libraries
  117. Requires: %{name} = %{version}-%{release}
  118. Requires: tcl
  119. %description tcl
  120. tcl bindings for VTK
  121. %description tcl -l ja
  122. VTK の tcl バインディングです。
  123. %package python
  124. Summary: Python bindings for VTK.
  125. Summary(ja): VTK の python バインディング
  126. Group: System Environment/Libraries
  127. Requires: %{name} = %{version}-%{release}
  128. Requires: python
  129. %description python
  130. python bindings for VTK
  131. %description python -l ja
  132. VTK の python バインディングです。
  133. %if %{with java}
  134. %package java
  135. Summary: Java bindings for VTK
  136. Summary(ja): VTK の Java バインディング
  137. Group: System Environment/Libraries
  138. Requires: %{name} = %{version}-%{release}
  139. Requires: java
  140. %description java
  141. Java bindings for VTK
  142. %description java -l ja
  143. VTK の Java バインディングです。
  144. %endif
  145. %package qt
  146. Summary: Qt bindings for VTK
  147. Summary(ja): VTK の Qt バインディング
  148. Group: System Environment/Libraries
  149. Requires: %{name} = %{version}-%{release}
  150. %description qt
  151. Qt bindings for VTK
  152. %description qt -l ja
  153. VTK の Qt バインディングです。
  154. %package qt-python
  155. Summary: Qt Python bindings for VTK
  156. Summary(ja): VTK の Qt Python バインディング
  157. Group: System Environment/Libraries
  158. Requires: %{name} = %{version}-%{release}
  159. %description qt-python
  160. Qt Python bindings for VTK
  161. %description qt-python -l ja
  162. VTK の Qt Python バインディングです。
  163. %package qt-tcl
  164. Summary: Qt TCL bindings for VTK
  165. Summary(ja): VTK の Qt TCL バインディング
  166. Group: System Environment/Libraries
  167. Requires: %{name} = %{version}-%{release}
  168. %description qt-tcl
  169. Qt TCL bindings for VTK
  170. %description qt-tcl -l ja
  171. VTK の Qt TCL バインディングです。
  172. %package testing-progs
  173. Summary: Tests programs for VTK.
  174. Summary(ja): VTK のテスト用プログラム
  175. Group: Development/Libraries
  176. Requires: %{name} = %{version}-%{release}
  177. %description testing-progs
  178. Testing programs for VTK
  179. %description testing-progs -l ja
  180. VTK のテスト用プログラムです。
  181. %package examples
  182. Summary: Examples for VTK
  183. Summary(ja): VTK のサンプル集
  184. Group: Applications/Engineering
  185. Requires: %{name} = %{version}-%{release}
  186. Requires: vtk-data = %{version}
  187. %description examples
  188. This package contains all the examples from the VTK source.
  189. To compile the C++ examples you will need to install the vtk-devel
  190. package as well. The Python and Tcl examples can be run with the
  191. corresponding packages (vtk-python, vtk-tcl).
  192. %package data
  193. Summary: Example data file for VTK
  194. Summary(ja): VTK のサンプルデータファイル
  195. Group: Development/Libraries
  196. BuildArch: noarch
  197. %description data
  198. This package contains all the data from the VTKData repository.
  199. These data are required to run various examples from the examples package.
  200. %prep
  201. %setup -q -n VTK-%{version}
  202. %patch0 -p1 -b .system
  203. %patch1 -p1 -b .install
  204. %patch2 -p1 -b .netcdf
  205. %patch3 -p1 -b .glext
  206. %patch4 -p1 -b .type
  207. # Remove included thirdparty sources just to be sure
  208. # TODO - vtksqlite
  209. for x in autobahn vtkexpat vtkfreetype vtkgl2ps vtkhdf5 vtkjpeg vtklibxml2 vtknetcdf vtkoggtheora vtkpng vtktiff twisted vtkzlib zope
  210. do
  211. rm -r ThirdParty/*/${x}
  212. done
  213. # Replace relative path ../../../VTKData with %{_datadir}/vtkdata-%{version}
  214. # otherwise it will break on symlinks.
  215. grep -rl '\.\./\.\./\.\./\.\./VTKData' . | xargs \
  216. perl -pi -e's,\.\./\.\./\.\./\.\./VTKData,%{_datadir}/vtkdata-%{version},g'
  217. # Save an unbuilt copy of the Example's sources for %doc
  218. mkdir vtk-examples
  219. cp -a Examples vtk-examples
  220. # Don't ship Win32 examples
  221. rm -r vtk-examples/Examples/GUI/Win32
  222. find vtk-examples -type f | xargs chmod -R a-x
  223. %build
  224. export CFLAGS="%{optflags} -D_UNICODE"
  225. export CXXFLAGS="%{optflags} -D_UNICODE"
  226. %if %{with java}
  227. export JAVA_HOME=/usr/lib/jvm/java
  228. # Arm/Aarch64 builders have less ram
  229. # https://bugzilla.redhat.com/show_bug.cgi?id=1115920
  230. %ifnarch s390
  231. export JAVA_TOOL_OPTIONS=-Xmx2048m
  232. %endif
  233. %endif
  234. mkdir build
  235. pushd build
  236. %cmake \
  237. -DBUILD_DOCUMENTATION:BOOL=ON \
  238. -DBUILD_EXAMPLES:BOOL=ON \
  239. -DBUILD_TESTING:BOOL=OFF \
  240. -DVTK_CUSTOM_LIBRARY_SUFFIX="" \
  241. -DVTK_INSTALL_ARCHIVE_DIR:PATH=%{_lib}/vtk \
  242. -DVTK_INSTALL_DATA_DIR=share/vtk \
  243. -DVTK_INSTALL_INCLUDE_DIR:PATH=include/vtk \
  244. -DVTK_INSTALL_LIBRARY_DIR:PATH=%{_lib}/vtk \
  245. -DVTK_INSTALL_PACKAGE_DIR:PATH=%{_lib}/cmake/vtk \
  246. -DVTK_INSTALL_PYTHON_MODULE_DIR:PATH=%{_lib}/python%{python_version}/site-packages \
  247. -DVTK_INSTALL_QT_DIR:PATH=%{_lib}/qt4/plugins/designer \
  248. -DVTK_INSTALL_TCL_DIR:PATH=share/tcl%{tcl_version}/vtk \
  249. -DTK_INTERNAL_PATH:PATH=/usr/include/tk-private/generic \
  250. %if %{with OSMesa}
  251. -DVTK_OPENGL_HAS_OSMESA:BOOL=ON \
  252. %endif
  253. %if %{with java}
  254. -DVTK_WRAP_JAVA:BOOL=ON \
  255. -DJAVA_INCLUDE_PATH:PATH=$JAVA_HOME/include \
  256. -DJAVA_INCLUDE_PATH2:PATH=$JAVA_HOME/include/linux \
  257. -DJAVA_AWT_INCLUDE_PATH:PATH=$JAVA_HOME/include \
  258. %else
  259. -DVTK_WRAP_JAVA:BOOL=OFF \
  260. %endif
  261. -DVTK_WRAP_PYTHON:BOOL=ON \
  262. -DVTK_WRAP_PYTHON_SIP:BOOL=ON \
  263. -DSIP_INCLUDE_DIR:PATH=/usr/include/python%{python_version} \
  264. -DVTK_WRAP_TCL:BOOL=ON \
  265. -DVTK_Group_Imaging:BOOL=ON \
  266. -DVTK_Group_Qt:BOOL=ON \
  267. -DVTK_Group_Rendering:BOOL=ON \
  268. -DVTK_Group_StandAlone:BOOL=ON \
  269. -DVTK_Group_Tk:BOOL=ON \
  270. -DVTK_Group_Views:BOOL=ON \
  271. -DModule_vtkFiltersStatisticsGnuR:BOOL=ON \
  272. -DModule_vtkTestingCore:BOOL=ON \
  273. -DModule_vtkTestingRendering:BOOL=ON \
  274. -DVTK_USE_OGGTHEORA_ENCODER=ON \
  275. -DVTK_USE_SYSTEM_LIBRARIES=ON \
  276. -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
  277. -DVTK_USE_SYSTEM_LIBPROJ4:BOOL=OFF \
  278. -DVTK_USE_SYSTEM_NETCDF:BOOL=ON \
  279. -DTCL_LIBRARY:FILEPATH=%{_libdir}/libtcl%{tcl_version}.so \
  280. -DTK_LIBRARY:FILEPATH=%{_libdir}/libtk%{tcl_version}.so \
  281. ..
  282. # TODO - MPI
  283. #-DVTK_Group_MPI:BOOL=ON \
  284. # Needed for some tests. Fails to compile at the moment. We don't run test though.
  285. # -DVTK_DATA_ROOT:PATH=%{_datadir}/vtkdata-%{version} \
  286. # Not working, see http://public.kitware.com/Bug/view.php?id=11978
  287. # -DVTK_USE_ODBC=ON \
  288. # Commented old flags in case we'd like to reactive some of them
  289. # -DVTK_USE_DISPLAY:BOOL=OFF \ # This prevents building of graphics tests
  290. # -DVTK_USE_MPI:BOOL=ON \
  291. # Got intermittent build error with -j
  292. make %{?_smp_mflags}
  293. # Remove executable bits from sources (some of which are generated)
  294. find . -name \*.c -or -name \*.cxx -or -name \*.h -or -name \*.hxx -or \
  295. -name \*.gif | xargs chmod -x
  296. %install
  297. rm -rf $RPM_BUILD_ROOT
  298. pushd build
  299. make install DESTDIR=$RPM_BUILD_ROOT
  300. # ld config
  301. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d
  302. echo %{_libdir}/vtk > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
  303. # Gather list of non-python/tcl libraries
  304. ls $RPM_BUILD_ROOT%{_libdir}/vtk/*.so.* \
  305. | grep -Ev '(Java|Qt|Python27D|TCL)' | sed -e's,^%{buildroot},,' > libs.list
  306. # List of executable utilities
  307. cat > utils.list << EOF
  308. vtkEncodeString
  309. EOF
  310. # List of executable examples
  311. cat > examples.list << EOF
  312. HierarchicalBoxPipeline
  313. MultiBlock
  314. Arrays
  315. Cube
  316. RGrid
  317. SGrid
  318. Medical1
  319. Medical2
  320. Medical3
  321. finance
  322. AmbientSpheres
  323. Cylinder
  324. DiffuseSpheres
  325. SpecularSpheres
  326. Cone
  327. Cone2
  328. Cone3
  329. Cone4
  330. Cone5
  331. Cone6
  332. EOF
  333. # Install examples too
  334. for filelist in examples.list; do
  335. for file in `cat $filelist`; do
  336. install -p bin/$file $RPM_BUILD_ROOT%{_bindir}
  337. done
  338. done
  339. # Fix up filelist paths
  340. for filelist in utils.list examples.list; do
  341. perl -pi -e's,^,%{_bindir}/,' $filelist
  342. done
  343. # Remove any remnants of rpaths on files we install
  344. # Seems to be some kind of java path
  345. for file in `cat examples.list`; do
  346. chrpath -d $RPM_BUILD_ROOT$file
  347. done
  348. chrpath -d $RPM_BUILD_ROOT%{_qt4_plugindir}/designer/libQVTKWidgetPlugin.so
  349. # Main package contains utils and core libs
  350. cat libs.list utils.list > main.list
  351. popd
  352. # Make scripts executable
  353. #chmod a+x %{buildroot}%{_libdir}/vtk/doxygen/*.pl
  354. #chmod a+x %{buildroot}%{_libdir}/vtk/testing/*.{py,tcl}
  355. # Remove exec bit from non-scripts and %%doc
  356. for file in `find %{buildroot} -type f -perm 0755 \
  357. | xargs -r file | grep ASCII | awk -F: '{print $1}'`; do
  358. head -1 $file | grep '^#!' > /dev/null && continue
  359. chmod 0644 $file
  360. done
  361. find Utilities/Upgrading -type f | xargs chmod -x
  362. # install VTKdata
  363. mkdir -p $RPM_BUILD_ROOT%{_datadir}
  364. pushd $RPM_BUILD_ROOT%{_datadir}
  365. tar -zpxf %{SOURCE1}
  366. mv VTK-%{version} %{name}-%{version}
  367. # (Verbosely) fix 0555 permissions
  368. find . -type f -perm 0555 | xargs -r echo chmod 0755 | sh -x
  369. # Remove execute bits from not-scripts
  370. for file in `find . -type f -perm 0755`; do
  371. head -1 $file | grep '^#!' > /dev/null && continue
  372. chmod 0644 $file
  373. done
  374. popd
  375. # Setup Wrapping docs tree
  376. rm -rf _docs
  377. mkdir -p _docs
  378. cp -pr --parents Wrapping/*/README* _docs/
  379. %clean
  380. rm -rf $RPM_BUILD_ROOT
  381. %post -p /sbin/ldconfig
  382. %postun -p /sbin/ldconfig
  383. %post tcl -p /sbin/ldconfig
  384. %postun tcl -p /sbin/ldconfig
  385. %post python -p /sbin/ldconfig
  386. %postun python -p /sbin/ldconfig
  387. %if %{with java}
  388. %post java -p /sbin/ldconfig
  389. %postun java -p /sbin/ldconfig
  390. %endif
  391. %post qt -p /sbin/ldconfig
  392. %postun qt -p /sbin/ldconfig
  393. %post qt-tcl -p /sbin/ldconfig
  394. %postun qt-tcl -p /sbin/ldconfig
  395. %post qt-python -p /sbin/ldconfig
  396. %postun qt-python -p /sbin/ldconfig
  397. %files -f build/main.list
  398. %defattr(-,root,root)
  399. %doc Copyright.txt README.html vtkLogo.jpg vtkBanner.gif _docs/Wrapping
  400. %config(noreplace) %{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
  401. %{_datadir}/vtk
  402. %dir %{_libdir}/vtk
  403. %files devel
  404. %defattr(-,root,root)
  405. %doc Utilities/Upgrading
  406. %{_bindir}/vtkHashSource
  407. %{_bindir}/vtkWrapHierarchy
  408. %{_includedir}/vtk
  409. %{_libdir}/vtk/*.so
  410. %{_libdir}/vtk/libvtkWrappingTools.a
  411. %{_libdir}/cmake/vtk/
  412. %{_bindir}/vtkParseOGLExt
  413. %{_docdir}/vtk-6.1/
  414. %{tcl_sitelib}/vtk/vtktcl.c
  415. %files tcl
  416. %defattr(-,root,root)
  417. %{_libdir}/vtk/*TCL.so.*
  418. %exclude %{_libdir}/vtk/*QtTCL.so.*
  419. %{_bindir}/vtk
  420. %{_bindir}/vtkWrapTcl
  421. %{_bindir}/vtkWrapTclInit
  422. %{tcl_sitelib}/vtk/
  423. %exclude %{tcl_sitelib}/vtk/vtktcl.c
  424. %files python
  425. %defattr(-,root,root)
  426. %{_bindir}/vtkpython
  427. %{_bindir}/vtkWrapPython
  428. %{_bindir}/vtkWrapPythonInit
  429. %{_libdir}/vtk/*Python27D.so.*
  430. %{python_sitearch}/*
  431. %exclude %{_libdir}/vtk/*QtPython27D.so.*
  432. %if %{with java}
  433. %files java
  434. %defattr(-,root,root)
  435. %{_libdir}/vtk/*Java.so.*
  436. %{_libdir}/vtk/vtk.jar
  437. %{_bindir}/vtkParseJava
  438. %{_bindir}/vtkWrapJava
  439. %endif
  440. %files qt
  441. %defattr(-,root,root)
  442. %{_libdir}/vtk/lib*Qt*.so.*
  443. %exclude %{_libdir}/vtk/*TCL.so.*
  444. %exclude %{_libdir}/vtk/*Python27D.so.*
  445. %{_qt4_plugindir}/designer/libQVTKWidgetPlugin.so
  446. %files qt-python
  447. %defattr(-,root,root)
  448. %{_libdir}/vtk/*Python27D.so.*
  449. %files qt-tcl
  450. %defattr(-,root,root)
  451. %{_libdir}/vtk/*TCL.so.*
  452. %files testing-progs
  453. #-f testing-progs-list
  454. %files examples -f build/examples.list
  455. %defattr(-,root,root)
  456. %doc vtk-examples/Examples
  457. %files data
  458. %defattr(-,root,root)
  459. %{_datadir}/%{name}-%{version}
  460. %changelog
  461. * Wed Jan 28 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.1.0-1
  462. - updated to 6.1.0
  463. - built with tcl/tk 8.5.15, libpng 1.6.12 and hdf5 1.8.14
  464. - added java, qt-tcl and qt-python subpackage
  465. * Mon May 09 2011 Shu KONNO <owa@bg.wakwak.com> 5.4.2-3
  466. - s/qt-devel/qt4-devel/ at BR:
  467. - add BR: libxml2-devel
  468. * Sun May 08 2011 Shu KONNO <owa@bg.wakwak.com> 5.4.2-2
  469. - remove _smp_mflags
  470. - added tcl_ver macro
  471. - added TCL_LIBRARY, TK_LIBRARY to cmake
  472. * Tue May 04 2010 Shu KONNO <owa@bg.wakwak.com> 5.4.2-1
  473. - updated vtk to 5.4.2
  474. - updated vtkdata to 5.4.2
  475. - added Obsoletes: %%{name}-ruby < 5.4.2
  476. - added Patch2: vtk-5.2.1-boost-1.42.patch (from Mandriva)
  477. - dropt Patch0: vtk-5.0-getsockname.patch
  478. - dropt Patch1: vtk-ruby-060915.patch
  479. * Thu Jul 31 2008 Shu KONNO <owa@bg.wakwak.com> 5.0.4-1vl5
  480. - updated vtk to 5.0.4
  481. - updated vtkdata to 5.0.4
  482. - built with xorg-x11-devel, python-2.5
  483. - applied new versioning policy
  484. - spec in utf-8
  485. * Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.0.2-0vl6
  486. - rebuild with expat-2.0.1
  487. - add BuildPrereq: freetype2-devel and drop freetype-devel
  488. - add BuildPrereq: qt-devel
  489. - add Requires: freetype2 and drop freetype
  490. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 5.0.2-0vl5
  491. - rebuild with tcl/tk-8.4.18
  492. * Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 5.0.2-0vl4
  493. - rebuild with tcl/tk-8.4.16
  494. * Mon Aug 27 2007 Shu KONNO <owa@bg.wakwak.com> 5.0.2-0vl3
  495. - added %%define py_ver, py_dir
  496. - added %%{?_smp_mflags} to make
  497. - change for x86_64
  498. - changed lib to %%{_lib}
  499. - added VTK_INSTALL_LIB_DIR=PATH=/%{_lib} in cmake
  500. - added --install-lib at VTK_PYTHON_SETUP_ARGS in cmake
  501. * Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0.2-0vl2
  502. - rebuild with new environment/toolchain
  503. * Fri Sep 15 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 5.0.2-0vl1
  504. - new upstream
  505. - add ruby patch
  506. * Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0.1-0vl1
  507. - new upstream
  508. - fixed spec file encoding
  509. - changed Group to System Environment/Libraries
  510. * Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 5.0.0-0vl1
  511. - source verion up
  512. * Tue Mar 29 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 4.4.2-0vl1
  513. - source verion up
  514. * Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 4.2.6-0vl1
  515. - initial build for Vine Linux