vine-spec-skeleton-vl.spec 2.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283
  1. Summary:rpm spec file generator for Vine Linux
  2. Name: vine-spec-skeleton
  3. Version: 0.4
  4. Release: 2%{?_dist_release}
  5. License: perl's
  6. Group: Development/Tools
  7. Source0: %{name}-%{version}.tar.gz
  8. Patch0: vine-spec-skeleton-0.4-elisp.patch
  9. Url: http://trac.vinelinux.org/wiki/vine-spec-skeleton
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildArch: noarch
  12. BuildRequires: perl perl-YAML perl-Class-Accessor perl-HTML-Template
  13. BuildRequires: perl-Email-Valid-Loose
  14. Requires: perl perl-YAML perl-Class-Accessor perl-HTML-Template
  15. Requires: perl-Email-Valid-Loose
  16. Distribution: Vine Linux
  17. Vendor: Project Vine
  18. Packager: iwaim
  19. %description
  20. rpm spec file generator for Vine Linux
  21. %prep
  22. %setup -q
  23. %patch0 -p1 -b .elisp
  24. %build
  25. CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
  26. make
  27. %install
  28. rm -rf $RPM_BUILD_ROOT
  29. mkdir -p $RPM_BUILD_ROOT%{_prefix}
  30. make DESTDIR=$RPM_BUILD_ROOT install
  31. find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
  32. find $RPM_BUILD_ROOT%{_prefix} -type f -print |
  33. sed "s@^$RPM_BUILD_ROOT@@g" |
  34. grep -v ^%{_mandir} |
  35. grep -v perllocal.pod |
  36. grep -v "\.packlist" > %{name}.files
  37. if [ "$(cat %{name}.files)X" = "X" ] ; then
  38. echo "ERROR: EMPTY FILE LIST"
  39. exit -1
  40. fi
  41. %check
  42. make test
  43. %clean
  44. rm -rf $RPM_BUILD_ROOT
  45. %files -f %{name}.files
  46. %defattr(-,root,root)
  47. %doc README Changes LICENSE
  48. %dir %{perl_vendorlib}/VineLinux
  49. %dir %{perl_vendorlib}/VineLinux/VSS
  50. %dir %{perl_vendorlib}/VineLinux/VSS/Skeleton
  51. %dir %{perl_vendorlib}/VineLinux/VSS/Skeleton/Elisp
  52. %dir %{perl_vendorlib}/VineLinux/VSS/Skeleton/PerlModule
  53. %dir %{perl_vendorlib}/VineLinux/VSS/Skeleton/SelfBuild
  54. %dir %{perl_vendorlib}/VineLinux/VSS/Type
  55. #%{_mandir}/man3/*
  56. %changelog
  57. * Thu Apr 14 2011 IWAI, Masaharu <iwai@alib.jp> 0.4-2
  58. - add elisp skeleton patch (Patch0)
  59. * Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 0.4-1
  60. - new upstream release
  61. - drop svn r664 patch (Patch1): upstream fixed
  62. - add {Build,}Requires: perl-Email-Valid-Loose
  63. * Thu Mar 25 2010 IWAI, Masaharu <iwai@alib.jp> 0.3-1
  64. - new upstream release
  65. - drop fix elisp skeleton patch (Patch0): upstream fixed
  66. - add upstream svn r664 patch (Patch1)
  67. - update Requires and BuildRequires: perl-HTML-Template
  68. * Tue Feb 23 2010 IWAI, Masaharu <iwai@alib.jp> 0.2-1
  69. - first release for Vine Linux