vine-printfilters-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336
  1. %define orig_name rhs-printfilters
  2. %define version 1.81
  3. Summary: Vine Linux Print Filter System
  4. Summary(ja): Vine Linux 印刷フィルター・システム
  5. Name: vine-printfilters
  6. Version: %{version}
  7. Release: 1%{?_dist_release}
  8. License: GPL
  9. Group: Applications/Publishing
  10. Source0: rhs-printfilters-%{version}.tar.gz
  11. Source1: testpages-vine.tar.gz
  12. Source2: printerdb-1.81.ja
  13. # Vine patch
  14. Patch0: printerdb-vine.diff
  15. Patch1: vine-printfilters-1.81-2.diff
  16. Patch2: rhs-printfilters-1.81-pips5.patch
  17. Patch5: rhs-printfilters-1.81-lang.patch
  18. # security fix
  19. Patch6: rhs-printfilters-1.63-PARANOIDSAFER.patch
  20. #BuildPreReq: transfig >= 3.2.3c
  21. Requires: mpage >= 2.4, lpr >= 0.17, ghostscript >= 5.10, findutils >= 4.1-23, nkf, pnm2ppa, diffutils, sed
  22. Obsoletes: rhs-printfilters
  23. Provides: rhs-printfilters
  24. Buildroot: %{_tmppath}/%{name}-root
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. #
  28. # these conflcts exists because Dr Mike changes the location of the filters
  29. #
  30. Conflicts: libgr-progs < 2.0.9-7
  31. %description
  32. The vine-printfilters package contains a set of print filters which
  33. are primarily meant to be used with the Vine printtool. These
  34. print filters provide an easy way for users to handle printing
  35. numerous file formats.
  36. %description -l ja
  37. vnie-printfilters パッケージには Vine printtool で使用される
  38. 印刷フィルタが含まれています。これらの印刷フィルターは様々な
  39. ファイルフォーマットの印刷を使用者が簡単に取り扱えるように
  40. なっています。
  41. %prep
  42. %setup -q -a 1 -n rhs-printfilters-%{version}
  43. cp %SOURCE2 printerdb.ja
  44. %patch0 -b .db
  45. %patch1 -p1 -b .filter
  46. %ifarch i386 i486 i586 i686
  47. %patch2 -p1 -b .epson
  48. %endif
  49. %patch5 -p1 -b .lang
  50. %patch6 -p1
  51. %build
  52. cp testpages-vine/testpage* .
  53. cp testpages-vine/vinelogos* .
  54. %install
  55. rm -rf %{buildroot}
  56. mkdir -p INSTALL_DIR=%{buildroot}/usr/lib/rhs/rhs-printfilters
  57. make INSTALLBIN="install -m0755" INSTALLDATA="install -m0644" \
  58. INSTALL_DIR=%{buildroot} install
  59. #cp %SOURCE2 $RPM_BUILD_ROOT/usr/lib/rhs/rhs-printfilters/printerdb.ja
  60. install -m 644 printerdb.ja %{buildroot}/usr/lib/rhs/rhs-printfilters
  61. %clean
  62. rm -rf %{buildroot}
  63. %pre
  64. # Requires:
  65. # bash, sed, grep, diff, rm, cat
  66. # Where is the printcap?
  67. PRINTCAP='/etc/printcap'
  68. # Where is the master filter?
  69. MASTER_FILTER='/usr/lib/rhs/rhs-printfilters/master-filter'
  70. # Make sure that we actually have these files
  71. if [ -f $PRINTCAP ] && [ -f $MASTER_FILTER ]
  72. then
  73. # Open printcap
  74. cat $PRINTCAP | (
  75. # Read each line (forcing it to ignore the '\' convention).
  76. while read -r line;
  77. do
  78. # if a line looks like ':if=filename:', but aint commented,
  79. if echo ${line} | grep -q -E -e '^[^#]{0}[[:space:]]*:if='
  80. then
  81. # strip it down to the file name,
  82. # (We can be a little messy, 'cause printcap uses
  83. # ':' as a control character, to it can't be in
  84. # the file name)
  85. FILTER=`echo ${line} | sed -e 's/^:if=//; s/:.*//'`
  86. # and if the filter it names is the same as the
  87. # master-filter, or does not exist, then
  88. case $FILTER in
  89. "/var/spool/lpd/"*"/filter" )
  90. # All filters we want to find match this pattern
  91. if [ ! -a $FILTER ] || diff -q $MASTER_FILTER $FILTER > /dev/null
  92. then
  93. # remove the named filter
  94. rm -f $FILTER
  95. # Adjust the printcap file to use the
  96. # master filter directly
  97. sed -e "s:$FILTER:$MASTER_FILTER:g" < $PRINTCAP > $PRINTCAP.tmp
  98. mv $PRINTCAP.tmp $PRINTCAP
  99. fi
  100. ;;
  101. * )
  102. ;;
  103. esac
  104. fi
  105. done
  106. )
  107. fi
  108. %files
  109. %defattr(-,root,root)
  110. %doc README READMEj CHANGES
  111. %dir /usr/lib/rhs/rhs-printfilters
  112. /usr/lib/rhs/rhs-printfilters/asc-to-escp
  113. /usr/lib/rhs/rhs-printfilters/asc-to-escpage
  114. /usr/lib/rhs/rhs-printfilters/asc-to-lips3
  115. /usr/lib/rhs/rhs-printfilters/asc-to-npdl
  116. /usr/lib/rhs/rhs-printfilters/asc-to-printer.fpi
  117. /usr/lib/rhs/rhs-printfilters/asc-to-ps.fpi
  118. /usr/lib/rhs/rhs-printfilters/general.cfg.in
  119. /usr/lib/rhs/rhs-printfilters/master-filter
  120. /usr/lib/rhs/rhs-printfilters/postscript.cfg.in
  121. /usr/lib/rhs/rhs-printfilters/printerdb
  122. /usr/lib/rhs/rhs-printfilters/printerdb.ja
  123. /usr/lib/rhs/rhs-printfilters/ps-to-printer.fpi
  124. /usr/lib/rhs/rhs-printfilters/rpm-to-asc.fpi
  125. /usr/lib/rhs/rhs-printfilters/ncpprint
  126. /usr/lib/rhs/rhs-printfilters/ppaprint
  127. /usr/lib/rhs/rhs-printfilters/smbprint
  128. /usr/lib/rhs/rhs-printfilters/directprint
  129. /usr/lib/rhs/rhs-printfilters/testpage.asc
  130. /usr/lib/rhs/rhs-printfilters/testpage.euc
  131. /usr/lib/rhs/rhs-printfilters/testpage.jis
  132. /usr/lib/rhs/rhs-printfilters/testpage.sj
  133. /usr/lib/rhs/rhs-printfilters/testpage.ps
  134. /usr/lib/rhs/rhs-printfilters/testpage-a4.ps
  135. /usr/lib/rhs/rhs-printfilters/textonly.cfg.in
  136. %changelog
  137. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 1.81-1vl5
  138. - applied new versioning policy, spec in utf-8
  139. * Sat Jul 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.81-0vl10
  140. - rebuilt and docdir moved to /usr/share/doc
  141. - s/Copyright/License/
  142. * Wed Mar 6 2002 Jun Nishii <jun@vinelinux.org> 1.81-0vl9
  143. - add lang patch again
  144. * Wed Jan 30 2002 Jun Nishii <jun@vinelinux.org> 1.81-0vl8
  145. - added pips (ver.2.x) entries in printerdb
  146. (rhs-printfilters-1.81-pips5.patch)
  147. * Fri Jan 25 2002 Jun Nishii <jun@vinelinux.org> 1.81-0vl7
  148. - added pips/eplaser entries in printerdb
  149. (rhs-printfilters-1.81-pips4.patch)
  150. - security fix
  151. * added rhs-printfilters-1.63-PARANOIDSAFER.patch
  152. * replace %pre by the script in rhs-printfilters-1.63-4.rh6.2j.src.rpm
  153. so as not to put filter in spool directory
  154. * Sun Apr 8 2001 Jun Nishii <jun@vinelinux.org> 1.81-0vl6
  155. - added many newest pips filters(670,780,880,900,2200,3300,3500)
  156. by epson kowa
  157. * Sun Apr 8 2001 Jun Nishii <jun@vinelinux.org> 1.81-0vl5
  158. - added eplaser db by epson kowa
  159. * Thu Feb 15 2001 Jun Nishii <jun@vinelinux.org>
  160. - 1.81-0vl4
  161. - added pips db epson kowa
  162. * Wed Feb 14 2001 Jun Nishii <jun@vinelinux.org>
  163. - 1.81-0vl3
  164. - bug fix in ps-to-printer.fpi, thanks Mr. Masaki Kawamura
  165. - added lang patch to exec gs on LANG env.
  166. * Fri Feb 9 2001 Jun Nishii <jun@vinelinux.org>
  167. - 1.81-0vl2
  168. - try to merge Duplex patch
  169. * Mon Oct 30 2000 Jun Nishii <jun@vinelinux.org>
  170. - 1.81-0vl1
  171. * Sun Oct 8 2000 Jun Nishii <jun@vinelinux.org>
  172. - 1.63-0vl3
  173. - bug fix for GSDriver: EPSONc and EPSON in printerdb.ja
  174. by Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp>, thanks!
  175. * Wed Oct 4 2000 Jun Nishii <jun@vinelinux.org>
  176. - 1.63-0vl2
  177. - requires pnm2pba (obsoletes pbm2ppa)
  178. * Sun Aug 20 2000 Jun Nishii <jun@vinelinux.org>
  179. - 1.63-0vl1
  180. - fix for EPSON 820C
  181. - follow up with RHL62
  182. * Mon Jul 10 2000 AYUHANA Tomonori <l@kondara.org>
  183. - (1.59-2k)
  184. - add -q at %setup
  185. - add -b at %patch
  186. * Tue Jul 4 2000 Norihito Ohmori <nono@kondara.org>
  187. - fix DJ720C bug (#585)
  188. * Mon Mar 13 2000 Daiki Matsuda <dyky@kondara.org>
  189. - fix for EPSON 770C/800C
  190. * Wed Feb 17 2000 Norihito Ohmori <nono@kondara.org>
  191. - fix duplex printing bug (#398)
  192. * Mon Feb 14 2000 Norihito Ohmori <nono@kondara.org>
  193. - RPM_OPT_FLAGS support
  194. - ad-hoc i18n
  195. - Change Name vine-printfilters
  196. - be a NoSrc :-P
  197. - Support Duplex/Simplex Printing.
  198. - HP DeskJet 710C/720C support using pbm2ppa.
  199. - printerdb modified for gs510j55
  200. - add ESC/P, ESC/Page ,LIPS III and NPDL text filters
  201. - Add printerdb.ja
  202. * Wed Jan 26 2000 Bill Nottingham <notting@redhat.com>
  203. - add stylus color 740 to printerdb
  204. * Mon Nov 8 1999 Bill Nottingham <notting@redhat.com>
  205. - revert ps-to-printer tempfile usage. There has
  206. to be a better way to do this.
  207. * Wed Jul 21 1999 Bill Nottingham <notting@redhat.com>
  208. - munge smbprint Yet Again(tm)
  209. * Thu Jul 8 1999 Bill Nottingham <notting@redhat.com>
  210. - make printerdb config(noreplace)
  211. * Thu Jul 1 1999 Bill Nottingham <notting@redhat.com>
  212. - add more drivers
  213. * Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
  214. - fix rpm printing
  215. * Mon Jun 14 1999 Bill Nottingham <notting@redhat.com>
  216. - use smbclient's -c command. Makes much more sense.
  217. * Mon May 24 1999 Bill Nottingham <notting@redhat.com>
  218. - hmm. The translate option went away at some point. Oops.
  219. * Mon May 3 1999 Bill Nottingham <notting@redhat.com>
  220. - yet another typo in SMB stuff. Urg.
  221. * Mon Apr 5 1999 Bill Nottingham <notting@redhat.com>
  222. - strip binaries
  223. * Thu Apr 1 1999 Bill Nottingham <notting@redhat.com>
  224. - fix some printerdb stuff for ghostscript brokenness
  225. * Fri Mar 19 1999 Bill Nottingham <notting@redhat.com>
  226. - remove some oboslete text
  227. * Mon Feb 8 1999 Bill Nottingham <notting@redhat.com>
  228. - uniprint support
  229. * Tue Dec 29 1998 Bill Nottingham <notting@redhat.com>
  230. - add workaround for Adobe(!) postscript driver
  231. * Mon Dec 28 1998 Bill Nottingham <notting@redhat.com>
  232. - remove 1bpp from cdj-based drivers, 'cos it's broken.
  233. * Wed Nov 18 1998 Bill Nottingham <notting@redhat.com>
  234. - add workgroup support to smbprint, fix quoting issues
  235. * Wed Sep 30 1998 Bill Nottingham <notting@redhat.com>
  236. - fix typo in ncpprint
  237. * Wed Sep 15 1998 Bill Nottingham <notting@redhat.com>
  238. - Added ncpprint to %files section (oops!)
  239. * Thu Sep 2 1998 Bill Nottingham <notting@redhat.com>
  240. - Added NCP printing support
  241. * Tue Jun 30 1998 Michael Maher <mike@redhat.com>
  242. - Fixed BUG 703, added findutils dependecy.
  243. - Added buildroot.
  244. * Fri May 08 1998 Prospector System <bugs@redhat.com>
  245. - translations modified for de, fr, tr
  246. * Wed Oct 22 1997 Michael Fulbright <msf@redhat.com>
  247. - Fixed printerdb to include 300x300 resolution for LaserJet 4 models
  248. - Restored troff file handling now troff fpi is 'safe'
  249. * Tue Oct 14 1997 Michael Fulbright <msf@redhat.com>
  250. - Fixed master-filter to NOT handle troff files automatically
  251. * Thu Jul 31 1997 Erik Troan <ewt@redhat.com>
  252. - built against glibc
  253. * Wed Apr 23 1997 Michael Fulbright <msf@redhat.com>
  254. - Fixed problem with asc-to-printer.fpi not handling cr/lf trans correct
  255. * Fri Apr 18 1997 Michael Fulbright <msf@redhat.com>
  256. - fixed up Canon 600/4000 printerdb def
  257. - added some HP Deskjets which I know work
  258. * Thu Apr 10 1997 Michael Fulbright <msf@redhat.com>
  259. - Added requirement that gs is installed. Pretty useless w/o it if
  260. you print anything interesting.
  261. * Fri Mar 13 1997 Michael Fulbright <msf@redhat.com>
  262. - Added conflicts so that packages with old filter loc won't hurt us.
  263. - Moved to version 1.2.
  264. - Added mpage support to allow nup printing.
  265. * Wed Mar 13 1997 Michael Fulbright <msf@redhat.com>
  266. - Added a DeskJet500Mono driver which links to the gs driver djet500.
  267. - Added a A4 paper size test page.
  268. - Fixed Makefile to build .ps test pages from the .fig files.
  269. * Mon Mar 10 1997 Michael Fulbright <msf@redhat.com>
  270. - Split filters off from printtool into this package .