viewnior-vl.spec 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148
  1. # We don't build with Gnome support by default to avoid a GConf dependency.
  2. # If you would like to set the Gnome background image with Viewnior, rebuild
  3. # the srpm with:
  4. # rpmbuild --rebuild viewnior-*-src.rpm --with gnome
  5. # or use bcond_without to change the default
  6. #%bcond_with gnome
  7. Name: viewnior
  8. Version: 1.6
  9. Release: 2%{?_dist_release}
  10. Summary: Elegant image viewer
  11. Summary(ja): エレガントな画像ビューア
  12. Group: Applications/Graphics
  13. License: GPLv3+
  14. URL: http://xsisqox.github.com/Viewnior
  15. Source0: http://cloud.github.com/downloads/xsisqox/Viewnior/%{name}-%{version}.tar.gz
  16. #Patch0: viewnior-0.7-dsofix.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. BuildRequires: exiv2-devel
  19. BuildRequires: gdk-pixbuf2-devel >= 2.4.0
  20. BuildRequires: glib2-devel >= 2.24
  21. BuildRequires: gtk2-devel >= 2.20
  22. BuildRequires: gnome-common
  23. BuildRequires: desktop-file-utils
  24. BuildRequires: gettext
  25. BuildRequires: intltool >= 0.35.0
  26. BuildRequires: perl-XML-Parser
  27. BuildRequires: shared-mime-info >= 0.20
  28. #%if %{with gnome}
  29. #BuildRequires: GConf2-devel
  30. #%endif
  31. %description
  32. Viewnior is an image viewer program. Created to be simple, fast and elegant.
  33. It's minimalistic interface provides more screen space for your images. Among
  34. its features are:
  35. * Fullscreen & Slideshow
  36. * Rotate, flip, save, delete images
  37. * Animation support
  38. * Browse only selected images
  39. * Navigation window
  40. * Simple interface
  41. * Configurable mouse actions
  42. %prep
  43. %setup -q -n Viewnior-%{name}-%{version}
  44. #%patch0 -p1 -b .dsofix
  45. # fix spurious executable perms
  46. chmod 0644 AUTHORS COPYING NEWS README TODO src/*
  47. %build
  48. ./autogen.sh
  49. %configure --enable-static=no \
  50. #%if %{with gnome}
  51. # --enable-wallpaper
  52. #%endif
  53. make %{?_smp_mflags} V=1
  54. %install
  55. rm -rf %{buildroot}
  56. make install DESTDIR=%{buildroot} INSTALL='install -p'
  57. %find_lang %{name}
  58. desktop-file-validate %{buildroot}/%{_datadir}/applications/%{name}.desktop
  59. %clean
  60. rm -rf %{buildroot}
  61. %post
  62. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  63. update-desktop-database &> /dev/null || :
  64. %postun
  65. if [ $1 -eq 0 ] ; then
  66. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  67. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  68. fi
  69. update-desktop-database &> /dev/null || :
  70. %posttrans
  71. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  72. %files -f %{name}.lang
  73. %defattr(-,root,root,-)
  74. %doc AUTHORS COPYING NEWS README TODO
  75. %{_bindir}/%{name}
  76. %{_datadir}/applications/%{name}.desktop
  77. %{_datadir}/icons/hicolor/*/apps/%{name}.*
  78. %{_datadir}/%{name}/
  79. %{_mandir}/man?/
  80. %changelog
  81. * Sat Jul 02 2016 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.6-2
  82. - rebuilt with new toolchain
  83. * Thu Mar 31 2016 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.6-1
  84. - new upstream release
  85. - fixed %%doc in %%files
  86. * Sat Nov 14 2015 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5-1
  87. - new upstream release
  88. - deleted Patch0
  89. - added BuildRequires: gnome-common
  90. * Sat Mar 08 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.4-1
  91. - new upstream release
  92. - added BuildRequires: exiv2-devel
  93. * Tue Feb 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3-1
  94. - new upstream release
  95. - dropt patch1
  96. * Sat Feb 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2-1
  97. - new upstream release
  98. - added patch1 to fix typo
  99. - added configure option: --enable-static=no
  100. * Thu Dec 16 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1-1
  101. - initial build for VineSeed
  102. * Wed Mar 31 2010 Christoph Wickert <cwickert@fedoraproject.org> - 1.0-1
  103. - Update to 1.0
  104. * Tue Feb 16 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.7-2
  105. - Add patch to fix DSO linking (#565018)
  106. - Switch to %%bcond macro
  107. * Mon Sep 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.7-1
  108. - Update to 0.7
  109. * Sat Sep 05 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6-2
  110. - Spec file cleanups from review.
  111. * Sat Aug 01 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6-1
  112. - Initial package