usermode-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609
  1. # VINE: 1.110 or upper drops halt/poweroff/reboot helpers
  2. # VINE: to upgrade 1.110+, we need to use systemd.
  3. Summary: Tools for certain user account management tasks.
  4. Summary(ja): ユーザアカウント管理用ツール
  5. Name: usermode
  6. Version: 1.109
  7. Release: 1%{?_dist_release}
  8. License: GPLv2+
  9. Group: Applications/System
  10. URL: https://fedorahosted.org/usermode/
  11. Source: https://fedorahosted.org/releases/u/s/usermode/usermode-%{version}.tar.xz
  12. ## Vine Source(s)/Patch(es)
  13. Source10: usermode-1.107-ja.po
  14. Patch10: usermode-1.37-halt-p.patch
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. Packager: daisuke
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: desktop-file-utils, glib2-devel, gtk2-devel
  20. BuildRequires: libglade2-devel, libuser-devel, pam-devel, util-linux-ng, libwnck-devel
  21. BuildRequires: libblkid-devel
  22. BuildRequires: perl-XML-Parser, libSM-devel, startup-notification-devel, gettext
  23. Requires: util-linux, pam >= 0.75, passwd
  24. Conflicts: SysVinit < 2.74-14
  25. %description
  26. The usermode package contains the userhelper program, which can be
  27. used to allow configured programs to be run with superuser privileges
  28. by ordinary users.
  29. %description -l ja
  30. usermode パッケージには、一般ユーザが設定されたプログラムをスーパーユー
  31. ザとして実行できるようにするユーザヘルパープログラムが含まれています。
  32. %package gtk
  33. Summary: Graphical tools for certain user account management tasks.
  34. Summary(ja): ユーザアカウント管理用グラフィカルツール
  35. Group: Applications/System
  36. Requires: %{name} = %{version}-%{release}
  37. %description gtk
  38. The usermode-gtk package contains several graphical tools for users:
  39. userinfo, usermount and userpasswd. Userinfo allows users to change
  40. their finger information. Usermount lets users mount, unmount, and
  41. format filesystems. Userpasswd allows users to change their
  42. passwords.
  43. Install the usermode-gtk package if you would like to provide users with
  44. graphical tools for certain account management tasks.
  45. %description gtk -l ja
  46. usermode-gtk には userinfo, usermount, userpasswd といったユーザ用
  47. グラフィカルツールも収められています。userinfo を使うと一般ユーザが自
  48. 分のアカウントの finger 情報を変更することが出来ます.
  49. usermount は一般ユーザがファイルシステムのマウント/アンマウント/初期化を
  50. 行うことを可能にします.userpasswd は一般ユーザが自分のパスワードを
  51. 変更するのに使います.
  52. 一般ユーザ向けに,アカウント管理用グラフィカルツールを提供したい場合は
  53. usermode パッケージをインストールして下さい.
  54. %prep
  55. %setup -q
  56. cp -f po/ja.po po/ja.po.orig
  57. cp -f %{SOURCE10} po/ja.po
  58. %patch10 -p1 -b .halt-p
  59. %build
  60. intltoolize --force --copy
  61. autoreconf
  62. %configure
  63. make -C po usermode.pot
  64. make -C po update-po
  65. make
  66. %install
  67. rm -rf $RPM_BUILD_ROOT
  68. make install DESTDIR=$RPM_BUILD_ROOT
  69. # We set up the shutdown programs to be wrapped in this package. Other
  70. # packages are on their own....
  71. mkdir -p $RPM_BUILD_ROOT/etc/pam.d $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps
  72. for wrappedapp in halt reboot poweroff ; do
  73. ln -s consolehelper $RPM_BUILD_ROOT%{_bindir}/${wrappedapp}
  74. install -m644 $wrappedapp $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps/${wrappedapp}
  75. cp shutdown.pamd $RPM_BUILD_ROOT/etc/pam.d/${wrappedapp}
  76. done
  77. cat <<EOF > $RPM_BUILD_ROOT/etc/security/console.apps/config-util
  78. USER=root
  79. UGROUPS=wheel
  80. EOF
  81. for desktopfile in $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
  82. do
  83. mv $desktopfile ${desktopfile/redhat-/}
  84. done
  85. %find_lang %{name}
  86. %clean
  87. rm -rf $RPM_BUILD_ROOT
  88. %files -f %{name}.lang
  89. %defattr(-,root,root)
  90. %attr(4711,root,root) /usr/sbin/userhelper
  91. %{_bindir}/consolehelper
  92. %{_mandir}/man8/userhelper.8*
  93. %{_mandir}/man8/consolehelper.8*
  94. # PAM console wrappers
  95. %{_bindir}/halt
  96. %{_bindir}/reboot
  97. %{_bindir}/poweroff
  98. %{_bindir}/shutdown
  99. %config(noreplace) /etc/pam.d/halt
  100. %config(noreplace) /etc/pam.d/reboot
  101. %config(noreplace) /etc/pam.d/poweroff
  102. %config(noreplace) /etc/security/console.apps/config-util
  103. %config /etc/security/console.apps/halt
  104. %config /etc/security/console.apps/reboot
  105. %config /etc/security/console.apps/poweroff
  106. %files gtk
  107. %defattr(-,root,root)
  108. %{_bindir}/usermount
  109. %{_mandir}/man1/usermount.1*
  110. %{_bindir}/userinfo
  111. %{_mandir}/man1/userinfo.1*
  112. %{_bindir}/userpasswd
  113. %{_mandir}/man1/userpasswd.1*
  114. %{_bindir}/consolehelper-gtk
  115. %{_mandir}/man8/consolehelper-gtk.8*
  116. %{_bindir}/pam-panel-icon
  117. %{_mandir}/man1/pam-panel-icon.1*
  118. %{_datadir}/%{name}
  119. %{_datadir}/pixmaps/*
  120. %{_datadir}/applications/*
  121. %changelog
  122. * Wed Jul 02 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.109-1
  123. - update to 1.109
  124. * Sat Jun 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.107-1
  125. - update to 1.107
  126. - add UGROUPS=wheel to config-util
  127. - update ja.po for better authentication dialog
  128. * Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.106.1-1
  129. - new upstream release
  130. * Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.98-1
  131. - new upstream release
  132. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.86-1vl5
  133. - applied new versioning policy, spec in utf-8
  134. * Sat Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.86-0vl3
  135. - rebuilt with libwnck 2.20.2
  136. - added Patch100 for avoiding desktop-file-install failure
  137. - fixed *.desktop.in files
  138. * Tue Sep 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.86-0vl2
  139. - fix Patch12
  140. - The old patch changes the application's locale by mistake.
  141. * Thu Sep 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.86-0vl1
  142. - new upstream release
  143. - add Patch12 to fix broken messages in consolehelper-gtk (<BTS:181>)
  144. - update ja.po
  145. * Thu Jun 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.85-0vl1
  146. - new upstream release
  147. * Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.81-0vl1
  148. - new upstream release
  149. - rebuild with new libwnck
  150. * Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.70-4vl3
  151. - rebuild with new libwnck
  152. * Sat Jul 3 2004 Tomoya TAKA <taka@vinelinux.org> 1.70-4vl2
  153. - fix lack of %%{_bindir}/shutdown
  154. * Mon Jun 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.70-4vl1
  155. - new upstream release
  156. - fixed spec's kanji code.
  157. - split gui related utilities to usermode-gtk subpackage.
  158. * Mon Nov 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.69-1vl1
  159. - new upstream release
  160. * Thu Oct 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.68-0vl1
  161. - new upstream release
  162. * Sat Jan 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.65-1vl1
  163. - merged with Vine Linux package 1.42-1vl5
  164. * Sat Aug 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.42-1vl5
  165. - enable system authentication even if %%{build6x} is set to 0
  166. (for compatibility with previous version)
  167. * Mon Aug 05 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.42-1vl4
  168. - reinstated /usr/bin/shutdown
  169. * Fri Aug 02 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.42-1vl3
  170. - rebuild with pam-0.75-39vl1
  171. - set build6x to 0
  172. * Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.42-1vl2
  173. - rebuild to remove rpmlib dependancy
  174. * Fri Jun 01 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  175. - 1.42-1vl1
  176. - based on 1.42-1 from Rawhide and merged some from 1.37-2vl2
  177. - %%define build6x 1 for Vine
  178. * Mon Jan 20 2003 Nalin Dahyabhai <nalin@redhat.com> 1.65-1
  179. - pass-through DESKTOP_STARTUP_ID
  180. * Mon Jan 6 2003 Nalin Dahyabhai <nalin@redhat.com> 1.64-1
  181. - set the requesting user PAM item to the invoking user's name (#81255)
  182. * Mon Nov 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.63-2
  183. - remove directory names from PAM config files, allowing the same config
  184. files to work for both arches on multilib boxes
  185. - translation updates
  186. * Wed Sep 4 2002 Nalin Dahyabhai <nalin@redhat.com> 1.63-1
  187. - userhelper: swallow the exec'd program's exit stauts, which would be
  188. misinterpreted by consolehelper anyway
  189. * Tue Sep 3 2002 Nalin Dahyabhai <nalin@redhat.com> 1.62-1
  190. - consolehelper: suppress dialog on successful execution
  191. - userhelper: return 0 on success, not 1 (what was I *thinking*?)
  192. * Mon Sep 2 2002 Nalin Dahyabhai <nalin@redhat.com> 1.61-1
  193. - userinfo: exit properly on escape. handle site_info field properly. go
  194. insensitive while running child process.
  195. - userpasswd: exit properly on cancel.
  196. - all of the above: reap the child instead of checking for pipe close -- this
  197. way is more robust (#68578,72684).
  198. - usermount: run mount/umount synchronously. capture stderr and display in a
  199. dialog. desensitize action buttons when no filesystems are selected.
  200. - consolehelper: display errors if we're attempting to run bogus programs
  201. (#72127)
  202. - translation updates (#70278)
  203. * Wed Aug 14 2002 Nalin Dahyabhai <nalin@redhat.com> 1.60-1
  204. - reconnect the "cancel" and "ok" buttons in userinfo
  205. - heed the cancel button when prompting for passwords in userinfo (#68578)
  206. - translation update
  207. * Wed Aug 14 2002 Nalin Dahyabhai <nalin@redhat.com> 1.59-2
  208. - change "forget password" to "forget authorization", because we don't actually
  209. remember the password (that would be scary, #71476)
  210. - translation update
  211. * Tue Aug 13 2002 Nalin Dahyabhai <nalin@redhat.com> 1.59-1
  212. - pam-panel-icon: overhaul, change the 'locked' icon to keyring-small, nix the
  213. 'unlocked' icon
  214. - consolehelper-gtk: properly set up the dialog buttons (should be 'cancel/ok'
  215. when we're asking questions, was always 'close')
  216. - disappear pam_timestamp_init
  217. * Wed Aug 7 2002 Nalin Dahyabhai <nalin@redhat.com> 1.58-2
  218. - install the new 'unlocked' icon
  219. * Tue Aug 6 2002 Jonathan Blandford <jrb@redhat.com>
  220. - New version.
  221. * Mon Aug 5 2002 Nalin Dahyabhai <nalin@redhat.com> 1.57-1
  222. - add support for BANNER and BANNER_DOMAIN in the userhelper configuration
  223. * Mon Aug 5 2002 Nalin Dahyabhai <nalin@redhat.com> 1.56-4
  224. - mark strings in the .glade file as translatable (#70278)
  225. - translation updates
  226. * Wed Jul 31 2002 Nalin Dahyabhai <nalin@redhat.com> 1.56-3
  227. - add icons for userpasswd and usermount
  228. * Wed Jul 24 2002 Nalin Dahyabhai <nalin@redhat.com> 1.56-2
  229. - actually include the icons
  230. - translation updates
  231. * Tue Jul 23 2002 Nalin Dahyabhai <nalin@redhat.com> 1.56-1
  232. - userinfo: prevent users from selecting "nologin" as a shell (#68579)
  233. - don't strip binaries by default; leave that to the buildroot policy
  234. - use desktop-file-install
  235. * Wed Jun 19 2002 Havoc Pennington <hp@redhat.com>
  236. - put pam-panel-icon in file list
  237. * Mon May 20 2002 Nalin Dahyabhai <nalin@redhat.com> 1.55-2
  238. - don't strip binaries which have no special privileges
  239. * Wed May 15 2002 Nalin Dahyabhai <nalin@redhat.com> 1.55-1
  240. - remove the pixmap we don't use any more (we use stock pixmaps now)
  241. - update translations
  242. * Tue Apr 16 2002 Nalin Dahyabhai <nalin@redhat.com> 1.54-1
  243. - suppress even error messages from Xlib when consolehelper calls
  244. gtk_init_check() to see if the display is available
  245. * Mon Apr 15 2002 Nalin Dahyabhai <nalin@redhat.com> 1.53-2
  246. - refresh translations
  247. * Thu Apr 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.53-1
  248. - refresh shell variable code from authconfig (#63175)
  249. * Tue Apr 9 2002 Nalin Dahyabhai <nalin@redhat.com> 1.52-2
  250. - refresh translations
  251. * Mon Apr 1 2002 Nalin Dahyabhai <nalin@redhat.com> 1.52-1
  252. - attempt to make prompts at the console more meaningful
  253. - when falling back, reset the entire environment to the user's
  254. * Thu Mar 28 2002 Nalin Dahyabhai <nalin@redhat.com>
  255. - stop giving the user chances to enter the right password if we get a
  256. conversation error reading a response (appears to be masked by libpam)
  257. (#62195)
  258. - always center consolehelper dialog windows
  259. * Wed Mar 27 2002 Nalin Dahyabhai <nalin@redhat.com> 1.51-1
  260. - patch to make gettext give us UTF-8 strings (which GTK needs) from ynakai
  261. * Fri Mar 22 2002 Nalin Dahyabhai <nalin@redhat.com> 1.50-6
  262. - update translations
  263. - actually include the glade files (#61665)
  264. * Mon Mar 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.50-5
  265. - update translations
  266. * Mon Feb 25 2002 Nalin Dahyabhai <nalin@redhat.com> 1.50-4
  267. - rebuild
  268. * Fri Feb 22 2002 Nalin Dahyabhai <nalin@redhat.com> 1.50-3
  269. - update translations
  270. * Thu Jan 31 2002 Nalin Dahyabhai <nalin@redhat.com> 1.50-2
  271. - rebuild to fix dependencies
  272. * Thu Jan 31 2002 Nalin Dahyabhai <nalin@redhat.com> 1.50-1
  273. - fix userpasswd dialog message being incorrect for password changes
  274. - use a dumb conversation function when text mode is invoked without a tty -- if
  275. the service's configuration doesn't call for prompts, then it'll still work
  276. - port from pwdb to libuser
  277. - catch child-exit errors correctly again
  278. - fix keyboard-grabbing
  279. * Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 1.49-3
  280. - add default locations for certain binaries to configure.in
  281. * Thu Jan 3 2002 Nalin Dahyabhai <nalin@redhat.com> 1.49-2
  282. - munge glade file to use stock items for buttons where possible
  283. * Mon Dec 10 2001 Nalin Dahyabhai <nalin@redhat.com> 1.49-1
  284. - the console.apps configs shouldn't be missingok
  285. - fix buildprereqs for gtk2/libglade2
  286. * Tue Dec 4 2001 Nalin Dahyabhai <nalin@redhat.com>
  287. - more gtk2 changes
  288. - split off a -gtk subpackage with all of the gtk-specific functionality
  289. * Wed Nov 28 2001 Nalin Dahyabhai <nalin@redhat.com>
  290. - the grand libglade/gtk2 overhaul
  291. - allow disabling display of GUI windows by setting "GUI=false" in the
  292. console.apps configuration file (default: TRUE)
  293. - allow disabling display of GUI windows by recognizing a magic option
  294. on the command-line of the program being wrapped (NOXOPTION, no default)
  295. * Fri Nov 9 2001 Nalin Dahyabhai <nalin@redhat.com> 1.46-1
  296. - restore the previous XAUTHORITY setting before opening PAM sessions
  297. * Fri Nov 2 2001 Nalin Dahyabhai <nalin@redhat.com> 1.45-1
  298. - propagate environment variables from libpam to applications
  299. * Wed Oct 3 2001 Nalin Dahyabhai <nalin@redhat.com> 1.44-1
  300. - only try to call gtk_main_quit() if we've got a loop to get out of (#54109)
  301. - obey RPM_OPT_FLAGS, obey
  302. * Tue Aug 28 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 1.43-1
  303. - Update translations
  304. * Mon Aug 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  305. - add build requirements on glib-devel, gtk+-devel, pam-devel (#49726)
  306. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  307. - Bump release + rebuild.
  308. * Wed Feb 14 2001 Preston Brown <pbrown@redhat.com>
  309. - final translation merge.
  310. * Wed Feb 14 2001 Nalin Dahyabhai <nalin@redhat.com>
  311. - clear the supplemental groups list before running binaries as root (#26851)
  312. * Wed Feb 7 2001 Nalin Dahyabhai <nalin@redhat.com>
  313. - set XAUTHORITY if we fall back to regular behavior (#26343)
  314. - make the suid helper 04711 instead of 04755
  315. * Mon Feb 5 2001 Nalin Dahyabhai <nalin@redhat.com>
  316. - refresh translations
  317. * Mon Jan 29 2001 Preston Brown <pbrown@redhat.com>
  318. - use lang finding script.
  319. * Thu Jan 25 2001 Yukihiro Nakai <ynakai@redhat.com>
  320. - Some fix for Japanese environment.
  321. - Use gtk_set_locale() instead of setlocale()
  322. - Copyright update.
  323. * Sun Jan 7 2001 Yukihiro Nakai <ynakai@redhat.com>
  324. - Add gettextized
  325. * Thu Nov 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  326. - fix segfault in userhelper (#20027)
  327. * Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
  328. - /sbin/shutdown, not /usr/sbin/shutdown (#19034)
  329. * Fri Oct 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  330. - don't pass on arguments to halt and reboot, because they error out
  331. * Thu Oct 5 2000 Nalin Dahyabhai <nalin@redhat.com>
  332. - fix the /usr/bin/shutdown wrapper so that root can call shutdown
  333. - only include the /usr/bin/shutdown wrapper on 6.x
  334. - also sanitize LC_MESSAGES
  335. - tweak sanitizing checks (from mkj)
  336. * Wed Oct 4 2000 Jakub Jelinek <jakub@redhat.com>
  337. - fix a security bug with LC_ALL/LANG variables (#18046)
  338. * Mon Aug 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  339. - mark defined strings translateable (#17006)
  340. * Thu Aug 24 2000 Nalin Dahyabhai <nalin@redhat.com>
  341. - fix incorrect user name
  342. - add a shell wrapper version of /usr/bin/shutdown
  343. - build for 6.x errata
  344. - bump revision to upgrade the errata
  345. * Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
  346. - fix stdin/stdout redirection shenanigans (#11706)
  347. - fix authentication and execution as users other than root
  348. - make sure the right descriptors are terminals before dup2()ing them
  349. - cut out an extra-large CPU waster that breaks GUI apps
  350. * Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  351. - fix typo (#16664)
  352. * Sun Aug 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  353. - previous fix, part two
  354. * Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  355. - fix inadvertent breakage of the shell-changing code
  356. * Fri Aug 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  357. - fix the "run unprivileged" option
  358. * Mon Aug 14 2000 Nalin Dahyabhai <nalin@redhat.com>
  359. - actually use the right set of translations
  360. * Fri Aug 11 2000 Nalin Dahyabhai <nalin@redhat.com>
  361. - remove the shutdown command from the list of honored commands
  362. * Wed Aug 9 2000 Nalin Dahyabhai <nalin@redhat.com>
  363. - merge in updated translations
  364. - set XAUTHORITY after successful authentication (#11006)
  365. * Wed Aug 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  366. - install translations
  367. - fixup a messy text string
  368. - make "Mount"/"Unmount" translatable
  369. - stop prompting for passwords to shut down -- we can hit ctrl-alt-del anyway,
  370. and gdm users can just shut down without logging in
  371. * Mon Jul 31 2000 Nalin Dahyabhai <nalin@redhat.com>
  372. - attempt to add i18n support
  373. * Wed Jul 12 2000 Nalin Dahyabhai <nalin@redhat.com>
  374. - attempt to get a usable icon for userhelper-wrap (#13616, #13768)
  375. * Wed Jul 5 2000 Nalin Dahyabhai <nalin@redhat.com>
  376. - fix them right this time
  377. * Mon Jul 3 2000 Nalin Dahyabhai <nalin@redhat.com>
  378. - fix verbosity problems
  379. * Mon Jun 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  380. - strip all binaries by default
  381. - add the name of the program being run to the userhelper dialog
  382. - add a graphic to the userhelper-wrap package
  383. - add a button to jump straight to nonprivileged operation when supported
  384. * Sun Jun 18 2000 Matt Wilson <msw@redhat.com>
  385. - rebuilt to see if we get stripped binaries
  386. * Mon Jun 5 2000 Nalin Dahyabhai <nalin@redhat.com>
  387. - move man pages to %%{_mandir}
  388. * Thu Jun 1 2000 Nalin Dahyabhai <nalin@redhat.com>
  389. - modify PAM setup to use system-auth
  390. - bzip2 compress tarball
  391. * Fri Mar 17 2000 Ngo Than <than@redhat.de>
  392. - fix problem with LANG and LC_ALL
  393. - compress source with bzip2
  394. * Thu Mar 09 2000 Nalin Dahyabhai <nalin@redhat.com>
  395. - fix problem parsing userhelper's -w flag with other args
  396. * Wed Mar 08 2000 Nalin Dahyabhai <nalin@redhat.com>
  397. - ignore read() == 0 because the child exits
  398. * Tue Mar 07 2000 Nalin Dahyabhai <nalin@redhat.com>
  399. - queue notice messages until we get prompts in userhelper to fix bug #8745
  400. * Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
  401. - free trip through the build system
  402. * Tue Jan 11 2000 Nalin Dahyabhai <nalin@redhat.com>
  403. - grab keyboard input focus for dialogs
  404. * Fri Jan 07 2000 Michael K. Johnson <johnsonm@redhat.com>
  405. - The root exploit fix created a bug that only showed up in certain
  406. circumstances. Unfortunately, we didn't test in those circumstances...
  407. * Mon Jan 03 2000 Michael K. Johnson <johnsonm@redhat.com>
  408. - fixed local root exploit
  409. * Thu Sep 30 1999 Michael K. Johnson <johnsonm@redhat.com>
  410. - fixed old complex broken gecos parsing, replaced with simple working parsing
  411. - can now blank fields (was broken by previous fix for something else...)
  412. * Tue Sep 21 1999 Michael K. Johnson <johnsonm@redhat.com>
  413. - FALLBACK/RETRY in consolehelper/userhelper
  414. - session management fixed for consolehelper/userhelper SESSION=true
  415. - fix memory leak and failure to close in error condition (#3614)
  416. - fix various bugs where not all elements in userinfo got set
  417. * Mon Sep 20 1999 Michael K. Johnson <johnsonm@redhat.com>
  418. - set $HOME when acting as consolehelper
  419. - rebuild against new pwdb
  420. * Tue Sep 14 1999 Michael K. Johnson <johnsonm@redhat.com>
  421. - honor "owner" flag to mount
  422. - ask for passwords with username
  423. * Tue Jul 06 1999 Bill Nottingham <notting@redhat.com>
  424. - import pam_console wrappers from SysVinit, since they require usermode
  425. * Mon Apr 12 1999 Michael K. Johnson <johnsonm@redhat.com>
  426. - even better check for X availability
  427. * Wed Apr 07 1999 Michael K. Johnson <johnsonm@redhat.com>
  428. - better check for X availability
  429. - center windows to make authentication easier (improve later with
  430. transients and embedded windows where possible)
  431. - applink -> applnk
  432. - added a little padding, especially important when running without
  433. a window manager, as happens when running from session manager at
  434. logout time
  435. * Wed Mar 31 1999 Michael K. Johnson <johnsonm@redhat.com>
  436. - hm, need to be root...
  437. * Fri Mar 19 1999 Michael K. Johnson <johnsonm@redhat.com>
  438. - updated userhelper.8 man page for consolehelper capabilities
  439. - moved from wmconfig to desktop entries
  440. * Thu Mar 18 1999 Michael K. Johnson <johnsonm@redhat.com>
  441. - added consolehelper
  442. - Changed conversation architecture to follow PAM spec
  443. * Wed Mar 17 1999 Bill Nottingham <notting@redhat.com>
  444. - remove gdk_input_remove (causing segfaults)
  445. * Tue Jan 12 1999 Michael K. Johnson <johnsonm@redhat.com>
  446. - fix missing include files
  447. * Mon Oct 12 1998 Cristian Gafton <gafton@redhat.com>
  448. - strip binaries
  449. - use defattr
  450. - fix spec file ( rm -rf $(RPM_BUILD_ROOT) is a stupid thing to do ! )
  451. * Tue Oct 06 1998 Preston Brown <pbrown@redhat.com>
  452. - fixed so that the close button on window managers quits the program properly
  453. * Thu Apr 16 1998 Erik Troan <ewt@redhat.com>
  454. - use gtk-config during build
  455. - added make archive rule to Makefile
  456. - uses a build root
  457. * Fri Nov 7 1997 Otto Hammersmith <otto@redhat.com>
  458. - new version that fixed memory leak bug.
  459. * Mon Nov 3 1997 Otto Hammersmith <otto@redhat.com>
  460. - updated version to fix bugs
  461. * Fri Oct 17 1997 Otto Hammersmith <otto@redhat.com>
  462. - Wrote man pages for userpasswd and userhelper.
  463. * Tue Oct 14 1997 Otto Hammersmith <otto@redhat.com>
  464. - Updated the packages... now includes userpasswd for changing passwords
  465. and newer versions of usermount and userinfo. No known bugs or
  466. misfeatures.
  467. - Fixed the file list...
  468. * Mon Oct 6 1997 Otto Hammersmith <otto@redhat.com>
  469. - Created the spec file.