unixODBC-vl.spec 9.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306
  1. Name: unixODBC
  2. Version: 2.3.4
  3. Release: 1%{?_dist_release}
  4. Summary: A complete ODBC Driver Manager for Linux
  5. Summary(ja): Linux 用 ODBC ドライバマネージャー
  6. Group: System Environment/Libraries
  7. # Programs are GPL, libraries are LGPL, except News Server library is GPL.
  8. License: GPLv2+ and LGPLv2+
  9. URL: http://www.unixODBC.org/
  10. Source: http://www.unixODBC.org/%{name}-%{version}.tar.gz
  11. Source1: odbcinst.ini
  12. Source4: conffile.h
  13. Source5: README.dist
  14. Patch6: export-symbols.patch
  15. Patch8: so-version-bump.patch
  16. Patch9: keep-typedefs.patch
  17. Conflicts: iodbc
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: automake autoconf libtool libtool-ltdl-devel bison flex
  20. BuildRequires: readline-devel
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. %description
  24. Install unixODBC if you want to access databases through ODBC.
  25. You will also need the mysql-connector-odbc package if you want to access
  26. a MySQL database, and/or the postgresql-odbc package for PostgreSQL.
  27. %package devel
  28. Summary: Development files for programs which will use the unixODBC library.
  29. Summary(ja): unixODBC ライブラリを用いるプログラムのための開発用ファイル
  30. Group: Development/Libraries
  31. Requires: %{name} = %{version}-%{release}
  32. %description devel
  33. The unixODBC package can be used to access databases through ODBC
  34. drivers. If you want to develop programs that will access data through
  35. ODBC, you need to install this package.
  36. %prep
  37. %setup -q
  38. %patch6 -p1
  39. %patch8 -p1
  40. %patch9 -p1
  41. chmod 0644 Drivers/MiniSQL/*.c
  42. chmod 0644 Drivers/nn/*.c
  43. chmod 0644 Drivers/template/*.c
  44. chmod 0644 doc/ProgrammerManual/Tutorial/*.html
  45. chmod 0644 doc/lst/*
  46. chmod 0644 include/odbcinst.h
  47. # Blow away the embedded libtool and replace with build system's libtool.
  48. # (We will use the installed libtool anyway, but this makes sure they match.)
  49. rm -rf config.guess config.sub install-sh ltmain.sh libltdl
  50. # this hack is so we can build with either libtool 2.2 or 1.5
  51. libtoolize --install || libtoolize
  52. %build
  53. aclocal
  54. automake --add-missing
  55. autoconf
  56. # unixODBC 2.2.14 is not aliasing-safe
  57. CFLAGS="%{optflags} -fno-strict-aliasing"
  58. CXXFLAGS="$CFLAGS"
  59. export CFLAGS CXXFLAGS
  60. %configure --with-gnu-ld=yes --enable-threads=yes \
  61. --enable-drivers=yes --enable-driverc=yes --enable-ltdllib
  62. # Get rid of the rpaths
  63. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  64. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  65. make all
  66. %install
  67. rm -rf $RPM_BUILD_ROOT
  68. make DESTDIR=$RPM_BUILD_ROOT install
  69. install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
  70. # multilib header hacks
  71. # we only apply this to known Red Hat multilib arches, per bug #181335
  72. case `uname -i` in
  73. i386 | x86_64 | ia64 | ppc | ppc64 | s390 | s390x | sparc | sparc64 )
  74. mv $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf_`uname -i`.h
  75. rm -f unixodbc_conf.h
  76. sed s/CONFFILE/unixodbc_conf/ %{SOURCE4} >unixodbc_conf.h
  77. install -m 644 unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}
  78. ;;
  79. *)
  80. ;;
  81. esac
  82. # add some explanatory documentation
  83. cp %{SOURCE5} README.dist
  84. # remove obsolete Postgres drivers from the package (but not the setup code)
  85. rm -f $RPM_BUILD_ROOT%{_libdir}/libodbcpsql.so*
  86. # copy text driver documentation into main doc directory
  87. # currently disabled because upstream no longer includes text driver
  88. # mkdir -p doc/Drivers/txt
  89. # cp -pr Drivers/txt/doc/* doc/Drivers/txt
  90. # don't want to install doc Makefiles as docs
  91. find doc -name 'Makefile*' | xargs rm
  92. # we do not want to ship static libraries
  93. rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
  94. # remove unpackaged files from the buildroot
  95. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  96. rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*
  97. rm -rf $RPM_BUILD_ROOT%{_datadir}/libtool
  98. # initialize lists of .so files
  99. find $RPM_BUILD_ROOT%{_libdir} -name "*.so.*" | sed "s|^$RPM_BUILD_ROOT||" > base-so-list
  100. find $RPM_BUILD_ROOT%{_libdir} -name "*.so" | sed "s|^$RPM_BUILD_ROOT||" > devel-so-list
  101. # move these to main package, they're often dlopened...
  102. for lib in libodbc.so libodbcinst.so libodbcpsqlS.so libodbcmyS.so
  103. do
  104. echo "%{_libdir}/$lib" >> base-so-list
  105. grep -v "/$lib$" devel-so-list > devel-so-list.x
  106. mv -f devel-so-list.x devel-so-list
  107. done
  108. %clean
  109. rm -rf $RPM_BUILD_ROOT
  110. %post -p /sbin/ldconfig
  111. %postun -p /sbin/ldconfig
  112. %files -f base-so-list
  113. %doc README COPYING AUTHORS ChangeLog NEWS doc
  114. %doc README.dist
  115. %config(noreplace) %{_sysconfdir}/odbc*
  116. %{_bindir}/odbcinst
  117. %{_bindir}/isql
  118. %{_bindir}/dltest
  119. %{_bindir}/iusql
  120. %{_bindir}/odbc_config
  121. %{_bindir}/slencheck
  122. %{_mandir}/man*/*
  123. %files devel -f devel-so-list
  124. %{_includedir}/*
  125. %changelog
  126. * Tue Jan 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.4-1
  127. - new upstream release.
  128. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.3.2-2
  129. - rebuilt with readline 6.3
  130. - removed kde-subpackage-related BuildRequires
  131. - added Japanese summary
  132. * Tue Jul 8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.2-1
  133. - new upstream release.
  134. - gui was discontinued in upstream.
  135. * Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-3
  136. - rebuild with VineSeed environment
  137. * Tue Apr 12 2011 IWAI, Masaharu <iwai@alib.jp> 2.2.14-2
  138. - add --with-qt-includes option for configure
  139. * Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.14-1
  140. - updated to 2.2.14
  141. * Sat Sep 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-1
  142. - applied new versioning policy
  143. - removed *.la files from devel package
  144. * Sun Sep 02 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-0vl1
  145. - updated to 2.2.12
  146. - rebuilt with new toolchain
  147. * Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-0vl3
  148. - use installed libltdl
  149. - added unixODBC-2.2.11-symbols.patch and nortldglobal.patch
  150. * Sat Apr 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl2
  151. - rebuilt with readline 5.1
  152. * Wed Aug 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl1
  153. - updated to 2.2.11
  154. - not libtoolize
  155. * Sat Sep 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.5-0vl2
  156. - added Patch100 to fix typo in doc/Makefile.am from failure on compiling
  157. * Fri Jun 6 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.5-0vl1
  158. - source upgrade
  159. - remove patch (no need)
  160. - run libtoolize etc for VineSeed
  161. * Wed Feb 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.4-0vl2
  162. - enable -kde subpackage on alpha, but still disable for Vine2.5/2.6
  163. * Sun Feb 9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.4-0vl1
  164. - source upgrade
  165. - change spec to build both VineSeed and Vine2.5/2.6
  166. - add patch from rawhide 2.2.3-6
  167. * Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl2
  168. - Requires: libjpeg (not libjpeg-6b)
  169. * Sun Oct 6 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl1
  170. - source upgrade
  171. - add BuildPrereq: autoconf253 automake15
  172. - add PreReq: ldconfig
  173. - fix %files section and clean up spec
  174. - for unixODBC-kde package
  175. - add Requires: unixODBC = %{version}
  176. - add Requires: XFree86-libs qt freetype2 libjpeg-6b libmng libpng zlib
  177. - delete .desktop files
  178. * Thu Apr 4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.0-0vl2
  179. - rebuild with KDE3
  180. * Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2.0-0vl1
  181. - updated unixODBC-2.2.0
  182. - fixed LinuxODBC.xpm and smallLinuxODBC.xpm dir
  183. * Wed Jan 30 2002 Tomoya TAKA <taka@vinelinux.org> 2.0.7-3vl2
  184. - remove -kde package on alpha
  185. * Fri Jan 4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.7-3vl1
  186. - Rebuild for Vine.
  187. * Sun Jun 24 2001 Than Ngo <than@redhat.com>
  188. - rebuild against qt-2.3.1, kde-2.1.x
  189. * Fri Jun 15 2001 Trond Eivind Glomsrød <teg@redhat.com>
  190. - Better default odbcinst.ini
  191. - Minor cleanups
  192. * Wed Jun 6 2001 Trond Eivind Glomsrød <teg@redhat.com>
  193. - 2.0.7
  194. * Wed Apr 25 2001 Trond Eivind Glomsrød <teg@redhat.com>
  195. - Fix for isql segfault on EOF/ctrl-d exit
  196. * Fri Apr 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
  197. - 2.0.6
  198. - add patch for 64 bit archs (dword shouldn't be "long int")
  199. * Wed Feb 28 2001 Trond Eivind Glomsrød <teg@redhat.com>
  200. - rebuild
  201. * Tue Nov 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
  202. - 1.8.13
  203. * Tue Oct 10 2000 Trond Eivind Glomsrød <teg@redhat.com>
  204. - enable GUI now that we have KDE compiled with the standard
  205. compiler
  206. - move the applnk entries to the KDE package
  207. * Thu Aug 24 2000 Nalin Dahyabhai <nalin@redhat.com>
  208. - add the missing shared libs to the non-devel package
  209. * Wed Aug 23 2000 Preston Brown <pbrown@redhat.com>
  210. - 1.8.12 fixes problems with the postgresql driver
  211. * Mon Jul 31 2000 Trond Eivind Glomsrød <teg@redhat.com>
  212. - disable KDE subpackage to avoid the mess that is C++ binary
  213. compatibility
  214. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  215. - automatic rebuild
  216. * Fri Jun 30 2000 Florian La Roche <laroche@redhat.com>
  217. - improved QTDIR detection
  218. * Wed Jun 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
  219. - 1.8.10
  220. - use %%{_tmppath}
  221. - update URL
  222. - including two missing libraries
  223. * Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
  224. - 1.8.9
  225. * Fri Jun 09 2000 Preston Brown <pbrown@redhat.com>
  226. - adopted for Winston, changed to Red Hat packaging standards
  227. * Tue Apr 18 2000 Murray Todd Williams <murray@codingapes.com>
  228. - added a unixODBC-devel RPM to the group, added KDE links and icons to system
  229. - all of which came from recommendations from Fredrick Meunier
  230. - <Fredrick.Meunier@computershare.com.au>
  231. * Mon Apr 17 2000 Murray Todd Williams <murray@codingapes.com>
  232. - unixODBC-1.8.7
  233. - moved install to $RPM_BUILD_ROOT so it didn't overrun existing files.