skrooge-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224
  1. Name: skrooge
  2. Summary: Personal finances manager
  3. Summary(ja): 個人向け財務管理ツール
  4. Version: 1.10.0
  5. Release: 2%{?_dist_release}
  6. Group: Applications/Productivity
  7. License: GPLv3+
  8. URL: http://skrooge.org
  9. Source0: http://download.kde.org/stable/skrooge/%{name}-%{version}.tar.bz2
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: akonadi-devel
  12. BuildRequires: grantlee-devel
  13. BuildRequires: kdelibs4-devel
  14. BuildRequires: kdepimlibs-devel
  15. BuildRequires: libofx-devel
  16. BuildRequires: qca2-devel
  17. BuildRequires: qjson-devel
  18. BuildRequires: shared-mime-info >= 0.23
  19. BuildRequires: soprano-devel
  20. BuildRequires: sqlite3-devel
  21. BuildRequires: gettext
  22. BuildRequires: desktop-file-utils
  23. Requires: %{name}-libs = %{version}-%{release}
  24. Requires(post): gtk2
  25. Requires(post): desktop-file-utils
  26. Requires(post): shared-mime-info
  27. Requires(postun): gtk2
  28. Requires(postun): desktop-file-utils
  29. Requires(postun): shared-mime-info
  30. %description
  31. %{name} is a personal finances manager,
  32. aiming at being simple and intuitive.
  33. It allows you to keep track of your expenses and incomes,
  34. categorize them, and build reports of them.
  35. %package libs
  36. Summary: Skrooge libraries
  37. Summary(ja): Skrooge ライブラリ
  38. Group: System Environment/Libraries
  39. Requires: kdelibs4 >= 4.4.0
  40. %description libs
  41. %{name} libraries.
  42. %package devel
  43. Summary: Development files for %{name}
  44. Summary(ja): %{name} の開発用ファイル
  45. Group: Development/Libraries
  46. Requires: %{name}-libs = %{version}-%{release}
  47. %description devel
  48. The %{name}-devel package contains libraries for
  49. developing applications that use %{name}.
  50. %prep
  51. %setup -q
  52. ## to prevent spurious-executable-perm in -debuginfo
  53. chmod -x skgbasegui/skglineedit.h
  54. chmod -x skgbasegui/skglineedit.cpp
  55. chmod -x skgbasegui/skglineeditdesignerplugin.h
  56. chmod -x skgbasegui/skgtablewidgetdesignerplugin.h
  57. chmod -x skgbasegui/skglineeditdesignerplugin.cpp
  58. chmod -x skgbasegui/skgtablewidgetdesignerplugin.cpp
  59. %build
  60. mkdir -p %{_target_platform}
  61. pushd %{_target_platform}
  62. %{cmake} \
  63. -Wno-dev \
  64. -DCMAKE_BUILD_TYPE=release \
  65. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  66. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  67. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  68. -DCMAKE_SHARED_LINKER_FLAGS="-Wl,--as-needed" \
  69. ..
  70. popd
  71. make %{?_smp_mflags} -C %{_target_platform}
  72. %install
  73. rm -rf %{buildroot}
  74. make install/fast -C %{_target_platform} DESTDIR=%{buildroot}
  75. %find_lang %{name}
  76. %clean
  77. rm -rf %{buildroot}
  78. %check
  79. desktop-file-validate %{buildroot}%{_datadir}/applications/kde4/skrooge.desktop
  80. %post
  81. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  82. %postun
  83. if [ $1 -eq 0 ] ; then
  84. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  85. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  86. update-desktop-database -q &> /dev/null
  87. update-mime-database %{_datadir}/mime &> /dev/null
  88. fi
  89. %posttrans
  90. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  91. update-desktop-database -q &> /dev/null
  92. update-mime-database %{_datadir}/mime &> /dev/null
  93. %post libs -p /sbin/ldconfig
  94. %postun libs -p /sbin/ldconfig
  95. %files -f %{name}.lang
  96. %defattr(-,root,root,-)
  97. %doc AUTHORS CHANGELOG COPYING README TODO
  98. %{_bindir}/*
  99. %{_datadir}/akonadi/agents/*.desktop
  100. %{_datadir}/applications/kde4/skrooge.desktop
  101. %{_datadir}/config/skrooge_*.knsrc
  102. %{_datadir}/config.kcfg/*.kcfg
  103. %{_datadir}/icons/hicolor/*/*/*
  104. %{_datadir}/kde4/apps/skrooge*/
  105. %{_datadir}/kde4/apps/skg*
  106. %{_datadir}/kde4/services/*.desktop
  107. %{_datadir}/kde4/servicetypes/*.desktop
  108. %{_datadir}/mime/packages/x-skg.xml
  109. %{_datadir}/doc/HTML/*/skrooge/
  110. %files libs
  111. %defattr(-,root,root,-)
  112. %{_libdir}/kde4/plugins/grantlee/*/*.so
  113. %{_libdir}/kde4/*.so
  114. %{_libdir}/lib*.so.*
  115. %files devel
  116. %defattr(-,root,root,-)
  117. %{_libdir}/lib*.so
  118. #{_libdir}/kde4/plugins/designer/libskg*.so
  119. %changelog
  120. * Mon Mar 9 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.10.0-2
  121. - rebuilt with libofx 0.9.10
  122. * Wed Dec 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.10.0-1
  123. - updated to 1.10.0
  124. - updated BuildRequires
  125. - built on current VineSeed
  126. * Sun May 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-2
  127. - add BuildRequires: soprano-devel
  128. * Sun Jan 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.0-1
  129. - Initial build for Vine Linux
  130. * Mon May 17 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.7.1-1
  131. - skrooge 0.7.1 bugfix release
  132. * Mon Apr 26 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.7.0-1
  133. - Skrooge 0.7.0
  134. * Wed Feb 10 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.6.0-1
  135. - New upstream source 0.6.0
  136. * Thu Jan 28 2010 Rex Dieter <rdieter@fedoraproject.org> 0.5.5-2
  137. - use %%{_kde4_version}, don't rely on kde4-config --version parsing
  138. * Sun Dec 27 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.5-1
  139. - Update to new upstream release
  140. - Corrects a lot of bugs and problems. See the CHANGELOG for details.
  141. * Sun Nov 30 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.4-1
  142. - Update to new upstream version
  143. - Corrects a lot of bugs and problems. See the changelog for details.
  144. * Sun Nov 01 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.3-1
  145. - Updated to new upstream version
  146. - Readded a -DCMAKE workaround (please keep it for now)
  147. - Useing chmod -x to prevent spurious-executable-perm. Bug filed.
  148. * Wed Oct 14 2009 Rex Dieter <rdieter@fedoraproject.org> 0.5.2-2
  149. - (HTML) docs patch, use %%find_lang --with-kde
  150. - own %%{_kde4_appsdir}/skrooge*/ dirs
  151. - %%check: omit extraneous desktop-file-validate's
  152. * Thu Oct 08 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.2-1
  153. - Changed to final 0.5.2 version
  154. - Bugfixes, including a nasty bug where one thinks the data is gone
  155. - added HTML documentation
  156. - added localizations
  157. * Tue Sep 22 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.2-0.1.beta
  158. - Changed to new upstream Version 0.5.2_beta (lots of bugfixes)
  159. * Mon Sep 21 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.1-0.5.beta
  160. - Added -libs Requires libofx
  161. * Mon Sep 21 2009 Rex Dieter <rdieter@fedoraproject.org> 0.5.1-0.4.beta
  162. - misc cosmetics
  163. - mime scriptlets
  164. - move icons to hicolor
  165. - -libs: drop dup'd docs, add min kdelibs4 dep
  166. * Thu Sep 17 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.1-0.3.beta
  167. - Spec file corrections and Version correction
  168. * Wed Sep 16 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.1-beta2
  169. - cleaned up desktop files
  170. * Tue Sep 15 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.1-beta1
  171. - changed version to 0.5.1 beta with fixed rpmlint output
  172. * Sun Sep 13 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.0-2
  173. - Fixed the spec and rpmlintoutput debuginfo-without-source
  174. * Fri Sep 11 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.0-1
  175. - Initial Release 0.5.0