setuptool-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147
  1. Summary: A text mode system configuration tool
  2. Summary(ja): テキストモードのシステム設定ツール
  3. # the name is "setuptool" because we already have a package
  4. # named "setup". Oh, well.
  5. Name: setuptool
  6. Version: 1.19.4
  7. Release: 2%{?_dist_release}
  8. License: GPL
  9. Group: Applications/System
  10. Source: %{name}-%{version}.tar.gz
  11. Source10: %{name}-1.19.4-ja.po
  12. Buildroot: %{_tmppath}/%{name}-%{version}-root
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. Packager: daisuke
  16. Requires: usermode
  17. BuildRequires: newt-devel, desktop-file-utils
  18. %description
  19. Setuptool is a user-friendly text mode menu utility which allows you
  20. to access all of the text mode configuration programs included in the
  21. Vine Linux operating system.
  22. %description -l ja
  23. setuptool は Vine Linux オペレーティングシステムに含まれる全ての
  24. テキストモード設定プログラムにアクセスするためのユーザフレンドリーな
  25. テキストモードのメニューユーティリティーです。
  26. %prep
  27. if [ -e %{buildroot} ] ; then
  28. [ "%{buildroot}" != "/" ] && %{__rm} -r %{buildroot}
  29. fi
  30. %setup -q
  31. cp -f %{SOURCE10} po/ja.po
  32. %build
  33. %configure
  34. %{__make}
  35. %{__make} setuptool.desktop
  36. %install
  37. %{__rm} -rf $RPM_BUILD_ROOT
  38. %{__make} install DESTDIR=$RPM_BUILD_ROOT
  39. desktop-file-install --dir $RPM_BUILD_ROOT%{_datadir}/applications setuptool.desktop
  40. %find_lang setup
  41. %post
  42. if [ -x %{_bindir}/update-desktop-database ] ; then
  43. %{_bindir}/update-desktop-database %{_datadir}/applications
  44. fi
  45. %postun
  46. if [ -x %{_bindir}/update-desktop-database ] ; then
  47. %{_bindir}/update-desktop-database %{_datadir}/applications
  48. fi
  49. %clean
  50. %{__rm} -rf %{buildroot}
  51. %files -f setup.lang
  52. %defattr(-,root,root)
  53. %doc README
  54. %{_sysconfdir}/pam.d/setup
  55. %{_sysconfdir}/security/console.apps/setup
  56. %dir %{_sysconfdir}/setuptool.d
  57. %{_sysconfdir}/setuptool.d/*
  58. %{_bindir}/*
  59. %{_sbindir}/*
  60. %{_datadir}/applications/*
  61. %changelog
  62. * Thu Apr 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.19.4-2
  63. - rebuild for Vine 6
  64. * Wed Aug 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.19.4-1
  65. - new upstream release
  66. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.2-6vl5
  67. - applied new versioning policy, spec in utf-8
  68. * Wed Feb 20 2008 Takuya Kobayashi <ruby11@cocoa.ocn.ne.jp> 1.2-5vl9
  69. - rebuild for Vine Seed
  70. * Wed Feb 20 2008 Takuya Kobayashi <ruby11@cocoa.ocn.ne.jp> 1.2-5vl8
  71. - update desktop entry file <BTS:VineLinux:509>
  72. - merge Source10,Source11 into new Source10
  73. - add %{_sbindir}/setup-with-su for xfce
  74. - update Source1(setuptool-ja.po) for %{_sbindir}/setup-with-su
  75. - update Spec File
  76. - update %%description
  77. - add %%check, %%post, and %%postun for desktop entry file
  78. - update %%prep and %%install for deleting unnecessary files
  79. - add Requires: newt
  80. - add BuildRequires: newt-devel desktop-file-utils
  81. - use macros
  82. * Sun Sep 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-5vl7
  83. - use alsaconf instead of sndconfig
  84. - add lokkit
  85. * Sun Aug 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2-5vl6
  86. - use License instead of Copyright
  87. * Sun Jul 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-5vl5
  88. - add Japanese translation for desktopfile. (SOURCE11)
  89. - add setuptool icon. (SOURCE10)
  90. * Sun Jul 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org>
  91. - 1.2-5vl4
  92. - added Patch12
  93. - Xconfigurator -> Xautoconfig4 for ppc
  94. - disable sndconfig for ppc
  95. * Thu Jun 28 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
  96. - 1.2-5vl3
  97. - change checkbox color
  98. - use better macros
  99. * Wed Feb 09 2000 Preston Brown <pbrown@redhat.com>
  100. - wmconfig -> desktop
  101. * Thu Feb 3 2000 Nalin Dahyabhai <nalin@redhat.com>
  102. - rebuilt in new environment
  103. * Mon Aug 2 1999 Matt Wilson <msw@redhat.com>
  104. - rebuilt against newt 0.50
  105. * Mon Apr 5 1999 Bill Nottingham <notting@redhat.com>
  106. - strip binary
  107. * Fri Mar 26 1999 Bill Nottingham <notting@redhat.com>
  108. - port to C, so we can get python out of base component
  109. * Tue Mar 16 1999 Bill Nottingham <notting@redhat.com>
  110. - add support for authconfig, remove cabaret
  111. * Wed Nov 05 1997 Michael K. Johnson <johnsonm@redhat.com>
  112. - initial version