rply-vl.spec 2.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110
  1. Name: rply
  2. Version: 1.1.3
  3. Release: 1%{?_dist_release}
  4. Summary: A library to read and write PLY files
  5. Group: Development/Libraries
  6. License: MIT
  7. URL: http://www.tecgraf.puc-rio.br/~diego/professional/%{name}/
  8. Source0: http://www.tecgraf.puc-rio.br/~diego/professional/%{name}/%{name}-%{version}.tar.gz
  9. Source1: rply_CMakeLists.txt
  10. Source2: RPLYConfig.cmake.in
  11. Source3: rply_cmake_export_cmakelists.txt
  12. Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  13. BuildRequires: cmake >= 2.6.0
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. %description
  17. RPly is a library that lets applications read and write PLY files.
  18. The PLY file format is widely used to store geometric information, such as 3D
  19. models, but is general enough to be useful for other purposes.
  20. RPly is easy to use, well documented, small, free, open-source, ANSI C,
  21. efficient, and well tested. The highlights are:
  22. * A callback mechanism that makes PLY file input straightforward;
  23. * Support for the full range of numeric formats;
  24. * Binary (big and little endian) and text modes are fully supported;
  25. * Input and output are buffered for efficiency;
  26. * Available under the MIT license for added freedom.
  27. %package devel
  28. Summary: Libraries and headers for rply
  29. Group: Development/Libraries
  30. Requires: %{name} = %{version}-%{release}
  31. %description devel
  32. Rply Library Header Files and Link Libraries
  33. %prep
  34. %setup -q
  35. # Add CMakeLists.txt file
  36. cp %{SOURCE1} CMakeLists.txt
  37. # Add CMake detection modules
  38. mkdir -p CMake/export
  39. mkdir -p CMake/Modules
  40. cp %{SOURCE2} CMake/Modules/
  41. cp %{SOURCE3} CMake/export/CMakeLists.txt
  42. %build
  43. %cmake -DCMAKE_BUILD_TYPE:STRING="Release"\
  44. -DCMAKE_VERBOSE_MAKEFILE=ON .
  45. make %{?_smp_mflags}
  46. %install
  47. rm -rf $RPM_BUILD_ROOT
  48. make install DESTDIR=$RPM_BUILD_ROOT
  49. %clean
  50. rm -rf $RPM_BUILD_ROOT
  51. %post -p /sbin/ldconfig
  52. %postun -p /sbin/ldconfig
  53. %files
  54. %defattr(-,root,root,-)
  55. %doc LICENSE
  56. %doc manual/*
  57. %{_libdir}/*.so.*
  58. %{_bindir}/*
  59. %files devel
  60. %defattr(-,root,root)
  61. %dir %{_includedir}/%{name}/
  62. %{_includedir}/%{name}/*
  63. %{_libdir}/*.so
  64. %dir %{_datadir}/%{name}/
  65. %{_datadir}/%{name}/rplyConfig.cmake
  66. %changelog
  67. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.3-1
  68. - new upstream release
  69. * Sat Apr 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.1-1
  70. - new upstream release
  71. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.01-1
  72. - initial build for Vine Linux
  73. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
  74. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  75. * Sun Mar 21 2010 Mario Ceresa mrceresa@gmail.com
  76. - Added CMake modules to detect the package
  77. * Thu Mar 04 2010 Mario Ceresa mrceresa@gmail.com
  78. - Fixed problems detected in https://bugzilla.redhat.com/show_bug.cgi?id=570258#c2
  79. * Wed Mar 03 2010 Mario Ceresa mrceresa@gmail.com
  80. - Initial RPM Release