rep-gtk-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168
  1. Name: rep-gtk
  2. Version: 0.18
  3. Release: 1%{?_dist_release}
  4. Summary: GTK+ binding for librep Lisp environment
  5. Summary(ja): librep Lisp 環境用 GTK+ バインディング
  6. Requires: librep >= 0.13, gtk+ >= 1.2
  7. License: GPL
  8. Group: Development/Languages
  9. URL: http://rep-gtk.sourceforge.net/
  10. Source: http://download.sourceforge.net/rep-gtk/rep-gtk-%{version}.tar.gz
  11. Patch0: rep-gtk-0.18-compat.patch
  12. Buildroot: %{_tmppath}/%{name}-%{version}-root
  13. BuildPrereq: librep-devel libglade-devel gnome-libs-devel gdk-pixbuf-devel
  14. BuildRequires: db4-devel alsa-lib-devel
  15. %description
  16. This is a binding of GTK+ for the librep Lisp interpreter. It is based
  17. on Marius Vollmer's guile-gtk package (initially version 0.15, updated
  18. to 0.17), with a new glue-code generator.
  19. %description -l ja
  20. rep-gtk は librep Lisp インタプリタ向け GTK+ バインディングです.
  21. Marius Vollmer さんの guile-gtk パッケージ (当初 0.15 で,現在バージョンは
  22. 0.17) をベースとして,新しく glue-code ジェネレータを追加しています.
  23. %package libglade
  24. Summary: librep binding for the libglade library for loading user interfaces.
  25. Summary(ja): librep 用 libglade バインディング
  26. Group: Development/Languages
  27. Requires: %{name} = %{version}, libglade
  28. %description libglade
  29. This is a binding of libglade for the librep Lisp interpreter. libglade
  30. allows applications to dynamically load XML descriptions of GTK+ widget
  31. hierarchies. These hierarchies may be created by the GLADE GUI builder.
  32. %description libglade -l ja
  33. rep-gtk-libglade は librep Lisp インタプリタ向け libglade バインディングです.
  34. libglade を使うと,アプリケーションから GTK+ ウィジェット階層を記述した
  35. XML を直接読みこむことが出来ます.その XML ファイルは GLADE GUI ビルダによって
  36. 作成することが出来ます.
  37. %package gnome
  38. Summary: GNOME binding for librep
  39. Summary(ja): librep 用 GNOME バインディング
  40. Group: Development/Languages
  41. Requires: %{name} = %{version}, gnome-libs, libglade
  42. %description gnome
  43. This is a binding of the various GNOME libraries for the librep Lisp
  44. interpreter. It include support for the basic GNOME functions, the
  45. GNOME user interface widgets, the GNOME Canvas architecture, and the
  46. GNOME version of libglade.
  47. %description gnome -l ja
  48. rep-gtk-gnome は librep Lisp インタプリタから様々な GNOME ライブラリに
  49. アクセスする為のバインディングです.基本的な GNOME の機能から,GNOME
  50. ユーザインタフェースウィジェット,GNOME Canvas アーキテクチャ,更には
  51. GNOME 版 libglade 迄様々な種類をサポートしています.
  52. %prep
  53. %setup
  54. %patch0 -p0 -b .compat
  55. %build
  56. LC_ALL=""
  57. LINGUAS=""
  58. LANG=""
  59. export LC_ALL LINGUAS LANG
  60. %configure --with-libglade --with-gnome
  61. make host_type=%{_target_platform}
  62. %install
  63. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  64. make install \
  65. host_type=%{_target_platform} \
  66. installdir=$RPM_BUILD_ROOT%{_libexecdir}/rep/%{_target_platform}
  67. ## remove unuse files
  68. rm -f $RPM_BUILD_ROOT%{_libexecdir}/rep/%{_target_platform}/gui/gtk-2/*.la
  69. %clean
  70. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  71. %files
  72. %defattr(-,root,root)
  73. %doc README README.guile-gtk BUGS ChangeLog gtk.defs gdk.defs
  74. %{_libexecdir}/rep/%{_target_platform}/gui/gtk-2/gtk.so
  75. %{_libexecdir}/rep/%{_target_platform}/gui/gtk-2/types.so
  76. #%{_libexecdir}/rep/%{_target_platform}/gui/gtk
  77. #%{_libexecdir}/rep/%{_target_platform}/gui/gtk.so
  78. #%{_libexecdir}/rep/%{_target_platform}/sgtk-types.so
  79. #%{_libexecdir}/rep/%{_target_platform}/gtk.so
  80. %files libglade
  81. %defattr(-,root,root)
  82. %doc libglade.defs examples/test-libglade examples/simple.glade
  83. %doc examples/rep-ui examples/rep-ui.glade
  84. %{_libexecdir}/rep/%{_target_platform}/gui/gtk-2/libglade.so
  85. #%{_libexecdir}/rep/%{_target_platform}/libglade.so*
  86. %files gnome
  87. %defattr(-,root,root)
  88. %doc gnome*.defs gdk-pixbuf.defs libglade.defs
  89. %doc examples/gnome-test examples/canvas-test
  90. %{_libexecdir}/rep/%{_target_platform}/gui/gtk-2/gnome-canvas.so
  91. %{_libexecdir}/rep/%{_target_platform}/gui/gtk-2/gnome-lib.so
  92. %{_libexecdir}/rep/%{_target_platform}/gui/gtk-2/gnome-ui.so
  93. #%{_libexecdir}/rep/%{_target_platform}/gui/gnome
  94. #%{_libexecdir}/rep/%{_target_platform}/gui/gnome.so
  95. #%{_libexecdir}/rep/%{_target_platform}/gnome*.so
  96. #%{_libexecdir}/rep/%{_target_platform}/libglade-gnome.so
  97. #%{_libexecdir}/rep/%{_target_platform}/gdk-pixbuf.so
  98. %changelog
  99. * Sun Sep 28 2008 Shu KONNO <owa@bg.wakwak.com> 0.18-1vl5
  100. - applied new versioning policy, spec in utf-8
  101. - new upstream release
  102. - added rep-gtk-0.18-compat.patch
  103. - removed *.la
  104. * Thu Nov 29 2007 Shu KONNO <owa@bg.wakwak.com> 0.15-1vl7
  105. - s/Copyright/License/
  106. * Sun Jul 17 2005 KANEKO Seiji <giragge@m2.pbc.ne.jp> 0.15-1vl6
  107. - rebuilt with db4-4.2.52 again (db4-devel)
  108. - add BuildRequires: db4-devel, alsa-lib-devel
  109. - commented Packager
  110. * Sat Nov 6 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.15-1vl5
  111. - rebuilt with db4-4.2.52
  112. * Mon Jan 20 2003 Satoshi MACHINO <machino@vinelinux.org> 0.15-1vl4
  113. - rebuild to remove old librep depandancy, it depended on gmp-2
  114. * Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15-1vl3
  115. - rebuild to remove rpmlib dependancy
  116. * Sun May 20 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  117. - 0.15-1vl2
  118. - rebuilt with librep = 0.13.6
  119. - added Japanese summary and description
  120. * Wed Dec 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  121. - 0.15-1vl1
  122. - rebuilt under rpm-3.0.6-0vl8
  123. * Tue Jun 13 2000 John Harper <john@dcs.warwick.ac.uk>
  124. - use better macros
  125. * Fri Sep 17 1999 John Harper <john@dcs.warwick.ac.uk>
  126. - specify installdir when installing
  127. * Tue Sep 14 1999 Aron Griffis <agriffis@bigfoot.com>
  128. - 0.4 spec file update: added buildroot