qwt-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198
  1. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.8.6)
  2. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
  3. %define _qt4_libdir %(pkg-config --variable libdir --silence-errors Qt 2>/dev/null || echo %{_libdir})
  4. %define _qt4_headerdir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_includedir})
  5. Name: qwt
  6. Summary: Qt Widgets for Technical Applications
  7. Version: 5.2.2
  8. Release: 28%{?_dist_release}
  9. License: LGPLv2 with exceptions
  10. Group: System Environment/Libraries
  11. URL: http://qwt.sourceforge.net/
  12. Source: http://downloads.sourceforge.net/qwt/qwt-%{version}.tar.bz2
  13. ## upstreamable patches
  14. # use qt_install system paths
  15. Patch50: qwt-5.2.2-qt_install_paths.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: qt4-devel
  18. %description
  19. The Qwt library contains GUI Components and utility classes which are primarily
  20. useful for programs with a technical background.
  21. Besides a 2D plot widget it provides scales, sliders, dials, compasses,
  22. thermometers, wheels and knobs to control or display values, arrays
  23. or ranges of type double.
  24. %package qt4
  25. Summary: Qt Widgets for Technical Applications
  26. Group: System Environment/Libraries
  27. Requires: qt4 >= %{_qt4_version}
  28. %description qt4
  29. The Qwt library contains GUI Components and utility classes which are primarily
  30. useful for programs with a technical background.
  31. Besides a 2D plot widget it provides scales, sliders, dials, compasses,
  32. thermometers, wheels and knobs to control or display values, arrays
  33. or ranges of type double.
  34. %package qt4-devel
  35. Summary: Development files for %{name}
  36. Group: Development/Libraries
  37. Requires: %{name}-qt4 = %{version}-%{release}
  38. %description qt4-devel
  39. %{summary}.
  40. %package doc
  41. Summary: Extra Developer documentation for %{name}
  42. Group: Documentation
  43. BuildArch: noarch
  44. %description doc
  45. %{summary}.
  46. %prep
  47. %setup -q -n qwt-%{version}
  48. %patch50 -p1 -b .qt_install_paths
  49. %build
  50. export QTDIR=%{_qt4_prefix}
  51. $QTDIR/bin/qmake CONFIG+=QwtSVGItem
  52. make %{?_smp_mflags}
  53. %install
  54. rm -rf $RPM_BUILD_ROOT
  55. make install INSTALL_ROOT=%{buildroot}
  56. # fixup docs bogosity
  57. rm -rf _docs_to_include
  58. mkdir -p _docs_to_include
  59. mv %{buildroot}%{_qt4_docdir}/html \
  60. _docs_to_include
  61. %post qt4 -p /sbin/ldconfig
  62. %postun qt4 -p /sbin/ldconfig
  63. %clean
  64. rm -rf $RPM_BUILD_ROOT
  65. %files qt4
  66. %doc CHANGES COPYING README
  67. %{_qt4_libdir}/libqwt.so.5*
  68. %{_qt4_plugindir}/designer/libqwt5_designer_plugin.so
  69. %files qt4-devel
  70. %{_mandir}/man3/*
  71. %{_qt4_headerdir}/qwt5-qt4/
  72. %{_qt4_libdir}/libqwt.so
  73. %{_qt4_libdir}/pkgconfig/qwt.pc
  74. %files doc
  75. # own these to avoid needless dep on qt/qt-doc
  76. %doc _docs_to_include/html/*
  77. %changelog
  78. * Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 5.2.2-28
  79. - rebuild with gcc-5.4.0
  80. * Sun Nov 9 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 5.2.2-27
  81. - Initial build for Vine Linux
  82. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.2-26
  83. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  84. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.2-25
  85. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  86. * Tue Oct 29 2013 Rex Dieter <rdieter@fedoraproject.org> - 5.2.2-24
  87. - cleanup
  88. - rework to avoid CONFIG+=install-qt
  89. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.2-23
  90. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  91. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.2-22
  92. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  93. * Tue Aug 14 2012 Rex Dieter <rdieter@fedoraproject.org> 5.2.2-21
  94. - don't change soname, just libqwt.so symlink
  95. * Fri Aug 03 2012 Rex Dieter <rdieter@fedoraproject.org> 5.2.2-20
  96. - pkgconfig support
  97. - bump release to -20
  98. * Tue Jul 31 2012 Rex Dieter <rdieter@fedoraproject.org> 5.2.2-5
  99. - make parallel-installable with qwt6
  100. * Tue Jul 31 2012 Rex Dieter <rdieter@fedoraproject.org> 5.2.2-4
  101. - Provides: qwt5-qt4(-devel)
  102. - pkgconfig-style deps
  103. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.2-3
  104. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  105. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.2-2
  106. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  107. * Sun Aug 07 2011 Rex Dieter <rdieter@fedoraproject.org> 5.2.2-1
  108. - 5.2.2
  109. * Thu Jul 14 2011 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-3
  110. - .spec cosmetics
  111. - use %%_qt4_ macros
  112. - -doc subpkg here (instead of separately built)
  113. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.1-2
  114. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  115. * Fri Apr 16 2010 Frank Büttner <frank-buettner@gmx.net> - 5.2.1-1
  116. - update to 5.2.1
  117. * Fri Feb 05 2010 Frank Büttner <frank-buettner@gmx.net> - 5.2.0-1
  118. - fix wrong lib names
  119. * Fri Feb 05 2010 Frank Büttner <frank-buettner@gmx.net> - 5.2.0-0
  120. - update to 5.2.0
  121. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.1-4
  122. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  123. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.1-3
  124. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  125. * Sun Jan 04 2009 Frank Büttner <frank-buettner@gmx.net> - 5.1.1-2
  126. - modify path patch
  127. * Sun Jan 04 2009 Frank Büttner <frank-buettner@gmx.net> - 5.1.1-1
  128. -update to 5.1.1
  129. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 5.0.2-6
  130. - Autorebuild for GCC 4.3
  131. * Sat Sep 29 2007 Frank Büttner <frank-buettner@gmx.net> - 5.0.2-5
  132. - add EPEL support
  133. * Sat Sep 29 2007 Frank Büttner <frank-buettner@gmx.net> - 5.0.2-4
  134. - remove parallel build, because it will fail sometimes
  135. * Fri Sep 28 2007 Frank Büttner <frank-buettner@gmx.net> - 5.0.2-3
  136. - fix some errors in the spec file
  137. * Fri Jul 06 2007 Frank Büttner <frank-buettner@gmx.net> - 5.0.2-2
  138. - fix some errors in the spec file
  139. * Mon Jun 11 2007 Frank Büttner <frank-buettner@gmx.net> - 5.0.2-1
  140. - update to 5.0.2
  141. - split doc
  142. * Thu May 15 2007 Frank Büttner <frank-buettner@gmx.net> - 5.0.1-1
  143. - start