qtsingleapplication-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206
  1. # Upstream uses weird versioning convention
  2. %global upstreamver 2.6_1-opensource
  3. Summary: Qt library to start applications only once per user
  4. Name: qtsingleapplication
  5. Version: 2.6.1
  6. Release: 10%{?_dist_release}
  7. Group: System Environment/Libraries
  8. License: GPLv3 or LGPLv2 with exceptions
  9. URL: http://qt.nokia.com/products/appdev/add-on-products/catalog/4/Utilities/qtsingleapplication
  10. Source0: http://get.qt.nokia.com/qt/solutions/lgpl/qtsingleapplication-%{upstreamver}.tar.gz
  11. # The following source and 2 patches are sent upstream:
  12. # http://bugreports.qt.nokia.com/browse/QTSOLBUG-119
  13. # To add qmake support for convenience for packages using this library:
  14. Source1: qtsingleapplication.prf
  15. Source2: qtsinglecoreapplication.prf
  16. # Don't build examples, Include qtsinglecoreapplication library in the build:
  17. Patch0: qtsingleapplication-build.diff
  18. # The library includes a duplicate of qtlockedfile. We link to it dynamically instead:
  19. Patch1: qtsingleapplication-dont-bundle-external-libs.patch
  20. # Additional API for building clementine
  21. # http://bugreports.qt.nokia.com/browse/QTSOLBUG-133
  22. Patch2: qtsingleapplication-add-api.patch
  23. # gcc-4.7 compilation fix
  24. Patch3: qtsingleapplication-gcc47.patch
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  26. BuildRequires: qt4-devel
  27. BuildRequires: qtlockedfile-devel
  28. Vendor: Project Vine
  29. Distribution: Vine Linux
  30. Packager: shaolin
  31. %{?_qt4_version:Requires: qt4%{?_isa} >= %{_qt4_version}}
  32. %description
  33. For some applications it is useful or even critical that they are started
  34. only once by any user. Future attempts to start the application should
  35. activate any already running instance, and possibly perform requested
  36. actions, e.g. loading a file, in that instance.
  37. The QtSingleApplication class provides an interface to detect a running
  38. instance, and to send command strings to that instance.
  39. %package devel
  40. Summary: Development files for %{name}
  41. Group: Development/Libraries
  42. Requires: %{name} = %{version}-%{release}
  43. Requires: qt4-devel
  44. %description devel
  45. This package contains libraries and header files for developing applications
  46. that use QtSingleApplication.
  47. %package -n qtsinglecoreapplication
  48. Summary: Qt library to start applications only once per user
  49. Group: System Environment/Libraries
  50. Obsoletes: %{name} < 2.6.1-3
  51. %description -n qtsinglecoreapplication
  52. For some applications it is useful or even critical that they are started
  53. only once by any user. Future attempts to start the application should
  54. activate any already running instance, and possibly perform requested
  55. actions, e.g. loading a file, in that instance.
  56. For console (non-GUI) applications, the QtSingleCoreApplication variant
  57. is provided, which avoids dependency on QtGui.
  58. %package -n qtsinglecoreapplication-devel
  59. Summary: Development files for qtsinglecoreapplication
  60. Group: Development/Libraries
  61. Obsoletes: %{name}-devel < 2.6.1-3
  62. Requires: qtsinglecoreapplication = %{version}-%{release}
  63. Requires: qt4-devel
  64. %description -n qtsinglecoreapplication-devel
  65. This package contains libraries and header files for developing applications
  66. that use QtSingleCoreApplication.
  67. %prep
  68. %setup -q -n %{name}-%{upstreamver}
  69. %patch0 -p1
  70. %patch1 -p1
  71. %patch2 -p1
  72. %patch3 -p1
  73. # We already disabled bundling this extrenal library.
  74. # But just to make sure:
  75. rm src/{QtLocked,qtlocked}*
  76. %build
  77. touch .licenseAccepted
  78. # Does not use GNU configure
  79. ./configure -library
  80. %{_qt4_qmake}
  81. make %{?_smp_mflags}
  82. %install
  83. rm -rf $RPM_BUILD_ROOT
  84. # libraries
  85. mkdir -p $RPM_BUILD_ROOT%{_qt4_libdir}
  86. cp -a lib/* $RPM_BUILD_ROOT%{_qt4_libdir}
  87. chmod 755 $RPM_BUILD_ROOT%{_qt4_libdir}/*.so.*.*.*
  88. # headers
  89. mkdir -p $RPM_BUILD_ROOT%{_qt4_headerdir}/QtSolutions
  90. cp -a \
  91. src/qtsingleapplication.h \
  92. src/QtSingleApplication \
  93. src/qtsinglecoreapplication.h \
  94. src/QtSingleCoreApplication \
  95. $RPM_BUILD_ROOT%{_qt4_headerdir}/QtSolutions
  96. mkdir -p $RPM_BUILD_ROOT%{_qt4_datadir}/mkspecs/features
  97. cp -a %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{_qt4_datadir}/mkspecs/features/
  98. %clean
  99. rm -rf $RPM_BUILD_ROOT
  100. %post -p /sbin/ldconfig
  101. %postun -p /sbin/ldconfig
  102. %post -n qtsinglecoreapplication -p /sbin/ldconfig
  103. %postun -n qtsinglecoreapplication -p /sbin/ldconfig
  104. %files
  105. %defattr(-,root,root,-)
  106. %doc LGPL_EXCEPTION.txt LICENSE.* README.TXT
  107. %{_qt4_libdir}/lib*SingleApplication*.so.*
  108. %files devel
  109. %defattr(-,root,root,-)
  110. %doc doc examples
  111. %{_qt4_libdir}/lib*SingleApplication*.so
  112. %dir %{_qt4_headerdir}/QtSolutions/
  113. %{_qt4_headerdir}/QtSolutions/QtSingleApplication
  114. %{_qt4_headerdir}/QtSolutions/%{name}.h
  115. %{_qt4_datadir}/mkspecs/features/%{name}.prf
  116. %files -n qtsinglecoreapplication
  117. %defattr(-,root,root,-)
  118. %doc LGPL_EXCEPTION.txt LICENSE.*
  119. %{_qt4_libdir}/lib*SingleCoreApplication*.so.*
  120. %files -n qtsinglecoreapplication-devel
  121. %defattr(-,root,root,-)
  122. %{_qt4_libdir}/lib*SingleCoreApplication*.so
  123. %dir %{_qt4_headerdir}/QtSolutions/
  124. %{_qt4_headerdir}/QtSolutions/QtSingleCoreApplication
  125. %{_qt4_headerdir}/QtSolutions/qtsinglecoreapplication.h
  126. %{_qt4_datadir}/mkspecs/features/qtsinglecoreapplication.prf
  127. %changelog
  128. * Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.6.1-10
  129. - rebuild with gcc-5.4.0
  130. * Thu Jan 9 2014 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.1-9
  131. - initial build for Vine Linux
  132. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.1-9
  133. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  134. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.1-8
  135. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  136. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.1-7
  137. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  138. * Wed Jan 11 2012 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> 2.6.1-6
  139. - gcc-4.7 compilation fix
  140. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.1-5
  141. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  142. * Wed Aug 11 2010 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> 2.6.1-4
  143. - Make the additional API patch backwards compatible
  144. * Wed Jul 21 2010 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> 2.6.1-3
  145. - Split the qtsinglecoreapplication bits into their own subpackages
  146. * Fri Jul 16 2010 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> 2.6.1-2
  147. - Add additional API to support clementine.
  148. * Sun Jun 06 2010 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> 2.6.1-1
  149. - Change version to 2.6.1. Upstream uses weird version convention 2.6_1
  150. - Own the directory %%{_qt4_headerdir}/QtSolutions/
  151. * Sat May 01 2010 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> 2.6-3
  152. - Add comments to the extra source and patches
  153. - Add a chmod 755 to make sure that the library gets the right permission
  154. * Thu Apr 15 2010 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> 2.6-2
  155. - Include .prf file
  156. - Don't bundle external qtlockedfile library
  157. - Fix typo in the description
  158. * Sun Apr 11 2010 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> 2.6-1
  159. - Initial Fedora package. Specfile partly borrowed from opensuse
  160. * Thu Dec 3 2009 Todor Prokopov <koprok@nand.bg>
  161. - Initial package.