qtscriptgenerator-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183
  1. %define qt4_ver 4.8.6
  2. # Qt4 version auto-detection
  3. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  4. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
  5. %define _qt4_bindir %(pkg-config --variable bindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/bin)
  6. %define _qt4_headerdir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_includedir})
  7. %define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
  8. %define _qt4_qmake %(pkg-config --variable qmake --silence-errors Qt 2>/dev/null || echo %{_qt4_bindir}/qmake)
  9. Name: qtscriptgenerator
  10. Summary: A tool to generate Qt bindings for Qt Script
  11. Summary(ja): Qt Script の Qt バインディングを生成するツール
  12. Version: 0.2.0
  13. Release: 2%{?_dist_release}
  14. Group: Development/Tools
  15. License: GPLv2
  16. URL: http://code.google.com/p/qtscriptgenerator/
  17. Source0: http://qtscriptgenerator.googlecode.com/files/qtscriptgenerator-src-%{version}.tar.gz
  18. Patch1: qtscriptgenerator-0.1.0-gcc44.patch
  19. Patch2: qtscriptgenerator-src-0.1.0-no_phonon.patch
  20. ## upstreamable patches
  21. Patch50: qtscriptgenerator-src-0.1.0-qmake_target.path.patch
  22. # needs work
  23. Patch51: qtscriptgenerator-kde_phonon443.patch
  24. ## debian patches
  25. Patch60: memory_alignment_fix.diff
  26. ## upstream patches
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  28. # explictly BR libxslt, for xsltproc
  29. BuildRequires: libxslt
  30. #BuildRequires: phonon-devel >= 4.4.2-2%{?_dist_release}
  31. BuildRequires: qt4-devel >= 4.5.0-7
  32. #BuildRequires: qt4-webkit-devel
  33. # not strictly required, but the expectation would be for the
  34. # bindings to be present
  35. Requires: qtscriptbindings = %{version}-%{release}
  36. %description
  37. Qt Script Generator is a tool to generate Qt bindings for Qt Script.
  38. %package -n qtscriptbindings
  39. Summary: Qt bindings for Qt Script
  40. Summary(ja): Qt Script の Qt バインディング
  41. Group: System Environment/Libraries
  42. Requires: qt4 >= %{_qt4_version}
  43. Provides: qtscript-qt = %{version}-%{release}
  44. %description -n qtscriptbindings
  45. Bindings providing access to substantial portions of the Qt API
  46. from within Qt Script.
  47. %prep
  48. %setup -q -n %{name}-src-%{version}
  49. %patch1 -p0 -b .gcc44
  50. %patch2 -p1 -b .no_phonon
  51. %patch50 -p1 -b .qmake_target.path
  52. %patch51 -p1 -b .kde_phonon
  53. %patch60 -p1 -b .memory_alignment
  54. %build
  55. # workaround buildsys bogosity, see also:
  56. # http://code.google.com/p/qtscriptgenerator/issues/detail?id=38
  57. export INCLUDE=%{_qt4_headerdir}
  58. pushd generator
  59. %{_qt4_qmake}
  60. make %{?_smp_mflags}
  61. ./generator
  62. popd
  63. pushd qtbindings
  64. %{_qt4_qmake}
  65. make %{?_smp_mflags}
  66. popd
  67. pushd tools/qsexec/src
  68. %{_qt4_qmake}
  69. make %{?_smp_mflags}
  70. popd
  71. %install
  72. rm -rf %{buildroot}
  73. mkdir -p %{buildroot}%{_qt4_plugindir}/script/
  74. # install doesn't do symlinks
  75. cp -a plugins/script/libqtscript* \
  76. %{buildroot}%{_qt4_plugindir}/script/
  77. cp -a tools/qsexec/README.TXT README.qsexec
  78. install -D -p -m755 tools/qsexec/qsexec %{buildroot}%{_bindir}/qsexec
  79. install -D -p -m755 generator/generator %{buildroot}%{_qt4_bindir}/generator
  80. %clean
  81. rm -rf %{buildroot}
  82. %files
  83. %defattr(-,root,root,-)
  84. %{_qt4_bindir}/generator
  85. %files -n qtscriptbindings
  86. %defattr(-,root,root,-)
  87. %doc LICENSE.LGPL LGPL_EXCEPTION.txt
  88. %doc README README.qsexec
  89. %doc doc/
  90. %doc examples/
  91. %{_bindir}/qsexec
  92. %{_qt4_plugindir}/script/libqtscript*
  93. %changelog
  94. * Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.2.0-2
  95. - rebuild with gcc-5.4.0
  96. * Tue Jan 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.2.0-1
  97. - updated to 0.2.0
  98. - removed BR: phonon-devel
  99. - dropt Patch3
  100. * Mon Jan 9 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.1.0-15
  101. - rebuilt with qt-4.8.0
  102. - added Patch3
  103. * Sun Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.1.0-14
  104. - rebuilt with qt-4.7.2
  105. - added Patch1
  106. * Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.1.0-13
  107. - initial build for Vine Linux
  108. * Sat May 08 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.1.0-12
  109. - BR: qt4-webkit-devel
  110. * Mon Mar 01 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.1.0-11
  111. - borrow memory_alignment_fix.diff from debian (should help arm/sparc)
  112. * Wed Nov 18 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.1.0-10
  113. - rebuild (qt-4.6.0-rc1, fc13+)
  114. * Mon Oct 19 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.1.0-9
  115. - fix build (for qt-4.6.0/phonon-isms)
  116. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.0-8
  117. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  118. * Tue Jun 09 2009 Rex Dieter <rdieter@fedoraproject.org> 0.1.0-7
  119. - upstream sun_issue27 patch
  120. * Fri Apr 10 2009 Rex Dieter <rdieter@fedoraproject.org> 0.1.0-6
  121. - qtscriptbindings: Provides: qtscript-qt ...
  122. * Tue Mar 24 2009 Rex Dieter <rdieter@fedoraproject.org> 0.1.0-5
  123. - qtscriptgenerator/qtscriptbindings pkgs
  124. - qtscriptbindings: include docs, examples
  125. * Mon Mar 23 2009 Rex Dieter <rdieter@fedoraproject.org> 0.1.0-4
  126. - include qsexec
  127. * Mon Mar 23 2009 Rex Dieter <rdieter@fedoraproject.org> 0.1.0-3
  128. - BR: phonon-devel
  129. * Fri Mar 20 2009 Rex Dieter <rdieter@fedoraproject.org> 0.1.0-2
  130. - qt-4.5.0-7 fixed wrt phonon, drop no_phonon patch
  131. * Fri Mar 06 2009 Rex Dieter <rdieter@fedoraproject.org> 0.1.0-1
  132. - first try