python-rdflib-vl.spec 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130
  1. # The upstream test suite does not pass on recent versions of Fedora
  2. # See package review (bug 378841)
  3. # For now, we disable running the test suite:
  4. %define run_tests 0
  5. Name: python-rdflib
  6. Summary: Python library for working with RDF
  7. Version: 3.1.0
  8. Release: 4%{?_dist_release}
  9. Group: Development/Languages
  10. License: BSD
  11. URL: http://rdflib.net
  12. Source0: http://rdflib.googlecode.com/files/rdflib-%{version}.tar.gz
  13. BuildArch: noarch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: python-devel
  16. BuildRequires: python-setuptools
  17. %if %{run_tests}
  18. BuildRequires: python-nose >= 0.9.2
  19. %endif
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. %description
  23. RDFLib is a Python library for working with RDF, a simple yet powerful
  24. language for representing information.
  25. The library contains parsers and serializers for RDF/XML, N3, NTriples,
  26. Turtle, TriX and RDFa. The library presents a Graph interface which can
  27. be backed by any one of a number of store implementations, including
  28. memory, MySQL, Redland, SQLite, Sleepycat, ZODB and SQLObject.
  29. %prep
  30. %setup -q -n rdflib-%{version}
  31. %build
  32. %{__python} setup.py build
  33. %install
  34. rm -rf $RPM_BUILD_ROOT
  35. %{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
  36. cp LICENSE $RPM_BUILD_ROOT/%{python_sitelib}/rdflib/LICENSE
  37. # Various .py files within site-packages have a shebang line but aren't
  38. # flagged as executable.
  39. # I've gone through them and either removed the shebang or made them
  40. # executable as appropriate:
  41. # __main__ parses URI as N-Triples:
  42. chmod +x $RPM_BUILD_ROOT/%{python_sitelib}/rdflib/plugins/parsers/ntriples.py
  43. # __main__ parses the file given on the command line:
  44. chmod +x $RPM_BUILD_ROOT/%{python_sitelib}/rdflib/plugins/parsers/notation3.py
  45. %check
  46. %if %{run_tests}
  47. %{__python} run_tests.py
  48. %endif
  49. %clean
  50. rm -rf $RPM_BUILD_ROOT
  51. %files
  52. %defattr(-,root,root,-)
  53. %doc LICENSE
  54. %{python_sitelib}/*
  55. %changelog
  56. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 3.1.0-4
  57. - rebuild with VineSeed environment
  58. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 3.1.0-3
  59. - rebuild with python-2.7.2
  60. * Sun Nov 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.1.0-2
  61. - Initial build for Vine Linux
  62. * Wed Sep 28 2011 David Malcolm <dmalcolm@redhat.com> - 3.1.0-1
  63. - 3.1.0; converting from arch-specific to noarch (sitearch -> sitelib);
  64. removing rdfpipe and various other extensions
  65. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.2-3
  66. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  67. * Thu Jul 22 2010 Thomas Spura <tomspur@fedoraproject.org> - 2.4.2-2
  68. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  69. * Wed Jan 6 2010 David Malcolm <dmalcolm@redhat.com> - 2.4.2-1
  70. - bump to 2.4.2 (#552909)
  71. - fix source URL to use version macro
  72. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-10
  73. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  74. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-9
  75. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  76. * Wed Dec 10 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.4.0-8
  77. - Rebuild for Python 2.6
  78. * Wed Oct 1 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-7
  79. - fix tab/space issue in specfile
  80. * Tue Sep 30 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-6
  81. - override autogeneration of provides info to eliminate unwanted provision
  82. of SPARQLParserc.so
  83. * Mon Sep 29 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-5
  84. - make various scripts executable, or remove shebang, as appropriate
  85. * Tue Feb 19 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-4
  86. - delete test subdir
  87. * Thu Jan 24 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-3
  88. - introduce macro to disable running the test suite, in the hope of eventually
  89. patching it so it passes
  90. * Mon Nov 19 2007 David Malcolm <dmalcolm@redhat.com> - 2.4.0-2
  91. - add python-setuptools(-devel) build requirement; move testing to correct stanza
  92. * Wed Aug 1 2007 David Malcolm <dmalcolm@redhat.com> - 2.4.0-1
  93. - initial version