perl-HTML-Parser-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199
  1. %define name perl-HTML-Parser
  2. %define real_name HTML-Parser
  3. %if %{?_dist_release} == "vl5" || %{?_dist_release} == "vl4"
  4. %define __find_provides /usr/lib/rpm/find-provides.perl
  5. %define __find_requires /usr/lib/rpm/find-requires.perl
  6. %endif
  7. %define rel 3
  8. Summary: A Perl module for parsing HTML.
  9. Summary(ja): HTML を解析するための Perl モジュール
  10. Name: %{name}
  11. Version: 3.68
  12. Release: %{rel}%{?_dist_release}
  13. License: GPL or Artistic
  14. Group: Development/Libraries
  15. Source: ftp://ftp.cpan.org/pub/perl/CPAN/modules/by-module/HTML/%{real_name}-%{version}.tar.gz
  16. Url: http://search.cpan.org/~gaas/HTML-Parser/
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. Requires: perl >= 5.8.6, perl-HTML-Tagset >= 3.03
  19. BuildRequires: perl >= 5.8.6, perl-HTML-Tagset >= 3.03
  20. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. %description
  24. The HTML-Parser module for perl to parse and extract information from
  25. HTML documents, including the HTML::Entities, HTML::HeadParser,
  26. HTML::LinkExtor, HTML::PullParser, and HTML::TokeParser modules.
  27. %prep
  28. %setup -q -n %{real_name}-%{version}
  29. %build
  30. CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS="vendor"
  31. make
  32. %install
  33. rm -rf $RPM_BUILD_ROOT
  34. # make install
  35. make DESTDIR=$RPM_BUILD_ROOT install
  36. [ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
  37. find $RPM_BUILD_ROOT/usr -type f -print |
  38. sed "s@^$RPM_BUILD_ROOT@@g" |
  39. grep -v perllocal.pod |
  40. grep -v "\.packlist" > perl-HTML-Parser-%{version}-filelist
  41. if [ "$(cat perl-HTML-Parser-%{version}-filelist)X" = "X" ] ; then
  42. echo "ERROR: EMPTY FILE LIST"
  43. exit -1
  44. fi
  45. %check
  46. make test
  47. %clean
  48. rm -rf $RPM_BUILD_ROOT
  49. %files -f perl-HTML-Parser-%{version}-filelist
  50. %defattr(-,root,root)
  51. %dir %{perl_vendorarch}/HTML
  52. %dir %{perl_vendorarch}/auto/HTML
  53. %dir %{perl_vendorarch}/auto/HTML/Parser
  54. %changelog
  55. * Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 3.68-3
  56. - build with Perl 5.16
  57. * Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 3.68-2
  58. - add directory in files
  59. * Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 3.68-1
  60. - new upstream release
  61. - add Requires: perl(:MODULE_COMPAT_...)
  62. - defined __find_{provides,requires} with vl4 and vl5 (updated 3.64-2)
  63. - add Vendor and Distribution tags
  64. * Tue Apr 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.64-2
  65. - undefine __find_provides and __find_requires at VineSeed
  66. - added Japanese summary
  67. * Sun Nov 1 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.64-1
  68. - new upstream release with security fix (CVE-2009-3627)
  69. * Fri Apr 25 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 3.56-2vl5
  70. - build on perl-5.10.0-1vl5
  71. * Tue Jul 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.56-0vl1
  72. - new upstream release
  73. - changed Group to Development/Libraries
  74. * Sat Dec 4 2004 IWAI, Masaharu <iwai@alib.jp> 3.41-0vl1
  75. - new upstream release
  76. - build on perl-5.8.6-0vl1
  77. - fix typo changelog: 3.34-0vl1 and 3.34-0vl2
  78. - update Url value
  79. - using perl_sitearch macro
  80. * Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 3.34-0vl2
  81. - built on perl-5.8.2
  82. * Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 3.34-0vl1
  83. - new upstream version
  84. - built on perl-5.8.1
  85. * Wed Apr 16 2003 Satoshi MACHINO <machino@vinelinux.org> 3.27-0vl1
  86. - New upstream version
  87. - build on perl-5.8.0
  88. -- changed Requires, Buildrequires
  89. * Tue Oct 08 2002 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  90. - 3.26-14vl2
  91. - Fix Requires, Buildrequires
  92. * Mon Oct 07 2002 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  93. - 3.26-14vl1
  94. - first build for Vine Linux
  95. - add define __find_provides / __find_requires
  96. - modefy files list (dir)
  97. * Tue Aug 6 2002 Chip Turner <cturner@redhat.com>
  98. - automated release bump and build
  99. * Tue Jun 4 2002 Chip Turner <cturner@redhat.com>
  100. - properly claim directories owned by package so they are removed when package is removed
  101. * Mon Jun 3 2002 Chip Turner <cturner@redhat.com>
  102. - fix for Makefile.PL sometimes prompting for input
  103. * Wed Mar 27 2002 Chip Turner <cturner@redhat.com>
  104. - update to 3.26, move to vendor_perl
  105. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  106. - automated rebuild
  107. * Thu Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 3.25-2
  108. - imported from mandrake. tweaked man path.
  109. * Tue Jul 03 2001 Fran輟is Pons <fpons@mandrakesoft.com> 3.25-1mdk
  110. - 3.25.
  111. * Wed Jun 20 2001 Christian Belisle <cbelisle@mandrakesoft.com> 3.18-3mdk
  112. - Fixed distribution tag.
  113. - Updated Requires.
  114. - Added an option to %makeinstall.
  115. * Sun Jun 17 2001 Geoffrey Lee <snailtalk@mandrakesoft.com> 3.18-2mdk
  116. - Rebuild against the latest perl.
  117. * Tue Feb 27 2001 François Pons <fpons@mandrakesoft.com> 3.18-1mdk
  118. - 3.18.
  119. * Tue Jan 30 2001 François Pons <fpons@mandrakesoft.com> 3.15-1mdk
  120. - 3.15.
  121. * Tue Dec 05 2000 François Pons <fpons@mandrakesoft.com> 3.14-1mdk
  122. - 3.14.
  123. * Thu Oct 12 2000 François Pons <fpons@mandrakesoft.com> 3.13-1mdk
  124. - 3.13.
  125. * Tue Aug 29 2000 François Pons <fpons@mandrakesoft.com> 3.11-1mdk
  126. - 3.11.
  127. * Thu Aug 03 2000 François Pons <fpons@mandrakesoft.com> 3.10-2mdk
  128. - macroszifications.
  129. - add doc.
  130. * Tue Jul 18 2000 François Pons <fpons@mandrakesoft.com> 3.10-1mdk
  131. - removed perllocal.pod from files.
  132. - 3.10.
  133. * Tue Jun 27 2000 Jean-Michel Dault <jmdault@mandrakesoft.com> 3.08-1mdk
  134. - update to 3.08
  135. * Wed May 17 2000 David BAUDENS <baudens@mandrakesoft.com> 3.05-4mdk
  136. - Fix build for i486
  137. - Use %%{_tmppath} for BuildRoot
  138. * Fri Mar 31 2000 Pixel <pixel@mandrakesoft.com> 3.05-3mdk
  139. - rebuild, new group, cleanup
  140. * Tue Feb 29 2000 Jean-Michel Dault <jmdault@netrevolution.com> 3.0.5-1mdk
  141. - upgrade to 3.05
  142. * Mon Jan 3 2000 Jean-Michel Dault <jmdault@netrevolution.com>
  143. - final cleanup for Mandrake 7
  144. * Thu Dec 30 1999 Jean-Michel Dault <jmdault@netrevolution.com>
  145. -updated to 3.02
  146. * Sun Aug 29 1999 Jean-Michel Dault <jmdault@netrevolution.com>
  147. - bzip2'd sources
  148. - updated to 2.23
  149. * Tue May 11 1999 root <root@alien.devel.redhat.com>
  150. - Spec file was autogenerated.