perl-Event-vl.spec 5.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177
  1. Name: perl-Event
  2. Version: 1.24
  3. Release: 1%{?_dist_release}
  4. Summary: Event loop processing
  5. Group: Development/Libraries
  6. License: GPL+ or Artistic
  7. URL: http://search.cpan.org/dist/Event/
  8. Source0: http://search.cpan.org/CPAN/authors/id/J/JP/JPRIT/Event-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildRequires: perl(Carp)
  11. BuildRequires: perl(Config)
  12. BuildRequires: perl(Exporter)
  13. BuildRequires: perl(ExtUtils::MakeMaker)
  14. BuildRequires: perl(Test) >= 1
  15. BuildRequires: perl(Time::HiRes)
  16. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  17. Requires: perl(Time::HiRes)
  18. %if %{_dist_release} > "vl6"
  19. %global __requires_exclude %{?__requires_exclude:__requires_exclude|}perl\\(attrs\\)
  20. %endif
  21. %{?perl_default_filter}
  22. %description
  23. The Event module provide a central facility to watch for various types of
  24. events and invoke a callback when these events occur. The idea is to delay the
  25. handling of events so that they may be dispatched in priority order when it is
  26. safe for callbacks to execute.
  27. %prep
  28. %setup -q -n Event-%{version}
  29. # Fix up permissions and shellbangs
  30. find ./ -type f -exec chmod -c -x {} \;
  31. perl -pi -e 's|#!./perl|#!/usr/bin/perl|' demo/*.t t/*.t util/bench.pl
  32. %{_fixperms} demo/ util/
  33. # Fix character encoding
  34. #patch0 -p1
  35. %if %{_dist_release} <= "vl6"
  36. cat << \EOF > %{name}-req
  37. #!/bin/sh
  38. %{__perl_requires} $* | sed -e '/perl(attrs)/d'
  39. EOF
  40. %global __perl_requires %{_builddir}/Event-%{version}/%{name}-req
  41. chmod +x %{__perl_requires}
  42. %endif
  43. %build
  44. perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
  45. make %{?_smp_mflags}
  46. %install
  47. make pure_install DESTDIR=%{buildroot}
  48. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  49. find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
  50. find %{buildroot} -depth -type d -exec rmdir --ignore-fail-on-non-empty {} ';'
  51. %{_fixperms} %{buildroot}
  52. %check
  53. make test
  54. %files
  55. %doc ANNOUNCE ChangeLog README README.EV TODO
  56. %doc Tutorial.pdf Tutorial.pdf-errata.txt demo/ t/ util/
  57. %doc %{perl_vendorarch}/Event.pod
  58. %{perl_vendorarch}/auto/Event/
  59. %{perl_vendorarch}/Event.pm
  60. %{perl_vendorarch}/Event/
  61. %{_mandir}/man3/Event.3pm*
  62. %{_mandir}/man3/Event::MakeMaker.3pm*
  63. %{_mandir}/man3/Event::generic.3pm*
  64. %changelog
  65. * Thu Apr 16 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.24-1
  66. - new upstream release
  67. - dropt Patch0 merged into upstream
  68. * Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.20-2
  69. - build with Perl 5.16
  70. * Fri Mar 02 2012 MATSUBAYASHi Kohji <shaolin@vinelinux.org> - 1.20-1
  71. - initial build for Vine Linux
  72. * Sun Jan 15 2012 Paul Howarth <paul@city-fan.org> 1.20-1
  73. - update to 1.20 (test suite fixes)
  74. - BR: perl(Carp), perl(Config), perl(Exporter)
  75. - since upstream doesn't ship license files, neither should we
  76. - make %%files list more explicit
  77. - use a patch to fix character encoding rather than scripted iconv
  78. - use DESTDIR rather than PERL_INSTALL_ROOT
  79. - no need for additional filtering on top of %%{?perl_default_filter}
  80. - don't package INSTALL file
  81. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 1.15-3
  82. - rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  83. * Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> 1.15-2
  84. - perl mass rebuild
  85. * Wed May 11 2011 Iain Arnell <iarnell@gmail.com> 1.15-1
  86. - update to latest upstream version
  87. - clean up spec for modern rpmbuild
  88. - filter perl(attrs) from requires
  89. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 1.12-6
  90. - rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  91. * Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> 1.12-5
  92. - rebuild to fix problems with vendorarch/lib (#661697)
  93. * Sat May 01 2010 Marcela Maslanova <mmaslano@redhat.com> 1.12-4
  94. - mass rebuild with perl-5.12.0
  95. * Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> 1.12-3
  96. - mass rebuild with perl-5.12.0
  97. * Mon Dec 07 2009 Stepan Kasal <skasal@redhat.com> 1.12-2
  98. - rebuild against perl 5.10.1
  99. * Tue Sep 01 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.12-1
  100. - add perl_default_filter
  101. - auto-update to 1.12 (by cpan-spec-update 0.01)
  102. - added a new req on perl(Test) (version 1)
  103. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 1.11-3
  104. - rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  105. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 1.11-2
  106. - rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  107. * Wed May 21 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.11-1
  108. - update to 1.11
  109. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.09-5
  110. - rebuild for perl 5.10 (again)
  111. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> 1.09-4
  112. - autorebuild for GCC 4.3
  113. * Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.09-3
  114. - rebuild for new perl
  115. * Tue Aug 21 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.09-2
  116. - bump
  117. * Fri Jun 01 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.09-1
  118. - update to 1.09
  119. - add t/ to doc
  120. * Sat Nov 04 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.08-1
  121. - update to 1.08
  122. * Sun Oct 15 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.07-1
  123. - update to 1.07
  124. * Thu Aug 31 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.06-2
  125. - bump for mass rebuild
  126. * Wed Jun 14 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.06-1
  127. - add explicit provides: perl(Event) = version... wasn't being picked up
  128. automagically for some reason
  129. - tweaked summary line
  130. - bumped release
  131. * Thu Jun 08 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.06-0
  132. - initial spec file for F-E