pcre-vl.spec 7.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255
  1. Name: pcre
  2. Version: 8.39
  3. Release: 1%{?_dist_release}
  4. Summary: Perl-compatible regular expression library
  5. Summary(ja): Perl 互換の正規表現ライブラリ
  6. Group: System Environment/Libraries
  7. License: BSD
  8. URL: http://www.pcre.org/
  9. Source0: ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/%{name}-%{version}.tar.bz2
  10. # Upstream thinks RPATH is good idea.
  11. Patch0: pcre-8.21-multilib.patch
  12. # Refused by upstream, bug #675477
  13. Patch1: pcre-8.32-refused_spelling_terminated.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: zlib-devel
  16. BuildRequires: bzip2-devel
  17. BuildRequires: libedit-devel
  18. # New libtool to get rid of rpath
  19. BuildRequires: autoconf, automake, libtool
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. Packager: inagaki
  23. %description
  24. Perl-compatible regular expression library.
  25. PCRE has its own native API, but a set of "wrapper" functions that are based on
  26. the POSIX API are also supplied in the library libpcreposix. Note that this
  27. just provides a POSIX calling interface to PCRE: the regular expressions
  28. themselves still follow Perl syntax and semantics. The header file
  29. for the POSIX-style functions is called pcreposix.h.
  30. %package devel
  31. Summary: Development files for %{name}
  32. Summary(ja): %{name} の開発用ファイル
  33. Group: Development/Libraries
  34. Requires: %{name} = %{version}-%{release}
  35. %description devel
  36. Development files (Headers, libraries for static linking, etc) for %{name}.
  37. %prep
  38. %setup -q
  39. # Get rid of rpath
  40. %patch0 -p1 -b .multilib
  41. %patch1 -p1 -b .terminated_typos
  42. # Because of rpath patch
  43. libtoolize --copy --force && autoreconf -vif
  44. # One contributor's name is non-UTF-8
  45. for F in ChangeLog; do
  46. iconv -f latin1 -t utf8 "$F" >"${F}.utf8"
  47. touch --reference "$F" "${F}.utf8"
  48. mv "${F}.utf8" "$F"
  49. done
  50. %build
  51. %configure \
  52. --enable-jit \
  53. --disable-static \
  54. --enable-utf8 \
  55. --enable-unicode-properties \
  56. --enable-pcregrep-libz \
  57. --enable-pcregrep-libbz2 \
  58. --enable-pcretest-libedit \
  59. --enable-pcre8 \
  60. --enable-pcre16 \
  61. --enable-pcre32
  62. make %{?_smp_mflags}
  63. %install
  64. rm -rf $RPM_BUILD_ROOT
  65. make install DESTDIR=$RPM_BUILD_ROOT
  66. rm -rf $RPM_BUILD_ROOT%{_datadir}/doc
  67. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  68. %check
  69. %ifarch s390 s390x ppc
  70. # larger stack is needed on s390, ppc
  71. ulimit -s 10240
  72. %endif
  73. make %{?_smp_mflags} check VERBOSE=yes
  74. %clean
  75. rm -rf $RPM_BUILD_ROOT
  76. %post -p /sbin/ldconfig
  77. %postun -p /sbin/ldconfig
  78. %files
  79. %defattr(-,root,root)
  80. %doc AUTHORS COPYING ChangeLog LICENCE NEWS README
  81. %{_bindir}/pcregrep
  82. %{_libdir}/*.so.*
  83. %{_mandir}/man1/pcregrep.*
  84. %files devel
  85. %defattr(-,root,root)
  86. %doc doc/html/*
  87. %{_bindir}/pcre-config
  88. %{_bindir}/pcretest
  89. %{_includedir}/*
  90. %{_libdir}/*.so
  91. %{_libdir}/pkgconfig/*.pc
  92. %{_mandir}/man1/pcre-config.*
  93. %{_mandir}/man1/pcretest.*
  94. %{_mandir}/man3/*
  95. %changelog
  96. * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.39-1
  97. - new upstream release.
  98. - dropped Patch1000,1001: fixed in upstream.
  99. * Wed Mar 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.38-1
  100. - new upstream release.
  101. - removed Patch2,Patch3 (no longer needed).
  102. - added Patch1000 to fix CVE-2016-1283.
  103. * Sun Apr 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.36-1
  104. - new upstream release
  105. - added patches including security fix from Fedora (CVE-2014-8964)
  106. * Thu Nov 20 2014 Petr Pisar <ppisar@redhat.com> - 8.36-3
  107. - Fix CVE-2014-8964 (unused memory usage on zero-repeat assertion condition)
  108. (bug #1165626)
  109. * Fri Nov 07 2014 Petr Pisar <ppisar@redhat.com> - 8.36-2
  110. - Reset non-matched groups within capturing group up to forced match
  111. (bug #1161587)
  112. * Mon May 09 2011 Petr Pisar <ppisar@redhat.com> - 8.12-3
  113. - Fix typos in manual pages (bugs #675476, #675477)
  114. * Thu Sep 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.35-1
  115. - new upstream release
  116. - add --enable-pcre32 and --enable-pcretest-libedit
  117. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 8.31-1
  118. - new upstream release
  119. - add --enable-pcre16 --enable-pcre8 --enable-jit
  120. - API change
  121. - change includedir to /usr/include
  122. * Sat Sep 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.13-1
  123. - new upstream release
  124. * Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.12-1
  125. - new upstream release
  126. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 8.10-2
  127. - rebuilt with rpm-4.8.1 for pkg-config
  128. * Thu Aug 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.10-1
  129. - new upstream release
  130. * Mon May 10 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 8.02-1
  131. - new upstream release with security fix
  132. * Sat Feb 6 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.01-1
  133. - new upstream release
  134. * Sat Jan 16 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.00-1
  135. - new upstream release
  136. * Tue Jul 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.9-2
  137. - add --enable-unicode-properties to configure option
  138. * Wed Jun 10 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.9-1
  139. - new upstream release
  140. - added BR: zlib-devel, bzip2-devel
  141. - removed static libraries from devel package
  142. - added Packager tag
  143. * Sat Jan 24 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.8-1vl5
  144. - new upstream release
  145. - spec in UTF-8
  146. * Sun Jul 6 2008 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.7-1vl5
  147. - new upstream release
  148. * Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
  149. - use macro for Release
  150. * Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
  151. - apply new virsioning policy.
  152. - remove *.la
  153. * Thu Feb 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.6-0vl1
  154. - new upstream release
  155. * Wed Nov 7 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.4-0vl1
  156. - new upstream release
  157. * Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.2-0vl1
  158. - new upstream release
  159. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.6-0vl2
  160. - rebuild with new environment/toolchain
  161. * Wed Feb 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6-0vl1
  162. - new upstream release
  163. * Mon Sep 5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl2
  164. - added --enable-utf8 option
  165. * Sun Sep 4 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl1
  166. - new upstream release
  167. * Thu Jan 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0-0vl1
  168. - new upstream release
  169. - added Japanese summary
  170. * Sun Apr 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5-0vl1
  171. - new upstream release
  172. * Mon Oct 13 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.4-0vl1
  173. - new upstream release
  174. * Mon May 5 2003 Tomoya TAKA <taka@vinelinux.org> 4.1-0vl3
  175. - skip 'make check' on alpha
  176. * Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl2
  177. - change install section
  178. - change files section
  179. * Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl1
  180. - update to 4.1
  181. - add %{_bindir}/pcretest
  182. - add %doc AUTHORS COPYING ChangeLog INSTALL LICENCE NEWS README
  183. * Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.9-0vl2
  184. - rebuild with new toolchains
  185. * Sat Mar 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.9-0vl1
  186. - Update to 3.9
  187. * Wed Dec 26 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.7-0vl1
  188. - Update to 3.7
  189. * Sun Oct 14 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.5-0vl1
  190. - Update to 3.5
  191. * Wed Oct 10 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.4-2vl1
  192. - Build for VineSeed
  193. * Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.4-2
  194. - Move libpcre to /lib, grep uses it these days (#41104)
  195. * Wed Apr 18 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  196. - Move this to a separate package, used to be in kdesupport, but it's
  197. generally useful...