opensource-cobol-vl.spec 2.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127
  1. %define pkg_name opensource-cobol
  2. %define pkg_version 1.5.0J
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: An open-source COBOL compiler
  5. Name: %{pkg_name}
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. License: GPLv2
  9. Group: Applications/Languages
  10. URL: https://www.osscons.jp/
  11. Source0: %{name}-%{version}-utf8.tar.gz
  12. Buildroot: %{_tmppath}/%{name}-%{version}-root
  13. %if %{?_dist_release} == "vl6"
  14. BuildRequires: db4-devel
  15. %else
  16. BuildRequires: libdb-devel
  17. %endif
  18. BuildRequires: gmp-devel
  19. BuildRequires: ncurses-devel
  20. BuildRequires: texinfo
  21. BuildRequires: texlive-common
  22. %if %{?_dist_release} == "vl6"
  23. BuildRequires: texlive-collection-texinfo
  24. %else
  25. BuildRequires: texlive-collection-plainextra
  26. BuildRequires: texlive-collection-fontsrecommended
  27. %endif
  28. %if %{?_dist_release} == "vl6"
  29. Requires: db4
  30. %else
  31. Requires: libdb
  32. %endif
  33. Vendor: Project Vine
  34. Distribution: Vine Linux
  35. Packager: ara_t
  36. %description
  37. "opensource COBOL" is open-source COBOL compiler,
  38. an extension of the Japan-specific features.
  39. "opensource COBOL" translates COBOL program to C code
  40. and compiles it using GCC or CL.
  41. It was forked from OpenCOBOL in 2012.
  42. See also OpenCOBOL project.
  43. http://www.opencobol.org/
  44. http://sourceforge.net/projects/open-cobol/
  45. %description -l ja
  46. opensource COBOLは、オーペンソースのCOBOLコンパイラであり、
  47. COBOLプログラムをC言語のコードに翻訳し、GCCあるいはCLを用いて
  48. コンパイルします。
  49. opensource COBOLは、オープンCOBOLソリューション部会によって
  50. OpenCOBOLに日本特有のビジネス環境に即したカスタマイズ、
  51. メンテナンスを加えたものです。
  52. %prep
  53. %{__rm} -rf ${RPM_BUILD_ROOT}
  54. %setup -q -n %{name}-%{version}-utf8
  55. %build
  56. %{configure} \
  57. --enable-utf8 \
  58. --disable-static
  59. %{__make} %{?_smp_mflags}
  60. %{__make} pdf html
  61. %check
  62. %{__make} check
  63. %install
  64. %{make_install}
  65. %{__rm} ${RPM_BUILD_ROOT}%{_libdir}/*.la
  66. %{__rm} ${RPM_BUILD_ROOT}%{_infodir}/dir
  67. %clean
  68. %{__rm} -rf ${RPM_BUILD_ROOT}
  69. %post
  70. /sbin/install-info %{_infodir}/open-cobol.info.gz %{_infodir}/dir 2>/dev/null
  71. %{_syssbindir}/ldconfig
  72. %preun
  73. if [ $1 = 0 ]; then
  74. /sbin/install-info --delete %{_infodir}/open-cobol.info.gz \
  75. %{_infodir}/dir 2>/dev/null
  76. fi
  77. %postun -p %{_syssbindir}/ldconfig
  78. %files
  79. %defattr(-,root,root)
  80. %doc AUTHORS ChangeLog COPYING* NEWS README THANKS TODO
  81. %doc texi/open-cobol.pdf
  82. %doc texi/open-cobol.html/
  83. %{_bindir}/
  84. %{_includedir}/libcob.h
  85. %{_includedir}/libcob
  86. %{_libdir}/libcob.so*
  87. %{_datadir}/locale/
  88. %{_datadir}/%{name}-%{version}
  89. %{_infodir}/*.info.gz
  90. %changelog
  91. * Sun Jun 19 2016 Toshiaki Ara <ara_t@384.jp> 1.5.0J-1
  92. - update to 1.5.0J
  93. - delete BuildRequires: texlive-collection-lang*
  94. * Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 1.4.0J-2
  95. - rebuild under texlive 2016 pretest
  96. - add BuildRequires
  97. * Fri May 13 2016 Toshiaki Ara <ara_t@384.jp> 1.4.0J-1
  98. - new package