openobex-vl.spec 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275
  1. %global udevdir /lib/udev
  2. Summary: Library for using OBEX
  3. Summary(ja): OBEX を利用するためのライブラリ
  4. Name: openobex
  5. Version: 1.7.1
  6. Release: 1%{?_dist_release}
  7. License: GPLv2+ and LGPLv2+
  8. Group: System Environment/Libraries
  9. URL: http://openobex.sourceforge.net
  10. Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}-Source.tar.gz
  11. Patch0: openobex-apps-flush.patch
  12. Patch1: openobex-1.7-obex_push.patch
  13. Patch2: openobex-1.7-udev_rule.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: bluez-libs-devel
  16. BuildRequires: cmake
  17. BuildRequires: docbook-style-xsl
  18. BuildRequires: doxygen
  19. BuildRequires: libusb1-devel
  20. BuildRequires: libxslt
  21. BuildRequires: sed
  22. ExcludeArch: s390 s390x
  23. #----------------------------------------------------------------------------
  24. %description
  25. OBEX (OBject EXchange) is a protocol usually used by various mobile
  26. devices to exchange all kind of objects like files, pictures, calendar
  27. entries (vCal) and business cards (vCard). This package contains the
  28. Open OBEX shared C library.
  29. %description -l ja
  30. OBEX(OBject EXchange) は様々なモバイル機器での、ファイル、写真、カレンダーエントリー(vCal) 、そして名刺(vCard)のような、すべての種類のオブジェクトを交換するために通常使用されているプロトコルです。
  31. このパッケージには、Open OBEX のC言語共有ライブラリが含まれています。
  32. #----------------------------------------------------------------------------
  33. %package devel
  34. Summary: Files for development of applications which will use OBEX
  35. Summary(ja): OBEX アプリ開発用ライブラリとヘッダーファイル
  36. Group: Development/Libraries
  37. Requires: %{name} = %{version}-%{release}
  38. Requires: bluez-libs-devel
  39. Requires: libusb1-devel
  40. Requires: pkgconfig
  41. %description devel
  42. Header files for development of applications which use OpenOBEX.
  43. %description devel -l ja
  44. Open OBEX を使用するアプリケーションを開発するためのヘッダーファイル等です。
  45. #----------------------------------------------------------------------------
  46. %package apps
  47. Summary: Applications for using OBEX
  48. Summary(ja): OBEX を使ったアプリケーション
  49. Group: Applications/Communications
  50. %description apps
  51. Open OBEX Applications to exchange all kind of objects like files, pictures,
  52. calendar entries (vCal) and business cards (vCard) using the OBEX protocol.
  53. %description apps -l ja
  54. Open OBEX アプリケーションは OBEX プロトコルを使用して、ファイル、写真、カレンダーエントリー(vCal) 、そして名刺(vCard)のような、すべての種類のオブジェクトを交換します。
  55. #----------------------------------------------------------------------------
  56. %prep
  57. %setup -q -n openobex-%{version}-Source
  58. %patch0 -p1 -b .flush
  59. %patch1 -p1 -b .push
  60. %patch2 -p1 -b .udev
  61. %build
  62. %cmake \
  63. -DCMAKE_SKIP_RPATH=YES \
  64. -DCMAKE_VERBOSE_MAKEFILE=YES \
  65. -DCMAKE_INSTALL_UDEVRULESDIR=%{udevdir}/rules.d \
  66. make %{?_smp_mflags}
  67. make openobex-apps %{?_smp_mflags}
  68. #----------------------------------------------------------------------------
  69. %install
  70. rm -rf $RPM_BUILD_ROOT
  71. make install DESTDIR=$RPM_BUILD_ROOT
  72. # we do not want .la files
  73. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  74. # don't ship obex_test program, that is for testing purposes only
  75. # and has some problems (multiple buffer overflows etc.)
  76. rm -f $RPM_BUILD_ROOT%{_bindir}/obex_test
  77. rm -f $RPM_BUILD_ROOT%{_mandir}/man1/obex_test.1*
  78. # HTML doc
  79. rm -rf _docs_to_include
  80. mkdir -p _docs_to_include
  81. mv $RPM_BUILD_ROOT%{_docdir}/%{name}/html _docs_to_include
  82. %clean
  83. rm -rf $RPM_BUILD_ROOT
  84. %post -p /sbin/ldconfig
  85. %postun -p /sbin/ldconfig
  86. %files
  87. %defattr(-, root, root)
  88. %doc AUTHORS COPYING COPYING.LIB ChangeLog README
  89. %{_sbindir}/obex-check-device
  90. %{_libdir}/libopenobex*.so.*
  91. %{udevdir}/rules.d/60-openobex.rules
  92. %files devel
  93. %defattr(-, root, root)
  94. %doc AUTHORS COPYING COPYING.LIB ChangeLog README
  95. %doc _docs_to_include/html
  96. %dir %{_includedir}/%{name}
  97. %{_includedir}/%{name}/*.h
  98. %{_libdir}/libopenobex*.so
  99. %{_libdir}/pkgconfig/openobex.pc
  100. %{_libdir}/cmake/OpenObex-%{version}
  101. %files apps
  102. %defattr(-, root, root)
  103. %{_bindir}/irobex_palm3
  104. %{_bindir}/irxfer
  105. %{_bindir}/ircp
  106. %{_bindir}/obex_find
  107. %{_bindir}/obex_tcp
  108. %{_bindir}/obex_push
  109. %{_mandir}/man1/irobex_palm3.1*
  110. %{_mandir}/man1/irxfer.1*
  111. %{_mandir}/man1/ircp.1*
  112. %{_mandir}/man1/obex_tcp.1*
  113. %{_mandir}/man1/obex_find.1*
  114. %{_mandir}/man1/obex_push.1*
  115. #----------------------------------------------------------------------------
  116. # Maintainers: babasaki@mindgear.org
  117. #
  118. #----------------------------------------------------------------------------
  119. %changelog
  120. * Tue Nov 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.7.1-1
  121. - updated to 1.7,1
  122. - added Patch1 and Patch2 from fc
  123. * Wed Oct 01 2014 Tomas Hozza <thozza@redhat.com> - 1.7.1-5
  124. - Fix udev rule to not use plugdev group (#1136580)
  125. * Thu Jan 09 2014 Tomas Hozza <thozza@redhat.com> - 1.7.1-2
  126. - Distribute Cmake config files
  127. * Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5-3
  128. - rebuild with VineSeed environment
  129. * Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 1.5-2
  130. - rebuilt with rpm-4.8.1 for pkg-config
  131. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5-1
  132. - new upstream release
  133. - drop Patch1, Patch2, Patch3, Patch4, Patch5
  134. * Sat Nov 7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3-15
  135. - for <BTS:847>
  136. - fixed %postun section
  137. - changed apps Group to Applications/Accessories
  138. * Fri Oct 24 2008 Seiichirou Babasaki 1.3-14
  139. - added "# Maintainers: " comments.
  140. - changed UTF-8 encode at bluez-gnome.vs.spec
  141. - Updated specfile
  142. * Fri Jun 13 2008 Seiichirou Babasaki 1.3-13
  143. - Updated specfile
  144. - LOGS - 1.3-12
  145. - improved utf(non ascii) support
  146. - Resolves: #430128
  147. - LOGS - 1.3-11
  148. - Autorebuild for GCC 4.3
  149. - LOGS - 1.3-10
  150. - Spec file cleanup
  151. - LOGS - 1.3-9
  152. - Spec file cleanup
  153. - Fixed wrong lib path in autoconf
  154. * Wed Jan 16 2008 Seiichirou Babasaki 1.3-8vl1
  155. - Import oponobex - Packager: Babasaki
  156. - Updated specfile
  157. #----------------------------------------------------------------------------
  158. * Tue Sep 18 2007 Jiri Moskovcak <jmoskovcak@redhat.com> 1.3-8
  159. - Changed sources in specfile URL to point to the right location
  160. * Fri Aug 24 2007 Jiri Moskovcak <jmoskovc@redhat.com> 1.3-7
  161. - Added ipv6 support
  162. - Resolves: #198396
  163. * Wed Aug 22 2007 Harald Hoyer <harald@redhat.com> - 1.3-6
  164. - changed license tag
  165. * Fri Mar 23 2007 Harald Hoyer <harald@redhat.com> - 1.3-5
  166. - specfile cleanup
  167. * Wed Feb 7 2007 Harald Hoyer <harald@redhat.com> - 1.3-4
  168. - readded obex_push
  169. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3-3.1
  170. - rebuild
  171. * Tue Jun 27 2006 Harald Hoyer <harald@redhat.com> - 1.3-3
  172. - removed more patches
  173. * Tue Jun 27 2006 Harald Hoyer <harald@redhat.com> - 1.3-2
  174. - added more build requirements
  175. - built now with enable-usb
  176. * Fri Jun 16 2006 Harald Hoyer <harald@redhat.com> - 1.3-1
  177. - version 1.3
  178. * Tue Jun 13 2006 Harald Hoyer <harald@redhat.com> - 1.2-2
  179. - more build requirements
  180. * Tue Jun 13 2006 Harald Hoyer <harald@redhat.com> - 1.2-1
  181. - version 1.2
  182. * Thu Feb 16 2006 Harald Hoyer <harald@redhat.com> 1.1-1
  183. - version 1.1
  184. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2.1
  185. - bump again for double-long bug on ppc(64)
  186. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2
  187. - rebuilt for new gcc4.1 snapshot and glibc changes
  188. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  189. - rebuilt
  190. * Mon May 02 2005 Harald Hoyer <harald@redhat.com> 1.0.1-4
  191. - added `OBEX_ServerAccept' to the exported symbols (bug rh#146353)
  192. * Wed Mar 02 2005 Harald Hoyer <harald@redhat.com>
  193. - rebuilt
  194. * Wed Feb 09 2005 Harald Hoyer <harald@redhat.com>
  195. - rebuilt
  196. * Mon Sep 13 2004 Harald Hoyer <harald@redhat.de> 1.0.1-1
  197. - version 1.0.1
  198. * Tue Jun 22 2004 Alan Cox <alan@redhat.com>
  199. - removed now unneeded glib requirement
  200. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  201. - rebuilt
  202. * Mon Apr 19 2004 David Woodhouse <dwmw2@redhat.com> 1.0.0-5
  203. - import for for #121271 from openobex CVS tree
  204. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  205. - rebuilt
  206. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  207. - rebuilt
  208. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  209. - rebuilt
  210. * Wed Jun 4 2003 Harald Hoyer <harald@redhat.de> 1.0.0-2
  211. - excludeArch s390 s390x
  212. * Wed Jun 4 2003 Harald Hoyer <harald@redhat.de> 1.0.0-1
  213. - redhatified specfile
  214. - bump to version 1.0.0
  215. * Thu May 18 2000 Pontus Fuchs <pontus.fuchs@tactel.se>
  216. - Initial RPM