ocaml-ounit-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207
  1. %global opt %(test -x %{_bindir}/ocamlopt && echo 1 || echo 0)
  2. Name: ocaml-ounit
  3. Version: 2.0.0
  4. Release: 13%{?_dist_release}
  5. Summary: Unit test framework for OCaml
  6. License: MIT
  7. Group: Development/Tools
  8. URL: http://ounit.forge.ocamlcore.org/
  9. Source0: http://forge.ocamlcore.org/frs/download.php/1258/ounit-%{version}.tar.gz
  10. ExcludeArch: sparc64 s390 s390x
  11. BuildRequires: ocaml >= 3.10.0
  12. BuildRequires: ocaml-findlib
  13. #BuildRequires: ocaml-ocamldoc
  14. # This may have been required by < 2.0.0, but doesn't seem to be
  15. # needed for newer versions.
  16. #BuildRequires: ocaml-camlp4-devel
  17. %description
  18. OUnit is a unit test framework for OCaml. It allows one to easily
  19. create unit-tests for OCaml code. It is based on HUnit, a unit testing
  20. framework for Haskell. It is similar to JUnit, and other xUnit testing
  21. frameworks.
  22. %package devel
  23. Summary: Development files for %{name}
  24. Group: Development/Libraries
  25. Requires: %{name} = %{version}-%{release}
  26. %description devel
  27. The %{name}-devel package contains libraries and signature files for
  28. developing applications that use %{name}.
  29. %prep
  30. %setup -q -n ounit-%{version}
  31. sh ./configure --destdir $RPM_BUILD_ROOT
  32. %build
  33. make all
  34. make doc
  35. %install
  36. rm -rf $RPM_BUILD_ROOT
  37. export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
  38. mkdir -p $OCAMLFIND_DESTDIR $OCAMLFIND_DESTDIR/stublibs
  39. make install
  40. # Remove this, reinstall it properly with a %%doc rule below.
  41. rm -rf $RPM_BUILD_ROOT/usr/local/share/doc
  42. %check
  43. make test
  44. %clean
  45. rm -rf $RPM_BUILD_ROOT
  46. %files
  47. %doc LICENSE.txt
  48. %{_libdir}/ocaml/oUnit
  49. %if %opt
  50. %exclude %{_libdir}/ocaml/oUnit/*.a
  51. %exclude %{_libdir}/ocaml/oUnit/*.cmxa
  52. %endif
  53. %exclude %{_libdir}/ocaml/oUnit/*.mli
  54. %files devel
  55. %doc LICENSE.txt README.txt
  56. %doc _build/src/api-ounit.docdir/*
  57. %if %opt
  58. %{_libdir}/ocaml/oUnit/*.a
  59. %{_libdir}/ocaml/oUnit/*.cmxa
  60. %endif
  61. %{_libdir}/ocaml/oUnit/*.mli
  62. %changelog
  63. * Wed May 27 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.0.0-13
  64. - Initial build for VineLinux
  65. * Mon Feb 16 2015 Richard W.M. Jones <rjones@redhat.com> - 2.0.0-12
  66. - Bump release and rebuild.
  67. * Mon Feb 16 2015 Richard W.M. Jones <rjones@redhat.com> - 2.0.0-11
  68. - ocaml-4.02.1 rebuild.
  69. * Mon Jan 26 2015 Richard W.M. Jones <rjones@redhat.com> - 2.0.0-10
  70. - Fix Source URL.
  71. - Rebuild against OCaml to fix "make inconsistent assumptions over
  72. implementation Arg".
  73. * Sat Aug 30 2014 Richard W.M. Jones <rjones@redhat.com> - 2.0.0-9
  74. - ocaml-4.02.0 final rebuild.
  75. * Sat Aug 23 2014 Richard W.M. Jones <rjones@redhat.com> - 2.0.0-8
  76. - ocaml-4.02.0+rc1 rebuild.
  77. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-7
  78. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  79. * Fri Aug 01 2014 Richard W.M. Jones <rjones@redhat.com> - 2.0.0-6
  80. - ocaml-4.02.0-0.8.git10e45753.fc22 rebuild.
  81. * Thu Jul 17 2014 Richard W.M. Jones <rjones@redhat.com> - 2.0.0-5
  82. - OCaml 4.02.0 beta rebuild.
  83. * Mon Jul 14 2014 Richard W.M. Jones <rjones@redhat.com> - 2.0.0-4
  84. - Remove workaround for code gen bug and try building against
  85. possibly fixed compiler.
  86. * Sun Jul 13 2014 Richard W.M. Jones <rjones@redhat.com> - 2.0.0-3
  87. - Add workaround for code generator bug on ARM (RHBZ#1119049).
  88. * Sat Jul 12 2014 Richard W.M. Jones <rjones@redhat.com> - 2.0.0-1
  89. - New upstream version 2.0.0.
  90. - Remove BR on camlp4.
  91. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.2-9
  92. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  93. * Fri Feb 14 2014 Richard W.M. Jones <rjones@redhat.com> - 1.1.2-8
  94. - Rebuild for updated Arg module (RHBZ#1065447).
  95. * Sat Sep 14 2013 Richard W.M. Jones <rjones@redhat.com> - 1.1.2-7
  96. - Rebuild for OCaml 4.01.0.
  97. - Enable debuginfo.
  98. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.2-6
  99. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  100. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.2-5
  101. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  102. * Fri Oct 19 2012 Richard W.M. Jones <rjones@redhat.com> - 1.1.2-4
  103. - Rebuild for OCaml 4.00.1.
  104. - Clean up the spec file.
  105. * Sat Jul 28 2012 Richard W.M. Jones <rjones@redhat.com> - 1.1.2-3
  106. - Bump and rebuild against new OCaml 4.00.0 official release.
  107. * Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.2-2
  108. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  109. * Sat Jun 30 2012 Richard W.M. Jones <rjones@redhat.com> - 1.1.2-1
  110. - New upstream version 1.1.2, fixed for OCaml 4.00.0.
  111. * Sat Jun 09 2012 Richard W.M. Jones <rjones@redhat.com> - 1.1.0-6
  112. - Rebuild for OCaml 4.00.0.
  113. * Mon May 14 2012 Richard W.M. Jones <rjones@redhat.com> - 1.1.0-5
  114. - Bump release and rebuild for new OCaml on ARM.
  115. * Fri Jan 06 2012 Richard W.M. Jones <rjones@redhat.com> - 1.1.0-4
  116. - Rebuild for OCaml 3.12.1.
  117. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-3
  118. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  119. * Wed Jan 5 2011 Richard W.M. Jones <rjones@redhat.com> - 1.1.0-2
  120. - New upstream version 1.1.0.
  121. - Project has moved to new upstream URL and Source0.
  122. - Rebuild for OCaml 3.12.0.
  123. - New build system:
  124. + doesn't need 'make allopt'
  125. + DESTDIR logic changed (see OASIS bug 852)
  126. + docdir moved
  127. - LICENSE and README files renamed.
  128. - BR camlp4.
  129. * Wed Dec 30 2009 Richard W.M. Jones <rjones@redhat.com> - 1.0.3-7
  130. - Rebuild for OCaml 3.11.2.
  131. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.3-6
  132. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  133. * Sat May 23 2009 Richard W.M. Jones <rjones@redhat.com> - 1.0.3-5
  134. - Rebuild for OCaml 3.11.1
  135. * Thu Apr 16 2009 S390x secondary arch maintainer <fedora-s390x@lists.fedoraproject.org>
  136. - ExcludeArch sparc64, s390, s390x as we don't have OCaml on those archs
  137. (added sparc64 per request from the sparc maintainer)
  138. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.3-4
  139. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  140. * Wed Nov 26 2008 Richard W.M. Jones <rjones@redhat.com> - 1.0.3-3
  141. - Rebuild for OCaml 3.11.0+rc1.
  142. * Wed Nov 19 2008 Richard W.M. Jones <rjones@redhat.com> - 1.0.3-2
  143. - Rebuild for OCaml 3.11.0
  144. * Sun Aug 31 2008 Richard W.M. Jones <rjones@redhat.com> - 1.0.3-1
  145. - New upstream version 1.0.3.
  146. * Mon May 12 2008 Richard W.M. Jones <rjones@redhat.com> - 1.0.2-2
  147. - License is MIT.
  148. * Sat May 3 2008 Richard W.M. Jones <rjones@redhat.com> - 1.0.2-1
  149. - Initial RPM release.