self-build-zsnes-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156
  1. %define pkgname zsnes
  2. %define name self-build-%{pkgname}
  3. %define version 1.51
  4. %define release 3%{?_dist_release}
  5. %define srcversion %(echo "%{version}src" | %{__sed} 's/\\.//')
  6. %define sourceurl0 http://prdownloads.sourceforge.net/%{pkgname}/%{pkgname}%{srcversion}.tar.bz2
  7. Summary: Package to automatically build %{pkgname} rpm package
  8. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  9. Name: %{name}
  10. Version: %{version}
  11. Release: %{release}
  12. Source0: %{pkgname}-vl.spec
  13. Source101: zsnes-1.51-Makefile.in.FIX.BROKENESS.patch
  14. Source102: zsnes-1.51-FORTIFY_SOURCE.patch
  15. Source103: zsnes-1.51-gcc43.patch
  16. Source104: zsnes-1.51-pulseaudio.patch
  17. License: GPLv2
  18. Group: Restricted Software
  19. Requires(post): self-build-setup
  20. Requires: SDL >= 1.2.0
  21. Requires: hicolor-icon-theme
  22. Requires(post): automake
  23. Requires(post): nasm >= 0.98
  24. Requires(post): zlib >= 1.1.0
  25. Requires(post): libpng >= 1.2.0
  26. Requires(post): SDL-devel >= 1.2.0
  27. Requires(post): zlib-devel >= 1.1.0
  28. Requires(post): libpng-devel >= 1.2.0
  29. Requires(post): ncurses-devel
  30. Requires(post): libao-devel
  31. Requires(post): desktop-file-utils
  32. %if %{?_dist_release} != "vl4"
  33. Requires: mesa-libGL
  34. Requires(post): xorg-x11-devel
  35. Requires(post): mesa-libGL-devel
  36. %else
  37. Requires: XOrg-gl
  38. Requires(post): XOrg-devel
  39. Requires(post): XOrg-gl-devel
  40. %endif
  41. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  42. ExclusiveArch: %{ix86}
  43. Packager: munepi
  44. %description
  45. ZSNES is one of Super Nintendo Entertainment System (SNES) emulators.
  46. If you install this package, it automaticaly downloads source
  47. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  48. And the created rpm packages are automatically installed
  49. if installation is executed by apt-get command or synaptic
  50. package manager.
  51. [Note]
  52. This package requires many other packages to compile
  53. targetsoftware. So it consume more disk space than usual.
  54. Also installation takes logner time because of compilation.
  55. (This will take a few minutes to quarter or half of an hour,
  56. depends on building environment)
  57. [About self-build package]
  58. For some kind of software, distributing of binary package
  59. may viorate the patent or law. Therefore we chose self-build
  60. packge, create binary package on your machine, for such kind
  61. of softwares instead of distributing binary package.
  62. Please obey the national law when you use the created binary
  63. packages. And if you want to use the softwares using patented
  64. thechnology, it may be required to get a permission, make an
  65. agreement or purchas a license. Please consider it with your
  66. purpose or way of use and take appropriate action.
  67. %description -l ja
  68. ZSNESはスーパーファミコンエミュレーターの1つです。
  69. このパッケージをインストールすると、自動的にソースコードを
  70. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  71. の rpm パッケージを作成します。
  72. また apt-get コマンドや synaptic パッケージマネージャから実行
  73. した場合は、作成された rpm パッケージのインストールも自動的に
  74. 行います。
  75. [注意]
  76. コンパイルに必要な多くの関連パッケージを要求するので通常より
  77. ディスクの領域を多く消費します。
  78. またインストール時にコンパイルを行うため、通常より時間がかか
  79. る場合があります。(環境にもよりますが数分から数十分程度)
  80. [self-build パッケージについて]
  81. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  82. 違反する可能性があるものがあります。その為、このような問題が
  83. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  84. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  85. ジという方法を採っています。
  86. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  87. アのライセンス、および利用する国の各種法令に従ってください。
  88. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  89. センスの購入などが必要となる場合がありますので、利用する目的
  90. や形態に応じて各自で判断し適切な対応を取ってください。
  91. %prep
  92. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  93. %install
  94. %{__rm} -rf ${RPM_BUILD_ROOT}
  95. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  96. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  97. %{__install} -m 644 %{SOURCE101} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  98. %{__install} -m 644 %{SOURCE102} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  99. %{__install} -m 644 %{SOURCE103} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  100. %{__install} -m 644 %{SOURCE104} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  101. %clean
  102. %{__rm} -rf ${RPM_BUILD_ROOT}
  103. %posttrans
  104. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}"
  105. %files
  106. %defattr(-,root,root)
  107. %{_datadir}/%{name}/*
  108. %changelog
  109. * Sun Jun 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.51-3
  110. - applied zsnes-1.51-gcc43.patch, zsnes-1.51-pulseaudio.patch
  111. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.51-2
  112. - avoided to execute self-build-rpm.sh on RPM transaction
  113. - moved %%post actions to %%posttrans
  114. * Mon Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.51-1
  115. - make self-build package from zsnes-1.51-0vl2.nosrc.rpm
  116. - applied new versioning policy
  117. - spec in utf8
  118. - dropped NoSource: 0
  119. - applied zsnes-1.51-Makefile.in.FIX.BROKENESS.patch,
  120. zsnes-1.51-FORTIFY_SOURCE.patch
  121. #, zsnes-1.51-gcc43.patch
  122. - added Requires: hicolor-icon-theme
  123. BuildRequires: automake ncurses-devel libao-devel desktop-file-utils
  124. - For vl5, added Requires: mesa-libGL
  125. BuildRequires: xorg-x11-devel mesa-libGL-devel
  126. - fixed ExclusiveArch: %{ix86}
  127. ### end of file