self-build-x265-vl.spec 5.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142
  1. %global pkgname x265
  2. %global name self-build-%{pkgname}
  3. %global version 1.8
  4. %global release 1%{?_dist_release}
  5. %global sourceurl0 http://ftp.videolan.org/pub/videolan/x265/x265_%{version}.tar.gz
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Source0: %{pkgname}-vl.spec
  12. #Source100: x265-pc-path.patch
  13. Source101: x265-test-shared.patch
  14. Source104: x265-detect_cpu_armhfp.patch
  15. License: GPLv2+ and BSD
  16. Group: Restricted Software
  17. Obsoletes: x265 < %{version}, x265-devel < %{version}
  18. Obsoletes: self-build-x265 < %{version}-%{release}
  19. Requires(post): self-build-setup >= 0.9.9
  20. # (build)requies of target package.
  21. Requires(post): cmake
  22. Requires(post): yasm
  23. BuildArch: noarch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. Packager: munepi
  26. %description
  27. The primary objective of x265 is to become the best H.265/HEVC encoder
  28. available anywhere, offering the highest compression efficiency and the
  29. highest performance on a wide variety of hardware platforms.
  30. If you install this package, it automaticaly downloads source
  31. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  32. And the created rpm packages are automatically installed
  33. if installation is executed by apt-get command or synaptic
  34. package manager.
  35. [Note]
  36. This package requires many other packages to compile
  37. targetsoftware. So it consume more disk space than usual.
  38. Also installation takes logner time because of compilation.
  39. (This will take a few minutes to quarter or half of an hour,
  40. depends on building environment)
  41. [About self-build package]
  42. For some kind of software, distributing of binary package
  43. may viorate the patent or law. Therefore we chose self-build
  44. packge, create binary package on your machine, for such kind
  45. of softwares instead of distributing binary package.
  46. Please obey the national law when you use the created binary
  47. packages. And if you want to use the softwares using patented
  48. thechnology, it may be required to get a permission, make an
  49. agreement or purchas a license. Please consider it with your
  50. purpose or way of use and take appropriate action.
  51. %description -l ja
  52. x265はH.265/HEVCをエンコードするためのライブラリです。
  53. このパッケージをインストールすると、自動的にソースコードを
  54. ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
  55. パッケージを作成します。
  56. また apt-get コマンドや synaptic パッケージマネージャから実行
  57. した場合は、作成された rpm パッケージのインストールも自動的に
  58. 行います。
  59. [注意]
  60. コンパイルに必要な多くの関連パッケージを要求するので通常より
  61. ディスクの領域を多く消費します。
  62. またインストール時にコンパイルを行うため、通常より時間がかか
  63. る場合があります。(環境にもよりますが数分から数十分程度)
  64. [self-build パッケージについて]
  65. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  66. 違反する可能性があるものがあります。その為、このような問題が
  67. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  68. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  69. ジという方法を採っています。
  70. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  71. アのライセンス、および利用する国の各種法令に従ってください。
  72. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  73. センスの購入などが必要となる場合がありますので、利用する目的
  74. や形態に応じて各自で判断し適切な対応を取ってください。
  75. %prep
  76. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  77. %install
  78. %{__rm} -rf ${RPM_BUILD_ROOT}
  79. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  80. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  81. %{__install} -m 644 %{SOURCE101} %{SOURCE104} \
  82. ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  83. %clean
  84. %{__rm} -rf ${RPM_BUILD_ROOT}
  85. %posttrans
  86. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 168000
  87. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  88. %{pkgname}-devel-%{version}-%{release}
  89. %files
  90. %defattr(-,root,root)
  91. %{_datadir}/%{name}
  92. %changelog
  93. * Sat Jan 23 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.8-1
  94. - new upstream release (ABI 68)
  95. * Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.7-1
  96. - new upstream release (ABI 59)
  97. * Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.6-1
  98. - new upstream release (ABI 51)
  99. - release tarballs are now hosted on videolan.org
  100. * Sat Feb 21 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.5-2
  101. - rebuild
  102. * Sat Feb 21 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.5-1
  103. - new upstream release
  104. - drop x265-pc-path.patch
  105. - add x265-1.5-test-shared.patch
  106. * Sat Feb 7 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4-2
  107. - added Group tag to Source0
  108. * Fri Jan 2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4-1
  109. - new upstream release
  110. - initial build based on RPM Fusion rawhide