self-build-vlc-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466
  1. #% global rcversion 2
  2. %define pkgname vlc
  3. %define name self-build-%{pkgname}
  4. %define version 2.2.2
  5. %define release 2%{?rcversion:.rc%rcversion}%{?_dist_release}
  6. %define with_mozilla 0
  7. #% define with_dc1394 1
  8. %define with_ncurses 0
  9. %define sourceurl0 http://download.videolan.org/pub/videolan/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.xz
  10. #% define sourceurl0 http://download.videolan.org/pub/videolan/testing/vlc-2.2.0-rc2/vlc-2.2.0-rc2.tar.xz
  11. Summary: Package to automatically build %{pkgname} rpm package
  12. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  13. Name: %{name}
  14. Version: %{version}
  15. Release: %{release}
  16. Obsoletes: vlc < %{version}-%{release}, vlc-devel < %{version}-%{release}
  17. Obsoletes: self-build-vlc < %{version}-%{release}
  18. Source0: %{pkgname}-vl.spec
  19. License: GPLv2+
  20. Group: Restricted Software
  21. Requires(post): self-build-setup >= 0.9.9
  22. Requires(post): unzip
  23. Requires(post): desktop-file-utils
  24. Requires(post): gettext
  25. Requires(post): gettext-devel
  26. Requires(post): libtool
  27. Requires(post): aalib-devel
  28. Requires(post): alsa-lib-devel
  29. Requires(post): avahi-devel
  30. Requires(post): cdparanoia-devel
  31. Requires(post): dbus-devel
  32. %{?_with_dirac: Requires(post): dirac-devel >= 1.0.0}
  33. #Requires(post): directfb-devel
  34. Requires(post): libdirectfb-devel
  35. Requires(post): flac-devel
  36. ##!! Requires(post): fluidsynth-devel
  37. Requires(post): fribidi-devel
  38. Requires(post): gnome-vfs2-devel
  39. Requires(post): gnutls-devel >= 1.0.17
  40. Requires(post): gsm-devel
  41. %if %{?_dist_release} >= "vl7"
  42. Requires(post): jack-audio-connection-kit-devel
  43. %endif
  44. %{?with_dc1394:Requires(post): libavc1394-devel}
  45. Requires(post): libass-devel >= 0.9.7
  46. ##!! Requires(post): libcaca-devel
  47. Requires(post): libcddb-devel
  48. Requires(post): libcdio-devel >= 0.77-3
  49. %{?with_dc1394:Requires(post): libavc1394-devel >= 0.5.3}
  50. %{?with_dc1394:Requires(post): libdc1394-devel >= 2.1.0}
  51. %{?with_dc1394:Requires(post): libdv-devel}
  52. Requires(post): libdvdnav-devel
  53. Requires(post): libdvdread-devel
  54. Requires(post): libebml-devel
  55. Requires(post): libid3tag-devel
  56. %{?_with_kate: Requires(post): libkate-devel}
  57. Requires(post): libmatroska-devel >= 0.7.6
  58. Requires(post): libmodplug-devel
  59. Requires(post): libmp4v2-devel
  60. Requires(post): libmpcdec-devel
  61. Requires(post): libmtp-devel
  62. Requires(post): libnotify-devel
  63. ##!! Requires(post): libprojectM-qt-devel
  64. Requires(post): libproxy-devel
  65. Requires(post): librsvg2-devel >= 2.9.0
  66. Requires(post): librtmp-devel
  67. Requires(post): libssh2-devel
  68. ##!! Requires(post): libsysfs-devel
  69. Requires(post): libshout-devel
  70. Requires(post): libsmbclient-devel
  71. ##!! Requires(post): libtar-devel
  72. Requires(post): libtheora-devel
  73. ##!! Requires(post): libtiger-devel
  74. Requires(post): libtiff-devel
  75. Requires(post): libudev-devel >= 142
  76. Requires(post): libupnp-devel
  77. Requires(post): libv4l-devel
  78. Requires(post): libva-devel
  79. Requires(post): libvorbis-devel
  80. Requires(post): libxml2-devel
  81. #Requires(post): lirc-devel
  82. %{?_with_lirc:Requires(post): lirc}
  83. #Requires(post): live555-devel >= 0-0.19.2008.04.03
  84. Requires(post): kernel-headers >= 2.6.20
  85. # Requires(post): libGL-devel
  86. # Requires(post): libGLU-devel
  87. Requires(post): libmusicbrainz-devel
  88. Requires(post): lua-devel
  89. ##!! Requires(post): minizip-devel
  90. ##!! Requires(post): mpeg2dec-devel >= 0.3.2
  91. %if %with_ncurses
  92. Requires(post): ncurses-devel
  93. %endif
  94. ##!! Requires(post): opencv-devel
  95. Requires(post): openslp-devel
  96. Requires(post): pcre-devel
  97. Requires(post): pulseaudio-libs-devel >= 0.9.8
  98. ##!! Requires(post): portaudio-devel
  99. Requires(post): qt4-devel >= 4.5.2
  100. ##!! Requires(post): schroedinger-devel
  101. Requires(post): SDL_image-devel
  102. Requires(post): speex-devel >= 1.1.5
  103. Requires(post): taglib-devel
  104. Requires(post): twolame-devel
  105. Requires(post): vcdimager-devel >= 0.7.21
  106. Requires(post): zlib-devel
  107. ##!! Requires(post): zvbi-devel
  108. # X-libs
  109. Requires(post): libXt-devel
  110. Requires(post): libXv-devel
  111. Requires(post): libXxf86vm-devel
  112. Requires(post): libX11-devel
  113. Requires(post): libXext-devel
  114. Requires(post): libXpm-devel
  115. Requires(post): libXvMC-devel
  116. Requires(post): xcb-util-devel
  117. Requires(post): xorg-x11-proto-devel
  118. Requires(post): pulseaudio-libs-devel >= 0.9.8
  119. %if %with_mozilla
  120. Requires(post): gecko-devel
  121. Requires(post): nspr-devel
  122. %endif
  123. Requires: TrueType-dejavu
  124. ## vine
  125. Requires(post): libgcrypt-devel
  126. Requires(post): wxGTK-devel
  127. Requires(post): mesa-libGL
  128. Requires(post): xorg-x11-devel
  129. Requires(post): mesa-libGL-devel
  130. Requires(post): self-build-libmpeg2
  131. Requires(post): self-build-a52dec
  132. Requires(post): self-build-faac
  133. Requires(post): self-build-faad2
  134. Requires(post): self-build-ffmpeg >= 2.4.0
  135. Requires(post): self-build-libdca
  136. Requires(post): self-build-libdvbpsi >= 1.0.0
  137. Requires(post): self-build-libmad
  138. Requires(post): self-build-x264 >= 0.136
  139. Requires(post): self-build-xvidcore
  140. BuildArch: noarch
  141. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  142. Packager: munepi
  143. %description
  144. VLC (initially VideoLAN Client) is a highly portable multimedia player
  145. for various audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX,
  146. mp3, ogg, ...) as well as DVDs, VCDs, and various streaming protocols.
  147. It can also be used as a server to stream in unicast or multicast in
  148. IPv4 or IPv6 on a high-bandwidth network.
  149. [Note]
  150. This package requires many other packages to compile
  151. targetsoftware. So it consume more disk space than usual.
  152. Also installation takes logner time because of compilation.
  153. (This will take a few minutes to quarter or half of an hour,
  154. depends on building environment)
  155. [About self-build package]
  156. For some kind of software, distributing of binary package
  157. may viorate the patent or law. Therefore we chose self-build
  158. packge, create binary package on your machine, for such kind
  159. of softwares instead of distributing binary package.
  160. Please obey the national law when you use the created binary
  161. packages. And if you want to use the softwares using patented
  162. thechnology, it may be required to get a permission, make an
  163. agreement or purchas a license. Please consider it with your
  164. purpose or way of use and take appropriate action.
  165. %description -l ja
  166. VLC(初期は VideoLAN Client)は高い可搬性のあるマルチメディアプレーヤーで,
  167. 様々なオーディオおよびビデオフォーマット(MPEG-1, MPEG-2, MPEG-4, DivX,
  168. mp3, ogg など)だけでなく,DVD や VCD,様々なストリーミングプロトコルにも
  169. 対応しています.
  170. また,高帯域幅上の IPv4 や IPv6 で,
  171. ユニキャストやマルチキャストのストリームに,
  172. サーバーとして使用することもできます.
  173. このパッケージをインストールすると、自動的にソースコードを
  174. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  175. の rpm パッケージを作成します。
  176. また apt-get コマンドや synaptic パッケージマネージャから実行
  177. した場合は、作成された rpm パッケージのインストールも自動的に
  178. 行います。
  179. [注意]
  180. コンパイルに必要な多くの関連パッケージを要求するので通常より
  181. ディスクの領域を多く消費します。
  182. またインストール時にコンパイルを行うため、通常より時間がかか
  183. る場合があります。(環境にもよりますが数分から数十分程度)
  184. [self-build パッケージについて]
  185. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  186. 違反する可能性があるものがあります。その為、このような問題が
  187. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  188. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  189. ジという方法を採っています。
  190. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  191. アのライセンス、および利用する国の各種法令に従ってください。
  192. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  193. センスの購入などが必要となる場合がありますので、利用する目的
  194. や形態に応じて各自で判断し適切な対応を取ってください。
  195. %prep
  196. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  197. %install
  198. %{__rm} -rf ${RPM_BUILD_ROOT}
  199. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  200. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  201. %clean
  202. %{__rm} -rf ${RPM_BUILD_ROOT}
  203. %posttrans
  204. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl0} 794000
  205. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  206. %{pkgname}-devel-%{version}-%{release}
  207. %files
  208. %defattr(-,root,root)
  209. %{_datadir}/%{name}
  210. %changelog
  211. * Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.2-2
  212. - rebuild with libcdio-0.93
  213. * Mon Feb 8 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.2-1
  214. - new upstream release
  215. * Sat Jan 23 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.1-4
  216. - rebuilt
  217. * Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.1-3
  218. - rebuild with gnutls-3.4.7
  219. * Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.1-2
  220. - rebuilt
  221. * Sun Apr 19 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.1-1
  222. - new upstream release
  223. * Sun Apr 12 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.0-4
  224. - new upstream release
  225. * Mon Mar 9 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.0-3.rc2
  226. - rebuild
  227. * Sat Feb 21 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.0-2.rc2
  228. - rebuild
  229. * Fri Jan 2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.0-1.rc2
  230. - updated to 2.2.0-rc2
  231. * Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.2-2
  232. - remove Requires(post): xosd-devel
  233. * Sat Dec 14 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.1.2-1
  234. - new upstream release
  235. * Wed Oct 2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.1.0-2
  236. - added Obsoletes: vlc < %{version}-%{release}, vlc-devel < %{version}-%{release}
  237. * Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.1.0-1
  238. - new upstream release
  239. - built with new x264 (ABI 0.136) and ffmpeg (1.2.x)
  240. * Wed Jul 3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.7-1
  241. - new upstream release
  242. * Tue Apr 30 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.6-1
  243. - new upstream release
  244. * Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.5-2
  245. - rebuilt with new x264 (ABI 0.129) and ffmpeg (1.1.x)
  246. * Mon Jan 14 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.5-1
  247. - new upstream release
  248. * Wed Nov 7 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.4-1
  249. - new upstream release
  250. * Fri Aug 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.3-1
  251. - new upstream release
  252. - s/wx-gtk2/wxGTK/g
  253. * Sat Jun 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.2-1
  254. - new upstream release
  255. * Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.1-1
  256. - new upstream release
  257. - dropped DC1394 and DV
  258. * Tue Jan 3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.13-1
  259. - new upstream release
  260. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.12-3
  261. - rebuilt with new x264 and ffmpeg
  262. * Wed Nov 2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.12-2
  263. - s/self-build-libmp4v2/libmp4v2/
  264. - s/self-build-libdvdnav/libdvdnav/
  265. * Sat Oct 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.12-1
  266. - new upstream release
  267. * Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.11-2
  268. - dropped Requires(post): svga-devel
  269. - added BuildArch: noarch
  270. * Thu Jul 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.11-1
  271. - new upstream release
  272. * Fri Jun 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.10-1
  273. - new upstream release
  274. - backport from 1.1-bugfix from RPM Fusion development
  275. * Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.9-2
  276. - added Requires(post): unzip
  277. * Sun Apr 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.9-1
  278. - new upstream release
  279. - applied vlc_patch_0.02/vlc118.diff in up0617.zip on 2sen.dip.jp/dtv
  280. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.8-1
  281. - new upstream release
  282. - added Requires(post):
  283. - libcddb-devel
  284. - libdc1394-devel >= 2.1.0
  285. - libmodplug-devel
  286. - libproxy-devel
  287. - librtmp-devel
  288. - libssh2-devel
  289. - libudev-devel >= 142
  290. - pcre-devel
  291. - vcdimager-devel >= 0.7.21
  292. - xcb-util-devel
  293. * Sat Feb 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.7-1
  294. - new upstream release
  295. - dropped upstreamed patches
  296. - applied a reverted patch to pulse.c for vl5
  297. * Sat Feb 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.6-2
  298. - backport lirc and signal fixes
  299. * Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.6-1
  300. - new upstream release
  301. - dropped temporarily BuildRequires: lirc
  302. - added BuildRequires: libass-devel as the tag Requires(post)
  303. * Sun Nov 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.5-1
  304. - new upstream release
  305. * Mon Aug 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.4-1
  306. - new upstream release
  307. * Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.2-1
  308. - new upstream release
  309. * Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.0-2
  310. - for only vl6, supported libva
  311. - set Obsoletes: vlc < 1.1.0 vlc-devel < 1.1.0
  312. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.0-1
  313. - new upstream release
  314. - added Requires(post): libva-devel
  315. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-3
  316. - renamed %%{Source0} to vlc-vl.spec
  317. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-2
  318. - added Requires(post): libsmbclient-devel
  319. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-1
  320. - new upstream release
  321. * Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-2
  322. - built with libdvbpsi-devel
  323. - dropped 0002-Default-aout-for-pulse.patch
  324. * Tue Jan 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-1
  325. - new upstream release
  326. - updated 0002-Default-aout-for-pulse.patch
  327. * Tue Nov 10 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-2
  328. - added Requires(post): libmtp-devel
  329. * Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-1
  330. - new upstream release
  331. * Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.2-2
  332. - rebuilt to add signature
  333. * Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.2-1
  334. - new upstream release
  335. - applied vlc-1.0.2-compiler.patch from RPM Fusion
  336. - added Requires(post): lua-devel
  337. * Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1
  338. - new upstream release
  339. * Sat Jul 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-2
  340. - added Obsoletes: vlc < 1.0.0, vlc-devel < 1.0.0
  341. * Wed Jul 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-1
  342. - new upstream release
  343. - clean-up some old patches and merged some patches from RPM Fusion package
  344. - added vlc-trunk-default_font-vine.patch
  345. - added vlc-handlers.schemas
  346. - Gonf2 url-handler support
  347. - added shine.c, enc_base.h
  348. - missing sources
  349. - check version between original spec and self-build spec in %%prep
  350. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.9a-3
  351. - dropped BuildArch: noarch (with svglib-devel for %%{ix86} x86_64)
  352. * Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.9a-2
  353. - rebuild with x264 >= 0.0.0-9.20090522
  354. - avoided to execute self-build-rpm.sh on RPM transaction
  355. - moved %%post actions to %%posttrans
  356. * Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.9a-1
  357. - new upstream release
  358. - added BuildArch: noarch
  359. - s/TrueType-DejaVu/TrueType-dejavu/
  360. * Sat Feb 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.8a-7
  361. - corrected release number in vlc.spec
  362. - dropped ExclusiveArch
  363. * Fri Feb 13 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.9.8a-6
  364. - add ppc to ExclusiveArch
  365. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.8a-5
  366. - changed to PreReq: self-build-faad2 from faad2-devel
  367. - changed to PreReq: self-build-libmad from libmad-devel
  368. * Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.8a-4
  369. - initial build
  370. ### end of file