libmad-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152
  1. # -*- coding: utf-8-unix -*-
  2. Summary: MPEG audio decoder library.
  3. Summary(ja): MPEG オーディオ復号化ライブラリ
  4. Name: libmad
  5. Version: 0.15.1b
  6. Release: 7%{?_dist_release}
  7. Group: System Environment/Libraries
  8. #Source: ftp://ftp.mars.org/pub/mpeg/%{name}-%{version}.tar.gz
  9. Source: http://prdownloads.sourceforge.net/mad/%{name}-%{version}.tar.gz
  10. URL: http://www.underbit.com/products/mad/
  11. License: GPL
  12. Buildroot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: gcc-c++
  14. Provides: mad = %{version}-%{release}
  15. %description
  16. MAD (libmad) is a high-quality MPEG audio decoder. It currently supports
  17. MPEG-1 and the MPEG-2 extension to Lower Sampling Frequencies, as well as
  18. the so-called MPEG 2.5 format. All three audio layers (Layer I, Layer II,
  19. and Layer III a.k.a. MP3) are fully implemented.
  20. MAD does not yet support MPEG-2 multichannel audio (although it should be
  21. backward compatible with such streams) nor does it currently support AAC.
  22. %package devel
  23. Summary: Header and library for developing programs that will use libmad.
  24. Summary(ja): labmad を使うプログラムを開発するためのライブラリ
  25. Group: Development/Libraries
  26. Requires: %{name} = %{version}
  27. %description devel
  28. MAD (libmad) is a high-quality MPEG audio decoder. It currently supports
  29. MPEG-1 and the MPEG-2 extension to Lower Sampling Frequencies, as well as
  30. the so-called MPEG 2.5 format. All three audio layers (Layer I, Layer II,
  31. and Layer III a.k.a. MP3) are fully implemented.
  32. This package contains the header file as well as the static library needed
  33. to develop programs that will use libmad for mpeg audio decoding.
  34. %prep
  35. %setup -q
  36. %__sed -i -e /-fforce-mem/d configure* # -fforce-mem gone in gcc 4.2, noop earlier
  37. touch -r aclocal.m4 configure.ac NEWS AUTHORS ChangeLog
  38. %__cat << EOF > mad.pc
  39. prefix=%{_prefix}
  40. exec_prefix=%{_prefix}
  41. libdir=%{_libdir}
  42. includedir=%{_includedir}
  43. Name: mad
  44. Description: MPEG Audio Decoder
  45. Requires:
  46. Version: %{version}
  47. Libs: -L%{_libdir} -lmad -lm
  48. Cflags: -I%{_includedir}
  49. EOF
  50. %build
  51. %configure \
  52. --enable-accuracy \
  53. --disable-debugging \
  54. --disable-static
  55. %__make %{?_smp_mflags} CPPFLAGS="$RPM_OPT_FLAGS"
  56. %install
  57. %__rm -rf $RPM_BUILD_ROOT
  58. %__make install DESTDIR=$RPM_BUILD_ROOT
  59. %__rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  60. %{__install} -D -p -m 0644 mad.pc %{buildroot}%{_libdir}/pkgconfig/mad.pc
  61. touch -r mad.h.sed %{buildroot}/%{_includedir}/mad.h
  62. %clean
  63. %__rm -rf %{buildroot}
  64. %post -p /sbin/ldconfig
  65. %postun -p /sbin/ldconfig
  66. %files
  67. %defattr(-, root, root)
  68. %doc CHANGES COPYING COPYRIGHT CREDITS README TODO
  69. %{_libdir}/*.so.*
  70. %files devel
  71. %defattr(-, root, root)
  72. %{_libdir}/*.so
  73. %{_libdir}/pkgconfig/*.pc
  74. %{_includedir}/*
  75. %changelog
  76. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.15.1b-7
  77. - change release to sync with self-build-libmad
  78. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.15.1b-6
  79. - rebuild with new toolchain
  80. * Mon Sep 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.15.1b-5
  81. - changed Source0: to http://prdownloads.sourceforge.net/mad
  82. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.15.1b-4
  83. - change release to sync with self-build-libmad
  84. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.15.1b-3
  85. - added %%configure options: --disable-static
  86. * Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 0.15.1b-2vl5
  87. - applied new versioning policy, spec in utf-8
  88. * Thu Jan 03 2007 Satoshi MACHINO <machino@vinelinux.org> 0.15.1b-1vl2
  89. - rebuilt on new toolchain
  90. * Thu Mar 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.15.1b-1vl1
  91. - Build for Vine Linux based on freshrpms
  92. - add Japanese summary
  93. - add %post and %postun script
  94. * Thu Feb 19 2004 Matthias Saou <http://freshrpms.net/> - 0.15.1b-1.fr
  95. - Update to 0.15.1b.
  96. * Sun Nov 2 2003 Matthias Saou <http://freshrpms.net/> - 0.15.0b-3.fr
  97. - Rebuild for Fedora Core 1.
  98. * Thu Aug 28 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  99. - Added mad.pc required by gstreamer-plugins.
  100. * Mon Mar 31 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  101. - Update to 0.15.0b.
  102. - Split a devel package.
  103. * Mon Mar 31 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  104. - Rebuilt for Red Hat Linux 9.
  105. - Added mad provides.
  106. * Fri Sep 27 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  107. - Rebuild for Red Hat Linux 8.0 (missing because of license issues).
  108. - Spec file cleanup.
  109. * Tue Mar 12 2002 Bill Nottingham <notting@redhat.com> 0.14.2b-3
  110. - ship libid3tag too
  111. * Thu Feb 21 2002 Bill Nottingham <notting@redhat.com>
  112. - rebuild
  113. * Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
  114. - split libmad off into a separate package