self-build-libdvbpsi-vl.spec 4.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127
  1. %define pkgname libdvbpsi
  2. %define name self-build-%{pkgname}
  3. %define version 1.2.0
  4. %define release 1%{?_dist_release}
  5. %define sourceurl0 http://download.videolan.org/pub/libdvbpsi/%{version}/%{pkgname}-%{version}.tar.bz2
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Source0: %{pkgname}-vl.spec
  12. License: LGPLv2+
  13. Group: Restricted Software
  14. # Requires(posttrans) not yet implemented. So we use (post) instead.
  15. Requires(post): self-build-setup >= 0.9.9
  16. Requires(post): graphviz
  17. #Requires(post): doxygen
  18. BuildArch: noarch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. Packager: munepi
  21. %description
  22. libdvbpsi is a very simple and fully portable library designed for
  23. MPEG TS and DVB PSI table decoding and generation.
  24. If you install this package, it automaticaly downloads source
  25. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  26. And the created rpm packages are automatically installed
  27. if installation is executed by apt-get command or synaptic
  28. package manager.
  29. [Note]
  30. This package requires many other packages to compile
  31. targetsoftware. So it consume more disk space than usual.
  32. Also installation takes logner time because of compilation.
  33. (This will take a few minutes to quarter or half of an hour,
  34. depends on building environment)
  35. [About self-build package]
  36. For some kind of software, distributing of binary package
  37. may viorate the patent or law. Therefore we chose self-build
  38. packge, create binary package on your machine, for such kind
  39. of softwares instead of distributing binary package.
  40. Please obey the national law when you use the created binary
  41. packages. And if you want to use the softwares using patented
  42. thechnology, it may be required to get a permission, make an
  43. agreement or purchas a license. Please consider it with your
  44. purpose or way of use and take appropriate action.
  45. %description -l ja
  46. libdvbpsi は MPEG TS と DVB PSI テーブル復号と生成のために設計された
  47. とても単純で完全な汎用ライブラリです。
  48. このパッケージをインストールすると、自動的にソースコードを
  49. ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
  50. パッケージを作成します。
  51. また apt-get コマンドや synaptic パッケージマネージャから実行
  52. した場合は、作成された rpm パッケージのインストールも自動的に
  53. 行います。
  54. [注意]
  55. コンパイルに必要な多くの関連パッケージを要求するので通常より
  56. ディスクの領域を多く消費します。
  57. またインストール時にコンパイルを行うため、通常より時間がかか
  58. る場合があります。(環境にもよりますが数分から数十分程度)
  59. [self-build パッケージについて]
  60. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  61. 違反する可能性があるものがあります。その為、このような問題が
  62. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  63. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  64. ジという方法を採っています。
  65. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  66. アのライセンス、および利用する国の各種法令に従ってください。
  67. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  68. センスの購入などが必要となる場合がありますので、利用する目的
  69. や形態に応じて各自で判断し適切な対応を取ってください。
  70. %prep
  71. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  72. %install
  73. %{__rm} -rf ${RPM_BUILD_ROOT}
  74. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  75. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  76. %clean
  77. %{__rm} -rf ${RPM_BUILD_ROOT}
  78. %posttrans
  79. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 92000
  80. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  81. %{pkgname}-devel-%{version}-%{release}
  82. %files
  83. %defattr(-,root,root)
  84. %{_datadir}/%{name}
  85. %changelog
  86. * Fri Jan 2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.0-1
  87. - new upstream release
  88. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.2.2-1
  89. - updated to 0.2.2
  90. - Switch to LGPLv2+
  91. - dropped BuildRequires: doxygen
  92. * Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.1.7-1
  93. - updated to 0.1.7
  94. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.1.6-2
  95. - renamed %%{Source0} to libdvbpsi-vl.spec
  96. * Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.1.6-1
  97. - initial bulid for self-build