self-build-k9copy-vl.spec 6.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185
  1. %define pkgname k9copy
  2. %define name self-build-%{pkgname}
  3. %define version 2.3.8
  4. %define release 1%{?_dist_release}
  5. %define sourceurl0 http://prdownloads.sourceforge.net/%{pkgname}/%{pkgname}-%{version}-Source.tar.gz
  6. %define _kde4_bindir %{_bindir}
  7. %define _kde4_iconsdir %{_datadir}/icons
  8. %define _kde4_datadir %{_datadir}
  9. %define _kde4_docdir %{_datadir}/doc
  10. %define _kde4_appsdir %{_datadir}/kde4/apps
  11. %define _qt4_qmake %{_libdir}/qt4/bin/qmake
  12. Summary: Package to automatically build %{pkgname} rpm package
  13. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  14. Name: %{name}
  15. Version: %{version}
  16. Release: %{release}
  17. Obsoletes: k9copy < 2.0.0
  18. Obsoletes: self-build-k9copy < 2.0.0
  19. Source0: %{pkgname}-vl.spec
  20. ## vine
  21. Source100: k9copy-2.3.5-ja.po
  22. # upstreamable patches
  23. #Source151: k9copy-2.3.5-dso.patch
  24. #Source152: k9copy-2.3.5-mimetype.patch
  25. License: GPLv2+
  26. Group: Restricted Software
  27. Requires(post): self-build-setup >= 0.9.0
  28. Requires(post): qt4-devel
  29. Requires(post): cmake
  30. Requires(post): desktop-file-utils
  31. Requires(post): self-build-ffmpeg
  32. Requires(post): gettext
  33. Requires(post): hal-devel
  34. Requires(post): kdelibs4-devel >= 4.4.3
  35. Requires(post): libdvdread-devel
  36. Requires(post): self-build-libmpeg2
  37. Requires(post): pkgconfig
  38. Requires(post): xine-lib-devel
  39. Requires: dvd+rw-tools
  40. Requires: dvdauthor
  41. Requires: kdebase-runtime >= 4.4.3
  42. ##
  43. Requires(post): self-build-mplayer
  44. BuildArch: noarch
  45. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  46. Packager: munepi
  47. %description
  48. Video DVD backup and creation program, features include:
  49. * Video stream compression for fit onto a single layer 4.7GB DVD
  50. * DVD Burning
  51. * Creation of ISO images
  52. * Audio tracks and subtitle selection
  53. * Video title preview
  54. * Preservation of the original menus
  55. If you install this package, it automaticaly downloads source
  56. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  57. And the created rpm packages are automatically installed
  58. if installation is executed by apt-get command or synaptic
  59. package manager.
  60. [Note]
  61. This package requires many other packages to compile
  62. targetsoftware. So it consume more disk space than usual.
  63. Also installation takes logner time because of compilation.
  64. (This will take a few minutes to quarter or half of an hour,
  65. depends on building environment)
  66. [About self-build package]
  67. For some kind of software, distributing of binary package
  68. may viorate the patent or law. Therefore we chose self-build
  69. packge, create binary package on your machine, for such kind
  70. of softwares instead of distributing binary package.
  71. Please obey the national law when you use the created binary
  72. packages. And if you want to use the softwares using patented
  73. thechnology, it may be required to get a permission, make an
  74. agreement or purchas a license. Please consider it with your
  75. purpose or way of use and take appropriate action.
  76. %description -l ja
  77. ビデオDVDバックアップと作成プログラム。
  78. 特徴は:
  79. * 片面一層4.7GB DVDへ収めるためのビデオストリーム圧縮
  80. * DVD書き込み
  81. * ISOイメージの作成
  82. * オーディオトラックとサブタイトル選択
  83. * ビデオタイトルプレビュー
  84. * オリジナルのメニューの保存
  85. このパッケージをインストールすると、自動的にソースコードを
  86. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  87. の rpm パッケージを作成します。
  88. また apt-get コマンドや synaptic パッケージマネージャから実行
  89. した場合は、作成された rpm パッケージのインストールも自動的に
  90. 行います。
  91. [注意]
  92. コンパイルに必要な多くの関連パッケージを要求するので通常より
  93. ディスクの領域を多く消費します。
  94. またインストール時にコンパイルを行うため、通常より時間がかか
  95. る場合があります。(環境にもよりますが数分から数十分程度)
  96. [self-build パッケージについて]
  97. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  98. 違反する可能性があるものがあります。その為、このような問題が
  99. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  100. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  101. ジという方法を採っています。
  102. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  103. アのライセンス、および利用する国の各種法令に従ってください。
  104. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  105. センスの購入などが必要となる場合がありますので、利用する目的
  106. や形態に応じて各自で判断し適切な対応を取ってください。
  107. %prep
  108. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  109. %install
  110. %{__rm} -rf ${RPM_BUILD_ROOT}
  111. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  112. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  113. %{__install} -m 644 \
  114. %{SOURCE100} \
  115. ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  116. %clean
  117. %{__rm} -rf ${RPM_BUILD_ROOT}
  118. %posttrans
  119. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 71000
  120. %files
  121. %defattr(-,root,root)
  122. %{_datadir}/%{name}/*
  123. %changelog
  124. * Tue Apr 3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.3.8-1
  125. - new upstream release
  126. - dropped upstreamed/unused patches
  127. * Sun May 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.3.7-1
  128. - new upstream release
  129. * Sat Aug 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.3.6-1
  130. - new upstream release
  131. * Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.3.5-1
  132. - new upstream release
  133. - added k9copy-2.3.5-ja.po
  134. - check version between original spec and self-build spec in %%prep
  135. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.4-4
  136. - added Requires(post): arts-devel
  137. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.4-3
  138. - added BuildArch: noarch
  139. - avoided to execute self-build-rpm.sh on RPM transaction
  140. - moved %%post actions to %%posttrans
  141. * Sat Jan 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.4-2
  142. - initial build
  143. ### end of file