self-build-k3b-extra-vl.spec 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135
  1. %define pkgname k3b-extra
  2. Summary: Package to automatically build %{pkgname} rpm package
  3. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  4. Name: self-build-%{pkgname}
  5. Version: 2.0.3a
  6. Release: 1%{?_dist_release}
  7. Source0: %{pkgname}-vl.spec
  8. %define sourceurl0 http://download.kde.org/stable/k3b/k3b-%{version}.tar.xz
  9. License: GPLv2+
  10. Group: Restricted Software
  11. Requires(post): self-build-setup >= 0.8
  12. Requires(post): self-build-ffmpeg
  13. Requires(post): self-build-lame
  14. Requires(post): self-build-libmad
  15. Requires(post): gettext
  16. Requires(post): kdelibs4-devel
  17. Requires(post): libkcddb-devel
  18. Requires(post): libsamplerate-devel
  19. Requires(post): libXpm-devel
  20. Requires(post): taglib-devel
  21. Requires: k3b >= %{version}
  22. BuildArch: noarch
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. Packager: inagaki
  27. %description
  28. This package contains additional plugins for K3b.
  29. - FFMpeg decoder for decoding WMA file(s)
  30. - MAD decoder for decoding MP3 file(s)
  31. - Lame MP3 encoder for encoding MP3 file(s)
  32. If you install this package, it automaticaly downloads source
  33. code ,compile it, and create rpm packages of k3b-extra.
  34. And the created rpm packages are automatically installed
  35. if installation is executed by apt-get command or synaptic
  36. package manager.
  37. [Note]
  38. This package requires many other packages to compile
  39. targetsoftware. So it consume more disk space than usual.
  40. Also installation takes logner time because of compilation.
  41. (This will take a few minutes to quarter or half of an hour,
  42. depends on building environment)
  43. [About self-build package]
  44. For some kind of software, distributing of binary package
  45. may viorate the patent or law. Therefore we chose self-build
  46. packge, create binary package on your machine, for such kind
  47. of softwares instead of distributing binary package.
  48. Please obey the national law when you use the created binary
  49. packages. And if you want to use the softwares using patented
  50. thechnology, it may be required to get a permission, make an
  51. agreement or purchas a license. Please consider it with your
  52. purpose or way of use and take appropriate action.
  53. %description -l ja
  54. K3b 向けに以下の追加プラグインを提供します.
  55. - WMA ファイルをデコードするための FFMpeg デコーダ
  56. - MP3 ファイルをデコードするための MAD デコーダ
  57. - MP3 ファイルをエンコードするための Lame MP3 エンコーダ
  58. このパッケージをインストールすると、自動的にソースコードを
  59. ダウンロードしてコンパイルし、k3b-extra の rpm パッケージを作成します。
  60. また apt-get コマンドや synaptic パッケージマネージャから実行
  61. した場合は、作成された rpm パッケージのインストールも自動的に
  62. 行います。
  63. [注意]
  64. コンパイルに必要な多くの関連パッケージを要求するので通常より
  65. ディスクの領域を多く消費します。
  66. またインストール時にコンパイルを行うため、通常より時間がかか
  67. る場合があります。(環境にもよりますが数分から数十分程度)
  68. [self-build パッケージについて]
  69. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  70. 違反する可能性があるものがあります。その為、このような問題が
  71. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  72. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  73. ジという方法を採っています。
  74. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  75. アのライセンス、および利用する国の各種法令に従ってください。
  76. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  77. センスの購入などが必要となる場合がありますので、利用する目的
  78. や形態に応じて各自で判断し適切な対応を取ってください。
  79. %prep
  80. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  81. %install
  82. %{__rm} -rf ${RPM_BUILD_ROOT}
  83. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  84. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  85. %clean
  86. %{__rm} -rf ${RPM_BUILD_ROOT}
  87. %posttrans
  88. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}"
  89. %files
  90. %defattr(-,root,root)
  91. %{_datadir}/%{name}
  92. %changelog
  93. * Sat Jan 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.0.3a-1
  94. - new upstream release
  95. * Fri Mar 4 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.2-2
  96. - added BR: libXpm-devel
  97. * Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.2-1
  98. - new upstream release
  99. * Sun Sep 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-2
  100. - fixed %%build section to remove qt-devel dependency
  101. * Wed Sep 8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-1
  102. - new upstream release
  103. * Thu Jul 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-1
  104. - initial bulid for Vine Linux