self-build-gstreamer-plugins-ugly-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191
  1. %define pkgname gstreamer-plugins-ugly
  2. %define major 0.10
  3. %define _gst_ver 0.10.26
  4. %define _gstpb_ver 0.10.26
  5. %define version 0.10.19
  6. %define release 3%{?_dist_release}
  7. %define sourceurl http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.bz2
  8. Summary: Package to automatically build %{pkgname} rpm package
  9. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  10. Name: self-build-%{pkgname}
  11. Version: %{version}
  12. Release: %{release}
  13. Source0: %{pkgname}-vl.spec
  14. Source101: gstreamer-plugins-ugly-x264.patch
  15. Source102: gstreamer-plugins-ugly-libcdio-0.92.patch
  16. License: LGPLv2+
  17. Group: Restricted Software
  18. Requires(post): self-build-setup >= 0.9.9
  19. # (build)requies of target package.
  20. Requires(post): libogg-devel, libtheora-devel, libvorbis-devel
  21. Requires(post): gstreamer-devel >= %{_gst_ver}
  22. Requires(post): gstreamer-plugins-base-devel >= %{_gstpb_ver}
  23. #Requires(post): gtk-doc >= 1.3
  24. Requires(post): python >= 2.1, python-pyxml
  25. Requires(post): glib2-devel >= 2.6
  26. Requires(post): twolame-devel
  27. Requires(post): liboil-devel >= 0.3.0
  28. Requires(post): libcdio-devel >= 0.82
  29. Requires(post): libdvdread-devel
  30. Requires(post): PyXML
  31. Requires(post): self-build-libmad >= 0.15
  32. Requires(post): libid3tag-devel >= 0.15
  33. Requires(post): self-build-ffmpeg
  34. Requires(post): self-build-x264
  35. Requires(post): self-build-libmpeg2
  36. Requires(post): self-build-a52dec
  37. Requires(post): self-build-lame
  38. Requires(post): self-build-libmad
  39. BuildArch: noarch
  40. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  41. Packager: munepi
  42. %description
  43. gstreamer-plugins-ugly is a set of ugly plugins for Gstreamer
  44. streaming-media framework.
  45. If you install this package, it automaticaly downloads source
  46. code, compile it, and create rpm packages of
  47. %{pkgname}-%{version}.
  48. And the created rpm packages are automatically installed
  49. if installation is executed by apt-get command or synaptic
  50. package manager.
  51. [Note]
  52. This package requires many other packages to compile
  53. targetsoftware. So it consume more disk space than usual.
  54. Also installation takes logner time because of compilation.
  55. (This will take a few minutes to quarter or half of an hour,
  56. depends on building environment)
  57. [About self-build package]
  58. For some kind of software, distributing of binary package
  59. may viorate the patent or law. Therefore we chose self-build
  60. packge, create binary package on your machine, for such kind
  61. of softwares instead of distributing binary package.
  62. Please obey the national law when you use the created binary
  63. packages. And if you want to use the softwares using patented
  64. thechnology, it may be required to get a permission, make an
  65. agreement or purchas a license. Please consider it with your
  66. purpose or way of use and take appropriate action.
  67. %description -l ja
  68. gstreamer-plugins-ugly は GStreamer ストリーミングメディア
  69. フレームワーク用 ugly プラグイン集です。
  70. このパッケージをインストールすると、自動的にソースコードを
  71. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  72. の rpm パッケージを作成します。
  73. また apt-get コマンドや synaptic パッケージマネージャから実行
  74. した場合は、作成された rpm パッケージのインストールも自動的に
  75. 行います。
  76. [注意]
  77. コンパイルに必要な多くの関連パッケージを要求するので通常より
  78. ディスクの領域を多く消費します。
  79. またインストール時にコンパイルを行うため、通常より時間がかか
  80. る場合があります。(環境にもよりますが数分から数十分程度)
  81. [self-build パッケージについて]
  82. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  83. 違反する可能性があるものがあります。その為、このような問題が
  84. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  85. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  86. ジという方法を採っています。
  87. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  88. アのライセンス、および利用する国の各種法令に従ってください。
  89. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  90. センスの購入などが必要となる場合がありますので、利用する目的
  91. や形態に応じて各自で判断し適切な対応を取ってください。
  92. %prep
  93. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  94. %install
  95. %{__rm} -rf ${RPM_BUILD_ROOT}
  96. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  97. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  98. %{__install} -m 644 %{SOURCE101} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  99. %{__install} -m 644 %{SOURCE102} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  100. %clean
  101. %{__rm} -rf ${RPM_BUILD_ROOT}
  102. %posttrans
  103. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 83000
  104. %files
  105. %defattr(-,root,root)
  106. %{_datadir}/%{name}
  107. %changelog
  108. * Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.19-3
  109. - rebuild with libcdio-0.93
  110. * Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.19-2
  111. - rebuild with libcdio-0.92
  112. - add Source102 (gstreamer-plugins-ugly-libcdio-0.92.patch)
  113. * Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
  114. - new upstream relase
  115. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
  116. - new upstream relase
  117. - built with new x264
  118. - License: LGPLv2+
  119. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
  120. - new upstream relase
  121. * Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.16-1
  122. - new upstream relase
  123. * Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.15-1
  124. - new upstream relase
  125. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
  126. - new upstream relase
  127. - renamed %%{Source0} to gstreamer-plugins-ugly-vl.spec
  128. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
  129. - new upstream relase
  130. * Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
  131. - new upstream relase
  132. - added Requires(post): self-build-libmpeg2
  133. - enable mpeg2dec with libmpeg2-devel in %%configure
  134. - check version between original spec and self-build spec in %%prep
  135. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
  136. - avoided to execute self-build-rpm.sh on RPM transaction
  137. - moved %%post actions to %%posttrans
  138. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
  139. - added BuildArch: noarch
  140. - dropped PreReq: gtk-doc >= 1.3
  141. * Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
  142. - new upstream relase
  143. * Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
  144. - changed to PreReq: self-build-libmad >= 0.15 from libmad-devel
  145. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
  146. - new upstream relase
  147. * Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.8-1
  148. - initial build for Vine Linux.