self-build-gstreamer-plugins-ffmpeg-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174
  1. %define pkgname gstreamer-plugins-ffmpeg
  2. %define name self-build-%{pkgname}
  3. %define version 0.10.13
  4. %define release 2%{?_dist_release}
  5. %define sourceurl0 http://gstreamer.freedesktop.org/src/gst-ffmpeg/gst-ffmpeg-%{version}.tar.bz2
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Source0: %{pkgname}-vl.spec
  12. Source1: gst-ffmpeg-0.10.13_gcc47.patch
  13. License: GPLv2+ and LGPLv2+
  14. Group: Restricted Software
  15. Requires(post): self-build-setup >= 0.9.9
  16. # (build)requies of target package.
  17. Requires: gstreamer >= 0.10.0
  18. Requires: gstreamer-plugins-base >= 0.10.0
  19. Requires(post): gstreamer-devel >= 0.10.0
  20. Requires(post): gstreamer-plugins-base-devel >= 0.10.0
  21. Requires(post): liboil-devel
  22. Requires(post): bzip2-devel
  23. Requires(post): self-build-ffmpeg
  24. BuildArch: noarch
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. Packager: munepi
  27. %description
  28. GStreamer is a streaming media framework, based on graphs of filters which
  29. operate on media data. Applications using this library can do anything
  30. from real-time sound processing to playing videos, and just about anything
  31. else media-related. Its plugin-based architecture means that new data
  32. types or processing capabilities can be added simply by installing new
  33. plugins.
  34. This package provides FFmpeg-based GStreamer plug-ins.
  35. If you install this package, it automaticaly downloads source
  36. code, compile it, and create rpm packages of
  37. %{pkgname}-%{version}.
  38. And the created rpm packages are automatically installed
  39. if installation is executed by apt-get command or synaptic
  40. package manager.
  41. [Note]
  42. This package requires many other packages to compile
  43. targetsoftware. So it consume more disk space than usual.
  44. Also installation takes logner time because of compilation.
  45. (This will take a few minutes to quarter or half of an hour,
  46. depends on building environment)
  47. [About self-build package]
  48. For some kind of software, distributing of binary package
  49. may viorate the patent or law. Therefore we chose self-build
  50. packge, create binary package on your machine, for such kind
  51. of softwares instead of distributing binary package.
  52. Please obey the national law when you use the created binary
  53. packages. And if you want to use the softwares using patented
  54. thechnology, it may be required to get a permission, make an
  55. agreement or purchas a license. Please consider it with your
  56. purpose or way of use and take appropriate action.
  57. %description -l ja
  58. GStreamer はメディアデータ操作用の filter graph をベースにし
  59. たストリーミングメディアフレームワークです。 このライブラリを
  60. 使用すればアプリケーションは、サウンドのリアルタイム処理から
  61. ビデオ再生まで、メディアに関係する全ての機能が利用できます。
  62. また Gstremer はプラグイン方式を採用していることから、新しい
  63. 種類のデータや機能への対応が、プラグインを追加することで簡単
  64. に実現できます。
  65. このパッケージは ffmpeg ベースの GStreamer プラグインを提供し
  66. ます。
  67. このパッケージをインストールすると、自動的にソースコードをダ
  68. ウンロードしてコンパイルし、%{pkgname}-%{version}
  69. の rpm パッケージを作成します。
  70. また apt-get コマンドや synaptic パッケージマネージャから実行
  71. した場合は、作成された rpm パッケージのインストールも自動的に
  72. 行います。
  73. [注意]
  74. コンパイルに必要な多くの関連パッケージを要求するので通常より
  75. ディスクの領域を多く消費します。
  76. またインストール時にコンパイルを行うため、通常より時間がかか
  77. る場合があります。(環境にもよりますが数分から数十分程度)
  78. [self-build パッケージについて]
  79. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  80. 違反する可能性があるものがあります。その為、このような問題が
  81. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  82. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  83. ジという方法を採っています。
  84. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  85. アのライセンス、および利用する国の各種法令に従ってください。
  86. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  87. センスの購入などが必要となる場合がありますので、利用する目的
  88. や形態に応じて各自で判断し適切な対応を取ってください。
  89. %prep
  90. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  91. %install
  92. %{__rm} -rf ${RPM_BUILD_ROOT}
  93. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  94. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  95. %{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  96. %clean
  97. %{__rm} -rf ${RPM_BUILD_ROOT}
  98. %posttrans
  99. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 126000
  100. %files
  101. %defattr(-,root,root)
  102. %{_datadir}/%{name}/*
  103. %changelog
  104. * Tue Oct 22 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.13-2
  105. - added Source1 to build with gcc-4.7 or later.
  106. * Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
  107. - new upstream release
  108. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
  109. - new upstream release
  110. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.11-3
  111. - dropped --with-system-ffmpeg in configure options
  112. (gstreamer-plugins-ffmpeg-vl.spec)
  113. * Sun Feb 06 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.11-2
  114. - added Requires(post): self-build-ffmpeg
  115. - already used system ffmpeg
  116. * Sat Jul 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.11-1
  117. - new upstream release
  118. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.10-1
  119. - new upstream release
  120. - renamed %%{Source0} to gstreamer-plugins-ffmpeg-vl.spec
  121. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.9-1
  122. - new upstream release
  123. * Sun Aug 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.8-1
  124. - new upstream release
  125. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.7-2
  126. - added BuildArch: noarch
  127. - avoided to execute self-build-rpm.sh on RPM transaction
  128. - moved %%post actions to %%posttrans
  129. * Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.7-1
  130. - new upstream release
  131. - corrected %%description
  132. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.6-1
  133. - initial build
  134. ### end of file