gstreamer-plugins-bad-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487
  1. %define majorminor 0.10
  2. %define gstreamer gstreamer
  3. %define gst_minver 0.10.33
  4. %define gstpb_minver 0.10.33
  5. Summary: GStreamer streaming media framework "bad" plug-ins
  6. Name: gstreamer-plugins-bad
  7. Version: 0.10.23
  8. Release: 5%{?_dist_release}
  9. # The freeze and nfs plugins are LGPLv2 (only)
  10. License: LGPLv2+
  11. Group: Applications/Multimedia
  12. URL: http://gstreamer.freedesktop.org/
  13. Source: http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-%{version}.tar.xz
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. Requires: %{gstreamer} >= %{gst_minver}
  16. BuildRequires: %{gstreamer}-devel >= %{gst_minver}
  17. BuildRequires: %{gstreamer}-plugins-base-devel >= %{gstpb_minver}
  18. BuildRequires: check
  19. BuildRequires: gettext
  20. BuildRequires: PyXML
  21. BuildRequires: libXt-devel
  22. BuildRequires: liboil-devel
  23. BuildRequires: libdirectfb-devel
  24. # BuildRequires: self-build-libdca-devel
  25. # BuildRequires: self-build-faac-devel
  26. # BuildRequires: self-build-faad2
  27. BuildRequires: gsm-devel
  28. BuildRequires: libmpcdec-devel
  29. BuildRequires: SDL-devel
  30. #BuildRequires: soundtouch-devel
  31. #BuildRequires: swfdec-devel
  32. #Buildrequires: wavpack-devel
  33. # BuildRequires: self-build-xvidcore-devel
  34. BuildRequires: bzip2-devel
  35. BuildRequires: mesa-libGLU-devel
  36. BuildRequires: neon-devel
  37. BuildRequires: libmms-devel
  38. BuildRequires: libmusicbrainz-devel
  39. #BuildRequires: libcdaudio-devel
  40. BuildRequires: jack-audio-connection-kit-devel
  41. #BuildRequires: mjpegtools-devel
  42. #BuildRequires: nas-devel
  43. # BuildRequires: self-build-x264-devel
  44. #BuildRequires: wildmidi-devel
  45. BuildRequires: libsndfile-devel
  46. #BuildRequires: libmodplug-devel
  47. #BuildRequires: libtimidity-devel
  48. #BuildRequires: gmyth-devel >= 0.4
  49. BuildRequires: libdc1394-devel
  50. BuildRequires: libexif-devel
  51. #BuildRequires: libiptcdata-devel
  52. #BuildRequires: exempi-devel
  53. #BuildRequires: dirac-devel
  54. #BuildRequires: libofa-devel
  55. BuildRequires: libdvdnav-devel
  56. BuildRequires: jasper-devel
  57. BuildRequires: openssl-devel
  58. BuildRequires: twolame-devel
  59. BuildRequires: libvdpau-devel
  60. BuildRequires: librtmp-devel
  61. BuildRequires: libvpx-devel
  62. %description
  63. GStreamer is a streaming media framework, based on graphs of elements which
  64. operate on media data.
  65. This package contains plug-ins that have licensing issues, aren't tested
  66. well enough, or the code is not of good enough quality.
  67. # %package extras
  68. # Summary: Extra GStreamer "bad" plugins (less often used "bad" plugins)
  69. # Group: Applications/Multimedia
  70. # Requires: %{name} = %{version}-%{release}
  71. # %description extras
  72. # GStreamer is a streaming media framework, based on graphs of elements which
  73. # operate on media data.
  74. # gstreamer-plugins-bad contains plug-ins that have licensing issues, aren't
  75. # tested well enough, or the code is not of good enough quality.
  76. # This package (gstreamer-plugins-bad-extras) contains extra "bad" plugins for
  77. # sources (mythtv), sinks (jack, nas) and effects (pitch) which are not used
  78. # very much and require additional libraries to be installed.
  79. %package devel
  80. Summary: Development files for the GStreamer media framework "bad" plug-ins
  81. Group: Development/Libraries
  82. Requires: %{name} = %{version}-%{release}
  83. Requires: gstreamer-plugins-base-devel
  84. %description devel
  85. GStreamer is a streaming media framework, based on graphs of elements which
  86. operate on media data.
  87. This package contains the development files for the plug-ins that have
  88. licensing issues, aren't tested well enough, or the code is not of good
  89. enough quality.
  90. # '
  91. %prep
  92. %setup -q -n gst-plugins-bad-%{version}
  93. sed -i "s|#include <stdafx.h>|#include <libmodplug/stdafx.h>|" ext/modplug/gstmodplug.cc ext/modplug/gstmodplug.cc
  94. %build
  95. %configure \
  96. --enable-debug --disable-static --disable-gtk-doc \
  97. --disable-ladspa --enable-experimental \
  98. --disable-siren --disable-valve --disable-dtmf --disable-autoconvert \
  99. --disable-liveadder \
  100. ;
  101. # Don't use rpath!
  102. %{__sed} -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  103. %{__sed} -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  104. %{__make} %{?_smp_mflags}
  105. %install
  106. %{__rm} -rf %{buildroot}
  107. %{__make} install DESTDIR="%{buildroot}"
  108. %find_lang gst-plugins-bad-%{majorminor}
  109. # Clean out files that should not be part of the rpm.
  110. %{__rm} -f %{buildroot}%{_libdir}/gstreamer-%{majorminor}/*.la
  111. %{__rm} -f %{buildroot}%{_libdir}/*.la
  112. %clean
  113. %{__rm} -rf %{buildroot}
  114. %post -p /sbin/ldconfig
  115. %postun -p /sbin/ldconfig
  116. %files -f gst-plugins-bad-%{majorminor}.lang
  117. %defattr(-,root,root,-)
  118. %doc AUTHORS COPYING README REQUIREMENTS
  119. # %{_bindir}/gst-camera
  120. # %{_bindir}/gst-camera-perf
  121. %{_libdir}/*.so.*
  122. %{_libdir}/gstreamer-%{majorminor}/*.so
  123. #%{_datadir}/gstreamer-0.10/presets/GstX264Enc.prs
  124. #%{_datadir}/gstreamer-%{majorminor}/camera-apps/gst-camera.glade
  125. #%{_datadir}/gstreamer-%{majorminor}/camera-apps/gst-camera.ui
  126. # # Plugins without external dependencies
  127. # %{_libdir}/gstreamer-%{majorminor}/libgstaacparse.so
  128. # %{_libdir}/gstreamer-%{majorminor}/libgstaiffparse.so
  129. # %{_libdir}/gstreamer-%{majorminor}/libgstamrparse.so
  130. # %{_libdir}/gstreamer-%{majorminor}/libgstbayer.so
  131. # %{_libdir}/gstreamer-%{majorminor}/libgstcdxaparse.so
  132. # %{_libdir}/gstreamer-%{majorminor}/libgstdccp.so
  133. # %{_libdir}/gstreamer-%{majorminor}/libgstdeinterlace.so
  134. # %{_libdir}/gstreamer-%{majorminor}/libgstdeinterlace2.so
  135. # %{_libdir}/gstreamer-%{majorminor}/libgstdvdspu.so
  136. # %{_libdir}/gstreamer-%{majorminor}/libgstfestival.so
  137. # %{_libdir}/gstreamer-%{majorminor}/libgstfilter.so
  138. # %{_libdir}/gstreamer-%{majorminor}/libgstflv.so
  139. # %{_libdir}/gstreamer-%{majorminor}/libgstfreeze.so
  140. # %{_libdir}/gstreamer-%{majorminor}/libgsth264parse.so
  141. # %{_libdir}/gstreamer-%{majorminor}/libgstlegacyresample.so
  142. # %{_libdir}/gstreamer-%{majorminor}/libgstrfbsrc.so
  143. # %{_libdir}/gstreamer-%{majorminor}/libgstmpeg4videoparse.so
  144. # %{_libdir}/gstreamer-%{majorminor}/libgstmpegdemux.so
  145. # %{_libdir}/gstreamer-%{majorminor}/libgstmpegtsmux.so
  146. # %{_libdir}/gstreamer-%{majorminor}/libgstmpegvideoparse.so
  147. # %{_libdir}/gstreamer-%{majorminor}/libgstmve.so
  148. # %{_libdir}/gstreamer-%{majorminor}/libgstmxf.so
  149. # %{_libdir}/gstreamer-%{majorminor}/libgstnsf.so
  150. # %{_libdir}/gstreamer-%{majorminor}/libgstnuvdemux.so
  151. # %{_libdir}/gstreamer-%{majorminor}/libgstpcapparse.so
  152. # %{_libdir}/gstreamer-%{majorminor}/libgstqtmux.so
  153. # %{_libdir}/gstreamer-%{majorminor}/libgstrawparse.so
  154. # %ifarch %{ix86} x86_64
  155. # %{_libdir}/gstreamer-%{majorminor}/libgstreal.so
  156. # %endif
  157. # %{_libdir}/gstreamer-%{majorminor}/libgstrtpmanager.so
  158. # %{_libdir}/gstreamer-%{majorminor}/libgstscaletempoplugin.so
  159. # %{_libdir}/gstreamer-%{majorminor}/libgstsdpelem.so
  160. # %{_libdir}/gstreamer-%{majorminor}/libgstselector.so
  161. # %{_libdir}/gstreamer-%{majorminor}/libgstspeed.so
  162. # %{_libdir}/gstreamer-%{majorminor}/libgststereo.so
  163. # %{_libdir}/gstreamer-%{majorminor}/libgstsubenc.so
  164. # %{_libdir}/gstreamer-%{majorminor}/libgsttta.so
  165. # %{_libdir}/gstreamer-%{majorminor}/libgstvideosignal.so
  166. # %{_libdir}/gstreamer-%{majorminor}/libgstvmnc.so
  167. # %{_libdir}/gstreamer-%{majorminor}/libgsty4menc.so
  168. # # System (Linux) specific plugins
  169. # %{_libdir}/gstreamer-%{majorminor}/libgstdvb.so
  170. # %{_libdir}/gstreamer-%{majorminor}/libgstfbdevsink.so
  171. # %{_libdir}/gstreamer-%{majorminor}/libgstoss4audio.so
  172. # %{_libdir}/gstreamer-%{majorminor}/libgstvcdsrc.so
  173. # # Plugins with external dependencies
  174. # %{_libdir}/gstreamer-%{majorminor}/libgstalsaspdif.so
  175. # %{_libdir}/gstreamer-%{majorminor}/libgstapexsink.so
  176. # %{_libdir}/gstreamer-%{majorminor}/libgstbz2.so
  177. # #%{_libdir}/gstreamer-%{majorminor}/libgstcdaudio.so
  178. # #%{_libdir}/gstreamer-%{majorminor}/libgstdc1394.so
  179. # %{_libdir}/gstreamer-%{majorminor}/libgstdfbvideosink.so
  180. # #%{_libdir}/gstreamer-%{majorminor}/libgstdirac.so
  181. # %{_libdir}/gstreamer-%{majorminor}/libgstdtsdec.so
  182. # %{_libdir}/gstreamer-%{majorminor}/libgstfaac.so
  183. # %{_libdir}/gstreamer-%{majorminor}/libgstfaad.so
  184. # %{_libdir}/gstreamer-%{majorminor}/libgstgsm.so
  185. # %{_libdir}/gstreamer-%{majorminor}/libgstjp2k.so
  186. # #%{_libdir}/gstreamer-%{majorminor}/libgstmms.so
  187. # %{_libdir}/gstreamer-%{majorminor}/libgstmetadata.so
  188. # #%{_libdir}/gstreamer-%{majorminor}/libgstmodplug.so
  189. # %{_libdir}/gstreamer-%{majorminor}/libgstmpeg2enc.so
  190. # %{_libdir}/gstreamer-%{majorminor}/libgstmplex.so
  191. # %{_libdir}/gstreamer-%{majorminor}/libgstmusepack.so
  192. # %{_libdir}/gstreamer-%{majorminor}/libgsttrm.so
  193. # %{_libdir}/gstreamer-%{majorminor}/libgstneonhttpsrc.so
  194. # #%{_libdir}/gstreamer-%{majorminor}/libgstofa.so
  195. # %{_libdir}/gstreamer-%{majorminor}/libresindvd.so
  196. # %{_libdir}/gstreamer-%{majorminor}/libgstsdl.so
  197. # %{_libdir}/gstreamer-%{majorminor}/libgstsndfile.so
  198. # #%{_libdir}/gstreamer-%{majorminor}/libgstswfdec.so
  199. # #%{_libdir}/gstreamer-%{majorminor}/libgsttimidity.so
  200. # %{_libdir}/gstreamer-%{majorminor}/libgsttwolame.so
  201. # #%{_libdir}/gstreamer-%{majorminor}/libgstwildmidi.so
  202. # %{_libdir}/gstreamer-%{majorminor}/libgstx264.so
  203. # %{_libdir}/gstreamer-%{majorminor}/libgstxvid.so
  204. # %files extras
  205. # %defattr(-,root,root,-)
  206. # # Plugins with external dependencies
  207. # %{_libdir}/gstreamer-%{majorminor}/libgstjack.so
  208. # #%{_libdir}/gstreamer-%{majorminor}/libgstmythtvsrc.so
  209. # #%{_libdir}/gstreamer-%{majorminor}/libgstnassink.so
  210. # #%{_libdir}/gstreamer-%{majorminor}/libgstsoundtouch.so
  211. %files devel
  212. %defattr(-,root,root,-)
  213. %{_libdir}/*.so
  214. %{_includedir}/gstreamer-%{majorminor}/gst/basecamerabinsrc/*.h
  215. %{_includedir}/gstreamer-%{majorminor}/gst/codecparsers/*.h
  216. %{_includedir}/gstreamer-%{majorminor}/gst/signalprocessor/gstsignalprocessor.h
  217. %{_includedir}/gstreamer-%{majorminor}/gst/video/*
  218. %{_includedir}/gstreamer-%{majorminor}/gst/interfaces/photography*
  219. %{_includedir}/gstreamer-%{majorminor}/gst/vdpau/*
  220. %{_libdir}/pkgconfig/*
  221. %{_datadir}/glib-2.0/schemas/org.freedesktop.gstreamer-0.10.default-elements.gschema.xml
  222. #%doc %{_datadir}/gtk-doc/html/gst-plugins-bad-plugins-0.10
  223. %changelog
  224. * Thu May 05 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.23-5
  225. - rebuild with soundtouch-1.9.2
  226. * Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.23-4
  227. - rebuild with gnutls-3.4.7
  228. * Tue Dec 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.23-3
  229. - rebuild with nettle-3.1.1
  230. * Sun Feb 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.23-2
  231. - fix spec file
  232. * Wed Mar 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.23-1
  233. - update to 0.10.23
  234. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.22-1
  235. - new upstream release
  236. - added BuildRequires: libvpx-devel
  237. * Wed Nov 2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-2
  238. - s/self-build-libdvdnav/libdvdnav/
  239. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-1
  240. - new upstream release
  241. - added BuildRequires:
  242. - libmms-devel
  243. - librtmp-devel
  244. * Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.20-1
  245. - new upstream release
  246. * Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
  247. - new upstream release
  248. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
  249. - new upstream release
  250. - added BuildRequires: libvdpau-devel
  251. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
  252. - new upstream release
  253. * Wed May 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.12-1
  254. - new upstream release
  255. - dropped gstreamer-plugins-bad-0.10.5-sys-modplug.patch,
  256. gst-plugins-bad-0.10.5-mms-seek.patch
  257. * Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
  258. - new upstream release
  259. - dropped devel and devel-docs subpackages
  260. * Sun Feb 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-2
  261. - rebuild with twolame-devel, libmpcdec-devel, mjpegtools-devel
  262. - changed to BuildRequires: self-build-faad2 from faad2-devel
  263. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-1
  264. - initial build based on RPM Fusion package
  265. * Sat Dec 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-3
  266. - Put devel docs in seperate subpackage to avoid multilib conflict (rf 276)
  267. * Wed Dec 17 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-2
  268. - Rebuild for new x264 (using patch from Rathann)
  269. * Sun Oct 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-1
  270. - New upstream release 0.10.9
  271. - Rebuild for new directfb
  272. * Sun Sep 14 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-4
  273. - Rebuild for new x264 and to generate new magic gstreamer provides
  274. * Sat Aug 16 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-3
  275. - Enable DVD navigation plugin
  276. * Fri Aug 1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-2
  277. - Release bump to keep rpmfusion version higher then livna
  278. * Fri Aug 1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-1
  279. - New upstream release 0.10.8
  280. - Merge changes from latest freshrpms package: enable ofa and dirac plugins
  281. * Fri Jun 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-2
  282. - Rebuild for new x264
  283. * Thu Apr 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-1
  284. - New upstream release 0.10.7
  285. - Drop many upstreamed patches
  286. * Sun Mar 9 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-3
  287. - Rebuild for new x264
  288. * Tue Feb 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-2
  289. - Enable dc1394 plugin
  290. * Sun Feb 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-1
  291. - New upstream release 0.10.6-1
  292. - Drop many upstreamed patches
  293. - Fixes conflict with the latest gstreamer-plugins-good (livna 1884)
  294. * Tue Feb 5 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-15
  295. - Fix compilation with gcc 4.3
  296. * Tue Feb 5 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-14
  297. - Add flv demuxer from CVS (livna bug 1846)
  298. * Sun Dec 9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-13
  299. - Add patch fixing compilation with mjpegtools 1.9.0rc3
  300. * Sun Dec 9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-12
  301. - Add patch from upstream vcs which makes mms honor your connection speed
  302. settings
  303. - Add (painstakingly self written) patch adding support for mms / mmsh seeking!
  304. * Tue Nov 13 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-11
  305. - Rebuild for new faad2
  306. * Sun Nov 4 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-10
  307. - Rebuild for new libdca
  308. * Thu Oct 18 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-9
  309. - Rebuild for new (old) faad2 (livna bug 1679)
  310. * Sat Sep 29 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-8
  311. - Update mythtvsrc code to CVS version (livna bug 1660)
  312. * Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-7
  313. - No libgstreal.so on ppc / ppc64
  314. * Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-6
  315. - Fix detection of libdts with current livna libtds, this might need to be
  316. changed back again for rpmfusion, depending on how libdts will look there
  317. * Sat Sep 22 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-5
  318. - Add mythtvsrc plugin (livna 1646)
  319. - Put some less often used plugins, which bring in also usually not installed
  320. deps in a -extras package
  321. * Sat Sep 15 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-4
  322. - Merge livna spec bugfixes into freshrpms spec for rpmfusion:
  323. - Set release to 4 to be higher as both livna and freshrpms latest release
  324. - Set package name and origin to rpmfusion
  325. - Make mpeg2enc plugin compile with current mjpegtools
  326. - Make the real plugins search for the RealPlayer .so files in various
  327. known possible locations instead of using only one hardcoded path to them
  328. - Make the wildmidi plugin work with the default Fedora timidity patch set
  329. - Add a couple of missing modtracker mimetypes to the modplug plugin
  330. - Use the system version of libmodplug
  331. - Fix building of the neonsrc plugin with the latest (rawhide) neon
  332. - Disable the ladspa plugin as this has been added to Fedora's rawhide
  333. gstreamer-plugins-good
  334. - Don't put an rpath in the .so's on x86_64
  335. - Re-enable gtk-doc now that we have a -devel package again
  336. - Enable libtimidity plugin
  337. - Fix detection of (and linking with) libdca for the dtsdec plugin
  338. * Tue Aug 21 2007 Matthias Saou <http://freshrpms.net/> 0.10.5-1
  339. - Update to 0.10.5.
  340. - Update faad2 patch : Some fixes went in, but faad2.h still produces an error.
  341. - Remove libgstqtdemux, libgstvideocrop and libgstwavpack, all are in good now.
  342. - Enable new nas, x264, wildmidi and libsndfile plugins.
  343. - Re-add devel package now that we have a main shared lib and header files.
  344. - Add check build requirement.
  345. * Wed Mar 30 2007 Matthias Saou <http://freshrpms.net/> 0.10.4-1
  346. - Update to 0.10.4 for F7.
  347. - Disable swfdec... does anything/anyone even use it here? Once it stabilizes
  348. somewhat more, maybe then it'll be worth re-enabling.
  349. - Re-enable wavpack, it works again now.
  350. - Enable libcdaudio support.
  351. - Enable jack support.
  352. - Enable ladspa support.
  353. - Enable mpeg2enc (mjpegtools) support.
  354. - Remove no longer present libgstvideo4linux2.so and add all new plugins.
  355. - Remove all gtk-doc references (all gone...?) and devel package too.
  356. * Tue Jan 9 2007 Matthias Saou <http://freshrpms.net/> 0.10.3-3
  357. - Update faad2 patch to also update the plugin sources, not just configure.
  358. * Mon Dec 18 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-2
  359. - Try to rebuild against new wavpack 4.40 from Extras : Fails.
  360. - Try to update to 0.10.3.2 pre-release : Fails, it needs a more recent gst.
  361. - Try to include patch to update wavpack plugin source from 0.10.3.2
  362. pre-release : Fails to find wavpack/md5.h.
  363. - Give up and disable wavpack support for now, sorry! Patches welcome.
  364. - Include patch to fix faad2 2.5 detection.
  365. - Add soundtouch support.
  366. * Thu Jun 1 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-1
  367. - Update to 0.10.3.
  368. - Add new translations.
  369. - Add libgstmodplug.so, libgstvideo4linux2.so and libgstxingheader.so.
  370. - Add new libmusicbrainz support.
  371. * Thu Mar 23 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-2
  372. - Add libmms support, thanks to Daniel S. Rogers.
  373. * Wed Feb 22 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-1
  374. - Update to 0.10.1.
  375. - Add libgstcdxaparse.so and libgstfreeze.so.
  376. - Enable libgstbz2.so, libgstglimagesink.so and libgstneonhttpsrc.so.
  377. * Wed Jan 25 2006 Matthias Saou <http://freshrpms.net/> 0.10.0.1-1
  378. - Update to 0.10.0.1, add new plugins.
  379. - Spec file cleanup and rebuild for FC5.
  380. * Mon Dec 05 2005 Thomas Vander Stichele <thomas at apestaart dot org>
  381. - 0.10.0-0.gst.1
  382. - new release
  383. * Thu Dec 01 2005 Thomas Vander Stichele <thomas at apestaart dot org>
  384. - 0.9.7-0.gst.1
  385. - new release with 0.10 major/minor
  386. * Sat Nov 12 2005 Thomas Vander Stichele <thomas at apestaart dot org>
  387. - new release
  388. - remove tta patch
  389. - don't check for languages, no translations yet
  390. - added gtk-doc
  391. * Wed Oct 26 2005 Thomas Vander Stichele <thomas at apestaart dot org>
  392. - 0.9.4-0.gst.1
  393. - new release
  394. - added speed plugin
  395. * Mon Oct 03 2005 Thomas Vander Stichele <thomas at apestaart dot org>
  396. - 0.9.3-0.gst.1
  397. - new release